Jump to content
Sign in to follow this  
bmw000

Easy Populate - Column count doesn't match value count at row 1

Recommended Posts

I am getting this error message when trying to import a file with easy populate.

 

I seached the forum and found this same error message, but the fix didn't seem to work for me. Probably because it was for another contribution.

 

Any ideas?

 

Easy Populate 2.76d-MS2 - Default Language : English(1)

 

File uploaded.

Temporary filename: /tmp/phpJd2MX3

User filename: qryJEWELRY01.txt

Size: 101607

| 416769 | 29-173-548 | SL2020 Con | Controls 1 | 38.75 | 1.00 | 1 | Famous Tra | Jewelry | Watches | Famous Tra | --none-- | Active !New Product!

1136 - Column count doesn't match value count at row 1

 

INSERT INTO products ( products_ship_price, products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '29-173-548-416769.jpg', '416769', '38.75', '1', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, NULL, '--none--', '1.00', '1', '' '10')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

I found out what was causing this error. It seems I was using and old version of the instructions for adding a new field to easy populate. I got that error fixed, but now I get a new error.

 

Easy Populate 2.76d-MS2 - Default Language : English(1)

 

File uploaded.

Temporary filename: /tmp/phppyWATW

User filename: qryJEWELRY01.txt

Size: 102804

| 416769a | 29-173-548 | SL2020 Con | Controls 1 | 38.75 | 1.00 | 2007-04-22 | 1 | Famous Tra | Jewelry | Watches | Famous Tra | --none-- | Active | 0 !New Product!

1048 - Column 'products_date_added' cannot be null

 

INSERT INTO products ( products_ship_price, products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '29-173-548-416769.jpg', '416769a', '38.75', '1', CURRENT_TIMESTAMP, "2007-04-22", NULL, '', '1.00', '1', '0', '10')

 

[TEP STOP]

 

Anyone have any ideas?

Edited by bmw000

Share this post


Link to post
Share on other sites

In my programming I have to remove the quotes surrounding CURRENT_TIMESTAMP to get things to work properly. Maybe you need to do the reverse. It's a SQL version issue I think.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×