Jump to content
Sign in to follow this  
enigma1

[Contribution] SEO-G

Recommended Posts

Are you sure you're using SEO-G?

 

I don't see any catalog>includes>classes>url_rewrite.php in my file structure at all.

 

Perhaps that's something related to what you installed recently?

 

I see no such file in my directory.

 

 

oh no im mistaken, i have installed Ultimate SEO URLs - by Chemo

 

 

my url_Rewrite.php file reads the following:

 

<?php
 /* By Daniel Kerr, Created 06/07/05, Released under the GNU General Public License */
 /* 
Updated by Daniel S. Friehe 2007-06-06
* Corrected and improved European-2-ASCII chars conversion
* Focus on german umlauts ('ß'=>'ss', 'ü'=>'ue')
--
Updated by Brian Burton 2005-11-08
*Fixed security hole that would allow mysql injection attacks
*If cPath isn't in the URL, all of the product's categories' names will be added to the URL anyway
 */
 class url_rewrite {


// Prepares URL characters
function prepare_url($url) {
  // Convert special characters from European countries into the English alphabetic equivalent
  // Improved by Daniel S. Friehe
  $transforms = array('À'=>'A','Á'=>'A','Â'=>'A','Ã'=>'A','Ä'=>'Ae','Å'=>'A','Ç'=>'C','È'=>'E','É'=>'E','Ê'=>'E','Ë'=>'E','Ì'=>'I',
					  'Í'=>'I','Î'=>'I','Ï'=>'I','Ñ'=>'N','Ò'=>'O','Ó'=>'O','Ô'=>'O','Õ'=>'O','Ö'=>'Oe','Ø'=>'O','Ù'=>'U','Ú'=>'U',
					  'Û'=>'U','Ü'=>'Ue','Ý'=>'Y','à'=>'a','á'=>'a','â'=>'a','ã'=>'a','ä'=>'ae','å'=>'a','ç'=>'c','è'=>'e','é'=>'e',
					  'ê'=>'e','ë'=>'e','ì'=>'i','í'=>'i','î'=>'i','ï'=>'i','ñ'=>'n','ò'=>'o','ó'=>'o','ô'=>'o','õ'=>'o','ö'=>'oe',
					  'ø'=>'o','ù'=>'u','ú'=>'u','û'=>'u','ü'=>'ue','ý'=>'y','ÿ'=>'y','ß'=>'ss'); 

  $url = strtr($url, $transforms);

  // Remove all non alphabetic and numeric charaters 
  $url = str_replace(' ', '-', ereg_replace('[^[:space:]a-zA-Z0-9_-]', '', $url));

  // Remove double '-'
  while (strstr($url, '--')) $url = str_replace('--', '-', $url);
  return $url;
}


// Select which pages to use SEO URLs on
function pages($page) {
  $page_array = array(FILENAME_DEFAULT, FILENAME_PRODUCT_INFO);
  return in_array($page, $page_array);
}

// Transform the URLs   
function transform_url($url) {
  global $languages_id;

  // Split the URL parts into an array
  $url_parts = parse_url($url);

  // Exit if the URL is not specified in the pages function
  if ((strpos($url, 'action')) || (!$this->pages(current($url_array = explode('/', trim(ltrim($url_parts['path'], DIR_WS_HTTP_CATALOG), '/'))))))
	return $url;

  // Remove the page name from the URL array
  array_shift ($url_array);

  // Empty the path for stores with there error reporting set to ALL
  $url_parts['path'] = rtrim(DIR_WS_HTTP_CATALOG, '/');

  // Start the transformation
  for ($i = 0; $i < sizeof($url_array); $i++) {
	switch ($url_array[$i]) {
	  case 'cPath':
		$i++;
		$category_array = explode('_', $url_array[$i]);

		foreach ($category_array as $categories_id) {
		  $category_query = tep_db_query("select distinct c.categories_id, cd.categories_name from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$categories_id . "' and c.categories_id = cd.categories_id and cd.language_id = '" . (int)$languages_id . "'");
		  $category_name = tep_db_fetch_array($category_query);
		  $url_parts['path'] .= '/' . $this->prepare_url($category_name['categories_name']);
		}

		break;

	  case 'products_id':
		$i++;

		//ADD CATEGORY NAME MODIFICATION - BB 2005-11-08
		//If cPath isn't in the URL, category names aren't added to the URL
		//This fixes that
		if (strpos($url, 'cPath') === false) {
		  $cat_array = array();
		  $cat_query = tep_db_query("SELECT cd.categories_name as name, c.parent_id FROM categories c LEFT JOIN categories_description cd ON (c.categories_id = cd.categories_id) LEFT JOIN products_to_categories p2c ON (p2c.categories_id = c.categories_id) WHERE p2c.products_id = '" . (int)$url_array[$i] . "' AND p2c.categories_id = c.categories_id AND cd.language_id = '" . (int)$languages_id . "'");
		  $cat_val = tep_db_fetch_array($cat_query);

		  $cat_array[] = $cat_val['name'];

		  //If this category has a parent, get the name
		  if (is_numeric($cat_val['parent_id']) && $cat_val['parent_id'] != '0') {
			$parent_id = $cat_val['parent_id'];
			while ($parent_id != '0') {
			  $cat_query = tep_db_query("SELECT cd.categories_name as name, c.parent_id FROM categories c LEFT JOIN categories_description cd ON (c.categories_id = cd.categories_id) WHERE cd.categories_id = '" . (int)$parent_id . "' AND cd.language_id = '" . (int)$languages_id . "'");
			  $cat_val = tep_db_fetch_array($cat_query);

			  $cat_array[] = $cat_val['name'];
			  $parent_id = $cat_val['parent_id'];
			}
		  }

		  //Reverse array order
		  $cat_array = array_reverse($cat_array);

		  for ($x = 0; $x <= sizeof($cat_array); $x++) {
			$url_parts['path'] .= '/' . $this->prepare_url($cat_array[$x]);
		  }
		}
		//END MODIFICATION - BB

		$product_query = tep_db_query("select distinct products_name from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$url_array[$i] . "' and language_id = '" . (int)$languages_id . "'");
		$product_name = tep_db_fetch_array($product_query);
		$url_parts['path'] .= (substr($url_parts['path'], -1) == '/' ? '' : '/') . $this->prepare_url($product_name['products_name']);
		break;

	  case 'manufacturers_id':
		$i++;

		$manufacturer_query = tep_db_query("select distinct manufacturers_name from " . TABLE_MANUFACTURERS . " where manufacturers_id = '" . (int)$url_array[$i] . "'");
		$manufacturer_name = tep_db_fetch_array($manufacturer_query);
		$url_parts['path'] .= '/' . $this->prepare_url($manufacturer_name['manufacturers_name']);
		break;

	  default:
		$url_parts['path'] .= '/' . $url_array[$i];

		break;
	}
  } 

  // Return the converted URL
  return $url_parts['scheme'] . '://' . $url_parts['host'] . $url_parts['path'] . '.html';
}

// Changes the names of URL's into intergers
function encrypt_url($url) {
  return sprintf('%u', crc32($this->prepare_url(strtolower($url))));
}

function request_url() {
  global $HTTP_GET_VARS;

  // Cache error messsage
  if (USE_CACHE <> true)
	exit ('Use cache needs to be set to \'true\' and the cache directory needs to be writable to use SEO URLs');

  // Search Engine Friendly URLs error messsage
  if (SEARCH_ENGINE_FRIENDLY_URLS <> true)
	exit ('SEF URLs needs to be set to \'true\' to use SEO URL\'s');

  // Force cookie error message
  if (SESSION_FORCE_COOKIE_USE <> true)
	exit ('Force cookie use needs to be set to \'true\' and cookie domain needs to be setup in config file to use SEO URLs');

  // Exit if not being called from the SEO pages or contains 'action'
  if ((!$this->pages(basename($_SERVER['PHP_SELF']))) || ($_SERVER['REQUEST_URI'] == '/') || (strpos($_SERVER['REQUEST_URI'], '.php')))
	return;

  // Put the request URL into an array
  $url = str_replace('.html', '', getenv('REQUEST_URI'));
  $request_url_array = explode('/', trim($url, '/'));

  // Get the cached URLs array
  $url_array = $this->cache_url();
  $new_url_arr = $url_array;

  for ($i = 0; $i < sizeof($request_url_array); $i++) {
	switch ($request_url_array[$i]) {
	  case 'sort':
		$i++;

		$HTTP_GET_VARS['sort'] .= $request_url_array[$i];

		break;

	  case 'page':
		$i++;

		$HTTP_GET_VARS['page'] .= $request_url_array[$i];

		break;

	  case 'language':
		$i++;

		$HTTP_GET_VARS['language'] .= $request_url_array[$i];

		break;

	  default:
	  $rodic = $url_array[$this->encrypt_url($request_url_array[$i])]['pvalue'];
	  if (isset($HTTP_GET_VARS['cPath']))
		  $modetests = $HTTP_GET_VARS['cPath'].$this->encrypt_url($request_url_array[$i]);
	  else
		  $modetests = $this->encrypt_url($request_url_array[$i]);

		if ($url_array[$modetests]['key'] == 'categories_id') {
		  if (!isset($HTTP_GET_VARS['cPath'])) {
			$HTTP_GET_VARS['cPath'] = $url_array[$this->encrypt_url($request_url_array[$i])]['value'];
			$rodic = $url_array[$this->encrypt_url($request_url_array[$i])]['value'];
		  } else {
			$HTTP_GET_VARS['cPath'] .= '_' . $url_array[$modetests]['value'];
		  }
		} else {
			$modetests = $rodic.$this->encrypt_url($request_url_array[$i]);
		  $HTTP_GET_VARS[$url_array[$modetests]['key']] .= $url_array[$modetests]['value'];
		}
		break;
	}
  }
}

// Caches the URLs into a file called url.cache that should be in the cache directory
function cache_url() {
  global $refresh;

  // Read cache is part of the built in OSC cache fucntion
		if (($refresh == true) || !read_cache($url_array, 'url.cache')) {
	// Adds the categories to the URL array
	// query enhanced for parent value for each produkt
	$categories_query = tep_db_query("select ".TABLE_CATEGORIES_DESCRIPTION.".categories_id as categories_id, ".TABLE_CATEGORIES_DESCRIPTION.".categories_name as categories_name, " . TABLE_CATEGORIES . ".parent_id as parent_id from " . TABLE_CATEGORIES_DESCRIPTION . " left join " . TABLE_CATEGORIES ." on (" . TABLE_CATEGORIES .".categories_id = " . TABLE_CATEGORIES_DESCRIPTION .".categories_id)");

	while ($categories = tep_db_fetch_array($categories_query)) {
		$prvok = $this->encrypt_url($categories['categories_name']);
		if ($categories['parent_id'] != 0) 
			$url_array[$categories['parent_id'].$prvok] = array('key' => 'categories_id', 'value' => $categories['categories_id'], 'pkey'=> 'parent_id', 'pvalue' => $categories['parent_id']);
		else
			$url_array[$prvok] = array('key' => 'categories_id', 'value' => $categories['categories_id'], 'pkey'=> 'parent_id', 'pvalue' => $categories['parent_id']);
	}
	// Adds the manufacturers to the URL array
	$manufacturers_query = tep_db_query("select manufacturers_id, manufacturers_name from " . TABLE_MANUFACTURERS);
	while ($manufacturers = tep_db_fetch_array($manufacturers_query)) {
	  $url_array[$this->encrypt_url($manufacturers['manufacturers_name'])] = array('key' => 'manufacturers_id', 'value' => $manufacturers['manufacturers_id']);
	}

	// Adds the products to the URL array
	$products_query = tep_db_query("select products_id, products_name from " . TABLE_PRODUCTS_DESCRIPTION);

	while ($products = tep_db_fetch_array($products_query)) {
	  $url_array[$this->encrypt_url($products['products_name'])] = array('key' => 'products_id', 'value' => $products['products_id']);
	}

	// Write cache is part of the built in OSC cache fucntion
	write_cache($url_array, 'url.cache');
  }
  return $url_array;
}
 }
?>

Edited by pure11

Share this post


Link to post
Share on other sites

looks like i had this installed: osCommerce Search Engine Otimized URL's

 

 

 

 

i removed the edits .. still had to turn cache off for this to work, but now everything works fine!

 

only problem i get this under the menu:

 

BOX_INFORMATION_ALLPRODS

BOX_SPECIALS_ALLPRODS

BOX_WHATSNEW_ALLPRODS

 

with links to the pages, do you know how i can fix this in any way ?

 

thank you so much for your help

Share this post


Link to post
Share on other sites

Hi all. I'm getting the cookie page when I try to access my admin. I have to go into .access to delete the changes in the mod, and then once I am in, I fix it. It seems it has this problem every browser session? Any suggestions on how to fix, it's getting a little annoying, but I still think its a great mod. Thanks all, any help would be great. I have the recent version installed.

Share this post


Link to post
Share on other sites
Hi Max: I did that once, with Credit Class Gift Voucher. I had duplicate entries in Admin.

 

If you use Cpanel and can use PHPmyadmin.....login and select your database and then look at the configuration entries for SEO-G. Select and delete the duplicate(s).

 

I don't know enough to say whether or not it's a cosmetic issue or it's something that needs to be taken care of. I just figure...if I install something and I end up with duplicate entries in Admin...it needs to be fixed. So, I fix it.

 

Andrea

 

 

Andrea,

 

Thanks for the suggestion, I'll take a look at that and see if I can fix it. I always get nervous when messing with the database, I'm afraid I'll mess it up so much, I won't be able to fix it. I'm new to working with databases, so I'm afraid I will really junk it up. ;) But when I get brave one day, i'll do what you suggested ;)

Share this post


Link to post
Share on other sites

Sabrina:

 

BOX_INFORMATION_ALLPRODS
BOX_SPECIALS_ALLPRODS
BOX_WHATSNEW_ALLPRODS

 

Is that a contrib? All Products, something like that?

 

All those errors say to me is that the files have not been defined in catalog>includes>languages>english.php

 

Like...

 

define('BOX_INFORMATION_ALLPRODS', 'Information');

 

So...take a look at that file. Perhaps you missed that file when installing...whatever it is. :) If those entries are there, then it may very well be SEO-G related. The contrib does have issues with a few other contribs and yours might very well be one of them.

 

Store Man: What are your settings in Configuration > Sessions?

 

And what do you mean you're deleting changes in .htaccess to get in? What exactly are you doing?

Share this post


Link to post
Share on other sites
Sabrina:

 

BOX_INFORMATION_ALLPRODS
BOX_SPECIALS_ALLPRODS
BOX_WHATSNEW_ALLPRODS

 

Is that a contrib? All Products, something like that?

 

All those errors say to me is that the files have not been defined in catalog>includes>languages>english.php

 

Like...

 

define('BOX_INFORMATION_ALLPRODS', 'Information');

 

So...take a look at that file. Perhaps you missed that file when installing...whatever it is. :) If those entries are there, then it may very well be SEO-G related. The contrib does have issues with a few other contribs and yours might very well be one of them.

 

thanks again! it was another contrib i had installed called all products you were right and i needed to define the info in the english.php file

 

thanks so much!

Edited by pure11

Share this post


Link to post
Share on other sites
Sabrina:

 

BOX_INFORMATION_ALLPRODS
BOX_SPECIALS_ALLPRODS
BOX_WHATSNEW_ALLPRODS

 

Is that a contrib? All Products, something like that?

 

All those errors say to me is that the files have not been defined in catalog>includes>languages>english.php

 

Like...

 

define('BOX_INFORMATION_ALLPRODS', 'Information');

 

So...take a look at that file. Perhaps you missed that file when installing...whatever it is. :) If those entries are there, then it may very well be SEO-G related. The contrib does have issues with a few other contribs and yours might very well be one of them.

 

Store Man: What are your settings in Configuration > Sessions?

 

And what do you mean you're deleting changes in .htaccess to get in? What exactly are you doing?

 

Thanks for taking on the question!!!! In order to get into admin I have to temporarily delete the addition the install guide says, which is:

 

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

 

Once I am in, I re-add that part, and as long as the SAME browser window is open, I don't have to do it again. It seems the problem occurs every browser session.

 

My Configuration > Sessions settings are as follows:

 

Session Directory

Force Cookie Use False

Check SSL Session ID False

Check User Agent False

Check IP Address False

Prevent Spider Sessions True

Recreate Session False

 

Thanks again, I would appreciate any help! :)

Share this post


Link to post
Share on other sites

Hi Max!

 

Your sessions configurations are fine. So, that's not it.

 

Your problem reminds me of my Googlefeeder problem. If I try to run it (and it comes from Admin), I get the cookie_usage.php page.

 

Hmmm...

 

That chunk of code you're deleting in .htaccess....do you see any other entries in the .htaccess file that may be duplicates of what you're entering for SEO-G?

 

I bring that up because I already had a few lines of that code in my own .htaccess file, for whatever reason.

 

Instead of putting in that big chunk of code the contrib tells you to, I put this in instead:

 

# Next line must be changed to match your osCommerce folder - the relative path 
RewriteBase /
RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
#-MS- SEO-G Added EOM

 

I left out the other stuff as it was already there. On that note...just thinking off the top of my head now, lol....you didn't add that code to catalog>ADMIN>.htaccess, did you? Only catalog>.htaccess should be edited.

Share this post


Link to post
Share on other sites
Hi Max!

 

Your sessions configurations are fine. So, that's not it.

 

Your problem reminds me of my Googlefeeder problem. If I try to run it (and it comes from Admin), I get the cookie_usage.php page.

 

Hmmm...

 

That chunk of code you're deleting in .htaccess....do you see any other entries in the .htaccess file that may be duplicates of what you're entering for SEO-G?

 

I bring that up because I already had a few lines of that code in my own .htaccess file, for whatever reason.

 

Instead of putting in that big chunk of code the contrib tells you to, I put this in instead:

 

# Next line must be changed to match your osCommerce folder - the relative path 
RewriteBase /
RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
#-MS- SEO-G Added EOM

 

I left out the other stuff as it was already there. On that note...just thinking off the top of my head now, lol....you didn't add that code to catalog>ADMIN>.htaccess, did you? Only catalog>.htaccess should be edited.

 

Thanks for responding. I don't see duplicate entries in my .htaccess, and I didn't add it to the catalog/admin/.htaccess. I'm stumped!

 

I have included both here, just in case I am really blind or something, lol ;)

 

Root .htaccess:

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

 

 

admin .htaccess:

 

# $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

AuthType Basic

AuthName "******"

AuthUserFile "/home/****/****/****"

require valid-user

 

Thanks again for any help!!

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites

Max: Your Admin>.htaccess file is far different from mine. Mine simply reads:

 

AuthType Basic

AuthName "OS Commerce Administration"

AuthUserFile "/home/xxxxxx/.htpasswds/xxxxx/admin/passwd"


require valid-user

 

I don't really know what else to say now. :'(

 

Just for the heck of it, save that file so you can put it back if you need to and change it to read like mine...just to see if that clears it up...if that's the culprit.

Share this post


Link to post
Share on other sites
Max: Your Admin>.htaccess file is far different from mine. Mine simply reads:

 

AuthType Basic

AuthName "OS Commerce Administration"

AuthUserFile "/home/xxxxxx/.htpasswds/xxxxx/admin/passwd"
require valid-user

 

I don't really know what else to say now. :'(

 

Just for the heck of it, save that file so you can put it back if you need to and change it to read like mine...just to see if that clears it up...if that's the culprit.

 

 

I tried your suggestion and I got the same cookie redirect page again. <sigh> This is driving me nuts! lol What's a store_man to do!!!

Share this post


Link to post
Share on other sites

dear sir

firt time sorry for my english , y hope to understand what y say.

y try for a week to install seo-url on my test server. y don't can install them. various problems ocures. y try to install seo-g on my test server , y install them in 5 minutes. a greath contribution and verry, verry easy to install. but y meet a problem. exist a sweet contribution nemed "lightbox" and if y activate seo-g button , don't work. if y deactivate seo-g button "lightbox" work ok. somebody can help with this problem ? y'm not a programmer but y "catch" how it work oscommerce. y read about 300-400 page on this forum but y found nothing about same problem. 10x in advance and another sorry for my english.

Share this post


Link to post
Share on other sites

ok, I'm back to this...

 

Store Man, do you have it rewriting secure pages? Perhaps that is your issue. But, I am just a few days into this so I could be wrong.

 

I tried a google feed, looks like it is working for me (at least I am not getting errors on a send). I am using http://addons.oscommerce.com/info/4455 Version 3.3b. It does still send the old urls, but I can accept that at this point.

 

I fixed the tell a friend issue by adding tell_a_friend.php to the products handler in the G-types section.

 

Now I am moving to the sitemap...I am still seeing this error if I click the notify google button:

 

Warning: fopen(/home/antique/public_html/catalog/google_sitemap.xml.gz) [function.fopen]: failed to open stream: Permission denied in /home/antique/public_html/catalog/admin/seo_reports.php on line 114

 

Warning: Cannot modify header information - headers already sent by (output started at /home/****/public_html/catalog/admin/seo_reports.php:114) in /home/****/public_html/catalog/admin/includes/functions/general.php on line 18

 

If anyone has a fix, please let me know...otherwise I'll keep plugging away on it!

Share this post


Link to post
Share on other sites

Ok, I have SEO G and when I have SEO url's it wont let someone post a review on a product. Anyone know how to fix this. I might need to add another function or whatever it is. If someone could please PM me the solution I would be very greatful.

Share this post


Link to post
Share on other sites

Rachael:

 

Warning: fopen(/home/antique/public_html/catalog/google_sitemap.xml.gz) [function.fopen]: failed to open stream: Permission denied in /home/antique/public_html/catalog/admin/seo_reports.php on line 114

Warning: Cannot modify header information - headers already sent by (output started at /home/****/public_html/catalog/admin/seo_reports.php:114) in /home/****/public_html/catalog/admin/includes/functions/general.php on line 18

 

I've got the same errors and do not know how to fix that. However, if you simply click on the Google XML button and do NOT select the Notify Google box...you'll be prompted to save the file to your harddrive and it will generate a sitemap that you can then manually upload to the root folder of your website.

 

However, the yucky part about the sitemap that it creates is that it's pulling the information from your SEO-G Reports.

 

Which means...unless you're getting rid of your 'old' urls in the Reports as you go...the sitemap will be full of old AND new urls for the same products, links, whatever. Meaning...duplicate content.

 

What you can do, is click on the Google XML button...save the file to your PC...open it with Notepad and hand-edit the file to delete any old, duplicate URLs and then save it anew and upload it to your root folder. Of course, you'll need to login to your Google account...click on My Account > Webmaster Tools and submit your new sitemap for approval.

Share this post


Link to post
Share on other sites
Hi, Max:

 

Try typing in http://www.yoursite.com/admin/index.php

 

Can you login to Admin with that or are you still getting redirected to the cookie monster page?

 

Yeah, I found your suggestion in an eariler post, and it still directed me to the cookie monster page!! LOL. Ever see that movie Groundhog Day with Bill Murray? LOL. That's what I feel like.

Share this post


Link to post
Share on other sites
ok, I'm back to this...

 

Store Man, do you have it rewriting secure pages? Perhaps that is your issue. But, I am just a few days into this so I could be wrong.

 

I tried a google feed, looks like it is working for me (at least I am not getting errors on a send). I am using http://addons.oscommerce.com/info/4455 Version 3.3b. It does still send the old urls, but I can accept that at this point.

 

I fixed the tell a friend issue by adding tell_a_friend.php to the products handler in the G-types section.

 

Now I am moving to the sitemap...I am still seeing this error if I click the notify google button:

If anyone has a fix, please let me know...otherwise I'll keep plugging away on it!

 

Thanks for the suggestion. I don't have secure pages since I process payments at Paypal, so I'm not sure if it is or isn't or how I would check. LOL.

Share this post


Link to post
Share on other sites

I'm guessing that what Rachael was getting at, Max, is...when you login to Admin and click on SEO-G...is the Process Secure Pages entry set to False?

 

I dunno...I still think the money has to be on your .htaccess file.

 

Did you try entering (in the .htaccess file) only what I have in mine, and leave the first half out?

 

Just this part:

 

# Next line must be changed to match your osCommerce folder - the relative path 
RewriteBase /
RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
#-MS- SEO-G Added EOM

Share this post


Link to post
Share on other sites

why do i get this error ?

 

The requested URL /mydomain/myfilename.html was not found on this server.

 

help please

Share this post


Link to post
Share on other sites

hi community

i've installed this great contribution and it's working almost perfectly. my english is worst and i gave my best to understand the documantation best as i can. i think my problem is the right configuration of seo-g. i read the whole thread and documentation but can't locate and analyse the problem. please help me with the right configuration and problems below, i will translate this to the german community.

 

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

1. problem:

the manufacture links of the product (little manufactures box) is generating fine like: /test/catalog/fox.html

 

when i'm using the dropdown of manufactures, the link is generating like this: ....../catalog/index.html?manufacturers_id=4

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

2. problem:

i got unice links from the categories, subcategories, allproducts and bestsellers like: /catalog/beloved.html

i recieve the same links directly from the these pages "/catalog/products_new.html" and "/catalog/specials.html"

 

but the image/picture links of "whats new" and "specials" generating this: /catalog/beloved_whatsnew-beloved.html

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

3. problem:

when i open a categorie, and push the drop down of "all manufactures" i got links like that: /catalog/index.php?cPath=3_10&sort=2a&filter_id=4

 

how i can get it like: /test/catalog/fox.html

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

4. problem:

the search function is building links like that: /catalog/advanced_search_result.html?keywords=beloved&x=0&y=0

 

is this possible?: /catalog/advanced_search_result-keywords=beloved&x=0&y=0.html

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

thanks for every help

Edited by esupply

Share this post


Link to post
Share on other sites
I'm guessing that what Rachael was getting at, Max, is...when you login to Admin and click on SEO-G...is the Process Secure Pages entry set to False?

 

I dunno...I still think the money has to be on your .htaccess file.

 

Did you try entering (in the .htaccess file) only what I have in mine, and leave the first half out?

 

Just this part:

 

# Next line must be changed to match your osCommerce folder - the relative path 
RewriteBase /
RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
#-MS- SEO-G Added EOM

 

Hi. I checked the process secure pages setting and it was set to false. I also tried your last suggestion, and I got the 404 error. LOL!!!!!!!!!!!! I feel, retarded, and stubborn!!!

Share this post


Link to post
Share on other sites
Hi. I checked the process secure pages setting and it was set to false. I also tried your last suggestion, and I got the 404 error. LOL!!!!!!!!!!!! I feel, retarded, and stubborn!!!

 

 

Here is my .htaccess file again, LOL!!!

 

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

Share this post


Link to post
Share on other sites

Contribution works great. If anyone is interested, I made a small modification to include the ability to submit your sitemap to yahoo and ask.com as well as google. It is just one modified file under Admin directory. All you should have to do is replace seo_reports.php

Share this post


Link to post
Share on other sites
Contribution works great. If anyone is interested, I made a small modification to include the ability to submit your sitemap to yahoo and ask.com as well as google. It is just one modified file under Admin directory. All you should have to do is replace seo_reports.php

Oh, and I want to add that SEO-G works great with another contribution I made. Identify Search Engine Bots in "Who's Online" available here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×