Jump to content
Sign in to follow this  
enigma1

[Contribution] SEO-G

Recommended Posts

what you mean specific rewrite? you need to have the mod_rewrite module for apache enabled. 404 usually means incorrect .htaccess or no rewrite (or the root.php is not there).

 

Thank you for your reply Mark, I don't think the mod_rewrite module is enabled but I will check this. Also I will check to see if the root.php is not there and I will post my .htaccess file later on today! I don't think there is anything wrong with the .htaccess file, i think it could be because of my local setup.

 

Thank you for developing something which is really useful.

:rolleyes:

Share this post


Link to post
Share on other sites
Thank you for your reply Mark, I don't think the mod_rewrite module is enabled but I will check this. Also I will check to see if the root.php is not there and I will post my .htaccess file later on today! I don't think there is anything wrong with the .htaccess file, i think it could be because of my local setup.

 

Thank you for developing something which is really useful.

:rolleyes:

if the mod_rewrite is not enabled you cannot use the module. Ususally hosts with apache server have this on so you could ask your host about it.

Share this post


Link to post
Share on other sites
if the mod_rewrite is not enabled you cannot use the module. Ususally hosts with apache server have this on so you could ask your host about it.

 

Here is my .htaccess file, I can't see anything wrong with it but then I am not a master in that area!

 

I will check with our host, is this something which can be seen under the server info page in admin?

 

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

RewriteBase /catalog/

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

Share this post


Link to post
Share on other sites
Here is my .htaccess file, I can't see anything wrong with it but then I am not a master in that area!

 

I will check with our host, is this something which can be seen under the server info page in admin?

 

ok make sure this line

 

RewriteBase /catalog/

 

corresponds to the osc root. So as I see it, I assume your store is at yoursite321.com/catalog/

 

for the mod_rewrite it may show under the Apache->Loaded Modules section of the server info (osc admin).

Edited by enigma1

Share this post


Link to post
Share on other sites
ok make sure this line

 

RewriteBase /catalog/

 

corresponds to the osc root. So as I see it, I assume your store is at yoursite321.com/catalog/

 

for the mod_rewrite it may show under the Apache->Loaded Modules section of the server info (osc admin).

 

Unfortunately I have looked on the server info page and it does not appear so I will check with our host.

 

I will also sort the site out locally first. I have two questions:

 

1. Does Ultimate SEO Urls use the same module to rewrite the URLS? I know our host has a site which uses this contribution.

2. Is it likely that the mod rewrite module for Apache will have been installed as default on my local machine? If you can point me in the right direction to look I would most appreciate it

 

Many thanks

Share this post


Link to post
Share on other sites
Unfortunately I have looked on the server info page and it does not appear so I will check with our host.

Yes sometimes the apache section is not shown. Depends on your host's configuration But that doesn't mean it's not there

 

 

1. Does Ultimate SEO Urls use the same module to rewrite the URLS? I know our host has a site which uses this contribution.

Yes it also uses the mod_rewrite.

 

2. Is it likely that the mod rewrite module for Apache will have been installed as default on my local machine? If you can point me in the right direction to look I would most appreciate it

for server configuration details you could check the apache site eg:

http://httpd.apache.org/docs/2.2/mod/mod_rewrite.html

and there are many forums for server related discussions like webmasterworld.com

Share this post


Link to post
Share on other sites

Hi,

 

First of all thanks for the contribution. I have just installed it on my demo version. The links come up but the problem is that I cant go to any of the links it says Error /root.php file not found where as my root.php is already in the directory. >_<

 

You can have a look for yourself, click on any link on this page:http://www.kingscomputers.co.uk/demo/

 

I am sure it must be something I have missed or done wrong in the installation.

 

Any suggestions is appriciated. Thanks for your time,

 

 

Hoda

Share this post


Link to post
Share on other sites
Hi,

 

First of all thanks for the contribution. I have just installed it on my demo version. The links come up but the problem is that I cant go to any of the links it says Error /root.php file not found where as my root.php is already in the directory. >_<

 

You can have a look for yourself, click on any link on this page:http://www.kingscomputers.co.uk/demo/

 

I am sure it must be something I have missed or done wrong in the installation.

 

Any suggestions is appriciated. Thanks for your time,

Hoda

Did you modify the .htaccess file according to the instructions? That should be located in the demo folder. If you have and still doesn't work post the entire .htaccess

 

The rest seems working if I emulate the mapping for example:

www.kingscomputers.co.uk/demo/root.php?msi-k8t-neo2-v2-via-k8t800-socket-939-6-channel-audio-agp-atx.html

Edited by enigma1

Share this post


Link to post
Share on other sites
Did you modify the .htaccess file according to the instructions? That should be located in the demo folder. If you have and still doesn't work post the entire .htaccess

 

The rest seems working if I emulate the mapping for example:

www.kingscomputers.co.uk/demo/root.php?msi-k8t-neo2-v2-via-k8t800-socket-939-6-channel-audio-agp-atx.html

 

Yes I have changed it as you said in the installation guide here is the full code:

 

---------------------------------------------------------------------------------------------------------------------

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

php_value register_globals 1

#</IfModule>

 

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

 

---------------------------------------------------------------------------------------------------------------------

 

Thank you for your reply

Share this post


Link to post
Share on other sites
Yes I have changed it as you said in the installation guide here is the full code:

no you haven't. The instructions show how to match the path where your osc catalog is. It's not at the root of the domain.

Share this post


Link to post
Share on other sites
The module is designed to operate from the osc root. So in your case I've no idea what will happen generating links from sub-folders.

 

Hi Mark, I'm not generating links from sub-folders. I'm trying to find a way to exclude folders and their contents from being generated by SEO-G. thanks!

Share this post


Link to post
Share on other sites

Hello,

 

Does anyone use it with FCKosc2.21 editor,

 

when the .htaccess is on the FCKosc2.21 contri doesnt work it shows the cookie page.

Maybee a change in the htaccess file helps me ????

 

HELP :)

THx

HEnk

Share this post


Link to post
Share on other sites
no you haven't. The instructions show how to match the path where your osc catalog is. It's not at the root of the domain.

 

 

Thanks for the help and you were right it is working now but all the links go to the cookie enable page even though i have cookies enabled. I dont know why :( I cant go no where.

 

Thank you,

 

Hoda

Share this post


Link to post
Share on other sites

Hi Mark, been using this mod since the begging, now have a few problems with the reports section, I have ended up with 500 pages of reports, now this has made the db bloat to 26mb after deleting the reports its back down to 6mb, is this normal?

 

Also since adding this mod the whose online section doesn’t work properly, if a user is on index.html it will report they are on cookie_uasge.php,

 

And for custom pages that I have added to the site such as prices.php, if I change the url to htm you get taken to the cookie_uasge.php, now I guess this is because the page isn’t generated from the system, is there anyway around this?

 

I’m using version 1.14 and will upgrade this week to the latest version.

 

any help or sugestions would be great.

 

Danny

Edited by drs101

Share this post


Link to post
Share on other sites
Hi Mark, I'm not generating links from sub-folders. I'm trying to find a way to exclude folders and their contents from being generated by SEO-G. thanks!

Then don't use the exclusion list as the module was designed to operate with osc stores and the scripts run from the catalog level..

 

Sub-folders can be exluded via the .htaccess on the sub-folder level (see documentation how the admin folder is excluded and the apache manual for things like the location, allowoverride etc directives) and when you have control of the server you can specify the if the .htaccess rules should propagate to the sub-folders. This case is server configuration dependent.

Share this post


Link to post
Share on other sites
Thanks for the help and you were right it is working now but all the links go to the cookie enable page even though i have cookies enabled. I dont know why :( I cant go no where.

 

Thank you,

 

Hoda

You have to follow the document and setup your configure.php file properly. See the example configuration file that comes with the archive.

Share this post


Link to post
Share on other sites
Hello,

 

Does anyone use it with FCKosc2.21 editor,

 

when the .htaccess is on the FCKosc2.21 contri doesnt work it shows the cookie page.

Maybee a change in the htaccess file helps me ????

 

HELP :)

THx

HEnk

yes you could change the .htaccess see the documentation "known issues" about the admin folder.

Share this post


Link to post
Share on other sites
Hi Mark, been using this mod since the begging, now have a few problems with the reports section, I have ended up with 500 pages of reports, now this has made the db bloat to 26mb after deleting the reports its back down to 6mb, is this normal?

 

Also since adding this mod the whose online section doesn’t work properly, if a user is on index.html it will report they are on cookie_uasge.php,

 

And for custom pages that I have added to the site such as prices.php, if I change the url to htm you get taken to the cookie_uasge.php, now I guess this is because the page isn’t generated from the system, is there anyway around this?

 

I’m using version 1.14 and will upgrade this week to the latest version.

 

any help or sugestions would be great.

 

Danny

I do not see the problem with the whosonline script. It shows the full url.

 

As of the size issue you need to examine the reports. Unless you have way too many products and categories there could be something else that is not configured properly. 500 pages mean around 50,000 links with the default split value. Set the safe mode switch to true.

Share this post


Link to post
Share on other sites
I do not see the problem with the whosonline script. It shows the full url.

 

As of the size issue you need to examine the reports. Unless you have way too many products and categories there could be something else that is not configured properly. 500 pages mean around 50,000 links with the default split value. Set the safe mode switch to true.

 

not sure what mean about the whosonline script, it doesnt report the correct url that the user is on, no matter what link i click it says im on cookie_usage.php, ill try the safe mode for the reports.

Share this post


Link to post
Share on other sites
not sure what mean about the whosonline script, it doesnt report the correct url that the user is on, no matter what link i click it says im on cookie_usage.php, ill try the safe mode for the reports.

I mean when I test it here (v1.20) with a stock osc.

Share this post


Link to post
Share on other sites

Hi, excuse me if i'm using this forum incorrectly.

I have loaded the SEO-G contibution and love it. I was wondering what type of sid killer will work with it?

Share this post


Link to post
Share on other sites
Hi, excuse me if i'm using this forum incorrectly.

I have loaded the SEO-G contibution and love it. I was wondering what type of sid killer will work with it?

I don't know, you need to try them. SEO-G is tested primarily with the stock osC and mods to rectify bugs are implemented as long as they can be replicated. Watch for mods to the .htaccess file with the sid-killer modules. Use the manual instructions and backup your files before installing.

Share this post


Link to post
Share on other sites

I`m having little problem.

when I enter "G-Controller" option in admin panel I get a message:

"1146 - Table 'stys_asdf.TABLE_SEO_TYPES' doesn't exist

 

select count(*) as total from TABLE_SEO_TYPES at where seo_types_status='1'"

 

I ran a sql query in PHPmyadmin:

SELECT count(*) as total FROM configuration WHERE configuration_group_id=24
and in total it was 17.

 

What should I do to solve this problem?

Share this post


Link to post
Share on other sites
I`m having little problem.

when I enter "G-Controller" option in admin panel I get a message:

 

I ran a sql query in PHPmyadmin: and in total it was 17.

 

What should I do to solve this problem?

You should go through the instructions and implement all steps. In this case you haven't changed the database_tables.php files.

Share this post


Link to post
Share on other sites

has anybody installed this on osc RC1? I was able to get everything working on the latest milestone, but can not get it to work with RC1


Powered By osC 2.2RC2a STS 4.5.8 - HTC 2.6.3 - FP 1.5.9 - BCH 1.0.0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×