Jump to content
Sign in to follow this  
enigma1

[Contribution] SEO-G

Recommended Posts

I updated to V1.20 when it came out and then I deleted all the products in the catalog and in seo-g including reports and then repopulated the whole catalog using easy-populate and then reconfigured all the links is SEO-G. Everything worked perfectly. Today, I added some new products into an existing category(s) with the Auto Names Builder set to true but the products added had the same name as previous entries and unique names/links were not added. The products were added but when I click on the link I am taken to the wrong product from the original set-up/config because of this (not unique). When I went into the controller I found the new products all had the same name and no number added on the end to make it unique. I tried using the controller to try and make the product names unique automatically but they kept coming up with the same identical name. The only solution was to manually add a numbering scheme on the end of the names to make them unique like the controller did on the original install. Any suggestions?

Share this post


Link to post
Share on other sites
I updated to V1.20 when it came out and then I deleted all the products in the catalog and in seo-g including reports and then repopulated the whole catalog using easy-populate and then reconfigured all the links is SEO-G. Everything worked perfectly. Today, I added some new products into an existing category(s) with the Auto Names Builder set to true but the products added had the same name as previous entries and unique names/links were not added. The products were added but when I click on the link I am taken to the wrong product from the original set-up/config because of this (not unique). When I went into the controller I found the new products all had the same name and no number added on the end to make it unique. I tried using the controller to try and make the product names unique automatically but they kept coming up with the same identical name. The only solution was to manually add a numbering scheme on the end of the names to make them unique like the controller did on the original install. Any suggestions?

 

you need to delete all products from the G-Controller. Then click the categories button to get to categories mode inside the products page of the G-Controller. Select all (use the header) click insert. This will insert all products and duplicated names will automatically get an index at the end. In order for SEO-G to append the numbers for products with the same name has to be done on the same run.

 

And finally delete the G-Reporrts

 

In general however you should not use duplicated urls (these are duplicates even if they have a different number). It defies the purpose of the SEO for urls.

Edited by enigma1

Share this post


Link to post
Share on other sites
you need to delete all products from the G-Controller. Then click the categories button to get to categories mode inside the products page of the G-Controller. Select all (use the header) click insert. This will insert all products and duplicated names will automatically get an index at the end. In order for SEO-G to append the numbers for products with the same name has to be done on the same run.

 

And finally delete the G-Reports

I may be misunderstanding what the Auto Names Builder does but I now know that SEO-G names/links cannot be created automatically if the product names are not unique, ... but I am still confused about Auto Names Builder. When does it automatically generate names? Does it add them any time you add a new unique product name to the catalog?

 

In general however you should not use duplicated urls (these are duplicates even if they have a different number). It defies the purpose of the SEO for urls.

I don't have any duplicate urls in the catalog but the product names are duplicated quite a bit. i.e. - (site.com/ford/truck), (site.com/chevy/truck), (site.com/dodge/truck)

 

However; the urls with only the product name in them (site.com/product_name) that you get when accessng a product from a module like manufacturers or what's new would be a duplicate if it did not get an index at the end.

Share this post


Link to post
Share on other sites
I may be misunderstanding what the Auto Names Builder does but I now know that SEO-G names/links cannot be created automatically if the product names are not unique, ... but I am still confused about Auto Names Builder. When does it automatically generate names? Does it add them any time you add a new unique product name to the catalog?

I don't have any duplicate urls in the catalog but the product names are duplicated quite a bit. i.e. - (site.com/ford/truck), (site.com/chevy/truck), (site.com/dodge/truck)

 

However; the urls with only the product name in them (site.com/product_name) that you get when accessng a product from a module like manufacturers or what's new would be a duplicate if it did not get an index at the end.

In this case you need to set the linkage of SEO-G types, for categories and products to the same value. (set them to 1). This will append the category with the product for the products links. It's really depends how you structure your store. The autobuilder automatically generates urls on the catalog end. But it's the linkage that is important to be set that way in your case.

 

All this is documented.

Share this post


Link to post
Share on other sites

Hi Mark, got SEO-G working now but encountered 2 problems. First is the google sitemap. If SEO-G XML Compress is true, when I download the XML file in the G-Report, it gives me an error when I extract the zip file.

 

Error:

goggle_sitemap.xml.gz: Unexpected end of archive

google_sitemap.xml.gz: CRC failed in google_sitemap.xml. The file is corrupt.

 

If SEO-G XML Compress is false, the file works fine when I download it.

 

The second problem is the affiliate program. We have an affiliate page and in the Reports section, we can see that it changes the URL from php to html but when I click on http://mto123.com/dev/affiliate/news.html, the page is blank. And in the G-Exclude, I can't find the scripts/files from the affiliate folder to exclude...

 

Is there a way to exclude these files?

Share this post


Link to post
Share on other sites
Hi Mark, got SEO-G working now but encountered 2 problems. First is the google sitemap. If SEO-G XML Compress is true, when I download the XML file in the G-Report, it gives me an error when I extract the zip file.

 

Error:

goggle_sitemap.xml.gz: Unexpected end of archive

google_sitemap.xml.gz: CRC failed in google_sitemap.xml. The file is corrupt.

check the server info from your osc admin, if you have zlib module

 

 

The second problem is the affiliate program. We have an affiliate page and in the Reports section, we can see that it changes the URL from php to html but when I click on http://mto123.com/dev/affiliate/news.html, the page is blank. And in the G-Exclude, I can't find the scripts/files from the affiliate folder to exclude...

 

Is there a way to exclude these files?

I see a cookies usage page here, probably means the url is not available and a redirect is taking place

Edited by enigma1

Share this post


Link to post
Share on other sites
when i set

Use Search-Engine Safe URLs (still in development) to false looks like the contrib dont work, because i see the url using Cpath.... (example http://www.domain.com/index.php?cPath=21)

and if set Search-Engine Safe URLs to Active i get the right url! (example http://www.domain.com/category.html)

 

Why it happend?

 

hope that someone can help me!

stock sefs should be set to false. Do you have a link to a category or product?

Edited by enigma1

Share this post


Link to post
Share on other sites
The left_column.php change is straight forward. When you add a line to include a new box it shows up with the osc admin. Check if you placed the files to the correct folders.

 

Sorry it has taken me awhile to reply, but I have redone the edits and for some reason I still have the same problem.

 

here is a link to the my test store http://sportivoconcepts.com/shop and here is a link to the zip files of the files I have edited. http://sportivoconcepts.com/uploads/v2.2[seo-g].zip

 

I do not know what I did wrong and I am usually not such a noob like this.


Powered By osC 2.2RC2a STS 4.5.8 - HTC 2.6.3 - FP 1.5.9 - BCH 1.0.0

Share this post


Link to post
Share on other sites
Sorry it has taken me awhile to reply, but I have redone the edits and for some reason I still have the same problem.

 

here is a link to the my test store http://sportivoconcepts.com/shop and here is a link to the zip files of the files I have edited. http://sportivoconcepts.com/uploads/v2.2[seo-g].zip

 

I do not know what I did wrong and I am usually not such a noob like this.

you haven't installed the module is simple as that. You only copied some files and I don't know where. Looking at the root.php I see this:

 

1146 - Table 'db152287237.TABLE_SEO_URL' doesn't exist

 

select seo_url_get, seo_url_org from TABLE_SEO_URL where seo_url_key = '569a9b713c6d7ff3fe644c260f4e6322'

 

[TEP STOP]

You need to go through the documentation and follow the manual instructions.

Share this post


Link to post
Share on other sites

I have installed the contrib but when I enable SEO Master in Admin and I test the linkage on the website, eg. www.marvuli.com/shop, I select a product and it displays the correct new SEO link in the status bar, but when I click on the link it takes me to the www.marvuli.com root. I know it has something to do with the porting of the root file but I think that I have done everthing as in the documentation. Can you please help.


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
I have installed the contrib but when I enable SEO Master in Admin and I test the linkage on the website, eg. www.marvuli.com/shop, I select a product and it displays the correct new SEO link in the status bar, but when I click on the link it takes me to the www.marvuli.com root. I know it has something to do with the porting of the root file but I think that I have done everthing as in the documentation. Can you please help.

have you moded the .htaccess file properly? Are there any other rules in it (other than SEO-G), or another .htaccess file that can control settings at the root of the domain?

Share this post


Link to post
Share on other sites
have you moded the .htaccess file properly? Are there any other rules in it (other than SEO-G), or another .htaccess file that can control settings at the root of the domain?

 

Here is my .htaccess file:

# -FrontPage-

 

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

 

<Limit GET POST>

order deny,allow

deny from all

allow from all

</Limit>

<Limit PUT DELETE>

order deny,allow

deny from all

</Limit>

AuthName www.marvuli.com

AuthUserFile /var/chroot/home/content/e/m/i/emilesteenkamp/html/_vti_pvt/service.pwd

AuthGroupFile /var/chroot/home/content/e/m/i/emilesteenkamp/html/_vti_pvt/service.grp

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

RewriteBase /shop/

RewriteRule ^(.*).html$ root.php?%{QUERY_STRING}

#-MS- SEO-G Added EOM


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
Here is my .htaccess file:

# -FrontPage-

 

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

 

<Limit GET POST>

order deny,allow

deny from all

allow from all

</Limit>

<Limit PUT DELETE>

order deny,allow

deny from all

</Limit>

AuthName www.marvuli.com

AuthUserFile /var/chroot/home/content/e/m/i/emilesteenkamp/html/_vti_pvt/service.pwd

AuthGroupFile /var/chroot/home/content/e/m/i/emilesteenkamp/html/_vti_pvt/service.grp

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

RewriteBase /shop/

RewriteRule ^(.*).html$ root.php?%{QUERY_STRING}

#-MS- SEO-G Added EOM

this looks to be from a protected folder. What is the .htaccess you have of the /shop/ folder. You need to follow the instructions and place the SEO-G changes to the right files.

Share this post


Link to post
Share on other sites
this looks to be from a protected folder. What is the .htaccess you have of the /shop/ folder. You need to follow the instructions and place the SEO-G changes to the right files.

 

Here is my .htaccess file of my /shop dir:

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

RewriteBase /shop/

RewriteRule ^(.*).html$ root.php?%{QUERY_STRING}

#-MS- SEO-G Added EOM


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
Here is my .htaccess file of my /shop dir:

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

RewriteBase /shop/

RewriteRule ^(.*).html$ root.php?%{QUERY_STRING}

#-MS- SEO-G Added EOM

 

ok can you make sure the other .htaccess files are clean? You should not put anything about this module in any other .htaccess file. Unless you know what you're doing.

 

So now where are the SEO-G links? I don't see them getting converted. Have you enabled the module are you done with the installation?

Share this post


Link to post
Share on other sites

I installed v1.16 of SEO-G and everything seemed to be OK except checkout and I think secure cookies.

 

My configuration has different paths for http and https files:

define('HTTP_SERVER', 'http://dressage-media.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://web78.secure-secure.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'dressage-media.com');

define('HTTPS_COOKIE_DOMAIN', 'web78.secure-secure.co.uk');

define('HTTP_COOKIE_PATH', '//');

define('HTTPS_COOKIE_PATH', '/dressage-media.com//');

 

When I'm in Cart Contents I see my items but checkout doesn't go to checkout-shipping.php as it should, it keeps me in cart contents.

Similarly, although I can creat an account ok, it doesn't remember me or my cart contents (secure cookies?).

I have set SEO-G admin to process secure pages false as instructed. In .htaccess I have set Rewritebase /

 

I upgraded to version 1.2 in the hope that this would fix my problem. When I ran the sql to update the database it has duplicated the entries in SEO-G configuration so I now have 2 entries for each setting. The readme seems to give instructions for a new install, but not for an upgrade. I backed up the database before running it but every time I get the same result.

 

Can you please help with both issues?

 

Thanks

Janet

Share this post


Link to post
Share on other sites
I installed v1.16 of SEO-G and everything seemed to be OK except checkout and I think secure cookies.

 

My configuration has different paths for http and https files:

define('HTTP_SERVER', 'http://dressage-media.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://web78.secure-secure.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'dressage-media.com');

define('HTTPS_COOKIE_DOMAIN', 'web78.secure-secure.co.uk');

define('HTTP_COOKIE_PATH', '//');

define('HTTPS_COOKIE_PATH', '/dressage-media.com//');

 

When I'm in Cart Contents I see my items but checkout doesn't go to checkout-shipping.php as it should, it keeps me in cart contents.

Similarly, although I can creat an account ok, it doesn't remember me or my cart contents (secure cookies?).

I have set SEO-G admin to process secure pages false as instructed. In .htaccess I have set Rewritebase /

 

I upgraded to version 1.2 in the hope that this would fix my problem. When I ran the sql to update the database it has duplicated the entries in SEO-G configuration so I now have 2 entries for each setting. The readme seems to give instructions for a new install, but not for an upgrade. I backed up the database before running it but every time I get the same result.

 

Can you please help with both issues?

 

Thanks

Janet

you can use phpmyadmin or this tool to get rid of the duplicate configuration entries.

http://www.oscommerce.com/community/contributions,5040

And I will update the documentation, although you suppose to read where it says database update between versions and do manual dbase updates.

 

Unless you put the code to properly identify secure connections, SEO-G won't work. It is in the documentation how to setup the application_top.php and root.php for this.

Edited by enigma1

Share this post


Link to post
Share on other sites
you can use phpmyadmin or this tool to get rid of the duplicate configuration entries.

http://www.oscommerce.com/community/contributions,5040

And I will update the documentation, although you suppose to read where it says database update between versions and do manual dbase updates.

 

Unless you put the code to properly identify secure connections, SEO-G won't work. It is in the documentation how to setup the application_top.php and root.php for this.

Thanks for the quick reply. I looked for info in the documentation but only found the list of modifications, not details of what to change.

Also not being very experienced with php I found the section on root & application_top difficult to understand and didn't think it applied to me as I haven't made modifications to application_top.

 

Anyway, I've done all that. The $request_type in application_top is the same as your example. I still get the same problem. I can't get from http://dressage-media.com//shopping_cart.php to checkout_shipping, and even when I have logged in I get the Welcome guest message, so it isn't recognising my account name.

Share this post


Link to post
Share on other sites
Also not being very experienced with php I found the section on root & application_top difficult to understand and didn't think it applied to me as I haven't made modifications to application_top.

Anyway, I've done all that. The $request_type in application_top is the same as your example. I still get the same problem. I can't get from http://dressage-media.com//shopping_cart.php to checkout_shipping, and even when I have logged in I get the Welcome guest message, so it isn't recognising my account name.

Well it's in the documentation. It is server dependent so you need to find what is the secure port

In addition the $request_type variable must be identified for SEO-G to function correctly. This is server dependent. The default osC code implements the following test:

 

// set the type of request (secure or not)

$request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

This may not work on every server. You need to identify the secure port or server/environment variable, here are couple of examples:

 

And you need to fix your configure.php what's this extra slash in between the domain and script???

dressage-media.com//shopping_cart.php

get rid of that.

Share this post


Link to post
Share on other sites
ok can you make sure the other .htaccess files are clean? You should not put anything about this module in any other .htaccess file. Unless you know what you're doing.

 

So now where are the SEO-G links? I don't see them getting converted. Have you enabled the module are you done with the installation?

 

I just enabled SEO-G again but it still does the same thing, I'll keep it enabled for a while so that you can see what it does, but the store is live so I don't want to keep it doing this for long.

I made sure there is not any other .htaccess files that has any info of SEO in it, there is only the .htaccess in the root dir but that is clean.


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
I just enabled SEO-G again but it still does the same thing, I'll keep it enabled for a while so that you can see what it does, but the store is live so I don't want to keep it doing this for long.

I made sure there is not any other .htaccess files that has any info of SEO in it, there is only the .htaccess in the root dir but that is clean.

 

I just cleaned the reports once more and now it seems to be fine, when I installed the mod I got 2 of each of the configurations, I enabled both and it seems fine, where can I go to delete the duplicated names, where in PHPmyAdmin.


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
I just enabled SEO-G again but it still does the same thing, I'll keep it enabled for a while so that you can see what it does, but the store is live so I don't want to keep it doing this for long.

I made sure there is not any other .htaccess files that has any info of SEO in it, there is only the .htaccess in the root dir but that is clean.

 

I just cleaned the reports once more and now it seems to be fine, when I installed the mod I got 2 of each of the configurations, I enabled both and it seems fine, where can I go to delete the duplicated names, where in PHPmyAdmin. What I did wass to exclude basically everything except the products as I only want the products to get URL friendlies and not the normal pages. I am going to test it now. Thanks for your help. Greatly appreciated!!!


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
I just cleaned the reports once more and now it seems to be fine, when I installed the mod I got 2 of each of the configurations, I enabled both and it seems fine, where can I go to delete the duplicated names, where in PHPmyAdmin. What I did wass to exclude basically everything except the products as I only want the products to get URL friendlies and not the normal pages. I am going to test it now. Thanks for your help. Greatly appreciated!!!

 

I just started testing and noticed that the left and right colums are much narrower than what they used to be, where can I change this to what it used to be?


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites
I just started testing and noticed that the left and right colums are much narrower than what they used to be, where can I change this to what it used to be?

 

In the root.php, there is a section for the application_top, do I need to copy the whole application_top file into this section? I saw there was a difference in the box_width, so this is why I ask.


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×