Jump to content
Sign in to follow this  
enigma1

[Contribution] SEO-G

Recommended Posts

I have upgraded the wonderful module and now I am trying to figure out why"information.php?info_id=1" didn't get translated to "faq.html".

 

I checked the seo_to_information in the database and everything seems okay. It looks like just only the last step in "translating" is not working. I also checked my SEO-G Report:

 

It only shows:

http://x.com/information.php to http://x.com/information.html

 

while for index.php it can show

http://x.com/index.php?cPath=1 http://x.com/scarfs.html

 

The information.php is not picking up the "info_id=1". Any help will be appreciated.

have you uncommented the support code from the catalog\includes\classes\seo_url.php? Search the code for "information pages unlimited" And activate the information pages unlimited in your osc Admin under the SEO-G types (click the status lamp to be at the green state).

Share this post


Link to post
Share on other sites
Hey guys.

 

I've a little problem over here. Once SEO-G is activated, every of my page link will be redirected to the cookie_usage.php page. I've gone through the pass post but can't find another resolution.

 

It would be great if someone can pinpoint the areas where the error occur such that I can dive into them and see what's wrong. Thanks.

This problem can be caused if your configure.php files isn't setup properly or the .htaccess. Start from there. Check the SEO-G documentation and sample files how to set them up properly.

Share this post


Link to post
Share on other sites

Hello,

 

I have tried to install SEO-G on a oscommerce. And all the categories is working fine.

 

But when I try to checkout the shop goes nuts.

 

The button has a strange link, something like www.domain.com/:///catalog/checkout_shipping.php

 

Does anyone know what the problem is?

 

Thanks in advance

Share this post


Link to post
Share on other sites
Hello,

 

I have tried to install SEO-G on a oscommerce. And all the categories is working fine.

 

But when I try to checkout the shop goes nuts.

 

The button has a strange link, something like www.domain.com/:///catalog/checkout_shipping.php

 

Does anyone know what the problem is?

 

Thanks in advance

start by checking the secure settings of your configure.php file. The included configure_example.php should help your to setup your store properly.

Share this post


Link to post
Share on other sites

first of all i wan't to thank you for this great contribution. It works fine, but i see some strange urls that the google bot want to index.

For example:

  • /linksSEO_DEFAULT_EXTENSION
  • /4?page=2
  • allprodsSEO_DEFAULT_EXTENSION
  • best_sellersSEO_DEFAULT_EXTENSION
  • 4?action=buy_now&products_id=32

Can i do something to stop this? I'am using the latest version.

Share this post


Link to post
Share on other sites

Hey Mark,

 

I realize where's the error coming from after I did a check on root.php . I left out the codes mentioned on the top section of the file and after including them, every time's working fine.

 

Thanks, a really great contribution.


Warmest Regards,

You Teck

Share this post


Link to post
Share on other sites

Hey Mark,

 

I realize where's the error coming from after I did a check on root.php . I left out the codes mentioned on the top section of the file and after including them, every thing's working fine now.

 

Thanks, a really great contribution.


Warmest Regards,

You Teck

Share this post


Link to post
Share on other sites

Hi Mark.

 

Brilliant contribution - thank you. The Google sitemap feature is incredibly useful.

 

Well done.

 

Regards,

 

 

Graham.

Share this post


Link to post
Share on other sites
first of all i wan't to thank you for this great contribution. It works fine, but i see some strange urls that the google bot want to index.

For example:

  • /linksSEO_DEFAULT_EXTENSION
  • /4?page=2
  • allprodsSEO_DEFAULT_EXTENSION
  • best_sellersSEO_DEFAULT_EXTENSION
  • 4?action=buy_now&products_id=32

Can i do something to stop this? I'am using the latest version.

What modules are you using. What's the difference from the stock osc. Looks like the dbase is not setup properly for the configuration.

 

can you post a link to a product so I can see what's going on?

Share this post


Link to post
Share on other sites

Hi,

 

First of all, thank you very much for this excellent contribution. I have installed it and it working fine except for 4 problems.

 

1- when I add items to the shopping cart, I get no items in the cart. When I set SEO_G master Switch to false it will add the item but the url doesn't change for categories. Also, it doesn't keep my session. after I login, and browse somewhere else, it will delete the items in the cart.

2. I had some problem with the database, and I reinstalled it and now I have 3 fields for each configuration field. I have attached an image. Is there away to take care of this

3. how to change the setting for the size of the page. Please go to http://texastire-wheel.com you will see that the right column is fine until the url changes and the left column gets resize.

4. How to get rid of the osCsid id? I have attached my config file.

 

Your help is highly appriciated.

 

 

Thanks,

Gus

Share this post


Link to post
Share on other sites
Hi,

 

First of all, thank you very much for this excellent contribution. I have installed it and it working fine except for 4 problems.

 

1- when I add items to the shopping cart, I get no items in the cart. When I set SEO_G master Switch to false it will add the item but the url doesn't change for categories. Also, it doesn't keep my session. after I login, and browse somewhere else, it will delete the items in the cart.

2. I had some problem with the database, and I reinstalled it and now I have 3 fields for each configuration field. I have attached an image. Is there away to take care of this

see post #398 in this thread for the duplication,

3. how to change the setting for the size of the page. Please go to you will see that the right column is fine until the url changes and the left column gets resize.

see post #365 in this thread

 

4. How to get rid of the osCsid id? I have attached my config file.

for the sessions I don't know could be your configure.php file, can you post your .htaccess and catalog\includes\configure.php minus the dbase sensitive info. (I do not see any files attached) Is unlikely the SEO-G code alters that. Could be something wrong with the installation you did.

Edited by enigma1

Share this post


Link to post
Share on other sites
What modules are you using. What's the difference from the stock osc. Looks like the dbase is not setup properly for the configuration.

 

can you post a link to a product so I can see what's going on?

 

I totally forgot that I changed the SQL statements, because it gave errors at the mysql version that my host is using. It didn't like that primary keys have a default value of zero, for example: categories_id int(11) default NULL.

This is the error that I get: ERROR 1171: All parts of a PRIMARY KEY must be NOT NULL; If you need NULL in a key, use UNIQUE instead

 

So I tried to be smart and changed the statement in: categories_id int(11) NOT NULL default '0'.

 

Here is a link to a product: http://www.islamproducten.nl/kookboek-deserts.html

 

thanks in advance

Share this post


Link to post
Share on other sites
see post #398 in this thread for the duplication,

 

see post #365 in this thread

for the sessions I don't know could be your configure.php file, can you post your .htaccess and catalog\includes\configure.php minus the dbase sensitive info. (I do not see any files attached) Is unlikely the SEO-G code alters that. Could be something wrong with the installation you did.

 

Thank you so much for your reply and your help. Please see the code below

 

////////////.htaccess/////////////////

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

ErrorDocument 400 /http_error.php?error_id=400

ErrorDocument 401 /http_error.php?error_id=401

ErrorDocument 403 /http_error.php?error_id=403

ErrorDocument 404 /http_error.php?error_id=404

ErrorDocument 405 /http_error.php?error_id=405

ErrorDocument 408 /http_error.php?error_id=408

ErrorDocument 415 /http_error.php?error_id=415

ErrorDocument 500 /http_error.php?error_id=500

ErrorDocument 501 /http_error.php?error_id=501

ErrorDocument 502 /http_error.php?error_id=502

ErrorDocument 503 /http_error.php?error_id=503

ErrorDocument 505 /http_error.php?error_id=505

ErrorDocument 504 /http_error.php?error_id=504

 

#-MS- SEO-G Added

Options +FollowSymLinks

RewriteEngine On

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING

#-MS- SEO-G Added EOM

 

 

#NOTE: if you've installed the catalog in a different directory, change /catalog/ above.

////END Of .htaccess file///////////////////

 

 

///////////configure file//////////////////

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://texastire-wheel.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://texastire-wheel.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'texastire-wheel.com/');

define('HTTPS_COOKIE_DOMAIN', 'texstire-wheel.com/');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/hsphere/local/home/texastir/texastire-wheel.com/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'mysql7.hostexcellence.com'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'mylogin');

define('DB_SERVER_PASSWORD', 'mypasswprd');

define('DB_DATABASE', '*********');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

define("ADMIN_EMAIL","************");

$admin_email_params=array('host' => '******',

'auth' => true,

'username' => '**********',

'password' => '********');

/*define('DIR_WS_TEMPLATES', 'templates/'); //used for the templates

define('DIR_WS_CONTENT', DIR_WS_TEMPLATES . 'content/'); //used for the templates

define('DIR_WS_JAVASCRIPT', DIR_WS_INCLUDES . 'javascript/'); //used for the templates*/

?>

Edited by gus21

Share this post


Link to post
Share on other sites
Thank you so much for your reply and your help. Please see the code below

your .htaccess is incorrect

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING

 

is missing the last character a closing bracket. Make sure you copy it exactly from the documentation

Share this post


Link to post
Share on other sites
I totally forgot that I changed the SQL statements, because it gave errors at the mysql version that my host is using. It didn't like that primary keys have a default value of zero, for example: categories_id int(11) default NULL.

This is the error that I get: ERROR 1171: All parts of a PRIMARY KEY must be NOT NULL; If you need NULL in a key, use UNIQUE instead

 

So I tried to be smart and changed the statement in: categories_id int(11) NOT NULL default '0'.

 

Here is a link to a product: http://www.islamproducten.nl/kookboek-deserts.html

 

thanks in advance

yes this is a bug with SEO-G will be fixed with the next version, for the dbase fields.

 

for the strange links you mentioned where do you see it? I checked what google indexed from your store seems there are no SEO-G links yet. Do these links show with the SEO-G reports page?

Share this post


Link to post
Share on other sites
your .htaccess is incorrect

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING

 

is missing the last character a closing bracket. Make sure you copy it exactly from the documentation

 

 

It works great now. Thanks alot for your great contribution and all your help.

Share this post


Link to post
Share on other sites

Hi Mark,

 

I have installed the SEO-G version 1.2 on my new oscommerce installation which is hosted at bluehost.com.

I have also followed the instructions. However, it seems there is a problem with the .htaccess file. I cant access the pages in the admin. each time I am redirected to cookie_usage.php with a message "We have detected that your browser does not support cookies, or has set cookies to be disabled."

 

When I commented the SEO-G lines in the .htaccess file the admin works fine. The front store however, works ok with very friendly URLs.

 

What seems to be the problem?

 

Thanks,

Hanan

Edited by hbenlulu

Share this post


Link to post
Share on other sites
yes this is a bug with SEO-G will be fixed with the next version, for the dbase fields.

 

for the strange links you mentioned where do you see it? I checked what google indexed from your store seems there are no SEO-G links yet. Do these links show with the SEO-G reports page?

 

All links in the report page looks normal, but when i look for example in who is online I see the following things.

  • Goole is trying to index the old links ---> good thing
  • Google is trying to index the new SEO-G links ----> good thing
  • Google is trying to index some strange urls ---> bad thing

I also see those links in my google webmaster help program --> webcrawl errors ---> links not found.

 

thanks in advance

Share this post


Link to post
Share on other sites
All links in the report page looks normal, but when i look for example in who is online I see the following things.
  • Goole is trying to index the old links ---> good thing
  • Google is trying to index the new SEO-G links ----> good thing
  • Google is trying to index some strange urls ---> bad thing

I also see those links in my google webmaster help program --> webcrawl errors ---> links not found.

 

thanks in advance

are you using other modules like multi-store? or are you using different databases? Why the SEO_DEFAULT_EXTENSION is appended? This may happen if the dbase configuration switch isn't there in some cases. Which implies different dbases or different config tables.

Share this post


Link to post
Share on other sites
Hi Mark,

 

I have installed the SEO-G version 1.2 on my new oscommerce installation which is hosted at bluehost.com.

I have also followed the instructions. However, it seems there is a problem with the .htaccess file. I cant access the pages in the admin. each time I am redirected to cookie_usage.php with a message "We have detected that your browser does not support cookies, or has set cookies to be disabled."

 

When I commented the SEO-G lines in the .htaccess file the admin works fine. The front store however, works ok with very friendly URLs.

 

What seems to be the problem?

 

Thanks,

Hanan

Could be your .htaccess or configure.php files aren't setup properly. The SEO-G documentation also shows what to do, to override the SEO-G settings for the admin folder via the admin\.htaccess

Share this post


Link to post
Share on other sites

I no longer get the full "path" in the URL for the products in my catalog (site.com/category1/category2/product1.html). I get the full path for everything up to the products page (site.com/category1/category2.html), but when I click on the actual products on any of the products pages, the url only shows the domain and product (site.com/product1.html). I know this is the default URL for all listings in "new products", "all-products" and "manufacturers" pages, but is there a way to make all urls in the catalog show the full path for products?

Share this post


Link to post
Share on other sites

Thanks Mark for a great contribution. :thumbsup: I have used it on my localhost for several weeks now and it worked well for me without any problems. However, when I uploaded it to my live domain I would receive server error 500. I read throughout the post and could not find a solution. With the help of my hosting company empress connections hosting, I was able to find a solution which is this

 

change

 

#-MS- SEO-G Added

Options -Indexes

Options FollowSymLinks

RewriteEngine on

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /catalog/

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

 

To this

 

#-MS- SEO-G Added

#Options -Indexes

#Options FollowSymLinks

RewriteEngine on

# Next line must be changed to match your osCommerce folder - the relative path

RewriteBase /catalog/

RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}

#-MS- SEO-G Added EOM

 

You have to remove or comment out ( using # ) these lines:

 

Options -Indexes

Options FollowSymLinks

 

That worked for me Thanks,

Culturebee

 

P.S. Thank empress connections hosting for there quick response and help :thumbsup:

Share this post


Link to post
Share on other sites
Thanks Mark for a great contribution. I have used it on my localhost for several weeks now and it worked well for me without any problems. However, when I uploaded it to my live domain I would receive server error 500. I read throughout the post and could not find a solution.

I don't know how you ended up with that .htaccess in the first place. The documentation lists

#-MS- SEO-G Added
Options +FollowSymLinks
RewriteEngine On
# Next line must be changed to match your osCommerce folder - the relative path 
RewriteBase /catalog/
RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING}
#-MS- SEO-G Added EOM

 

and this typically works with most apache servers. Sometimes you may have to remove the followsymlinks, depends on the server settings but with a local server the default settings work.

 

So I've no plans to change anything about the .htaccess.

Edited by enigma1

Share this post


Link to post
Share on other sites
I no longer get the full "path" in the URL for the products in my catalog (site.com/category1/category2/product1.html). I get the full path for everything up to the products page (site.com/category1/category2.html), but when I click on the actual products on any of the products pages, the url only shows the domain and product (site.com/product1.html). I know this is the default URL for all listings in "new products", "all-products" and "manufacturers" pages, but is there a way to make all urls in the catalog show the full path for products?

You can change the linkage column in G-Types. Set it for products, categories, manufacturers to the same value (default 1). This will force SEO-G to concatenate the parameters for generated links.

Edited by enigma1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×