Jump to content
Sign in to follow this  
enigma1

[Contribution] SEO-G

Recommended Posts

That hasn't had any effect on my live site. On my local site it either doesn't change the URL or it causes the product URL to appear the same as the category URL.

you need to clear the reports if you change the linkage. And it's fully functional. You need to set the linkage accordingly Products must have lower values than Categories otherwise you will get problems if the cPath overrides the products_id. Lower values have priority overriding. See the documentation.

Share this post


Link to post
Share on other sites
I will do some more testing and include the fix with the next version.

 

Thanks for the report.

 

Thanks for the fix. It works a treat.

Share this post


Link to post
Share on other sites

Release v1.20 is now available with the following features/bug fixes.

 

- Added SEO support for Authors for the articles manager.

- Added SEO support for Information Pages Unlimited

- Added SEO support for Links Manager

- Added Separate redirection table with configurable redirection number for each URL..

- Fix for the links targeted by secondary handlers with directory structures.

 

http://www.oscommerce.com/community/contributions,5080

 

The documentation is also updated. Added examples and pointers to this thread for better utilization of the module.

Share this post


Link to post
Share on other sites
Ok, for the ipn.php I don't know the file you're using but in general any php file in your store that is called separately (ie is not part of the osc framework) and has a visible link (ie it goes through the tep_href_link function) you place it in the exclusion list so SEO-G does not tranlate it. Because such files may not include the application_top.php file. So goto osC Admin->SEO-G->G-Exclude and add the ipn.php in it. See if that works. (I will make a note in the documentation for the next version about this).

 

For elmar ask stefan for details (post in the elmar support forum), I do not know how the module works I briefly checked the files and seems it parses server parameters that perhaps SEO-G does not rectify. The problem I have is the description is not in English so I am having a hard-time understanding the code flow.

 

Hi,

 

i just tried to exclude the file, but the file isnt in root directory, so i cant add it.

How can i add a file when it isnt in the root-directory ? I have take a look in the DB,

but there is an "seo_exclude_key" ... So, is this possible ?

 

TIA

 

 

Tyv

Share this post


Link to post
Share on other sites
Hi,

 

i just tried to exclude the file, but the file isnt in root directory, so i cant add it.

How can i add a file when it isnt in the root-directory ? I have take a look in the DB,

but there is an "seo_exclude_key" ... So, is this possible ?

 

TIA

Tyv

then it's not applicable. Only root files are processed by SEO-G. The mod rewrite is in the root of the osC folder. And any other folders beneath are not passed through the tep_href_link function so there is no conversion. Now if you have a root file that includes your ipn.php you need to locate it but I don't understand your original question.

Share this post


Link to post
Share on other sites

ipn.php was in the dropdown list on the exclude page in the admin panel, so I excluded it, but the last order that went through on paypal also stuck at pending and didn't update to paypal authorised. I've checked the list and there are a couple more paypal IPN files on the list so I've done those too. If it comes to it I'll exclude everything that's part of the checkout process and see where that takes me.

Share this post


Link to post
Share on other sites
ipn.php was in the dropdown list on the exclude page in the admin panel, so I excluded it, but the last order that went through on paypal also stuck at pending and didn't update to paypal authorised. I've checked the list and there are a couple more paypal IPN files on the list so I've done those too. If it comes to it I'll exclude everything that's part of the checkout process and see where that takes me.

theoretically that shouldn't matter. Because as long as you build your links via the tep_href_link function the form links will also be converted and then decoded. For instance I have it working with .html links going and coming from paypal.

Share this post


Link to post
Share on other sites

Well something's not working! Am using the devosc IPN rather than the official one though, so perhaps there's the difference?

Share this post


Link to post
Share on other sites
Well something's not working! Am using the devosc IPN rather than the official one though, so perhaps there's the difference?

there is, that particular implementation has its own application_top.inc.php to begin with. So it has to be customized in a similar way as with the regular application_top. But this goes outside the scope of the SEO-G

Share this post


Link to post
Share on other sites

I just installed your new Release v1.20, and it's running well.

 

I was wondering about the new support features for:

 

- Added SEO support for Authors for the articles manager.

- Added SEO support for Information Pages Unlimited

- Added SEO support for Links Manager

 

Are these related modules? I'm looking for information about them. Please supply links, if possible. Thanks.

 

Aloha!

Edited by waverider75

Share this post


Link to post
Share on other sites
I just installed your new Release v1.20, and it's running well.

 

I was wondering about the new support features for:

 

- Added SEO support for Authors for the articles manager.

- Added SEO support for Information Pages Unlimited

- Added SEO support for Links Manager

 

Are these related modules? I'm looking for information about them. Please supply links, if possible. Thanks.

 

Aloha!

There in the admin\includes\classes\ folder, the seo class files. The url is listed in the header section. I will also update the documentation to list the links with the next version.

http://www.oscommerce.com/community/contributions,1026

http://www.oscommerce.com/community/contributions,1256

http://www.oscommerce.com/community/contributions,1709

Haven't done extensive testing with these.

Share this post


Link to post
Share on other sites

Hello,

 

did anybody use elmar with this contribution ? Does it work ?

 

I cant get it work, alwaays the same error. I installed the update 1.20, enabled seo in elmar, .. but the same error:

Fatal error: Call to a member function on a non-object in /var/www/vhost/damrotech-test/includes/functions/html_output.php on line 76

Line 76 in html_output.php: $link = $g_seo_url->get_seo_url($link, $separator);

 

Hum, anybody any idea ?

Share this post


Link to post
Share on other sites
Hello,

 

did anybody use elmar with this contribution ? Does it work ?

 

I cant get it work, alwaays the same error. I installed the update 1.20, enabled seo in elmar, .. but the same error:

Fatal error: Call to a member function on a non-object in /var/www/vhost/damrotech-test/includes/functions/html_output.php on line 76

Line 76 in html_output.php: $link = $g_seo_url->get_seo_url($link, $separator);

 

Hum, anybody any idea ?

As I mentioned earlier I am not familiar with that module. But the error perhaps indicates another "application_top.php" type file. So search your files see if there is another one somewhere. Also see the post in the previous page about the ipn.php. Could be a similar issue. You need to customize these files to include the seo-g class like is done with the regular application_top.php

Share this post


Link to post
Share on other sites
Hello,

 

did anybody use elmar with this contribution ? Does it work ?

 

I cant get it work, alwaays the same error. I installed the update 1.20, enabled seo in elmar, .. but the same error:

Fatal error: Call to a member function on a non-object in /var/www/vhost/damrotech-test/includes/functions/html_output.php on line 76

Line 76 in html_output.php: $link = $g_seo_url->get_seo_url($link, $separator);

 

Hum, anybody any idea ?

 

Here is an alternative you can do in html_output.php I tested the code a bit it may help you in this case if you cannot locate what's going on with other files that require the seo-g class being defined

 

in catalog\includes\function\html_output.php find this code:

if( $connection == 'NONSSL' || SEO_PROCESS_SSL == 'true' )

$link = $g_seo_url->get_seo_url($link, $separator);

 

 

change it to:

	if( isset($g_seo_url) && is_object($g_seo_url) ) {
  if( $connection == 'NONSSL' || SEO_PROCESS_SSL == 'true' )
	$link = $g_seo_url->get_seo_url($link, $separator);
}

 

So basically I added an extra validation step, if the SEO-G class is not defined for whatever reason the system will not attempt to call it. I will include it with the next version.

Edited by enigma1

Share this post


Link to post
Share on other sites

Any help fella's, I have installed this contribution and I get

 

Parse error: syntax error, unexpected $end in /var/www/vhosts/pdas4u.co.uk/httpdocs/shop/includes/application_top.php on line 530

 

 

Cheers

Keith

Share this post


Link to post
Share on other sites
Any help fella's, I have installed this contribution and I get

 

Parse error: syntax error, unexpected $end in /var/www/vhosts/pdas4u.co.uk/httpdocs/shop/includes/application_top.php on line 530

Cheers

Keith

see post #215 in this thread.

Share this post


Link to post
Share on other sites

Just a quick question - my host uses a zues server - am I able to use this cont?

 

Thanks

Share this post


Link to post
Share on other sites
Just a quick question - my host uses a zues server - am I able to use this cont?

 

Thanks

I don't think it will work by default, you will have to customize the server scripts as far I can tell.

Share this post


Link to post
Share on other sites
As I mentioned earlier I am not familiar with that module. But the error perhaps indicates another "application_top.php" type file. So search your files see if there is another one somewhere. Also see the post in the previous page about the ipn.php. Could be a similar issue. You need to customize these files to include the seo-g class like is done with the regular application_top.php

 

Hu,

 

i found the problem. Im useing another application_top for elmar ... so after i modified it, all works great ... my fault. It was a long time ago, so dont remember all changes ...

 

Great Contrib, thanks

Share this post


Link to post
Share on other sites

I was looking into your cache recommendations and found a typo in the readme file for the 5029 contribution link.

Both links point to the 2873 contribution.

 

Your readme file provides a list of all the specific changes for each new version making it easy to upgrade from a previous version without uninstalling/reinstalling the entire contribution. I wish there was a way to make the minor OSC version changes without starting over from scratch each time like I do with SEO-G.

Thanks again for your awesome contribution. SEO-G should be used as a model for not only other contributions, but for OSC itself.

Share this post


Link to post
Share on other sites
I was looking into your cache recommendations and found a typo in the readme file for the 5029 contribution link.

Both links point to the 2873 contribution.

 

Your readme file provides a list of all the specific changes for each new version making it easy to upgrade from a previous version without uninstalling/reinstalling the entire contribution. I wish there was a way to make the minor OSC version changes without starting over from scratch each time like I do with SEO-G.

Thanks again for your awesome contribution. SEO-G should be used as a model for not only other contributions, but for OSC itself.

Allright thanks, I will update the documentation with the next version to correct the link.

Share this post


Link to post
Share on other sites

Hey guys.

 

I've a little problem over here. Once SEO-G is activated, every of my page link will be redirected to the cookie_usage.php page. I've gone through the pass post but can't find another resolution.

 

It would be great if someone can pinpoint the areas where the error occur such that I can dive into them and see what's wrong. Thanks.


Warmest Regards,

You Teck

Share this post


Link to post
Share on other sites

Hey guys.

 

I've a little problem over here. Once SEO-G is activated, every of my page link will be redirected to the cookie_usage.php page. I've gone through the pass post but can't find another resolution.

 

It would be great if someone can pinpoint the areas where the error occur such that I can dive into them and see what's wrong. Thanks.


Warmest Regards,

You Teck

Share this post


Link to post
Share on other sites

I have upgraded the wonderful module and now I am trying to figure out why"information.php?info_id=1" didn't get translated to "faq.html".

 

I checked the seo_to_information in the database and everything seems okay. It looks like just only the last step in "translating" is not working. I also checked my SEO-G Report:

 

It only shows:

http://x.com/information.php to http://x.com/information.html

 

while for index.php it can show

http://x.com/index.php?cPath=1 http://x.com/scarfs.html

 

The information.php is not picking up the "info_id=1". Any help will be appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×