Jump to content
Sign in to follow this  
Razorx3d

I have problem withcatalog when try to add in greek

Recommended Posts

when i try to add a new catalog or new item in admin console and want to write it in greek the word after the 4-5 letter appear like this word why?(i wrote english word so you can understand were the problem is) can someone help me everywere else the greek words are ok except insede the admin and also in shop if i create new catlog or item.

 

 

help me please i am despert. :'(

Share this post


Link to post
Share on other sites

Hello Razorx3d,

 

you need to change your varchar(32) to varchar(255) in categories_description in your phpmyadmin.

 

Hope this helps - It didn't help me though :(

Edited by Pizelli

Share this post


Link to post
Share on other sites

i am sorry but cant find that varchar(32) to varchar(255) were is this opption i my phpmyadmin i cant find it. plaese heeeelp someone

Share this post


Link to post
Share on other sites

Select Greek from main admin panel before editing categories / products.

Share this post


Link to post
Share on other sites
Select Greek from main admin panel before editing categories / products.

the problem is i can not select greek language in catalog, despite that i have installed it already. :blush:

Share this post


Link to post
Share on other sites

You have to install the language files (admin and catalog) and you have to install the language through your admin / Localization / Languages.

 

Changing following setting in the file: catalog/admin/includes/languages/english.php

 

define('CHARSET', 'iso-8859-1');

 

to

 

define('CHARSET', 'iso-8859-7');

 

enables you to add greek characters without a problem in your admin (if iso is used)

Share this post


Link to post
Share on other sites
Guest

Still scrambled.

 

I have enabled Greek on my Mac just about everywhere.

 

Yassou!

Share this post


Link to post
Share on other sites

Well. I found a workaround....that in ../Languages you need to specify your language..ie greek.php but that probebly will not work since there is asked for a .php file....so change your greek.php to .php ( leave greek out). Give it a try...it worked for me...DO NOT FORGET TO SAVE YOUR greek.php FIRST. :thumbsup:

( I realise it is part of the problem ).

Share this post


Link to post
Share on other sites

I run into similar problems.

Changing the charset in the admin/includes/languages/english.php to 8859-7 did fix my following problem:

I installed the greek zones/taxes, but since I could not enter the greek .sql I mported the english one and edited all the entries to greek via the administration tool. The displaying of the names was fine (apart from the administration-shop location) but I the creation of new users was impossible. The droplist had all the zones correctly, but no matter which one you'd choose it complained again that you had to choose one.

 

 

The catalog entries got fixed with the varchar(255) that also appled to zone names.

 

When you guys mean you installed the greek language pack I'm assuming you're talking about the greek-iso contribution?

Share this post


Link to post
Share on other sites
Guest
I run into similar problems.

Changing the charset in the admin/includes/languages/english.php to 8859-7 did fix my following problem:

I installed the greek zones/taxes, but since I could not enter the greek .sql I mported the english one and edited all the entries to greek via the administration tool. The displaying of the names was fine (apart from the administration-shop location) but I the creation of new users was impossible. The droplist had all the zones correctly, but no matter which one you'd choose it complained again that you had to choose one.

 

 

The catalog entries got fixed with the varchar(255) that also appled to zone names.

 

When you guys mean you installed the greek language pack I'm assuming you're talking about the greek-iso contribution?

 

varchar(255) does the trick if anyone else gets the same problem.

Edited by 2progressive

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×