Jump to content
Sign in to follow this  
Pnop

Worldpay V3c

Recommended Posts

Hi,

I have installed V3c and everything appears to be working ok except for the fact it doesn't add the order to orders, anyone else had the same problem?

Share this post


Link to post
Share on other sites

Make sure you have uploaded the Result C/Y files to your worldpay installation and are running a recent snapshot of OS 2.2. Otherwise, please give more details.


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

Hi, Ian.

Thanks for replying.

 

I have followed the install instructions to the letter and upload the c&y results pages as per those instructions.

 

When I make a test purchase the transaction appears to be fine and I get all the replies etc. But the order doesn't show up in the orders list and consequently doesn't get emailed to us?

 

Could it be anything to do with the return url in the worldpay admin?

 

Please bear with us as we are new to php aswell!

Share this post


Link to post
Share on other sites

Hi

 

No - not that. Callback in worldpay is not actually used for this mod, so should be switched off.

 

Return to the store is controlled by the c/y files. If the transaction is cancelled, the customer will be returned to the payment page and if it is successful, to the checkout confirmation page (actually checkout_process.php). Clearly, if you go back to the payment page the transaction is not completed so no order details added etc. And if the checkout confirmation page, then the order process will complete correctly.

 

Does this happen? If not what does?


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

The check out operation goes right through and and says sucess etc. I even get the mail from world pay saying this but the order doesn't appear on list in admin or os doesn't email through to us?

Share this post


Link to post
Share on other sites

hi guys, I want to know if i am setting this up right as well..

i have uploaded the c/y files, when u go to my site,

www.asroma-addict.com/catalog/

 

-->make a purchase, u get to the /checkout_confirmation.php, click on "confirm order", u are then sent to the owrld pay secure page, for their test site "bmycharity"...put in the dummy credit card number, and volia it works

 

...but the end user does not get redirected back to my page...nor do i recieve any order confirmation via emails or from the admin...is this because of that we are using the test site "bmycharity" and not our own?

 

Ian, since you are the master with WorldPay I was wondering if you can tell me whether I did right or did wrong?

 

---here's one last thing, i never updated the c & y files, do i need to put any info in there?? :?:

 

thanks

Share this post


Link to post
Share on other sites

Is the double ">"> correct at the end of this section?

 

<meta http-equiv="Refresh" content="0; url=<wpdisplay item="MC_failURL">">

Share this post


Link to post
Share on other sites
hi guys, I want to know if i am setting this up right as well..

i have uploaded the c/y files, when u go to my site,

www.asroma-addict.com/catalog/

 

-->make a purchase, u get to the /checkout_confirmation.php, click on "confirm order", u are then sent to the owrld pay secure page, for their test site "bmycharity"...put in the dummy credit card number, and volia it works

 

...but the end user does not get redirected back to my page...nor do i recieve any order confirmation via emails or from the admin...is this because of that we are using the test site "bmycharity" and not our own?

 

Ian, since you are the master with WorldPay I was wondering if you can tell me whether I did right or did wrong?

 

---here's one last thing, i never updated the c & y files, do i need to put any info in there?? :?:

 

thanks

 

This is the same that happens to us. Is it down to being in test mode?

The success page comes through and everything just not updated in oscommerce.

Thank you, your payment was successful

Merchant's Reference:

WorldPay Transaction ID:

This was NOT a live transaction - no money has changed hands

 

Please contact WorldPay immediately if there has been a problem making your payment.

 

Then nothing? No redirect back or finish is that what is supposed to happen?

Share this post


Link to post
Share on other sites

I get the emails confirming order from worldpay and the customer one but nothing is updated in oscommerce?

Share this post


Link to post
Share on other sites

Lots of questions and lots of issues still with worldpay. half this forum is taken up with WorldPay issues (or so it seems..)

 

The double ">"> is correct.

You must load the c/y files from the mod to worldpay to work correctly.

 

If you get the emails from worldpay and are directed back to the 'Success' part of the store but are not getting a completed order, then the problem could be with session ids timing out - or ... one thought, are you using search engine safe urls with all cookies disabled? As I dont think that will work either?


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites
If you get the emails from worldpay and are directed back to the 'Success' part of the store but are not getting a completed order, then the problem could be with session ids timing out - or ... one thought, are you using search engine safe urls with all cookies disabled? As I dont think that will work either?

 

Please explain?

I am using IE6 and I have worldpay enable in the options for cookies, is that what you are talking about?

How do I alter session ids timing out or what are safe urls?

 

Told you I was newish to php and the likes!

 

Thanks for helping though

Share this post


Link to post
Share on other sites

One further trick I have suggested before, is to replace the form post in the worldpay.php file with a mailto: youremailaddress so that you can see what is being posted to worldpay and check that session ids etc are shown. If you do this, you will get a visus warning from your PC and then an email to yourself with a txt file attachment.


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites
I have worldpay enable in the options for cookies, is that what you are talking about?

How do I alter session ids timing out or what are safe urls?

 

safe urls use '/' rather than '?' - check your store urls to see what you are using.

 

When IE security / Privacy is set to the highest level, all cookies are stopped so the store has to keep track of the customer by adding the session ids to the url string. But as it is, there are still problems with this aspect of OS. So if the session ids get 'lost' or time out, the store has no way to know who the customer was when it gets the return from WP. It is easy to tell actually. Just log in then close down all browser windows. Then go back to your store again. Are you still logged in?


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

Another problem here though with the not emailing order!

The items are staying in the customers shopping cart.

So you log out of the shop and then go back in and the items are still in the cart?

 

Please advise onsteps to correct anyone!

Share this post


Link to post
Share on other sites

Okay - I dont know what your problem is :( but I can tell you that all your issues ARE related to the same problem which is to do with NOT completing the checkout_process.

 

I can also tell you that I am using this module myself and just did a test transaction with no problem so there should be no issue with Worldpay or the mod.

 

The issue to look at is why do you not complete the checkout_process or if you do, why does it not remeber the Session id? Really, you can only discover this if you check what is being posted and received back. ie make sure that the information that comes back from WP is the same as that sent and that both include the SID.


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

i sincery apologize for my last post Ian...

i was just informed by WorldPay that I was using the wrong id (was using my company id instead of install id)

i apologize again Ian

made a test purchase, it got updated in my admin and received an email

 

now what i am looking at is the md5 install...any thoughts on that?

Share this post


Link to post
Share on other sites

No problem - version 3c should work with MD5 but take a look at the main WP module to see how the MD5 string is created - you may want a different mix of fields to the ones I setup.


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

I have tried (god knows I have tried!) everything in this thread, updated the C/Y files on worldpay ver 3C using a pre november snapshot.

 

Worldpay confirms the payment, but still no record of the order in the admin panel.

 

All cookies are enabled in the browser and search engine safe url's are set to false but still the last stage is missing!

 

 

What could it be :?:

 

(By the way, what does happen when a order comes in, apart from the order being flagged in the admin panel?)

 

:( :roll:

 

Penge

Share this post


Link to post
Share on other sites

You should see the 'Order Success' page in your store when the customer is returned to it from WP if the transaction is successful or the payments page if it is not.

 

What page do you get?


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

The last few steps are as follows:

'I'm ready to purchase' page shows the products, sub-total, tax, shipping, total, delivery address, payment method.

Press 'confirm order'

I goes to 'https://select.worldpay.com/wcc/purchase' in the same browser window.

Fill out the card number, details and name. The card holders details are correct.

Select 'make payment' and new page is loaded saying the payment was successful, merchant ref and transaction ID and that's it !!

 

I do receive confirmation emails from shopper@worldpay and orders@worldpay, but going back to the admin, no orders are pending, processed or delivered.

 

I cannnot get back to my shop unless I reload the url. When I go back to the shop, it recognises me and welcomes me back but nothing is shown in the shopping cart until I log in. Then my previous selections are shown, the ones which I tried to purchase previously.

 

If it recognises me and knows I have items in the cart, should it display them without having to log in?

 

Does worldpay have to confirm the successful payment back to the shop?

 

Penge

Share this post


Link to post
Share on other sites

Make sure that you have the OS supplied Result C / Y forms loaded to WP and that you have NOT selected Callback.

 

Your problem is that the C / Y forms are not loading - they do this is a planned error situation - WP tries to callback, fails and so tries the C/ Y forms. These have a built in auto-redirect that takes you back to the store. Without them, you will hang on WPs default banner page.


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

thanks for sticking with this...

 

Your right, the is that the C / Y forms are not loading.

 

The resultY & resultC.html files are in the /catalog directory and are the same as version 3C worldpay mod.

 

I do not have the callback option in my worldpay module

 

Allow Worldpay

1

 

Worldpay ID

*****

 

Mode

100

 

Use MD5

0

 

MD5 secret key

Share this post


Link to post
Share on other sites

Okay, next thing to try is: Can you get back to your OS store from WP by using the back button and still see your order (you may need to refresh the page).

 

If this works, then the problem must be that the MC_successURL and MC_failURL are going wrong somewhere.


Ian-san

Flawlessnet

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×