Jump to content
Sign in to follow this  
brahms2

Papal Express "select a payment method" loop

Recommended Posts

Dear Brian,

 

My store is now live from today. Many thanks!!!

There still seem to be a problem that I don't know how to solve.

When we sign in and choose Paypal Express we reach eventually somewhere on the payment page, at the last stage before the final confirmation, stuck in loop where it displays on a red bar the following error:

"Please select a payment method for your order."

That is also a pointer that sends me back to the Payment Method...

Yet, if I do the checkout pressing on the yellow Paypal button present on the Login page, I do not have this problem.

You may see our online store and the problem live here: www.verifresh.com/onlinestore

The Credit card payment is fine.

I would really appreciate any sugestion that may help pass over this loop.

Best,

Theodore

Share this post


Link to post
Share on other sites

Theodore:

Please keep the support questions to the PayPal WPP thread here:

http://forums.oscommerce.com/index.php?sho...981&st=2080

 

I've heard of this problem, and experienced it once, but it requires a very specific order of clicking to reproduce. Can you give me a 123 list of what you do so that I can reproduce this problem?

 

 

Papal Express? Have they souped up the Pope Mobile?

I laughed at that more than I should have.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Dear Brian,

 

I conformed to your advice and added the issue descriotions to yout Paypal thread here:

http://forums.oscommerce.com/index.php?sho...p;#entry1042613

 

Thanks a million

Theodore ;)

PS: your friends comments claimed some tears from me... i had a crack:))) ooops...

 

Theodore:

Please keep the support questions to the PayPal WPP thread here:

http://forums.oscommerce.com/index.php?sho...981&st=2080

 

I've heard of this problem, and experienced it once, but it requires a very specific order of clicking to reproduce. Can you give me a 123 list of what you do so that I can reproduce this problem?

I laughed at that more than I should have.

Share this post


Link to post
Share on other sites

So has anyone figured out the exact cause of the redirect back to the store from paypal, which gives the "checkout_payment.php?error_message=Please+select+a+payment+method+for+your+order" Error?

 

I cannot figure this one out to save my life. register_globals is on, shop works fine otherwise, and credit card payments work fine....

 

any ideas?

Share this post


Link to post
Share on other sites
So has anyone figured out the exact cause of the redirect back to the store from paypal, which gives the "checkout_payment.php?error_message=Please+select+a+payment+method+for+your+order" Error?

 

I cannot figure this one out to save my life. register_globals is on, shop works fine otherwise, and credit card payments work fine....

 

any ideas?

 

me too need an answer from someone, somewhere, anywhere!

Share this post


Link to post
Share on other sites

me too need an answer from someone, somewhere, anywhere!

 

The error: error_message=Please+select+a+payment+method+for+your+order.

 

is Solved by changing

if ( ( is_array($payment_modules->modules) && (sizeof($payment_modules->modules) > 1) && !is_object($payment) ) || (is_object($payment) && ($payment->enabled == false)) ) {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL'));

}

 

BY

 

if ( ( is_array($payment_modules->modules) && (sizeof($payment_modules->modules) > 1) && !is_object($$payment) ) || (is_object($$payment) && ($$payment->enabled == false)) ) {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL'));

}

Share this post


Link to post
Share on other sites

The error: error_message=Please+select+a+payment+method+for+your+order.

 

is Solved by changing

if ( ( is_array($payment_modules->modules) && (sizeof($payment_modules->modules) > 1) && !is_object($payment) ) || (is_object($payment) && ($payment->enabled == false)) ) {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL'));

}

 

BY

 

if ( ( is_array($payment_modules->modules) && (sizeof($payment_modules->modules) > 1) && !is_object($$payment) ) || (is_object($$payment) && ($$payment->enabled == false)) ) {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL'));

}

 

 

Can any1 clarify what page this code is on? as i am getting this error as well..

Share this post


Link to post
Share on other sites

Can any1 clarify what page this code is on? as i am getting this error as well..

 

checkout_confirmation.php

Share this post


Link to post
Share on other sites

checkout_confirmation.php

 

Thanks Dennisra.

 

omundofazdeconta, my checkout_confirmation page is already coded like this, but I am still getting:

 

The error: error_message=Please+select+a+payment+method+for+your+order.

 

Any ideas why?

 

Please can you help, would really appreciate it.

 

Thanks in advance

Share this post


Link to post
Share on other sites

 

Please help the uninitiated. I am setting up a wordpress online store using OScommerce and have worked through many issues, but for almost a week now cannot resolve this problem. Please, please can someone help me? I am receiving an error message when I try to confirm an order, and it doesn't matter if it's cash, Paypal or money order. When I try to confirm an order, I am returned to the payment information screen and receive the error message in the red bar, "Please select a payment method for your order." Also, the billing address disappears except for a comma in the bottom left of the address box. There is a request on the screen too, "Please choose from your address book where you would like the invoice to be sent to." I have seen this problem posted in several places, and one recommendation is to change the billing and shipping Zones to none. This does not fix the problem for me. I want to open my store, but obviuously it's useless if I can't confirm a single transaction! Can someone please steer me, using layman's terms, tell me how to fix this problem. Thank You. One additional piece of information: This problem goes away when I use my provider's 5.2 PHP instead of 5.4 PHP. The site runs dead slow, however, using 5.2 PHP, and it's going away. So I need this store to work with 5.4 PHP. Please let me know if I can provide any additional information.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×