Jump to content
Skittles

Optional Related Products, Version 4.0

Recommended Posts

i wonder if this module works with sppc contributtion....?

 

ok. i've test it and it works, but it shows the original price not the sppc price...

 

it has 2 sides... the costumer sees a price but when he add the product the sorprise is so good when he sees a discount price..

 

on the other side.. the original price could be a deterrent, of his original impulse to buy that related product.

 

well...

Share this post


Link to post
Share on other sites
good, ,good, module, but i wonder if this module works with sppc contributtion....?

 

any ligth about this... thanks

axioma,

 

Sorry, this contribution does not support the Special Price Per Customer customer contribution.

 

-Skittles

Share this post


Link to post
Share on other sites

Hi Skittles,

 

I installed ORP 4.0 and everything is fine, great addition. It works with SPPC and Hidden Products for SPPC. But when I try to install PayPal_Shopping_Cart_IPN_v3.1.5 it stops working. The left column in the admin page does not show off properly and the main screen disappears. I suspect there are some common code lines from the two contribs (PayPal and ORP) mutually excluding, but not being fluent with PHP (to say the least) I really don't know what to do.

Is there any known issue with the two contribs, and have you any solution for this? I really would like to keep both, if possible.

 

Thank you

Share this post


Link to post
Share on other sites
Hi Skittles,

 

I installed ORP 4.0 and everything is fine, great addition. It works with SPPC and Hidden Products for SPPC. But when I try to install PayPal_Shopping_Cart_IPN_v3.1.5 it stops working. The left column in the admin page does not show off properly and the main screen disappears. I suspect there are some common code lines from the two contribs (PayPal and ORP) mutually excluding, but not being fluent with PHP (to say the least) I really don't know what to do.

Is there any known issue with the two contribs, and have you any solution for this? I really would like to keep both, if possible.

 

Thank you

microkid,

 

I don't have the answer for you right now, and I can't work on it before Monday.

 

We are just about to leave for the rest of the holiday weekend, to my mother-in-law's, hubby just started the car...

 

I'll take a look on Monday or Tuesday and get back to you with what I find.

 

Anyone else have an answer for microkid, please feel free to jump in and help.

 

Hope all had a great Thanksgiving Day. Enjoy the rest of the weekend.

 

-Skittles

Share this post


Link to post
Share on other sites

have a problem when i create a set

 

i have A with B, C, D "Reciprocate"

than i "Inherit" product A to product X

 

than i have A and X with B, C, D

 

that´s okay !

 

---> my problem is when i attach E to A

than i have A with B, C, D, E

 

but X have just B, C, D --> i missing here E

 

 

thnx.s

Share this post


Link to post
Share on other sites
have a problem when i create a set

 

i have A with B, C, D "Reciprocate"

than i "Inherit" product A to product X

 

than i have A and X with B, C, D

 

that´s okay !

 

---> my problem is when i attach E to A

than i have A with B, C, D, E

 

but X have just B, C, D --> i missing here E

thnx.s

truelovestore_en,

 

You will need to 'attach' E to X in a separate operation.

 

Here's how it works:

 

When you create a relationship, a record is created in the database. If you use Reciprocate, two records are created: one for A -> B and another for B -> A.

 

When A has B, C and D related to it, then you have X Inherit A, three records are created in the database, one each for B -> X, C -> X and D -> X.

 

There is nothing in the code that will cause future changes to A to also be applied to X.

 

Hope this helps...

-Skittles

Share this post


Link to post
Share on other sites

Hi, I did everything right, but I keep receiving this message when I try to run the database.

Is there a way to install it from my mysql??

 

1146 - Table 'achei_cart.TABLE_PRODUCTS_OPTIONS_PRODUCTS' doesn't exist

 

select pa.* from TABLE_PRODUCTS_OPTIONS_PRODUCTS pa left join products_description pd on pa.pop_products_id_master = pd.products_id and pd.language_id = '1' order by pd.products_name, pa.pop_order_id, pa.pop_id

 

Its the first time that I am installing, so I think I'm not suppost to have the table that is asking above.

Could you please help me to understand?

 

Thank you

Share this post


Link to post
Share on other sites
Hi, I did everything right, but I keep receiving this message when I try to run the database.

Is there a way to install it from my mysql??

 

1146 - Table 'achei_cart.TABLE_PRODUCTS_OPTIONS_PRODUCTS' doesn't exist

 

select pa.* from TABLE_PRODUCTS_OPTIONS_PRODUCTS pa left join products_description pd on pa.pop_products_id_master = pd.products_id and pd.language_id = '1' order by pd.products_name, pa.pop_order_id, pa.pop_id

 

Its the first time that I am installing, so I think I'm not suppost to have the table that is asking above.

Could you please help me to understand?

 

Thank you

marispb,

 

The table names are constants that are defined in the database_tables.php files located in the includes directory of both the catalog and the admin directories. A very common issue, for any contribution that adds tables to the database, is that one or the other of these files doesn't get updated.

 

As the filenames are identical, and the information added to the files is identical, it is so very easy to think you've 'completed that step' when you have actually only updated one of the files.

 

Constants are always uppercase. So anytime you have an error with a constant showing in the code, you need to define the constant.

 

In this case, you need to revisit Step 3, and make sure you've made the change in both the [catalog/]admin/includes/database_tables.php file and the [catalog/]includes/database_tables.php file:

 

3) Add database table definition for Both Admin and Catalog files

3a) in [catalog/]admin/includes/database_tables.php
	Add anywhere before the final "?>"

	/* Optional Related Products (ORP) */
	  define('TABLE_PRODUCTS_RELATED_PRODUCTS', 'products_related_products');
	//ORP: end


3b) in [catalog/]includes/database_tables.php
	Add anywhere before the final "?>"

	/* Optional Related Products (ORP) */
	  define('TABLE_PRODUCTS_RELATED_PRODUCTS', 'products_related_products');
	//ORP: end

 

Once you have the new table defined in both files, you shouldn't get the error anymore. If everything else is set up correctly, it should start working for you.

 

Good luck, and Happy Holidays!

-Skittles

Share this post


Link to post
Share on other sites

My customer just found an error in the Module. When you open the product with the related products, click on "Buy Now" on any of those related products, it will send you to your basket. Press "Continue Shopping". It will send you back to the same product page with product, that you bought, is still in the related products area. Now try to buy any of other related products with their "buy now" button - it will add one more product to your basket, which will be the same as previous one. The problem is in module file, line 92:

. tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action'))

it should be

. tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action', 'rp_products_id'))

 

because when you click "Continue Shopping", you are sent back to the same address _plus_ rp_products_id parameter. It might be problems because of this module mixed with SEO modules, I have no idea.

Share this post


Link to post
Share on other sites
My customer just found an error in the Module. When you open the product with the related products, click on "Buy Now" on any of those related products, it will send you to your basket. Press "Continue Shopping". It will send you back to the same product page with product, that you bought, is still in the related products area. Now try to buy any of other related products with their "buy now" button - it will add one more product to your basket, which will be the same as previous one. The problem is in module file, line 92:

. tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action'))

it should be

. tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action', 'rp_products_id'))

 

because when you click "Continue Shopping", you are sent back to the same address _plus_ rp_products_id parameter. It might be problems because of this module mixed with SEO modules, I have no idea.

kazkas,

 

Thanks for reporting the problem.

 

I was unable to duplicate the behavior on my development copy of osCommerce. That would imply the problem is caused by incompatible code between Optional Related Products and another mod or contribution.

 

As you have found a solution, it may be helpful to others reading this thread to know what other contributions are installed on your client's shop. I hope you'll reply with that information, when you get the chance.

 

Thanks, and Happy Holidays!

-Skittles

Share this post


Link to post
Share on other sites

After adding this contrib I'm not able to add products to cart that have negative stock values... Before it was all ok. I click add to cart and cart si showing, but no product gets added to cart.

 

Allow checkout is set to true.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
After adding this contrib I'm not able to add products to cart that have negative stock values... Before it was all ok. I click add to cart and cart si showing, but no product gets added to cart.

 

Allow checkout is set to true.

luckyno,

 

I just checked this behavior on my development server. When I add a product which is out of stock, it works as expected. This is true whether I 'add to cart' from the product listing page or 'buy now' from the Optional Related Products listing.

 

Adding a product to the cart is accomplished by code in application_top.php. There are two modifications in application_top.php to support this contribution. I recommend you start looking there.

 

Also, if you have other contributions installed, there may be a conflict in code changes. If and when that occurs, you need to blend the code changes where they both modify the same code. Not for the faint of heart!

 

Good luck,

-Skittles

Share this post


Link to post
Share on other sites

Hi Skittles,

 

First question on the forum by me!

 

I tried to install ORP 4.0 on a fresh osCommerce Online Merchant v2.2 RC2. No other contribs added prior on this test.

The admin part work well. I am able to view, select, choose, "insert" and so on in admin.

But I am not able to see any related products in Catalog, and the boxes to the right disappears

when choosing a products wich has related products.

Feel free to visit,

 

Click here!

 

The items listed as packs (in Categories) are the master product, and the items listed as singles are supposed to be the slaves.

 

IF You or anyone can point me to the direction where to look, I am really grateful.

 

Thanks in advance!

tltj

Share this post


Link to post
Share on other sites
Hi Skittles,

 

First question on the forum by me!

 

I tried to install ORP 4.0 on a fresh osCommerce Online Merchant v2.2 RC2. No other contribs added prior on this test.

The admin part work well. I am able to view, select, choose, "insert" and so on in admin.

But I am not able to see any related products in Catalog, and the boxes to the right disappears

when choosing a products wich has related products.

Feel free to visit,

 

<a href="http://www.brodyrproffs.se" target="_blank">

Click here!

</a>

 

The items listed as packs (in Categories) are the master product, and the items listed as singles are supposed to be the slaves.

 

IF You or anyone can point me to the direction where to look, I am really grateful.

 

Thanks in advance!

tltj

 

I contacted tltj via PM, and got access to his files. What I found was he had inadvertently used the modified module file that supports the contribution Graphical Borders 2.1.

 

Because Graphical Borders 2.1 wasn't installed, it prevented the remainder of the page to be displayed.

 

Once he installs the correct module file, the page should render correctly.

 

-Skittles

Share this post


Link to post
Share on other sites

Thanks Skittles!

 

That was great support! Works perfect and this is a great contribution. Recommended!

 

Best regards,

tltj

Share this post


Link to post
Share on other sites

Hi there,

 

I was looking through the thread for an example of the contribution on a live site, the couple of links I clicked on where broken or did not have the contribution installed.

 

Could you post a few links of sites with the contribution working.

 

Thanks,

Ally


"Know that this is your God, who could not consent to send anyone else to save you, but would come himself that he might gain for himself all your love." St Alphonsus Ligouri

Share this post


Link to post
Share on other sites
Hi there,

 

I was looking through the thread for an example of the contribution on a live site, the couple of links I clicked on where broken or did not have the contribution installed.

 

Could you post a few links of sites with the contribution working.

 

Thanks,

Ally

 

Here's mine ACE Go Kart Buggy (item with related products).

 

Hi Skittles,

Thanks for this contrib, works very nice! (I changed mine a bit to match my box array (boxes)/

Question? where or where is the <br> or \n that needs to be removed so that the price is not 2 lines below the description.

 

i.e.

 

Green Widget Gone Wild

 

@ $12.00

 

 

rather have it...

 

Green Widget Gone Wild

@ $12.00

 

 

THANKS!!!!!!!!! :)


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites
Here's mine ACE Go Kart Buggy (item with related products).

 

Hi Skittles,

Thanks for this contrib, works very nice! (I changed mine a bit to match my box array (boxes)/

Question? where or where is the <br> or \n that needs to be removed so that the price is not 2 lines below the description.

 

i.e.

 

Green Widget Gone Wild

 

@ $12.00

rather have it...

 

Green Widget Gone Wild

@ $12.00

THANKS!!!!!!!!! :)

Top_Speed,

 

There aren't any <br> tags to remove. I used paragraph tags instead.

 

Here is an excerpt from the install file, with information on how to control the spacing between lines:

 

Optional Step:

The "name", "model", "name & model", "price" and "quantity" text are each wrapped
in html paragraph tags ( "<p>" and "</p>"). To control the space between these lines,
you can add a CSS definition for the class "productListing-data" in stylesheet.css.

	Look For:

	TD.productListing-data {

	Add your new class definition immediately below the existing definition,
	after the ending curly bracket. Here is where you would make changes to
	the font face, style, size, color, etc.

	TD.productListing-data p {
	  margin:2px;
	  padding:0;
	  text-align:center;
	}

This gives you a lot more control over the total appearance, not just the spacing.

 

Have fun,

-Skittles

Share this post


Link to post
Share on other sites

I installed everything 3 different times and each time, I come to the page below. Nothing shows but the configuration box. So I can't even get to set up the related products part. Help!

 

shot.png

Share this post


Link to post
Share on other sites
I installed everything 3 different times and each time, I come to the page below. Nothing shows but the configuration box. So I can't even get to set up the related products part. Help!

blueicreate,

 

Based on the image you provided, it appears the page is not loading completely. You have a header, but no footer. And only one of several menu boxes is loading in the left column. ([catalog/]admin/includes/boxes/configuration.php).

 

Configuration.php pulls the information for the menu directly from the database, but I don't see "Related Products" in the list. This could indicate the problem has something to do with the Configuration menu. To determine if that is the case, open [catalog/]admin/includes/column_left.php and comment out the command to require configuration.php, like this:

 

//  require(DIR_WS_BOXES . 'configuration.php');
 require(DIR_WS_BOXES . 'catalog.php');
 require(DIR_WS_BOXES . 'modules.php');
 require(DIR_WS_BOXES . 'customers.php');
 require(DIR_WS_BOXES . 'taxes.php');
 require(DIR_WS_BOXES . 'localization.php');
 require(DIR_WS_BOXES . 'reports.php');
 require(DIR_WS_BOXES . 'tools.php');

Then reload the page. If the page loads fully, minus the Configuration menu, you have isolated the problem to the configuration menu. If the page still doesn't finish loading, try commenting out each of the boxes one at a time, to determine which menu code is breaking the page.

 

Then get back to us here, and let us know what you found out, so one of us can suggest the next course of action.

 

-Skittles

Share this post


Link to post
Share on other sites
Top_Speed,

 

There aren't any <br> tags to remove. I used paragraph tags instead.

 

Here is an excerpt from the install file, with information on how to control the spacing between lines:

 

Optional Step:

The "name", "model", "name & model", "price" and "quantity" text are each wrapped
in html paragraph tags ( "<p>" and "</p>"). To control the space between these lines,
you can add a CSS definition for the class "productListing-data" in stylesheet.css.

	Look For:

	TD.productListing-data {

	Add your new class definition immediately below the existing definition,
	after the ending curly bracket. Here is where you would make changes to
	the font face, style, size, color, etc.

	TD.productListing-data p {
	  margin:2px;
	  padding:0;
	  text-align:center;
	}

This gives you a lot more control over the total appearance, not just the spacing.

 

Have fun,

-Skittles

 

Thank you Skittles :)

 

I missed that in the instructs I guess.

 

Kind Regards

-KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites
Thank you Skittles :)

 

I missed that in the instructs I guess.

 

Kind Regards

-KJ

KJ,

 

You're welcome.

 

I hope you enjoy the contribution.

 

When you have your shop finished and live, let us know the URL so we can check it out.

 

Take care,

-Skittles

Share this post


Link to post
Share on other sites

Hello Skittles,

 

I put it on one of my sites: www.gokartsRus.com

 

Here is a product page that incorporates your fine contrib: 250cc Buggy Go-Kart

 

Thanks again!

-KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

Okay, so the whole page loads when I comment out the catalog.php but I don't know what to fix in that file.

 

 

blueicreate,

 

Based on the image you provided, it appears the page is not loading completely. You have a header, but no footer. And only one of several menu boxes is loading in the left column. ([catalog/]admin/includes/boxes/configuration.php).

 

Configuration.php pulls the information for the menu directly from the database, but I don't see "Related Products" in the list. This could indicate the problem has something to do with the Configuration menu. To determine if that is the case, open [catalog/]admin/includes/column_left.php and comment out the command to require configuration.php, like this:

 

//  require(DIR_WS_BOXES . 'configuration.php');
 require(DIR_WS_BOXES . 'catalog.php');
 require(DIR_WS_BOXES . 'modules.php');
 require(DIR_WS_BOXES . 'customers.php');
 require(DIR_WS_BOXES . 'taxes.php');
 require(DIR_WS_BOXES . 'localization.php');
 require(DIR_WS_BOXES . 'reports.php');
 require(DIR_WS_BOXES . 'tools.php');

Then reload the page. If the page loads fully, minus the Configuration menu, you have isolated the problem to the configuration menu. If the page still doesn't finish loading, try commenting out each of the boxes one at a time, to determine which menu code is breaking the page.

 

Then get back to us here, and let us know what you found out, so one of us can suggest the next course of action.

 

-Skittles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×