Jump to content
Sign in to follow this  
Sandbag

[Contribution] Leapfrog - Dynamic Visitor Tracking

Recommended Posts

Hi everyone.

 

I am ALMOST ready to release Leapfrog V1.2. It has several new features including:

  • Visitor country displayed
  • Length of page view displayed
  • Ability to show/hide spider and robot sessions
  • Now compatible with Ultimate SEO URLs 'out of the box'
  • Improved image handling - fixes problems people had seeing the product images

You can see the new version in action in the following locations:

 

Simulated demo - clicks generated artificially

Live demo - click around in my dummy shop and see your movements being tracked!

 

Before I release it, I need a couple of people to test it to make sure I haven't missed anything. This is to prevent a duff version being uploaded to the contributions sections. Anyone willing to test the new version, please PM me for a link. Only need one or two testers so if you want a sneak peak make sure you get PMing fast!

 

Thanks,

 

Ed

 

Ed,

 

Nice work, very nice indeed. Can you make the referal field a bit wider (or in two lines) so that one can read all the referal url?

 

Thanks

Edited by Tomcat

Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites
Ed,

 

Nice work, very nice indeed. Can you make the referal field a bit wider (or in two lines) so that one can read all the referal url?

 

Thanks

 

Unfortunately, the referal cannot be made longer. Stretching it onto two or more lines causes display problems.

 

However, did you know that by hovering over the referal text you will see the full text? Also, you can click on the text to be shown the full URL.

Share this post


Link to post
Share on other sites

I've just upgraded from Leapfrog 1.1 to 1.2. I now get this message at the bottom of my store's main page (the footer):

 

1054 - Unknown column 'thumb_url' in 'field list'

 

I have removed the Leapfrog additions to the footer.php file until I get the issue resolved but would love to reinsert the lines.

 

How can I rectify this?

 

Thanks,

Anthony

Share this post


Link to post
Share on other sites

I actually completely removed the 1.1 Leapfrog table then reinstalled the new SQL data. That resolved the footer issue.

 

Next problem, the Leapfrog admin page doesn't show anything except for the Settings button. There is a large blank flash field there but nothing in it.

 

Anthony

Share this post


Link to post
Share on other sites
I've just upgraded from Leapfrog 1.1 to 1.2. I now get this message at the bottom of my store's main page (the footer):

 

1054 - Unknown column 'thumb_url' in 'field list'

 

I have removed the Leapfrog additions to the footer.php file until I get the issue resolved but would love to reinsert the lines.

 

How can I rectify this?

 

Thanks,

Anthony

 

delete the existing leapfrog table and run the new sql statement included in package 1.2

 

I upgraded to version 1.2.3 as well and have a different issue: records are not written to DB, not even one and if I run admin/leapfrog.php with Firefox ( 1.5 or 2) the browser crashes...

 

Any help on that ?

 

Thanks

Edited by Tomcat

Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites
I actually completely removed the 1.1 Leapfrog table then reinstalled the new SQL data. That resolved the footer issue.

 

Next problem, the Leapfrog admin page doesn't show anything except for the Settings button. There is a large blank flash field there but nothing in it.

 

Anthony

 

Nothing should show except the settings button until someone actually clicks in your store. I know its an obvious suggestion but did you try that?

Share this post


Link to post
Share on other sites
delete the existing leapfrog table and run the new sql statement included in package 1.2

 

I upgraded to version 1.2.3 as well and have a different issue: records are not written to DB, not even one and if I run admin/leapfrog.php with Firefox ( 1.5 or 2) the browser crashes...

 

Any help on that ?

 

Thanks

 

Two suggestions. First check that the file catalog/includes/functions/leapfrog.php is present and that it is V1.2. You can check this by looking at line 112. You should see a new if statement with the varialbe LEAPFROG_EXCLUDE_ROBOTS.

 

The second suggestion is to make sure that the code in catalog/includes/footer.php is still present. There should be a call to lf_update_tracking at the bottom of this file.

 

As for the browser crashing, what exactly is happening? Does Leapfrog display an error message or is it the entire browser which freezes?

Share this post


Link to post
Share on other sites

Actually, in relation to the above post I should mention something else.

 

Leapfrog will not start tracking until you visit the Leapfrog admin page. This is because on startup it inserts some configuration settings into the database. So, I think you will have to solve the browser crashing issue before any records will show in the DB.

Share this post


Link to post
Share on other sites
Actually, in relation to the above post I should mention something else.

 

Leapfrog will not start tracking until you visit the Leapfrog admin page. This is because on startup it inserts some configuration settings into the database. So, I think you will have to solve the browser crashing issue before any records will show in the DB.

 

 

Hi,

 

I removed the if statement on line 112 and now works like a charm. Thanks


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites
Hi,

 

I removed the if statement on line 112 and now works like a charm. Thanks

 

I'm glad that fixed it, but it does mean that you can't use the settings menu to stop robots being tracked. Still not sure why that line would cause the admin to crash. Hmm...

Share this post


Link to post
Share on other sites

I found that i was not able to see anybody clicking around.

 

 

--"L"eapfrog -- in 3 places in the line of $query = "INSERT INTO " . TABLE_CONFIGURATION_GROUP . -- admin/includes/functions/leapfrog.php .

 

I Changed the "L" to lower case "l" to match in these 3 spots as it would match in the sql : --"l"eapfrog-- as CREATE TABLE IF NOT EXISTS `leapfrog` --- that sql was already loaded.

 

Now it works for me.

 

Also a small add to admin/leapfrog.php to spread out the table a bit:

 

height="1500" width="650"

 

Finally got it to work, Flashy!!

Great Contribution

DanielSilly

neverbetter.com

Share this post


Link to post
Share on other sites
I'm glad that fixed it, but it does mean that you can't use the settings menu to stop robots being tracked. Still not sure why that line would cause the admin to crash. Hmm...

 

Hi,

 

Are you sure the if statemets makes sense ?

if ( (LEAPFROG_EXCLUDE_ROBOTS == 'true' && $wo_session_id != '') || LEAPFROG_EXCLUDE_ROBOTS == 'false') {

 

Meaning: if LEAPFROG_EXCLUDE_ROBOTS is true and session is not empty or LEAPFROG_EXCLUDE_ROBOTS is false...

 

Thanks


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites

LOL. Yeah. That if statement is a bit of a head messer but I still belive it to be correct.

 

It's saying, if LEAPFROG_EXCLUDE_ROBOTS is false then do the tracking.

Also do the tracking if LEAPFROG_EXCLUDE_ROBOTS is true AND there IS a session id (in other words we don't want to track spiders, but this person has a session id so probably isn't a spider.

 

BTW - Flash does get caches by the browser. You may want to empty your tempory internet files and then reload the admin page. Otherwise you could still be looking at the previous release.

 

Hi,

 

Are you sure the if statemets makes sense ?

if ( (LEAPFROG_EXCLUDE_ROBOTS == 'true' && $wo_session_id != '') || LEAPFROG_EXCLUDE_ROBOTS == 'false') {

 

Meaning: if LEAPFROG_EXCLUDE_ROBOTS is true and session is not empty or LEAPFROG_EXCLUDE_ROBOTS is false...

 

Thanks

Share this post


Link to post
Share on other sites
Nothing should show except the settings button until someone actually clicks in your store. I know its an obvious suggestion but did you try that?

 

I did, yes.

 

A

Share this post


Link to post
Share on other sites

I _THINK_ I'm moving forward with this. Now this is the problem I'm having. The following error occurs.

 

Unable to connect to the Leapfrog data feed.

 

Please read the following suggestions:

 

1. Do you have an admin login contribution installed? If so you must edit it to allow Leapfrog to access '/admin/leapfrog_feed.php'.

 

2. Are you using IE and SSL? There is a known issue with this setup. Please see INSTALL.txt for details. Alternatively switch to Firefox.

 

3. Visit the support thread on the official osCommerce forum. There might be an answer there.

 

Code: LDF004

 

 

I get this in both IE and Firefox. As far as I know I do NOT have an admin login contrib.

 

Anthony

Share this post


Link to post
Share on other sites

LDF004 occurs if Leapfrog cannot access the data feed. To check the feed, open a browser and type in:

 

http://www.yourdomain.com/catalog/admin/leapfrog_feed.php?action=newclicks&lastclick=1

 

Remember to replace yourdomain.com and put SSL in if you use it (e.g. https://). Make sure that when you see that page it contains XML code.

Share this post


Link to post
Share on other sites

NICE UPDATE!!!!

 

Installed no probs and took care of a few minor issues like SEO... great work!

Share this post


Link to post
Share on other sites

thanks sand!

 

i now have the same error as jay.

 

<?xml version="1.0" encoding="utf-8" ?>

<clicks />

Share this post


Link to post
Share on other sites

This means that no clicks are being registered in the database.

 

1. Make sure the lf_update_tracking() code is in the catalog/includes/footer.php.

2. Make sure catalog/includes/functions/leapfrog.php is present.

3. If that doesn't work, open catalog/includes/functions/leapfrog.php and search for:

 

if ( (LEAPFROG_EXCLUDE_ROBOTS == 'true' && $wo_session_id != '') || LEAPFROG_EXCLUDE_ROBOTS == 'false') {

 

Replace with

 

if (true) {

 

It's a bit of a hack but might help.

 

thanks sand!

 

i now have the same error as jay.

 

<?xml version="1.0" encoding="utf-8" ?>

<clicks />

Share this post


Link to post
Share on other sites
I found that i was not able to see anybody clicking around.

--"L"eapfrog -- in 3 places in the line of $query = "INSERT INTO " . TABLE_CONFIGURATION_GROUP . -- admin/includes/functions/leapfrog.php .

 

I Changed the "L" to lower case "l" to match in these 3 spots as it would match in the sql : --"l"eapfrog-- as CREATE TABLE IF NOT EXISTS `leapfrog` --- that sql was already loaded.

 

Now it works for me.

 

Just to let you all know, I'm not sure why this works. The capital 'L's and lowercase 'l's refer to different things. One is the database table, and another is a string in the database table.

 

By all means try changing them, but it might mess something else up. I will investigate further.

Share this post


Link to post
Share on other sites

it works now after changing to

if (true) {

!!

 

thanks!

 

This means that no clicks are being registered in the database.

 

1. Make sure the lf_update_tracking() code is in the catalog/includes/footer.php.

2. Make sure catalog/includes/functions/leapfrog.php is present.

3. If that doesn't work, open catalog/includes/functions/leapfrog.php and search for:

 

if ( (LEAPFROG_EXCLUDE_ROBOTS == 'true' && $wo_session_id != '') || LEAPFROG_EXCLUDE_ROBOTS == 'false') {

 

Replace with

 

if (true) {

 

It's a bit of a hack but might help.

Share this post


Link to post
Share on other sites

btw sandbag, is there a way to have a "auto clear of the database" say once every 1 hour or whatever time that we can set?

 

That will be very useful if we simply open the page and let it run by itself, say on the office non-stop!

Share this post


Link to post
Share on other sites

There isn't at the moment but it sounds like a nice new feature to me! (*starts coding V1.3*)

 

Glad that fix sorted the tracking for you. At a guess I would say it worked because $wo_session_id was returning an empty string, but can't understand why this would be.

 

btw sandbag, is there a way to have a "auto clear of the database" say once every 1 hour or whatever time that we can set?

 

That will be very useful if we simply open the page and let it run by itself, say on the office non-stop!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×