Jump to content
Sign in to follow this  
billskullman

I get weird symbols when changing languagefiles.

Recommended Posts

Hello everyone.

I had a programmer install a bunch of contributions and design for me on an oscommerceshop, but now when i try to edit the languagefiles i get weird symbols in the top left corner of the page. The symbols are: 

Im trying to use Swedish in my languagefiles but i also get this when changing in the english languagefiles.

Please help.

Thanks

Bill

Share this post


Link to post
Share on other sites
now when i try to edit the languagefiles i get weird symbols in the top left corner of the page. The symbols are: 

Im trying to use Swedish in my languagefiles but i also get this when changing in the english languagefiles.

Please help.

Thanks

Bill

 

And You are editing the language files with...?

Don't use Word. Use any decent text editor. (Word is not a text editor, it's a word processor)

 

Another cause could be wrong character encoding. Most servers hereabouts default to ISO-latin-1 (ISO-8859-1) which shows åäö just fine. osC also defaults to ISO-latin-1. UTF-8 (Unicode) would be better, but currently we often have to live with latin 1.

 

Sjölångben

Share this post


Link to post
Share on other sites
Im using microsoft expression web to edit the files.

It is similar to dreamweaver.

What testeditor should i use?

There are many texteditors out there. Some are free and some are not so free. The choice is yours to make. I honestly can't recommend any specific software because I use a mac and the text editor(s) I use are mac-only ;)

I've been told that Notepad is usable, and that one comes with Windows. The problem with Word and many html-editors is that they add extra characters/tags to the text and these characters mess up the php code. (in static html these extra tags usually don't cause problems).

So whichever editor you use make sure you save the text(s) as PLAIN TEXT.

Where do i see which encoding it is on the shop?

Open /catalog/includes/languages/swedish.php and look at lines 15-20. You should see something like

// Examples:
// on RedHat try 'en_US'
// on FreeBSD try 'en_US.ISO_8859-1'
// on Windows try 'en', or 'English'
@setlocale(LC_TIME, 'en_US.ISO_8859-1');

It probably has "swe" instead of "en". This is the osC out-of-the-box setting. You must save your (edited) files with the same encoding. Better editors let you see/choose the encoding they are using and/or saving in. (xxx8859-1 and latin-1 mean the same thing).

Also if you look at the source code of any web page (in your browser) youl'll see something like this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xml:lang="en" lang="en" xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />

where after the <head> you see the line beginning with "<meta http-equiv=" has the "charset=xxxxxxx" which should tell your browser which character set/encoding to use, in this (forum page) case UTF-8.

Lycka till

Sjölångben

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×