Jump to content
AlexStudio

[contribution] Super Download Store

Recommended Posts

Intermitent bug problems:

 

I sell MP3 files and have noticed a bug with this add-on. Very intermitently the customer orders an MP3 file, it shows up in their account order, with the file as available, the number of downloads available, BUT NO DOWNLOAD BUTTON AND LINK shows up. I can order the file under a test account and I have no problems, nor does the majority of customers. Both times this has occured, the customers ordered a number of files, and only one of the files had no download button. I am not sure how often this occurs.

 

Also, I found out that I am not able to add or create an order for an MP3 file or files with no charge as a customer service option. The download button does not show up within the order on the customer's end.

 

Any ideas??? Writing for support for this add-on seems like an exercise in futility, but I got to try. By the way, I still have trouble with MP3 orders when customers use PayPal Express as noted above. Anyone with coding hints?????????

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Alex,

 

For the most part, really loving this contribution. I've been asked to set up osCommerce for a site that sells graphics tutorials, and this has made a whole lot of things so much simpler and more usable.

 

Have come across one weird problem, though. A standard tutorial includes 4 files: 2 .swf files which are the actual tutorials and 2 .zip files which have the graphical elements used in the tutorial. The .zips are downloading just fine. However, the .swfs are downloading at double the size of the actual files - for example, a 22Mb file will download at 44Mb or so.

 

Any idea why this might be happening? Is this likely to be an issue with the code handling the downloads, or a file/server problem?

Share this post


Link to post
Share on other sites
I can order the file under a test account and I have no problems, nor does the majority of customers. Both times this has occured, the customers ordered a number of files, and only one of the files had no download button. I am not sure how often this occurs.
It's very hard to tell why those glitches happened. Could be the server, the clients' browsers, bad connections...etc, but I don't think it's a bug since it works most of the time.

 

Also, I found out that I am not able to add or create an order for an MP3 file or files with no charge as a customer service option. The download button does not show up within the order on the customer's end.
How did you add those free orders?

 

Any ideas??? Writing for support for this add-on seems like an exercise in futility, but I got to try. By the way, I still have trouble with MP3 orders when customers use PayPal Express as noted above. Anyone with coding hints?????????
That's really odd that Paypal Pro works but not Paypal Express. Can't tell what went wrong by reading your posts. This SDS add-on is simply an enhanced version of the stock download module, it has nothing to do with payments.

 

The .zips are downloading just fine. However, the .swfs are downloading at double the size of the actual files - for example, a 22Mb file will download at 44Mb or so.

 

Any idea why this might be happening? Is this likely to be an issue with the code handling the downloads, or a file/server problem?

I have no idea why this can happen, but it sounds like a file type issue. Packing those .swf files as .zip or .rar will eliminate your problem.

Super Download Shop, PayPal Express Checkout IPN, Selling Downloads, Visual Validation (preventing robotic flood), phpBB2 Integration

 

Yes, I'm willing to help, but please ask in the right place. Think twice before trying to PM me, it might be ignored.

Share this post


Link to post
Share on other sites

Please! I need some help! I can´t open my admin page anymore before install this contibution. I sent the original files but nothing hapens. The problem is in the database? I don´t have the english language option in my store, that´s the problem? Thanks.

Share this post


Link to post
Share on other sites

Please: desconsider previous post.

 

Please! I need some help! I can´t open my admin page anymore AFTER to install this contibution. If it not exist. I sent the original files but nothing happens. The problem is in the database? I don´t have the english language option in my store, that´s the problem? Thanks.

Share this post


Link to post
Share on other sites

Hi

 

I was wondering if this add on works with the latest version of osc, and is it compatable with other add ons like Header Tags SEO which has modifications to the admin section.

Share this post


Link to post
Share on other sites

I've just downloaded the add on, but all I see is a .tar file which I don't know what to do with - can anyone help? :blink: I use WIndows and have never used a tar file before.

Share this post


Link to post
Share on other sites

I've just downloaded the add on, but all I see is a .tar file which I don't know what to do with - can anyone help? :blink: I use WIndows and have never used a tar file before.

 

Well I figured it out and got 7Zip to extract it so I managed to look at the files.

Just in case any other newbie has the same problem. Easy when you know how eh?... :D

Edited by Dali45

Share this post


Link to post
Share on other sites

Quick question. Does this contribution work if I want to sell both downloadable and non-donwloadable products. Lets say I was selling music for example - if I offered both a music download and a cd option, and someone added both to their basket to buy, would it mess the checkout process up in any way?

Share this post


Link to post
Share on other sites

I have another question which I hope someone might be able to answer - I would like to use this add on using the latest version of osC, RC2a, and am wondering if there will be any issues with using paypal standards payment module that it comes with as this uses IPN.

Share this post


Link to post
Share on other sites

This appears to be a great contribution. I am using it to offer pdf versions of our company catalog for download on our website. I am having one issue. Evrything is working properly except ther is no link for download. I have the name of the catalog, the expiry date which I was able to correct with information somehere in this thread, and the number of available downloads. I cannot click on the name to download and there is no visible link to it. What could be the problem?

Share this post


Link to post
Share on other sites

http://www.shop.eu/CONTENT_DOWNLOAD.php?order=8&id=1

It was not it been possible to take file. How do to repair?

Edited by krys121

Share this post


Link to post
Share on other sites

I know this is probably a noob question, but I don't understand how I need to change the definitions in step 3.2 of the instructions.

 

The directions I'm having problems with are:

 

- STEP 3.2 - And then add new definitions to files list below: (Do NOT overwrite your existing files with the ones came with this package!!)

catalog/includes/database_tables.php

catalog/admin/includes/configure.php

catalog/admin/includes/database_tables.php

catalog/admin/includes/languages/english/products_attributes.php

 

I did all of the previous steps in the directions: Backing it all up, copying files, using winmerge, etc. I generally understand what a definition does (I'm new to PHP but I understand definitions in Java and C++). I don't understand what exactly needs to be changed in these scripts, though.

Share this post


Link to post
Share on other sites

I'm sorry, I should have read the files. That was a stupid question. I'm copying the new definitions from the new files to over to the old files now.

 

I need stronger coffee or something.

Share this post


Link to post
Share on other sites

I know this is probably a noob question, but I don't understand how I need to change the definitions in step 3.2 of the instructions.

 

The directions I'm having problems with are:

 

- STEP 3.2 - And then add new definitions to files list below: (Do NOT overwrite your existing files with the ones came with this package!!)

catalog/includes/database_tables.php

catalog/admin/includes/configure.php

catalog/admin/includes/database_tables.php

catalog/admin/includes/languages/english/products_attributes.php

 

I did all of the previous steps in the directions: Backing it all up, copying files, using winmerge, etc. I generally understand what a definition does (I'm new to PHP but I understand definitions in Java and C++). I don't understand what exactly needs to be changed in these scripts, though.

 

On those four files you mentioned, all that needs to be done is ADD the scripts from the MODIFIED versions in the package to the respective files in your store. Like it says, DO NO REPLACE the files, just add the script to the end of the current files in your store.

 

Example: From the modified_folder/catalog/admin/includes/database_tables.php

 

You'll see this:

 

/***********************************************************
 Add the new definitions below to your existing file
 DO NOT override your existing file with this one !!
************************************************************/

// BOF Super Download Shop v1.0 mod
 define('TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS', 'products_attributes_download_groups');
 define('TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS_FILES', 'products_attributes_download_groups_files');
 define('TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS_TO_FILES', 'products_attributes_download_groups_to_files');
// EOF Super Download Shop v1.0 mod
?>

 

Just add that at the end of: your stores catalog/admin/includes/database_tables.php and so on a so fourth.

 

Hope it helps :)

 

Edit: Just read you already sorted it, haha got any coffee left? ;)

Edited by trickz100

Share this post


Link to post
Share on other sites

OK, I'm getting an unexplained error on my Admin Panel, and I'm hoping someone can help.

 

The Error is:

File Groups

1146 - Table 'rox1033706203108.TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS' doesn't exist

 

select download_group_id, download_group_name from TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS where download_group_id != 0 and language_id = 1 order by download_group_id

 

[TEP STOP]

 

Now, I've gone into phpAdmin and checked the table and it is there. It was, however, empty, so I added one record with ID = 0 and language = 1, and left the only other field blank. I do have a screen capture of the table in phpAdmin if that will help anyone.

 

Is there something else I need to do?

 

Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

OK, I'm getting an unexplained error on my Admin Panel, and I'm hoping someone can help.

 

The Error is:

File Groups

1146 - Table 'rox1033706203108.TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS' doesn't exist

 

select download_group_id, download_group_name from TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD_GROUPS where download_group_id != 0 and language_id = 1 order by download_group_id

 

[TEP STOP]

 

Now, I've gone into phpAdmin and checked the table and it is there. It was, however, empty, so I added one record with ID = 0 and language = 1, and left the only other field blank. I do have a screen capture of the table in phpAdmin if that will help anyone.

 

Is there something else I need to do?

 

Any help is greatly appreciated.

 

Can anyone help here, please? This is on a live store and I cannot add downloadable products to the store now.

Share this post


Link to post
Share on other sites

Answered in the post above yours.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Answered in the post above yours.

 

Regards

Jim

 

No, actually it's not answered there.

 

I DID that and the result is this error message.

 

I guess I'm left with no alternative but to delete this. I cannot go on without being able to add products to my store.

Share this post


Link to post
Share on other sites

Then you made the changes to the wrong file, or didn't upload the file to the right place. That error can only happen if you didn't define the database table name. Period.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Then you made the changes to the wrong file, or didn't upload the file to the right place. That error can only happen if you didn't define the database table name. Period.

 

Regards

Jim

Perhaps you missed this part of my earlier question.

 

 

Now, I've gone into phpAdmin and checked the table and it is there. It was, however, empty, so I added one record with ID = 0 and language = 1, and left the only other field blank. I do have a screen capture of the table in phpAdmin if that will help anyone.

Share this post


Link to post
Share on other sites

No, I read what you wrote. You're still not reading what I write, so I'm giving up now.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I seem to be having the same problem that karinha has been having http://forums.oscommerce.com/index.php?showtopic=250062&view=findpost&p=1114280

 

I think I've upped all my settings in my php.ini file and I am in safe mode. (execution times, socket timeouts, memory limit up to 150M, etc)

 

All my files are ending up corrupt in XP and not fully downloading in vista (90mb files are only coming in at 65mb). files download fully in win 7 and mac osx.

 

XP files are the correct size, but I get a "invalid or corrupted" file error when trying to extract.

 

downloading the files directly works (i took off .htaccess protection for a test)

 

any help would be greatly appreciated. I'd be glad to give you access to an account with files available in an order for download.

 

thanks!

Share this post


Link to post
Share on other sites

Well, I finally got this working, but now I have a new problem.

 

I split my file into 2 smaller files.

 

I created a group.

 

I go to insert the file into the group and osCommerce says the file does not exist.

 

I have checked and re-named and done everything I can think of.

 

The file IS there in /download

 

/download is chmod 777

 

/pub is chmod 777

 

the file exists and is named properly.

 

Ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×