Jump to content
Sign in to follow this  
rigadin2

[Contribution] TinyMCE Anywhere

Recommended Posts

Have read my way through the Forum and have reached the conclusion, that no one has been able to get ibrowser to work without ACA. Any way i hope that someday someone will be able to give comprehensive help getting this contribution to work. It sounded to good to be TRUE.

 

keep ROCKING

 

Claudia

Share this post


Link to post
Share on other sites
Hi

I installes ACA 2.6.3 along with the mods the tinyMCE discriptions work but when I hit the ibrowser button I get Forbidden to access the ibrowser.php file and a 404 error.

 

I have made sure I cen access on the serever the file. At a loss

this file deny .php script executing for public.

catalog\includes\.htaccess

 

i resolve this proble by adding file to this directory with this text:

catalog\admin\includes\javascript\tiny_mce\plugins\ibrowser2\.htaccess

 

<Files *.php>

Order Allow,deny

Allow from all

</Files>

Worked like a charm for me. Thank you! :)

Edited by Patty

Patty

Share this post


Link to post
Share on other sites

I really need some help now. I've been trying all day to fix the problem with product image and tinyMCE.

 

The thing is tinyMCE will save the product image in the db as

<img src="http://localhost/My%20Webs/catalog/images/dvd/frantic.gif

instead of just the file name dvd/frantic.gif

 

On the admin side, when I view the products under a category, the thumbnail path looks like this:

http://localhost/My%20Webs/catalog/images/dvd/frantic.gif%3C/td%3E%20%20%3C/tr%3E%20%20%3Ctr%3E%20%20%20%20%3Ctd%20class=

And when editing the product, the thumbnail preview looks like this:

http://localhost/My%20Webs/catalog/images/dvd/frantic.gif%3Cinput%20type=

 

I've searched everywhere, tried everything to no avail. :(

None of the relative_urls and filter_save_image function tips worked so far.

 

On products description and other pages image insertion works just fine. It's just the product image that is having this issue (iBrowser2).

 

I'm using RC2 + PHP 5.2.8 + MySQL 5.1.30 on my localhost.

 

Could someone please help me keep my sanity and give me a clue on how to fix this??? Pleeeeease??? :blink:

Edited by Patty

Patty

Share this post


Link to post
Share on other sites

HI Jack,

 

well most of my site is using tiny mce anywhere now and no problems.

 

I do have one problem still.

 

This is with the information pages unlimited with the addtional welcome message setcion, basically I can use tiny mce for the information pages but not for the welcome messages.

 

The gID is 1 for the infomartion pages and 2 for the welcome messages, I can only get the tiny mce to work for gID=1.

 

so if I change the gID's in the database to 1 everything uses tiny mce on them all but the information pages and the welcome messages are in the information.

 

I want to use the same editor across the entire site and tiny mce is my preference, when I use the fck editor for the unlimited information pages then both welcome messages and information pages are editable with the html features.

 

can you shed any light on how to get the tiny mce to work for the welcome messages as well as the information pages?

 

Thanks

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I have problem with some errors showing in the error log (C-panel).

 

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/fullpage, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/layer, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/devkit, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/nonbreaking, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/visualchars, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/media, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:25 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/admin/includes/javascript/tiny_mce/plugins/cleanup, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...age=1&bID=2

[sun Jun 21 13:33:15 2009] [error] [client xxx.xxx.xx.x.xx] File does not exist: /home/xxxxxx/public_html/dev/404.shtml, referer: http://xxx.xxxxxxx.xxx/admin/extra_info_pa...&action=new

 

Is there anyone who understand this errors? and what can i do to correct them?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi, having a vierd problem with Header Tag seo and TinyMCE anywhere. Se post 3591 in HT SEO forum.

 

I just want to hear if any other have had the same issue. It only affect categori description in HT SEO and IE(firefox ok). It adds and replace / change text when saving and the only time it works normal is when i save the first text for the firs time. When editing after it all ends up in garbage(se limnk to other post at top)

 

I have tryed mayn variants to fix it but with no luck. Even if i reinstall and only add HT SEO and TinyMCE it fails.

Can you try to edit the categori description and se if you get the error.

 

In firefox it all works as expected. I have tryed to get some ansvers in HT SEO tread but none that helps fix the problem.

 

Inn all other places the editor is working as expected.

Share this post


Link to post
Share on other sites

I also have trouble with garbage signs when using TinyMCE on special pages. Everytime i Insert a table and save the document I get br-tags verywhere in the table. Like this

 

<table>

<tr> <br>

<td>hello</td><br>

<td>hi</td><br>

</tr><br>

</table>

 

this causes IE and Firefox to push the table to the bottom om the page.

 

Does anyone know what causes this?

Share this post


Link to post
Share on other sites

Hello,

 

Can someone tell me how to turn off in admin/categories.php the debug development kit drop down box?

 

Thanks Jr

Share this post


Link to post
Share on other sites

Hi,

 

Is there a way to add more font sizes to tinymce?

At the moment it only uses:

xx-small,x-small,small,medium,large,x-large,xx-large

 

But these do not match the font sizes used on my site.

 

Any ideas?

Share this post


Link to post
Share on other sites

Hi,

It seems that the last update to TinyMCE Anywhere was 17 Sep 2007.

My TinyMCE Anywhere install works fine with FF and IE on Fedora and XP but when I try to use Chrome none of the buttons in TinyMCE work.

Everything looks fine; they just don't do anything!

I found an "Uncaught TypeError: Cannot read property 'baseNode' of undefined"

in the java script of tiny_mce.js but that's as far as I can take it.

Does anyone have this combination working with Chrome?

Is anyone maintaining TinyMCE Anywhere?

Thanks,

Ralph

Share this post


Link to post
Share on other sites

Hi,

 

I moved my store to another host, and also changed domain. After that I upgraded my MS2.2 store to RC2a.

My problem is that now the Tiny MCE editor in many of my pages in admin does not show. It still shows when I go to admin in my old store at my old host.

 

Anybody know how to make it show again?

 

 

Thanks :-)


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

This is a great contribution and I really appreciate it. I like it more than Fckeditor and Ckeditor because the image drop down list allows you to just type a letter and it brings you to the alphabetical listing with that letter first in your images list.

 

The trouble is I upgraded to the newest version and now the image list is randomly sorted and not in alphabetical order. Anyone know how to correct that?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×