Latest News: (loading..)
Sign in to follow this  
Followers 0
Colin J

WorldPay - Callback

2 posts in this topic

Hello:

 

Text below is from install.txt for Worldpay v4.0 Version 1.9. I am having the problem outlined. Pardon my ignorance but I am assuming this is dealt with via phpmyadmin. However, if I go to phpmyadmin order_status and then browse, the order status values and names appear to be in place.

 

Am I missing something?

 

I have noticed a number or references to this problem of orders not appearing in admin/orders once processing has occured but can't find a suggested resolution other then the one proposed below which does not seem to apply to me.

 

Any help is much, much appreciated.

 

____________________

 

ps. I found that orders were not appearing in my admin screen once payment had been received. I found this was nothing to do with the payment module but that 3 rows were missing from the order_status table.

 

INSERT INTO orders_status VALUES (1, 1, 'Pending');

INSERT INTO orders_status VALUES (2, 1, 'Processing');

INSERT INTO orders_status VALUES (3, 1, 'Delivered');

Will reslve this problem. Only do this if you experience the same problem.

Share this post


Link to post
Share on other sites

Answer to my own post. The problem was the callback url used in worldpay admin.

 

Do not use the quotes: https://<wpdisplay item="MC_callback">

Should be: https://<wpdisplay item=MC_callback>

 

Same goes for http.

 

Hello:

 

Text below is from install.txt for Worldpay v4.0 Version 1.9. I am having the problem outlined. Pardon my ignorance but I am assuming this is dealt with via phpmyadmin. However, if I go to phpmyadmin order_status and then browse, the order status values and names appear to be in place.

 

Am I missing something?

 

I have noticed a number or references to this problem of orders not appearing in admin/orders once processing has occured but can't find a suggested resolution other then the one proposed below which does not seem to apply to me.

 

Any help is much, much appreciated.

 

____________________

 

ps. I found that orders were not appearing in my admin screen once payment had been received. I found this was nothing to do with the payment module but that 3 rows were missing from the order_status table.

 

INSERT INTO orders_status VALUES (1, 1, 'Pending');

INSERT INTO orders_status VALUES (2, 1, 'Processing');

INSERT INTO orders_status VALUES (3, 1, 'Delivered');

Will reslve this problem. Only do this if you experience the same problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0