Jump to content
Sign in to follow this  
Helter

Linkpoint module problems.

Recommended Posts

Hi, I'm trying to get linkpoint setup on my fresh oscommerce installation, and am getting nowhere *fast*.

 

I've tried both the Linkpoint API module and the Linkpointconnect module, and both seem to do the exact same thing. I put in the information (either a test card number or a real one) and get sent directly to a blank screen at the checkout_confirmation.php address. If I click enter on the url again, I get the message

 

The first four digits of the number entered are: <br>If that number is correct, we do not accept that type of credit card.<br>If it is wrong, please try again.

 

Which I'm guessing means that no data was transmitted.

 

Just to test, I changed my submission form URL in yourpay to a different address, and was still sent to the same blank page, making me suspect that I'm not even connecting to linkpoint. I asked the server admin to check if he could be firewalling port 1129, and he says that he's not. From the command line I executed "wget staging.linkpt.net:1129" and while I couldn't get an HTTP response, it did report a connection to the server, so I don't think that's it.

 

Another curious aspect of this is that the same thing happens whether I use my test account store number of my production store number. It's odd, because the linkpoint API module requires a PEM file that should be linked to the store number, and I only have one for my production account, so I'd expect that using my test account store number would throw and error of some sort, which it isn't.

 

If anyone could give me a hand it would be greatly appreciated. I don't even really know where to begin to troubleshoot this.

 

Thanks

Share this post


Link to post
Share on other sites

I had problems with my Linkpoint too and the guys who developed the module couldn't help me because they were too busy with their business, but they gave me a very good suggestion of look for help in a place where you can hire a freelancer programer. Well, it's 3 months that I'm battling with my oscommerce website trying to install contributions, shipping module, credit card module, etc . Now, this freelancer is going to fix my Linkpoint and install 9 more contributions and I hope I don't have to worry or lose my time with this anymore. If I knew this before I'm sure my website would be live long time ago. I'm not sure if I can post the address here, just in case if you want to know please feel free to ask me.

Good luck with yr website.

Meg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×