Jump to content
Sign in to follow this  
GemRock

Header Tags for novices

Recommended Posts

the reasons for a blank page could too many to list - you may list 100 but miss one which happens to the very reason! so without actually working/looking at the site in question, i can only suggest you double check your installation at the admin side, eg, make sure you dont upload a language file as a script file (with same name as the language file but much bigger file size) by mistake.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hello,

i've installed the Header Tags For Novices V3.0 and i have a problem. The first part works very good (it automatically generate the title tag, the description tag and the keywords tag).

I have installed the headers_tags_edit too, and i have a problem with it. From the backoffice i can fill and update the form with the Page Title Tag, Description Tag and Keywords Tag. The form updates them succesfully, and in the database, i can see that the fields title_tag, desc_tag and keywords_tat have the text i've entered in the product i was updating. But the problem is that at the website, the tags are the automatically generated, not the tags i've entered in this product. Any suggestion??

Thank you very much

Share this post


Link to post
Share on other sites
... the problem is that at the website, the tags are the automatically generated, not the tags i've entered in this product. Any suggestion??

Thank you very much

could you post what you entered in product info.php, is it sometihng like below?

<title><?php echo $header_tags[title_tag]; ?></title>
<meta name="description" content="<?php echo $header_tags[desc_tag]; ?>">
<meta name="keywords" content="<?php echo $header_tags[keywords_tag]; ?>">

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
could you post what you entered in product info.php, is it sometihng like below?
<title><?php echo $header_tags[title_tag]; ?></title>
<meta name="description" content="<?php echo $header_tags[desc_tag]; ?>">
<meta name="keywords" content="<?php echo $header_tags[keywords_tag]; ?>">

Ken

 

 

Thank you for your reply. I have this:

 

<title><?php echo ((strlen($categories['categories_name']) > 1) || (strlen($manufacturers['manufacturers_name']) > 1)) ? $header_tags['products_name'] . ' - ' . $breadcrumb_tags->trail_tags(' ') . ' - ' . TITLE : TITLE; ?>
</title>
<meta name="description" content="<?php echo $header_tags['products_name'] . strip_tags($breadcrumb_tags->trail_tags(' ')); ?>">
<meta name="keywords" content="<?php echo $header_tags['products_name'] . strip_tags($breadcrumb_tags->trail_tags(', ')); ?>">

Share this post


Link to post
Share on other sites
could you post what you entered in product info.php, is it sometihng like below?
<title><?php echo $header_tags[title_tag]; ?></title>
<meta name="description" content="<?php echo $header_tags[desc_tag]; ?>">
<meta name="keywords" content="<?php echo $header_tags[keywords_tag]; ?>">

Ken

 

I have replaced it with this code and now it works perfect. Thank you!!. Why doesn't it work with the old code? i copied it from the installation notes.

Alex

Share this post


Link to post
Share on other sites

I hope this is an easy question to answer and an easy problem to fix. I just installed this contribution, and prior to this I also had a similar problem. My websites title is E-Commerce even though I have set the Store Name in the configuration. Any suggestions on how to fix this simple problem? My headers look like this when iI look at the source "Custom - Devil Sticks - E-Commerce" when it should be "Custom - Devil Sticks - My Sites Name". Thanks for any help you can provide.

Share this post


Link to post
Share on other sites

One more thing, the catagory is showing up in the meta tags with no space between the actual item and the catagory so my metatags look like "Stone PipesPipes" when what I want is "Stone Pipes Pipes" or just "Stone Pipes" without the catagory. What is the easiest and best way to fix this? I am thinking I just need to alter the products_information.php code a little to prevent this.

Edited by jester420247sl

Share this post


Link to post
Share on other sites

I found the code I need to remove, it was the

. strip_tags($breadcrumb_tags->trail_tags(', '))

in the poduct_information.php now my meta tags dont have so much redundant info.

Share this post


Link to post
Share on other sites
I still have the "E-Commerce" issue though on all the titles of my pages.

the Title is defined in eg, english.php, not the store name. for any other issues, you need to say what version you use and where you get it from. always remember to download the instructions posted at google code site or my site.

 

the forum failed to send out emails to me...dont know why...i saw your question by accident.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
I still have the "E-Commerce" issue though on all the titles of my pages.

 

In your admin panel, under Tools / Define Languages / english.php

 

find this or something similar

 

// page title

define('TITLE', STORE_NAME);

 

the above is how my page title is set and 'STORE_NAME' displays my store name in my page titles. You can change this to anything you want.

 

Hope this helps

Share this post


Link to post
Share on other sites
In your admin panel, under Tools / Define Languages / english.php

 

find this or something similar

 

// page title

define('TITLE', STORE_NAME);

 

the above is how my page title is set and 'STORE_NAME' displays my store name in my page titles. You can change this to anything you want.

 

Hope this helps

 

That is much better than the sloppy way I did it, thanks yet again.

Share this post


Link to post
Share on other sites

Hi I have installed SEO Dynamic Header Tags V4 and I have a couple of problems. It all seemed to go ok but i can only view 3 products within the admin section. It will not let me show more than that despite there being a drop down list to select 10, 20 30 Etc. I have also tried entering just a couple of test keywords into the corresponding boxes and then clicked update to which it says that they have been updated. When however i then view the product page source it has not placed the keywords into the product page, they remain empty. I am obviously missing something any help would be appreciated. I am using Oscommerce v2.2 RC2a. I dont receive any errors or nothing just will not place the keywords in as said and will only let me view 3 products or 3 categories. I have gone over everything twice but cannot see any steps I have missed.

Share this post


Link to post
Share on other sites
...I have gone over everything twice but cannot see any steps I have missed.

did you download the installation (v2) from the googlecode site or from my website (which is the latest version)?

this contribution generates the least support issue as it does not require lots of modifications to your site if you follow the instructions.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
did you download the installation (v2) from the googlecode site or from my website (which is the latest version)?

this contribution generates the least support issue as it does not require lots of modifications to your site if you follow the instructions.

Ken

 

I downloaded header tags V4.0 fromyour signature

Share this post


Link to post
Share on other sites
I downloaded header tags V4.0 fromyour signature

 

both the contribution and the instruction are actually here. The two files are separate.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
both the contribution and the instruction are actually here. The two files are separate.

 

Ken

 

Hi i will download it now. That is the one that i am using when i looked at the instructions Etc I downloaded the instructions and the contribution which is version 4.

 

I can PM you the user name and password to the website admin section if you want so that you can see what i mean.

Edited by pgreen50

Share this post


Link to post
Share on other sites

then pm me asap. i only have 10 minutes.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

I have had a quick look at it. it appears the categories part is working OK ( i tested it by enetring title. desc & keywords) and the rows per page. so my suggestion is first to reupload the products header tags file.

 

btw, are you using a template shop?

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hi Ken think you may have gone but there is no products header tags file in the download unless its called something else.

 

I have reuploaded all files to the server and as you say the categories is working fine its just the products one now. Hopefully when you get time you could perhaps see the reason as to why its not functioning. Thanks for your time today.

Edited by pgreen50

Share this post


Link to post
Share on other sites

sorry by that i meant: header_tags_edit.php, which is about 18KB in size. make sure you use the one from my googlecode site.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Done that but still no joy. Done it twice now. Thanks in advance. Does it matter if its ASCII or Binary upload format?

Edited by pgreen50

Share this post


Link to post
Share on other sites

you are NOT using the newest header_tags_edit.php as far as i can see. so get it from my signature (click on Contribution).

depending on you FTP application, you can use Auto or binary, but NOT ASCII.

 

Ken

edit: sorry, you are but the one on the googlecode site is a bit out of date.

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×