Jump to content
Sign in to follow this  
GemRock

Header Tags for novices

Recommended Posts

Hello everyone,

 

Just came upon Ken's contribution and this thread. I am working on a new oscommcerce site and this sounds like something we definitely should implement.

 

My question: does anyone care to share their site so I can see how exactly it turns out after installing this contribution?

 

Thank you! :)

What do you think you will actually see?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Thanks for the greeat Contribution.

But I have one problem:(

When i fill in the data in admin, Product Meta tags is ok, but the data I fill in Category Meta Tags dont`t shows in my website.

Sorry for the bad eng

Share this post


Link to post
Share on other sites
Thanks for the greeat Contribution.

But I have one problem:(

When i fill in the data in admin, Product Meta tags is ok, but the data I fill in Category Meta Tags dont`t shows in my website.

Sorry for the bad eng

if you have followed the installation instructions fully, then, by default, category meta tags only show on index/home page, not on product info page.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
What do you think you will actually see?

 

 

I'm not sure! :huh:

 

I was thinking this would allow different pages in an oscommerce site to have different and more meaningful title tags rather than the exact same title at the top of every page?

Share this post


Link to post
Share on other sites
I'm not sure! :huh:

 

I was thinking this would allow different pages in an oscommerce site to have different and more meaningful title tags rather than the exact same title at the top of every page?

yes, itd do that which is "printed on the tin". why not spend 5 minutes to try it out?

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
if you have followed the installation instructions fully, then, by default, category meta tags only show on index/home page, not on product info page.

 

Ken

 

Thanks for the answer. I have followed the instruction fully. But i will check it again. Is not showing in the productlisting(category), only in the productinfo.

Share this post


Link to post
Share on other sites

anyone wants to have a look how it works can go to my website home page (can be found under my profile, i am not putting the link here as this may be against the forum rules), followed by osc/ , which is a default setup, ie, no manual entries at admin. For best results, it is recommended you manually fill in the title tag, keywords tag and description tag for products as well as for categories. Given that you could enter scores of products/categories in one single page, the process should not take long.

 

Good Luck!

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
i am not sure what exactly you mean?

 

Ken

 

When i had the older version of this contrib installed, the manufacturers name was displayed in the title tag when you those a manufacturer from manufacturers list. ex. if you choose AsRock, it would say "Asrock - websitename" in the title tag, now it just say "websitename".

 

I have tried to put this code from the old contrib

|| (strlen($manufacturers['manufacturers_name']) > 1)

in the title tag in index.php, but with no luck.. Complete code from my old contrib is

<title><?php echo (strlen($categories['categories_name']) > 1) || (strlen($manufacturers['manufacturers_name']) > 1) ? $breadcrumb_tags->trail_tags(' ') . ' - ' . TITLE : TITLE; ?></title>
<meta name="description" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(' ')); ?>">
<meta name="keywords" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(', ')); ?>">

 

I am missing the titletag on the manufacturers because it gave me a better google rating on many products.

Share this post


Link to post
Share on other sites

Try to replace the title tag with:

<title><?php echo ((strlen($categories['categories_name']) > 1) || (strlen($manufacturers['manufacturers_name']) > 1)) ? $breadcrumb_tags->trail_tags(' ') . ' - ' . TITLE : TITLE; ?></title>

if in doubt then have a look at my osc demo as mentioned above. i copied the title tag bit from the osc demo's index.php.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Try to replace the title tag with:
<title><?php echo ((strlen($categories['categories_name']) > 1) || (strlen($manufacturers['manufacturers_name']) > 1)) ? $breadcrumb_tags->trail_tags(' ') . ' - ' . TITLE : TITLE; ?></title>

 

and the new V.2 install

<title><?php echo (strlen($title_tag) > 1) ? $title_tag . ' - ' . TITLE : $title_home_default . ' - ' . TITLE; ?></title>

 

In the V.2 install the manufactuerer code seems to have been moved to product_info.php, but is not working right.

 

Solving this will make this contrib the ultimate seo for oscommerce i think :D

Share this post


Link to post
Share on other sites

well, unless you only have one manufacturer, i cant think of an example of you can have both at the same time. you click on a category, and that category could have products from different makers/suppliers, on the other hand, you select a manufacturer, and that manufact. could have products in different categories, which means you can only show either category name or manufact. name, but not both, in the title.

one way to by pass this would be entering the title tag the way you want from admin for each product as you would know what category it is in and which manufact. it is from. such as this:

 

product name --------- title tage

productX --------- categoryA - manufact.Y - store name

 

for the above to work you will need to reverse back to the previous or the new title tag format in the index.php.

 

HTH,

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

what i said above RE each product should be each category, ie, you add a manufacturer of your choice for a category. or what is your suggestion?

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hello,

I am trying to integrate this with STS. None of these ideas are quite doing the trick. I'd be happy to paypal a donation to anyone who is familiar with integrating these two contributions, for some personalized help with this.

 

Thanks,

 

Scott

Share this post


Link to post
Share on other sites

Scott

someone has done it before. have you read through this thread possibly from page 3?

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

I have tried all of the ideas in the forum, but I still haven't gotten it perfect yet. I just fiddled around with it some more and I think I know whats wrong.. or.. what I don't understand.

 

Why is this:

 

$header_tags[title_tag];

 

Returning both the category and the title tag?

 

The category is "bulk herbs" and the product is "Butea superba."

 

$header_tags[title_tag]; returns "bulk herbs butea superba"

 

If I can figure that out, I might be able to get this to work.

 

Thanks so much for your hard work, Ken. I'll try to give back by sharing my experience with integrating these two scripts, once I get it finished.

Share this post


Link to post
Share on other sites

If possible, could someone delete my last couple posts?

 

Regarding STS integration::

 

I have it working much better now. I had to comment out the part in application_top that adds the category to the title tag.

 

Here is what I have for includes/sts_inc/general.php:

 

// Header Tags for novices w/STS v4.3.3 BOF
$sts->template['headertags']= "<title>";
$sts->template['headertags'] .= (strlen($breadcrumb_tags->trail_tags('')) > 0) ? TITLE . ' - ' . $breadcrumb_tags->trail_tags(' - ') . ' - ' . $header_tags[title_tag] : TITLE;
$sts->template['headertags'] .= "</title>\n";
$sts->template['headertags'] .= "<meta name=\"description\" content=\"";
$sts->template['headertags'] .= htmlspecialchars($header_tags[desc_tag]);
$sts->template['headertags'] .= "\">\n<meta name=\"keywords\" content=\"";
$sts->template['headertags'] .= htmlspecialchars($header_tags[keywords_tag]);
$sts->template['headertags'] .= "\">\n";
// Header Tags for novices EOF

 

It seems to be working pretty well.

Share this post


Link to post
Share on other sites

Regarding this line of code in /modules/sts_inc/general.php::

 

$sts->template['headertags'] .= (strlen($breadcrumb_tags->trail_tags('')) > 0) ? TITLE . ' - ' . $breadcrumb_tags->trail_tags(' - ') . ' - ' . $header_tags[title_tag] : TITLE . ' - ' . HEADING_TITLE;

 

Right now it shows

 

[sTORE NAME - CATEGORY - SUBCATEGORY] when browsing categories, and [sTORE NAME - CATEGORY - SUBCATEGORY - PRODUCT TITLE] when viewing a product.

 

Is there any way I can just display [sTORE NAME - PRODUCT TITLE] on the products page? I don't really understand the funky if-then action going on in that line of code, but it seems like might be easy.

 

Thanks for the help!

Share this post


Link to post
Share on other sites

Hi Scott

 

If your problem is understanding that 'funky if-then' bit, then here is what it would look like if written in a normal way (or a non-php way):

 

if (strlen($breadcrumb_tags->trail_tags('')) > 0) {
$sts->template['headertags'] .= TITLE . ' - ' . $breadcrumb_tags->trail_tags(' - ') . ' - ' . $header_tags[title_tag];
} else {
$sts->template['headertags'] .= TITLE . ' - ' . HEADING_TITLE;
}

 

I dont have such a template setup so I can't offer more specific advice. The way I do it is probably kill the part of the template that interferes with <head> </head> section of the index and product info pages, so that you can add the tags just like a non-template osc system.

 

HTH

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

i installed this contribution and every thing seemed fine until i went in admin and added tags to a product. i got this message:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

select count(*) as total from products p, products_description pd where p.products_id = pd.products_id and pd.language_id = '1'order by

 

[TEP STOP]

 

Sort All Product Name Ascendingly Sort All Product Name Descendingly

Product Name

 

 

Page Title Tag (Optional)

 

 

Description Tag (Optional)

 

 

Keywords Tag (Optional)

Share this post


Link to post
Share on other sites

i installed this contribution and every thing seemed fine until i went in admin and added tags to a product. i got this message:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

select count(*) as total from products p, products_description pd where p.products_id = pd.products_id and pd.language_id = '1'order by

 

[TEP STOP]

 

Sort All Product Name Ascendingly Sort All Product Name Descendingly

Product Name

 

 

Page Title Tag (Optional)

 

 

Description Tag (Optional)

 

 

Keywords Tag (Optional)

Share this post


Link to post
Share on other sites

Hi Sophia

 

which version you installed and where you got it from? it looks like the problem is unique to you as no others have ever reported this error.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Hi Sophia

 

which version you installed and where you got it from? it looks like the problem is unique to you as no others have ever reported this error.

 

Ken

 

 

I got it from here

 

for some reason i cant get the read me file to open now but it did ealier and gave reference to a google project page. There I followed the instructions form an html page but all the files were copied from the link I just gave you.

 

i will update if i get the readme file open later. that way you will see exactly what i did. thanks again.

Share this post


Link to post
Share on other sites

HI Sophia

 

The latest version of the contribution and the install instruction is in fact at the google code page which you can get by following the link NEW: xhtml 1.0 strict compliant osCommerce v2.2 Final UK version & Non-UK version in my signature.

please confirm the version you actually use and whether you still get the error.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

HI Ken,

 

I created tags for other products without problems last night so not sure why I got the error before. Everything seems fine now. I followed your link above but the page looks a bit different from the one I downloaded from. Thanks for your response. If I get an errors in future I will first download from the link you just gave then post here if it continues. thanks a million......sophia

Share this post


Link to post
Share on other sites

I just installed the new version of this and everything seems fine, except when in admin, I click on catalog-->product meta tags, the page is blank. The same thing happens when I click on category meta tags. Is there something I did wrong? As I want to manually edit some of the title and header tags on the pages in admin. Please help! Thanks

Edited by mmart621

Check out unique health supplements

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×