Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
GemRock

Header Tags for novices

Recommended Posts

i dont think i understand your question. there is a comma there (Cylinders, Copper ), or maybe show me what it should look like?

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
i dont think i understand your question. there is a comma there (Cylinders, Copper ), or maybe show me what it should look like?

 

Ken

sorry ken trust me to have the most complicated web sites in the world ..lol with the origanal code.

 

<meta name="description" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(' ')); ?>">

<meta name="keywords" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(', ')); ?>">

 

every thing seems to be fine untill you go down 4 layers and then when the product is on the 4 the layer down it seems to miss the comma or space..

 

layer 1 all ok) http://lpssupplies.com/underfloor-heating-systems-c-218.html

<meta name="description" content="Underfloor Heating Systems">

<meta name="keywords" content="Underfloor Heating Systems">

 

layer 2 all ok) http://lpssupplies.com/underfloor-heating-...-c-218_219.html

<meta name="description" content="Underfloor Heating Systems Electric Underfloor">

<meta name="keywords" content="Underfloor Heating Systems, Electric Underfloor">

 

layer 3 all ok) http://lpssupplies.com/electric-underfloor...18_219_123.html

<meta name="description" content="Underfloor Heating Systems Electric Underfloor Underfloor Heating Controllers">

<meta name="keywords" content="Underfloor Heating Systems, Electric Underfloor, Underfloor Heating Controllers">

 

layer 4 goes wrong for some reason ?? ) http://lpssupplies.com/digistat-p-1513.html

<meta name="description" content="Digi-StatUnderfloor Heating Systems Electric Underfloor Underfloor Heating Controllers">

<meta name="keywords" content="Digi-StatUnderfloor Heating Systems, Electric Underfloor, Underfloor Heating Controllers">

 

 

sorry if i have not explained myself correctly.. Mike

Share this post


Link to post
Share on other sites

layer 4 is the product_info.php, whereas the other 3 layers are index.php. would this give you some hints? as you did not say which file the meta tags code was from.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
layer 4 is the product_info.php, whereas the other 3 layers are index.php. would this give you some hints? as you did not say which file the meta tags code was from.

 

Ken

 

 

 

Ken your a star from a far! Many thanks once again for the pointers, Mike

Share this post


Link to post
Share on other sites
Guest
it should only take you one minute (far from your whole life) to sort this out if you read the instructions another time with a bit more care perhaps :) : you forgot to upload one language file to the server or you uploaded it to the wrong place.

 

Good Night & Good Luck!

Ken

Thanks i worked that a short while after i made the post.

 

Nick

Share this post


Link to post
Share on other sites

I have just released a new version of this contribution (v4.00) that adds the ability to edit header tags for categories. Please go to: http://addons.oscommerce.com/info/4822

or download directly from here

 

Your feedback is welcome!

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

a separated installation guide for version 4.00 has been uploaded. you can get it from the same location where you got the contribution from.

 

Enjoy!

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
I have just released a new version of this contribution (v4.00) that adds the ability to edit header tags for categories. Please go to: http://addons.oscommerce.com/info/4822

or download directly from here

 

Your feedback is welcome!

 

Ken

 

Hi,

 

Thanks for developing this great addon. I have just installed v4 from scratch and I have just a few comments:

1. for some reason, the line

require(DIR_WS_INCLUDES . 'column_left.php');

is commented on the 2 admin files: header_tags_category_edit.php and header_tags_edit.php

 

2. The title tag in index.php is appearing like " - SHOP NAME" instead of just "SHOP NAME". I changed the file from

<title><?php echo $header_tags[title_tag]; ?></title>

to:

<title><?php

if ($title_home_default == "") {

echo (strlen($title_tag) > 1) ? $title_tag . ' - ' . TITLE : TITLE;

}

else

{

echo (strlen($title_tag) > 1) ? $title_tag . ' - ' . TITLE : $title_home_default . ' - ' . TITLE;

}

?></title>

 

I have not tried the manual editing of Meta Tags yet.

 

Br

Pedro

Edited by pedro.antunes

Share this post


Link to post
Share on other sites

Hi Pedro

 

Thanks for raising this issue. :thumbsup: There seems to be one line of code missing:

$title_home_default = STORE_NAME;

 

which should be added to the code below (if you want your shop's name appears in the title):

 

//default keywords for the index (home) page

$kws_home_default .= STORE_NAME;

//default Description for the index (home) page

$desc_home_default = "ENTER YOUR DEFAULT DESCRIPTION TAG TEXT HERE FOR THE HOME PAGE";

 

If you don't want the shop name in the title, then your mod works.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Just checked my files, in fact the code should be like this:

//default title tag for the index (home) page

$title_home_default = 'ENTER YOUR DEFAULT TITLE TEXT HERE';

//default keywords for the index (home) page

$kws_home_default .= STORE_NAME;

//default Description for the index (home) page

$desc_home_default = "ENTER YOUR DEFAULT DESCRIPTION TAG TEXT HERE FOR THE HOME PAGE";

 

which should replace the block of code mentioned in my above post.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

have just uploaded a revised installation guide.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
...for some reason, the line

require(DIR_WS_INCLUDES . 'column_left.php');

is commented ...

Hi Pedro

 

This is a 'screen estate usage' issue: if you are using a wide screen display, which i believe many people don't, then you can uncommented that line of code as mentioned in your post, although there is no need to, because you dont need the left column be there when entering or editing header tags. The Back button at the bottom would take you back to the Categories/Products page with the left column shown.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Hi Pedro

 

This is a 'screen estate usage' issue: if you are using a wide screen display, which i believe many people don't, then you can uncommented that line of code as mentioned in your post, although there is no need to, because you dont need the left column be there when entering or editing header tags. The Back button at the bottom would take you back to the Categories/Products page with the left column shown.

 

Ken

Hi Ken,

 

You are right, I'm not using a wide screen display so I have to scrool right to see the entire pages. But even if I dont have the left column I still have the space for it and I still need to scrool right.

 

Thanks anyway.

 

br

Pedro

Share this post


Link to post
Share on other sites
...But even if I dont have the left column I still have the space for it and I still need to scrool right...

 

Hi Pedro

 

As shown in the screenshots that are included in the contribution and taken on a 1024 by 768 px display, there should not be a vertical scrollbar there unless on a 800 by 600px display which I believe not many people are using nowadays but if you are one of the few then sorry for the inconvenience - you may change or define the width of the 4 <td> to fit into yours.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

further to my post above, did you change the width of the left column, ie, in the line just above the "require left column php"? it'd read:

<td width="1" valign="top"><table border="0" width="1" cellspacing="1" cellpadding="1">

Note that the width has been set to 1px so there'd not be space on the left.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
...there should not be a vertical scrollbar...

should read 'there should not be a horizontal scrollbar'.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
should read 'there should not be a horizontal scrollbar'.

 

Ken

Hi Ken,

 

I don't think that is an issue, at least for me, since I use your addon for my personal shop... But I figured out how to fix it. I changed this:

echo "<td class=\"smallText\" align=\"center\"><input type=\"text\" size=\"60\" name=\"desc_tag_new[".$categories[$i]['id']."]\" value=\"".$categories[$i]['desc']."\"></td>\n";

 

into this:

echo "<td class=\"smallText\" align=\"center\"><input type=\"text\" size=\"50\" name=\"desc_tag_new[".$categories[$i]['id']."]\" value=\"".$categories[$i]['desc']."\"></td>\n";

 

and it now fits and doesn't mess with the layout.

 

I had the this issue because I changed the width of the left column to 165px (fixed) in the CSS file in order to fit some long names without splitting the lines in 2 (there are still some but I don't want the left column to take half the screen :D).

 

br,

Pedro

Edited by pedro.antunes

Share this post


Link to post
Share on other sites
Hi Ken,

Thanks for your reply, i've just installed the contrib, but i can't find out how to manually

add tags for each category and the same for the other languages.

Desiree

 

Hi Desiree

 

1. select the language you want from the language dropdown box at top right when you first log in to admin;

2. select Catalog (obviously this word may be different if not English);

3. in the Catalog box, select Product Header Tags, if you want to manually enter or edit header tags for products; or select Category Header Tags, if you want to enter or edit header tags for Categories.

 

after entering header tags for a product or category, you can click on the name of product or category on the leftmost column to see how it works (you may want to look at the page source).

 

HTH

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

I have uploaded a revised Installation Instructions (install-v2.zip). If you have a multi-lingual shops and want to manually enter/edit/show header tags in different languages, then you MUST follow the new installation instructions. Note that main changes are in the How To Use section, in particular, the code added to the index.php file.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hi,

I installed Header Tags SEO v3.1.0. Its very gr8 contribution. But I have two problems:

1) I have multilanguage website and its only working on my default language. When I switch to English language the tags are showing empty and not working. (I have written all tags from my admin for all languages)

 

2) And after installed my second language is showing the right column in the middle of product_info page...My default language product_info page is showing the right column normally...

 

Have you any suggestions?

 

Thanks

Hakan

Share this post


Link to post
Share on other sites

1. please see my reply two posts above;

2. the contribution only modifies the header section and has nothing to do with the page layout, so i don't know the answer your 2nd question (or are you sure you are actually using my contribution as some other header tags contrib may modify other part of the page and I don't have version number of 3.1.0?).

 

and you should install version 4.00 of my contribution instead


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hi Ken trying to get this work with my store its all installed etc but when adding the 3 fields keywords, title, desc it doesnt show up when i refresh the product page? Any ideas?

 

Am using SEO G mod as well

Edited by af0i0f9af

Share this post


Link to post
Share on other sites

without the shop's url what i can say is double check installation making sure all steps are followed, in particular the section "How to use - adding dynamic header tags to your shop", ie, modification made to the product info php file.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
without the shop's url what i can say is double check installation making sure all steps are followed, in particular the section "How to use - adding dynamic header tags to your shop", ie, modification made to the product info php file.

Ken

 

Hi Ken checked it over thoroughly and its as it should be. Could it be a permissions issue?

Share this post


Link to post
Share on other sites

if you want the issue be resolved quickly, then post your url to me. there is no such thing as permission issue for a stock osc, unless yours has had some stange addon installed.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×