Jump to content
Sign in to follow this  
GemRock

Header Tags for novices

Recommended Posts

thanks jgeoff.

 

the focus is on the products_info pages.

 

as for the categories, there's no description field the categories tables in the stock osc. at the moment you could only go so far as to add category names to the header tags (in index.php):

<title><?php echo (strlen($categories['categories_name']) > 1) ? $breadcrumb_tags->trail_tags(' - ') . ' - ' . TITLE : TITLE; ?></title>
<meta name="description" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(' ')); ?>">
<meta name="keywords" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(', ')); ?>">

this will add category/subcategory names to the header tags, as can been seen on the live demo site.

it is possible to make the same modification in the categories_description table (to add the 3 header tags fields), and at the admin to edit/enter custom tags info for each category. but then this would make it a bit more complicated and it may not be called 'for novices'. owuld consider this in the future updates, as well as taking into account the manufacturers.

 

anyone still has the error of 'Call to a member function trail_tags() on a non-object '?

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
...2) Also - I think you need to strip out quotation marks (\") in the descriptions as it breaks the HTML meta tag ...

 

My tests showed no problem RE quotation marks.

1. you can not enter quotation marks in edit/enter header tags at admin;

2. if there are quotation marks in product description it shows up with no problem.

 

if you think theres a problem, could you post more details and examples.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
My tests showed no problem RE quotation marks.

1. you can not enter quotation marks in edit/enter header tags at admin;

2. if there are quotation marks in product description it shows up with no problem.

 

if you think theres a problem, could you post more details and examples.

 

Ken

 

 

Hi Ken -

 

I'll clarify... it doesn't not work, but if you view source in, say, Firefox (that's color-coded), you'll see that it's unexpected and might cause a minor problem -- I'm not sure. This includes quotation marks a few times, but as we know, standard HTML should be <meta name="content"> rather than <meta="content "quoted" content"> -- it's just not clean. If it's possible to strip them, or change the double-quotes to single-quotes, I think it'd work out fine. I'm no programmer, so.... just thinking aloud here. ;)

 

e.g.,

<meta name="description" content="Our newest PMD recorder is small enough to fit in the palm of your hand, but it has features that make more expensive, full-sized field recorders green with envy. It can run for hours on just four AA batteries. It records on Compact Flash media cards which you can find in any discount store, and will store more than 36 hours of mono on a single card. If audio quality is your key requirement, you get over an hour of pristine, uncompressed, 16-bit .wav files. Editing can be achieved right there in the field using either of two editing modes, or you can use your favorite audio editing application by transferring files to your PC-the PMD660 even has its own USB port. XLR inputs, phantom power, built-in mics and more-it's all there in the PMD660. Highlights WINNER of the 2005 Radio World "Cool Stuff Award"WINNER of the 2005 Radio Magazine "Pick Hit Award"Smallest PMD yet-fits in your handUses inexpensive, widely available Compact Flash media (CF)Operates for four hours on four AA batteriesT">


osC v2.2 RC2a w/ no special templates

PHP Version 5.2.14 / MySQL 5.0.91-community

Share this post


Link to post
Share on other sites
..I'll clarify... it doesn't not work, ..

 

I thought you were talking about the meta tag being broken, ie, the description did not show at all.

yes FF's page source does highlight the quotation marks in red - kind of warning perhaps but IE and safali do not seem to care at all. bear in mind that meta tags are for search engines to 'read', not for human beings, i am not sure if SEs would see it as a problem. instead i think SEs would look for the closing '>' of a meta tag and would not just stop at quotation marks.

 

if you are concerned about this, then, in product_info.php, you can change this:

<meta name="description" content="<?php echo $header_tags[desc_tag]; ?>">

to this

<meta name="description" content="<?php echo str_replace('"',"'",$header_tags[desc_tag]); ?>">

That will make FF happy.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Necessary or not, it now works great -- thanks again! B)


osC v2.2 RC2a w/ no special templates

PHP Version 5.2.14 / MySQL 5.0.91-community

Share this post


Link to post
Share on other sites

What I referred to as the categories pages are indeed the index pages for the various categories in the categories box (e.g., index.php/cPath/21, index.php/cPath/22, etc., for as many categories as are in the box) I'm not sure Ken, why you say the categories box is irrelevant and if the irrelevance pertains to the index.php/cPath/x pages as well. Like the products_info.php pages, the title and meta tags for the index.php/cPath/x pages use the title of the respective categories by default; however, unlike the products_info.php pages the description and keywords can't be modified via admin/header_tags_edit.php. How to modify the description and keywords on the index.php/cPath/x pages is the question.

 

Although it made common sense to me to refer to the index.php/cPath/x pages as "categories pages", I do understand why, when there is no such thing as a categories.php page, it's necessary to be more precise.

 

 

well, the question remains the same: what is a categories page?

 

1. theres no categories.php (am not talking about the irrelevant categories box) on the shop front (that customers can view & order products);

 

2. this contribution only (in the installation doc) affects the index page (or otherwise called Home page), and the products_info.php

 

Please use common names or simply use the file names so that can be understood without guessing.

 

Ken

Share this post


Link to post
Share on other sites

Thanks, Ken. Needing a separate modification to the categories_description table answers the question about adding descriptions and keywords to the index.php/cPath/x pages. I'll just have to wait and see if this is added to a future update.

 

Thanks again for a great contribution.

 

Bob

 

thanks jgeoff.

 

the focus is on the products_info pages.

 

as for the categories, there's no description field the categories tables in the stock osc. at the moment you could only go so far as to add category names to the header tags (in index.php):

<title><?php echo (strlen($categories['categories_name']) > 1) ? $breadcrumb_tags->trail_tags(' - ') . ' - ' . TITLE : TITLE; ?></title>
<meta name="description" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(' ')); ?>">
<meta name="keywords" content="<?php echo strip_tags($breadcrumb_tags->trail_tags(', ')); ?>">

this will add category/subcategory names to the header tags, as can been seen on the live demo site.

it is possible to make the same modification in the categories_description table (to add the 3 header tags fields), and at the admin to edit/enter custom tags info for each category. but then this would make it a bit more complicated and it may not be called 'for novices'. owuld consider this in the future updates, as well as taking into account the manufacturers.

 

 

 

Ken

Edited by rodazac

Share this post


Link to post
Share on other sites
...why you say the categories box is irrelevant...

the categories box i mentioned refers to the one on the left (by default) or right column, which has no bearing on the header tags.

 

unlike years before, now meta tags may not be as important as one may think they would although some tgas may still be used by search engines, hence th eidea of this contribution - minimum effort yet still have some useful tags info or even custom tags info - something better than none at all.

 

yes when i have time i'd look at the categories bits.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Problem:

Anytime I make any changes in the admin section for the optional install it makes me re-login everytime I change anything! Whats wrong?

 

32 Degrees


plasma.jpg

Share this post


Link to post
Share on other sites
Problem:

Anytime I make any changes in the admin section for the optional install it makes me re-login everytime I change anything! Whats wrong?

 

32 Degrees

 

Let re-explain that. I installed the mod and the optional part. Everything works great except the admin section where you can enter in the desired values. Every time I hit the update button it brings me to the login screen. I cant figure out why and thus I'm stuck editing products via phpmyadmin. I'm not using the template system either.


plasma.jpg

Share this post


Link to post
Share on other sites
...Everything works great except the admin section where you can enter in the desired values. Every time I hit the update button it brings me to the login screen. ...

it is a cookie problem: turn on your browser to accept cookie or add the site admin to the trust site zone (IE), or use FireFox.

 

I will look into it further when I got time, and it looks it just needs to append the oscid at the end of the url.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

I'm not exactly sure what you mean about the ocID. I do not feel the issue is cookie related for the reasons. First I re-verified that I could accept cookies, which I could. I even added my site to the allow list to make sure. I've been using FireFox during this testing. When I click update I'm taking to this login page.

 

http://www.13thgreen.com/*****/login.php?osCAdminID=764d28391eae32e86f6d729317d57766

 

You help is greatly appreciated I'm trying to get this resolved to I can hand it over to my client to edit themselves

 

*Note: I changed the location of my admin folder for security reasons. Could this have something to do with it? Everything thing else works fine. I have not had this problem ever before.

 

Thanks!

Edited by 32 Degrees

plasma.jpg

Share this post


Link to post
Share on other sites
..

http://www.13thgreen.com/*****/login.php?osCAdminID=764d28391eae32e86f6d729317d57766

...

i tested it on a (under-development) site on live server and I could reproduce that same problem but after i added it to trust zone (IE7) or used FF (default set up) then the problem went away.

 

oscid i sthe bit at the end of url if cookie is turned off. in your case it is this:

 

osCAdminID=764d28391eae32e86f6d729317d57766

 

the fact that you see that oscid at end of url indicates that your browser is not accepting cookie. if all fail then i would suggest disable admin log in and use .htaccess to protect admin folder until problem solved.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
i tested it on a (under-development) site on live server and I could reproduce that same problem but after i added it to trust zone (IE7) or used FF (default set up) then the problem went away.

 

oscid i sthe bit at the end of url if cookie is turned off. in your case it is this:

 

osCAdminID=764d28391eae32e86f6d729317d57766

 

the fact that you see that oscid at end of url indicates that your browser is not accepting cookie. if all fail then i would suggest disable admin log in and use .htaccess to protect admin folder until problem solved.

 

Ken

 

I'm glad to see that you were able to replicate the problem. I've tried this on both IE6 & the latest FF on two computers and the results are the same. I do not think my admin gives out cookies. If thats the case I'm sure I'm not the only one who doesn't use cookies and uses osCid instead. That said isn't there some way to make it compliant for both users. The login page is an important aspect for my client and getting rid of it is not exactly desirable. I think that if the update command was updated to include the oscid session then I would not have this problem. Can you code this to work? My PHP knowledge is very minimal. If not, are there any other possible solutions. I really like this mod and would be very disappointed if I could not use it :(.


plasma.jpg

Share this post


Link to post
Share on other sites

Update:

 

Cookies are on, each time I log-in a cookie is created and stored in my browser which the correct osCadminID. So I do not think that is the problem. I really think it has something to do with

<form name="update" method="POST" action="<?php echo "$PHP_SELF?action=update&page=$page&sort_by=$sort_by&cPath=$current_category_id&row_by_page=$row_by_page&manufacturer=$manufacturer"; ?>">

 

or

 

<?php echo tep_image_submit('button_update.gif', IMAGE_UPDATE, "action=update&cPath=$current_category_id&page=$page&sort_by=$sort_by&row_by_page=$row_by_page");?>

 

Can't we just add something that carries the oscid session number with it??

Edited by 32 Degrees

plasma.jpg

Share this post


Link to post
Share on other sites

Ryan

 

the problem is I tested on 3 browsers: FF, safali (both with newest version/update and default setup), it worked straightaway without problem (ie, no update -> logout), and IE7 which I use th emost and is not default setup but after I add the site to allow cookies (i think this is IE7's new feature), theres no problem at all. I havent tested on IE6 as yet.

I appreciate your comment RE chnages and yes I agree it'd work regardless browser setup (sort of) but it'd take time, which at th emoment I dont have much, to test it.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

I don't understand where my problem is. I have tested this on 4 computers, 4 default installations of FF, 2 times on IE7, and once on IE6, and still I get the same error each time. It really sucks that your telling me theres nothing you can do. Do you have any idea why might be the problem? Also at the moment you say you dont have any time. Can you give me quote for your services to fix this selected issue?

 

Thanks

 

Ryan


plasma.jpg

Share this post


Link to post
Share on other sites

I don't know what the problem could be on your end, I've had no problems with FF. But, the admin area does "time out" after a certain amount of time (not sure how long), and I have to log in again after inactivity. But certainly not every action, so I don't know.... But if I get some time in the near future, and you need exact answers, then we'll see...

 

I'd rather GemRock work on my few feature requests... ;)

Edited by jgeoff

osC v2.2 RC2a w/ no special templates

PHP Version 5.2.14 / MySQL 5.0.91-community

Share this post


Link to post
Share on other sites
<form name="update" method="POST" action="<?php echo "$PHP_SELF?action=update&page=$page&sort_by=$sort_by&cPath=$current_category_id&row_by_page=$row_by_page&manufacturer=$manufacturer"; ?>">

OK, try to replace the above code with this:

 

<?php echo tep_draw_form('update', FILENAME_HEADER_TAGS_EDIT, "action=update&page=$page&sort_by=$sort_by&cPath=$current_category_id&row_by_page=$row_by_page&manufacturer=$manufacturer", 'post'); ?>

 

Good Luck!

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hi!

 

I installed it untill the point: Now, go to your osCommerce Home page, click a category or product. This will add 3 new fields to the table products_description in the database.

But my product detail page does not show anything. There is no way to edit it. What do I do wrong?

Share this post


Link to post
Share on other sites
Hi!

 

I installed it untill the point: Now, go to your osCommerce Home page, click a category or product. This will add 3 new fields to the table products_description in the database.

But my product detail page does not show anything. There is no way to edit it. What do I do wrong?

it does not say to stop there. so you should continue to follow the instructions.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function: tep_get_category_htc_title() in /home/myshopon/public_html/admin/categories.php on line 1038

 

 

 

i get this error when trying to edit my categories can anyone help me on how to fix this or tell me where i went wrong.

Share this post


Link to post
Share on other sites
Fatal error: Call to undefined function: tep_get_category_htc_title() in /home/myshopon/public_html/admin/categories.php on line 1038

my contribution does NOT use that function referred to in the error msg. so it has nothing to do with it.

make sure you know what contribution you are installing or installed before.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

This might be conflicting a little with Chemo's Ultimate SEO URLs contrib... I'm no longer getting any META descriptions and keywords for categories and even the home page -- but I am with product info pages. Or maybe that's designed, I forget now -- but do you think some logic could be added so that IF the description and keywords fields are blank THEN use some default description and keywords?

 

Thanks for any ideas!

 

JG


osC v2.2 RC2a w/ no special templates

PHP Version 5.2.14 / MySQL 5.0.91-community

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×