Jump to content
Sign in to follow this  
GemRock

Header Tags for novices

Recommended Posts

I have added this contribution to my first site (RC1) no problem at all works wonderfully and my files were installed in catalog so followed instructions exactly.

 

I have now added this contribution to site two (RC2) and receive this message

 

1054 - Unknown column 'pd.title_tag' in 'field list'

 

select p.products_id, p.manufacturers_id, pd.products_name, pd.title_tag, pd.desc_tag, pd.keywords_tag, p.manufacturers_id from products p, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' limit 0, 20

 

when I access:-

http://www.naturallyavocado.com/admin/header_tags_edit.php

 

If I access admin section normally the title Header Tags does not appear at all as a section.

 

My files were loaded into the route file not/catalog/ so I substituted the instructions into the folders without the catalog but I wondered if there was some reference somewhere in the scripting to /catalog/ that will need changing.

 

Help please so I can get this up and running asap.

 

I have posted this request under general assistance as well as I had forgotten you have a specific section. Sorry about that.

 

regards

 

Liz


Liz

 

A very appreciative member still attempting to climb the steep learning curve!

Share this post


Link to post
Share on other sites

Hi Liz

 

please read my post #248 - just a few posts above yours.

Generally speaking, whatever folder your osc shop is in, it'd still work the same way, ie, it is not relevant.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Hi Liz

 

please read my post #248 - just a few posts above yours.

Generally speaking, whatever folder your osc shop is in, it'd still work the same way, ie, it is not relevant.

 

Ken

 

Hi Ken

 

Thanks for that it seems to have resolved half the issue! I can now access it by going www.naturallyavocado.com/admin/header_tags_edit.php but it has not appeared as a choice in the catalog section of admin like it did on site 1???? What have I missed or not done???

 

Liz


Liz

 

A very appreciative member still attempting to climb the steep learning curve!

Share this post


Link to post
Share on other sites
...What have I missed or not done???

Liz

well, you did miss something: steps 1 -3 in optional_install_instructions.txt

 

Good luck!

Ken

PS

you must change the read/write permission of includes/configure.php of your site NOW!

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
well, you did miss something: steps 1 -3 in optional_install_instructions.txt

 

Good luck!

Ken

PS

you must change the read/write permission of includes/configure.php of your site NOW!

 

Tried wont stay done from my end have notified hosts 9 am this morning and still waiting. I had a similar problem on site 1 and I couldnt alter it, well that is wrong I could alter it but it wouldn't stay altered it kept going back to what it wanted to be, in this case 644.

 

regards

 

Liz


Liz

 

A very appreciative member still attempting to climb the steep learning curve!

Share this post


Link to post
Share on other sites
well, you did miss something: steps 1 -3 in optional_install_instructions.txt

 

Good luck!

Ken

PS

you must change the read/write permission of includes/configure.php of your site NOW!

 

 

Ken on site one I am having a problem that the last four products on my list I put the keywords in - no problems but then I update and they disappear so in effect I cannot add keywords for the last four items. What do I need to do to rectify this situation so that all products can have keywords added? The remainder of products are fine.

 

regards

 

Lz


Liz

 

A very appreciative member still attempting to climb the steep learning curve!

Share this post


Link to post
Share on other sites
...the last four items. What do I need to do to rectify this situation so that all products can have keywords added? The remainder of products are fine.

 

regards

 

Lz

Sorry I dont know the answer. what I do know is that theres a difference (and therefore the solution) between:

1. you got 5 products the first one is OK but the other 4 is not;

and

2. you got 500 products all are OK but the last 4 ie from 497 to 500.

 

Which is your situation?

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Sorry I dont know the answer. what I do know is that theres a difference (and therefore the solution) between:

1. you got 5 products the first one is OK but the other 4 is not;

and

2. you got 500 products all are OK but the last 4 ie from 497 to 500.

 

Which is your situation?

 

23 products 19 ok 4 not

 

Liz


Liz

 

A very appreciative member still attempting to climb the steep learning curve!

Share this post


Link to post
Share on other sites
23 products 19 ok 4 not

 

Liz

try this:

1. change 'max. value of search results' to a number that is bigger than 23 or the max.number of products;

or,

2. open header_tags_edit.php for edit, search & replace all instances of MAX_DISPLAY_SEARCH_RESULTS to a number as mentioned in 1 above.

 

Ken

PS

off topic but just out of curiosity: why certified in Russa is important? do you intend to solely sell to Russians and you do not sell to UK customers? do you think UK customers would appreciate your site being certified in Russia? IMO & be honest, quite the opposit is true if not putting me off completely.


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
try this:

1. change 'max. value of search results' to a number that is bigger than 23 or the max.number of products;

or,

2. open header_tags_edit.php for edit, search & replace all instances of MAX_DISPLAY_SEARCH_RESULTS to a number as mentioned in 1 above.

 

Ken

PS

off topic but just out of curiosity: why certified in Russa is important? do you intend to solely sell to Russians and you do not sell to UK customers? do you think UK customers would appreciate your site being certified in Russia? IMO & be honest, quite the opposit is true if not putting me off completely.

 

I am afraid neither work!

1. was already set to 24 and I made that 30

2. Only one instance and I changed 'MAX_DISPLAY_ROW_BY_PAGE' , MAX_DISPLAY_SEARCH_RESULTS to '30'

 

Next suggestion

 

Off topic the certified Russia is actually a new insistance of the manufacturer.


Liz

 

A very appreciative member still attempting to climb the steep learning curve!

Share this post


Link to post
Share on other sites
I am afraid neither work!...

Hi Liz

 

I am afraid I am running out of idea. No one except you ever report this problem, and I have just tested it on the demo site found no problem. you could take a look if you like to see if there any difference. I guess there may be something unusual on that site.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed it and want to check if I've done something wrong, no error messages but I can't display more than 20 product names in the "Header Tags Entry/Edit" section and also can't figure out how it can automatically populate - although i may have missunderstood that it could.

 

www.copybits.co.uk

 

Please help if you can :)

 

All the best

 

Jo

Share this post


Link to post
Share on other sites

Hi Jo

 

A new version will be released soon possibly at the weekend. Version 3.00 should address all the issues (including multi-language support) reported so far, and has been tested on osc 2.2 RC2a, php 5.2.4 or later with register_globals either ON or OFF.

For older version of osc 2.2 (with Aug. 2006 updates), I have tested it on php 4.4.x with register_globals ON (was not able to get a register_globals OFF setup).

 

So, if you could just wait a day or two.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

as mentioned in my previous post, a new version now can be downloaded following the link in my signature.

 

Version 3.00 is register_globals compatible and has beed tested on php 4.4.x and php 5.2.x with register_globals ON or OFF. It is also compatible with the newest release of osCommerce RC2a and it should continue to be compatible with the final release of osCommerce online merchant 2.2.

 

It addresses a number of issues reported so far with the older versions. It is 'independent' as it always be, meaning that it does not rely on any other contribution.

 

You should only download version 3.00 from now on. But if you have been using an older version and it has been working with no problem, then you do not have to upgrade.

 

The installation document is now in HTML format so it should be easier to use.

 

Hope you find it useful with your SEO/SEM endeavour.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hello Ken,

 

Many thanks for your application - I have been able to install v.3

 

On Osc, I am getting a page for Header Tags Entry/Edit. However, changing these is not updating my the title bar for my products

 

Please advise

 

Thanks

 

Regards

 

Anish

Share this post


Link to post
Share on other sites

if you have done the minimum installation correctly and verify that the header tags have populated to every product info page, then I do not see why it wont update the product info page title according to what you have entered. make sure you dont have two title tags in product_info.php.

 

you probably need to post your site url so that I can kave a look.

 

Ken

Hello Ken,

 

Many thanks for your application - I have been able to install v.3

 

On Osc, I am getting a page for Header Tags Entry/Edit. However, changing these is not updating my the title bar for my products

 

Please advise

 

Thanks

 

Regards

 

Anish


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Ken,

 

My website is www.kanishka.co.uk

 

I would be grateful for your advice

 

Thanks

 

Regards

 

Anish

Share this post


Link to post
Share on other sites

Ken,

 

I have noticed this in product_info.php. Please advise how much I should delete, Many thanks

 

?>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php if ( defined( 'NAVBAR_TITLE' ) ) { echo NAVBAR_TITLE; } else { echo TITLE; } ?></title>

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

<script language="javascript"><!--

function popupWindow(url) {

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res

izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le

ft=150')

}

Share this post


Link to post
Share on other sites

please refer to the 'How to Use' section for instruction. in particular, this bit

<title><?php if ( defined( 'NAVBAR_TITLE' ) ) { echo NAVBAR_TITLE; } else { echo TITLE; } ?></title>
will need to be deleted, and replace by:
<title><?php echo $header_tags[title_tag]; ?></title>
<meta name="description" content="<?php echo $header_tags[desc_tag]; ?>">
<meta name="keywords" content="<?php echo $header_tags[keywords_tag]; ?>">

for details, see the installation file and refer to the section of How to use - adding dynamic header tags to your shop.

 

and if you are using a template then there would more to do for the contribution to work

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Please do NOT send PM msg to me RE support issues of my contribution. Please instead post your questions to the forum support thread, as many people may ask the same question. I do not have the time to reply to each pm msg, although I could do my best to answer questions posted on here.

 

Thank you,

 

Ken

sorry but only pm me if you want a fee paying service.


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Please note that currently the keyword tag can only have about 50 words maximum. The description tag can have about 200 words maximum (the table/database can store more than that but only the first 200 words would be shown.

IMH, it is not necessary to have more than 50 keywords and 200 words description. if you think you need more, then you can make changes in the application.php. Let me know and I will post instruction on where to change.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Apologies, Ken. I managed to sort that out.

 

Your contribution seems to be helping in assigning keywords and descriptions to product pages, but what about category pages?

 

Also, you say that

 

By default, the header_tags_edit.php does not show the left column. If you want to show it, then open header_tags_edit.php, uncomment line 297 so that it looks like:

 

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

 

 

It seems that my left column is showing, so what would I do in this case, i.e. reversing the above?

 

Many thanks

 

Please do NOT send PM msg to me RE support issues of my contribution. Please instead post your questions to the forum support thread, as many people may ask the same question. I do not have the time to reply to each pm msg, although I could do my best to answer questions posted on here.

 

Thank you,

 

Ken

sorry but only pm me if you want a fee paying service.

Share this post


Link to post
Share on other sites

it is in fact line 119 that needs to be uncommented.

 

will upload a new installation file to correct this, sorry.

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

have just uploaded version 3.01, which fixes an error in install.html

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×