Jump to content
natewlew

News Blog V1.0

Recommended Posts

I installed the mod. So far it looks pretty smooth except that I get this error on the homepage of the site now:

 

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/.orange/teargraphics/tearstonegraphics.com/includes/application_top.php on line 312

 

The admincp tools>news all functions properly. I've also imported the SQL and uploaded the files per the instructions.

 

Someone please help point me in the right direction on what to start looking at to troubleshoot this :)

Share this post


Link to post
Share on other sites

I figured it out. Don't use commas in your keywords line in the news.php, or put in an escape slash before the commas.

Edited by Tearstone

Share this post


Link to post
Share on other sites

Great contrib yet!

 

I would like to make my oscommerce more looks like a News website. So actually I would like 3 things and I don't know yet how to figure it out.

#1 The news or articles made showing within the home page without having a new module or infobox being installed, I want it as a part of the website not like a module...

#2 How to find what is my rss channel so that I could promote it everywhere within the rss readers (they actually don't accept the rss.php as a channel)

#3 Why when someone add a reply to any article it suddenly reduce the background so that the news and answer themselves comes out of the frame?


Light travels faster than sound. Thats why sometimes people look bright until they speak...

Share this post


Link to post
Share on other sites

Oh I notice I forgot to mention also that I cannot use html tags when creating new articles, any idea how to fix it also?

Dave


Light travels faster than sound. Thats why sometimes people look bright until they speak...

Share this post


Link to post
Share on other sites

Hi All!

I've got some ideas for this contribution.

A blog is fairly easy to manage and a great way to publish (hopefully) interesting and attractive content.

  • Moving the menu with the Months / View all / RSS feed menu into a Infobox.
    (That would make the news blog reachable from all pages on the site and reduce clutter on the news.php page)
  • Adding a module that could show the latest posts on the index.php page.
    (Great osc-coders have made a wide variety of modules, so why not for this one?)
  • Having the latest posts expanded like in many other blog systems.
    (Less user-clicks and more content exposure.)
  • Formatting the Month links to a more international format.
    (...than "March 2008" for instance...)

Have anyone succeeded in this before or does anyone like to share the knowledge needed to make it happen?

//Micke

Share this post


Link to post
Share on other sites

I am still trying to make my news blog...

Have a lot of problems with the RSS as the rss 1.0 you are referring to in earlier post which will pur all products in our store to rss.php to have a feed channel and as you are using the same rss.php but with a complete different way to code, I can't make them to work together and have my products and articles within one single rss together...

Also I am still looking forward to have my articles to live together with my featured products boxes, isn't there anyway to replace the existing news onto it by our articles made with your contrib?

 

If anyone could help me this it would be very appreciated and you can see it working on my website at the bottom link of this post

Sincerely,

Dave

ebayauctionblog.com


Light travels faster than sound. Thats why sometimes people look bright until they speak...

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for this GREAT contribution.

 

When i push on rss icon, nothing happens, just a window ask me to download the file rss.php.

 

Can anybody explain me why, please?

 

 

Moreover, is it possible to change the "article=6" in "....catalog/news.php?article=6" with the Article Title ??

 

 

Thanks again!!!

Share this post


Link to post
Share on other sites

Hi,

I have just installed this contribution and i need some help in creating my rss.xml file. I used the code suggested in one of the posts to create a php file called create_rss.php. Placed this file in catalog/admin/ also set the chmods to 777 as well as the catalog/rss.php to 777 it seems to redirect back me correctly to the admin page but no .xml file can be found anywhere.

 

Could I please please get some help on this thanks

Edited by potatocake

Share this post


Link to post
Share on other sites

Just wanted to thank you for such a wicked addon.

 

does exactly what it says on the tin and so so easy to install. took me half a day to get it looking as I wanted it but that was my fault!!

 

I tested so many with failed results, this was the only one that worked and was easy.

 

Thank you again!

Share this post


Link to post
Share on other sites
Just wanted to thank you for such a wicked addon.

 

does exactly what it says on the tin and so so easy to install. took me half a day to get it looking as I wanted it but that was my fault!!

 

I tested so many with failed results, this was the only one that worked and was easy.

 

Thank you again!

 

 

Hey, would you mind please describing which contrib version you used and also any mods you had to make? I would like to add this contib but would like to be aware of any issues first,

thanks

Sol

Share this post


Link to post
Share on other sites

I get the following error when running news.sql on PHPmyadmin any help would be appreciated

 

stirling-bathrooms.co.uk

 

Error

 

SQL query:

 

-- phpMyAdmin SQL Dump

-- version 2.9.2

-- http://www.phpmyadmin.net

--

-- Host: localhost

-- Generation Time: Jan 18, 2007 at 07:25 PM

-- Server version: 4.1.20

-- PHP Version: 4.3.9

--

-- --------------------------------------------------------

--

-- Table structure for table `news`

--

INSERT INTO configuration_group( configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible )

VALUES (

'367', 'News Blog', 'News Blog Configuration', 200, 1

);

 

MySQL said: Documentation

#1146 - Table 'stirlin2_backup8212008222818stirlin2tar.configuration_group' doesn't exist


stirling-bathrooms

Share this post


Link to post
Share on other sites
Great contrib yet!

 

I would like to make my oscommerce more looks like a News website. So actually I would like 3 things and I don't know yet how to figure it out.

#1 The news or articles made showing within the home page without having a new module or infobox being installed, I want it as a part of the website not like a module...

#2 How to find what is my rss channel so that I could promote it everywhere within the rss readers (they actually don't accept the rss.php as a channel)

#3 Why when someone add a reply to any article it suddenly reduce the background so that the news and answer themselves comes out of the frame?

 

Hey Dave,

 

Did you ever get an answer, or find a solution, to question #3? I am having the same problem.

Share this post


Link to post
Share on other sites

Has anyone thought of, and or accomplished, being able to add multiple topics to this mod?

 

I like the simplicity and ease of use, but I'd like to have more categories than just "news" and would love to know if it's been done before I go and try reverse engineering it myself.

 

-Thanks,

Share this post


Link to post
Share on other sites

Hey, ran into a problem. After opening shop/news.php i get mysql error:

 

 

News	  
1146 - Table 'np14488_1.TABLE_NEWS' doesn't exist

select distinct month_date from TABLE_NEWS order by month_date asc limit 12

[TEP STOP]

 

Did everything that was told, imported the mysql file.

Share this post


Link to post
Share on other sites
Hey, ran into a problem. After opening shop/news.php i get mysql error:

 

 

News	  
1146 - Table 'np14488_1.TABLE_NEWS' doesn't exist

select distinct month_date from TABLE_NEWS order by month_date asc limit 12

[TEP STOP]

 

Did everything that was told, imported the mysql file.

 

 

Ok, got that issue out of the way.

Now im having a problem with tables. I mean, it wont open news blog inside normal shop tables, it opens it outside of frames. Thats pretty annoying and i have no idea how to fix that ;(

 

http://oops.pri.ee

Share this post


Link to post
Share on other sites

I am developing a store in Portuguese (Brazil) and the file "rss.php" does not work well with accents, by replacing the "??".

 

could you tell me why that?

 

thanks.

sorry for bad english.

Share this post


Link to post
Share on other sites
Problem #2 is solved by adding the line "define('NAVBAR_TITLE', 'News');" to your shops language files

 

Now edit the following files on your server:

Open /catalog/includes/languages/english.php and add this line at the bottom, right above: ?>

define('VIEW_ALL', 'View All');
define('NEWS', 'News');
define('NAVBAR_TITLE', 'News');

 

You don't want to do that on the english.php file or it will change everything to the NAVBAR_TITLE.

 

All you have to do is go to news.php under /includes/languages/ and add

 

define('NAVBAR_TITLE', 'WHATEVER YOU WANT TO CALL YOUR BLOG');

 

and it should show up.


Remember what the Bible says: He who is without sin, cast the first rock. And I shall smoketh it.

Share this post


Link to post
Share on other sites

Hi

 

Just installed this and all seems well, except in the admin panel there is NO option to add a new article or edit the current article that's there? Any ideas why this is?

 

I've been through the installation several times and no luck. Theres no actual errors displaying just lack of things, also I haven't edited ANY of the files, fresh from the folder.

 

Cheers.

Share this post


Link to post
Share on other sites
You don't want to do that on the english.php file or it will change everything to the NAVBAR_TITLE.

 

All you have to do is go to news.php under /includes/languages/ and add

 

define('NAVBAR_TITLE', 'WHATEVER YOU WANT TO CALL YOUR BLOG');

 

and it should show up.

 

I just installed and had this problem but decided to revert back to my original site...well I made new databases and uploaded files that I backed up BEFORE I attempted this cont. I always get this in admin side: BOX_HEADING_CATALOG BOX_HEADING_MODULES BOX_HEADING_CUSTOMERS BOX_HEADING_LOCATION_AND_TAXES BOX_HEADING_LOCALIZATION BOX_HEADING_REPORTS BOX_HEADING_TOOLS

 

*Also*

 

on the top: HEADER_TITLE_ADMINISTRATION | HEADER_TITLE_ONLINE_CATALOG | HEADER_TITLE_SUPPORT_SITE

 

The columns are show BOX_HEADING before the word and it looks horrible...Where can I debug this Mysite.com/catalog/admin/configuration.php?gID=1&selected_box=configuration ???? please help if you can

Share this post


Link to post
Share on other sites
I just installed and had this problem but decided to revert back to my original site...well I made new databases and uploaded files that I backed up BEFORE I attempted this cont. I always get this in admin side: BOX_HEADING_CATALOG BOX_HEADING_MODULES BOX_HEADING_CUSTOMERS BOX_HEADING_LOCATION_AND_TAXES BOX_HEADING_LOCALIZATION BOX_HEADING_REPORTS BOX_HEADING_TOOLS

 

*Also*

 

on the top: HEADER_TITLE_ADMINISTRATION | HEADER_TITLE_ONLINE_CATALOG | HEADER_TITLE_SUPPORT_SITE

 

The columns are show BOX_HEADING before the word and it looks horrible...Where can I debug this Mysite.com/catalog/admin/configuration.php?gID=1&selected_box=configuration ???? please help if you can

 

Problem solved...what happened? to start off last "addition" in the instructions are wrong >>>>Addition by Lunaxod:

 

Open /catalog/includes/column_right.php and insert

 

After:

include(DIR_WS_BOXES . 'languages.php');

this:

include(DIR_WS_BOXES . 'news.php');

 

Creates error in the box BOX_HEADING_

 

NEXT PROBLEM: was mentioned by one member then the next post claims some other cod which is wrong. The correct one is Open /catalog/includes/languages/english.php and add this line at the

 

bottom, right above: ?>

 

define('VIEW_ALL', 'View All');

define('NEWS', 'News');

define('NAVBAR_TITLE', 'News'); <<<THIS LINE WAS MISSING--

 

THX for all the feed back. I love it when there is no help, if there is contributer claims his contrib. had nothing to do with the problem. If I could, I would write Contributions that are universally recognized and useful to all.

Share this post


Link to post
Share on other sites
Problem solved...what happened? to start off last "addition" in the instructions are wrong >>>>Addition by Lunaxod:

 

Open /catalog/includes/column_right.php and insert

 

After:

include(DIR_WS_BOXES . 'languages.php');

this:

include(DIR_WS_BOXES . 'news.php');

 

Creates error in the box BOX_HEADING_

 

NEXT PROBLEM: was mentioned by one member then the next post claims some other cod which is wrong. The correct one is Open /catalog/includes/languages/english.php and add this line at the

 

bottom, right above: ?>

 

define('VIEW_ALL', 'View All');

define('NEWS', 'News');

define('NAVBAR_TITLE', 'News'); <<<THIS LINE WAS MISSING--

 

THX for all the feed back. I love it when there is no help, if there is contributer claims his contrib. had nothing to do with the problem. If I could, I would write Contributions that are universally recognized and useful to all.

Share this post


Link to post
Share on other sites

Did anyone answer the question about the RSS feed icon? I click on it and it wants to download the rss.php file. This isn't correct is it?


Matt Clark

General Manager

Share this post


Link to post
Share on other sites

All is prefect, but i have some problem when i click the title link....!!!

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/xxx/public_html/catalog/includes/header.php:196) in /home/xxx/public_html/catalog/includes/boxes/categories.php on line 59

 

 

need some help, make me big confuse...!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×