Jump to content
Sign in to follow this  
hex1848

USPS Click-N-Ship Stopped working?

Recommended Posts

Any of you guys using the USPS shipping mod that integrates with Click-N-Ship? It stopped working for me last week. Basically when you do the form post to the Click-N-Ship label input page, it redirects you back to the main Click-N-Ship home page.

 

I sent the customer service department an email and got the following response:

 

Dear Customer,

 

Thank you for contacting us. We do not support any program that attempts to implement with our usps.com label program and are taking the necessary steps to prevent this from happening.

 

USPS Internet Customer Care Center

icustomercare@usps.com

 

Does anyone else use the module? Please send the Click-N-Ship team a message. If several of us contact them, maybe we can stop these "necessary steps" from happening.

Share this post


Link to post
Share on other sites
Any of you guys using the USPS shipping mod that integrates with Click-N-Ship? It stopped working for me last week. Basically when you do the form post to the Click-N-Ship label input page, it redirects you back to the main Click-N-Ship home page.

 

I sent the customer service department an email and got the following response:

Does anyone else use the module? Please send the Click-N-Ship team a message. If several of us contact them, maybe we can stop these "necessary steps" from happening.

 

We've been using Click-N-Ship for almost a year, but have been looking for a different solution the whole time. USPS is not interested in making things easy. USPS doesn't have an API available for anybody, except maybe Pitney Bowes, Stamps.com and Endicia. USPS is absolutely not interested in working with anybody. I don't know why they would care if people are using automated systems with their online forms? Doesn't cost them anything, in fact, makes them money. What's up with that???

 

We've met with Pitney Bowes, and talked with Stamps.com and Endicia. So far, none of them have had good shipping solutions. Endicia told us that they have some kind of an API but that they weren't interested in making a shipping module for OSC. They told us that we should do it ourselves but that it would consist of hosting the service. It will cost us several thousand to develop this, but it might be something that we'll do now. We'd probably make it available to others, but it wouldn't be free like Click-N-Ship, because we'd have to pay for our overhead, and also pay Endicia for service. Not a great solution, but better than anything else out there.

Share this post


Link to post
Share on other sites

i use this contrib to save time when using USPS shipping and it saves a LOT of time. has anybody got a hack to work around this?

Share this post


Link to post
Share on other sites

Having the same problem here (using the differentshipping.php contribution) - This mod WAS a huge time saver - I hope that someone figures out a hack.

Share this post


Link to post
Share on other sites

Same here. I have been looking around the forum to see if anyone is having the same problem. I looked into the code, don't know how to fix the problem. Currently, I have to manually typing those label information.

 

lubert

 

Having the same problem here (using the differentshipping.php contribution) - This mod WAS a huge time saver - I hope that someone figures out a hack.

Share this post


Link to post
Share on other sites

I am having the same problem. When I am taken to the USPS page, I am signed in, but I am at the Click and Ship page with no data carried over from the module. I wrote USPS and got this:

 

Dear Customer,

 

There is nothing different as far as I know at this time. If you use Click&Ship via your web-site are you connecting through a shortcut? If so, you may need to remove and re-create it.

Jack

USPS Internet Customer Care Center

icustomercare@usps.com

 

If anyone has a fix for this PLEASE post. I will do the same.

 

 

 

Any of you guys using the USPS shipping mod that integrates with Click-N-Ship? It stopped working for me last week. Basically when you do the form post to the Click-N-Ship label input page, it redirects you back to the main Click-N-Ship home page.

 

I sent the customer service department an email and got the following response:

Does anyone else use the module? Please send the Click-N-Ship team a message. If several of us contact them, maybe we can stop these "necessary steps" from happening.

Share this post


Link to post
Share on other sites

From what I can tell it may be a problem with the following line in the code.

 

https://ecap21.usps.com/cgi-bin/ecapbv/scri...terLabelInfo.do

 

If you plug the last part that is supposed to direct your data to the site it fails to load.

"https://sss-web.usps.com/cns/enterLabelInfo.do"

 

That link will ONLY load if you submit the data from the link...

"https://sss-web.usps.com/cns/landingSubmit.do"

 

I believe that either the webmin of USPS has made it so that link can only be hit from the USPS redirect or the initial code "https://ecap21.usps.com/cgi-bin/ecapbv/scripts/login.jsp?app=GSS&appURL=https://sss-web.usps.com/cns/enterLabelInfo.do" is triggering an IDS (Intrusion Detection System). I work for a network security company and I do believe that the "File Inclusion" signature would be tripped with this code.

 

Here is an article.

http://lwn.net/Articles/203904/

 

 

Anyone have any ideas?

Share this post


Link to post
Share on other sites

I had the same problem and found out that I used the old USPS Shipping Label Contribution. You can go here http://www.oscommerce.com/community/contri...y,2/search,usps to get the latest module and install it on your website. Depending on the old code, you might have to remove the old code and replace it with the new code. One thing to note, run the update.sql file instead of the configuration.sql file. I hope this work for you, it worked for me.

Share this post


Link to post
Share on other sites
I had the same problem and found out that I used the old USPS Shipping Label Contribution. You can go here http://www.oscommerce.com/community/contri...y,2/search,usps to get the latest module and install it on your website. Depending on the old code, you might have to remove the old code and replace it with the new code. One thing to note, run the update.sql file instead of the configuration.sql file. I hope this work for you, it worked for me.

 

Have you considered Dazzle by Endicia ? It is pretty fast, the only downside is you have to cut and past the address.


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×