AlexStudio

PayPal Express Checkout IPN Payment Module

406 posts in this topic

I anyone else getting contacted about transactions not completing once they pass over to paypal?

2 customers called today, both happened to be ordering from me and some other businesses that use osc and the ipn module.

 

If so, anyone aware of the fix to the issue, I do not see mentions in the threads yet?

Share this post


Link to post
Share on other sites

Further to previous message, resetting our Paypal API access seemed to fix everything for about a wek....I'm now getting a handling amount error - please see below.

 

This started about 24 hours ago and all payments have now stopped coming in...it happens just when the customer is about to click pay right at the end.

 

For some reason the TAX amount is being sent to paypal (even though here in Australia GST is included in the total).

 

Then the TAX is being refunded via a credit to the handling charge. Why is this?

 

I think it might be the cause of the error but I'm not sure - in any event the grand total works out the same...but realyl no tax amount should be sent to paypal and no tax credit should be applied via the handling charge being a negative amount.

 

Kind Regards

John

___________________

 

 

In function: before_process()

Response from PayPal:

 

[security] = N/A

[RequesterCredentials]

[0]

[Credentials]

[0]

[username] = N/A

[Password] = N/A

[subject] = N/A

 

[DoExpressCheckoutPaymentResponse]

[0]

[Timestamp] = 2008-07-12T05:10:57Z

[Ack] = FailureWithWarning

[CorrelationID] = f1613a531553d

[Errors]

[0]

[shortMessage] = Invalid Data

[LongMessage] = Handling total is invalid.

[ErrorCode] = 10428

[severityCode] = Error

 

[1]

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

 

[Version] = 2.0

[build] = 628921

[DoExpressCheckoutPaymentResponseDetails]

[0]

[PaymentInfo]

[0]

[TransactionType] = none

[PaymentType] = none

[PaymentStatus] = None

[PendingReason] = none

[ReasonCode] = none

 

 

 

From this request: (WARNING!!) DO NOT expose your API Username/Password to the public!!

 

[?xml version="1.0" encoding="utf-8"?]

[soap:Envelope xmlns:soap=http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema]

[soap:Header]

[RequesterCredentials xmlns=urn:ebay:api:PayPalAPI]

[Credentials xmlns=urn:ebay:apis:eBLBaseComponents]

[username]x[/username]

[Password]x[/Password]

[/Credentials]

[/RequesterCredentials]

[/soap:Header]

[soap:Body]

[DoExpressCheckoutPaymentReq xmlns=urn:ebay:api:PayPalAPI]

[DoExpressCheckoutPaymentRequest]

[Version xmlns=urn:ebay:apis:eBLBaseComponents]2.0[/Version]

[DoExpressCheckoutPaymentRequestDetails xmlns=urn:ebay:apis:eBLBaseComponents]

[PaymentAction]Sale[/PaymentAction]

[Token]EC-93K748124Y601152B[/Token]

[PayerID]JSR9UTZ22FCFN[/PayerID]

[PaymentDetails]

[OrderTotal currencyID=AUD]14.99[/OrderTotal]

[OrderDescription]xxx[/OrderDescription]

[itemTotal currencyID=AUD]9.99[/itemTotal]

[shippingTotal currencyID=AUD]5[/shippingTotal]

[HandlingTotal currencyID=AUD]-1.36[/HandlingTotal]

[TaxTotal currencyID=AUD]1.36[/TaxTotal]

[NotifyURL]https://www.jja-entertainment.com.au/ext/modules/payment/paypal_ec/ipn.php?language=english[/NotifyURL]

[Custom]Phone: -- Email: [/Custom]

[shipToAddress]

[Name]JJA Entertainment[/Name]

[street1]x[/street1]

[street2][/street2]

[CityName]Sydney[/CityName]

[stateOrProvince]NEW SOUTH WALES[/stateOrProvince]

[PostalCode]x[/PostalCode]

[Country]AU[/Country]

[/shipToAddress]

[PaymentDetailsItem][Name]DEUS EX GAME OF THE YEAR 2 CD SET PC NEW & SEALED (eBay #200237998762, x)[/Name][Number]22950 (2088)[/Number][Amount currencyID=AUD]9.08[/Amount][Quantity]1[/Quantity][Tax currencyID=AUD]0.91[/Tax][/PaymentDetailsItem]

[/PaymentDetails]

[/DoExpressCheckoutPaymentRequestDetails]

[/DoExpressCheckoutPaymentRequest]

[/DoExpressCheckoutPaymentReq]

[/soap:Body]

[/soap:Envelope]

Share this post


Link to post
Share on other sites
Further to previous message, resetting our Paypal API access seemed to fix everything for about a wek....I'm now getting a handling amount error - please see below.

This started about 24 hours ago and all payments have now stopped coming in...it happens just when the customer is about to click pay right at the end.

For some reason the TAX amount is being sent to paypal (even though here in Australia GST is included in the total).

Then the TAX is being refunded via a credit to the handling charge. Why is this?

I think it might be the cause of the error but I'm not sure - in any event the grand total works out the same...but realyl no tax amount should be sent to paypal and no tax credit should be applied via the handling charge being a negative amount.

Kind Regards

John

__________________

In function: before_process()

Response from PayPal:

I had the same problem all at once starting like around 10-12 july. It seems like they have closed the negative handling amount fix door.

 

I had too tidy up the calculations in paypal_ec.php (am using the one from AlexStudio in express checkout contrib)

 

I replaced the calculation to be: (note // is removed code)

 

$su_total = round($order->info['subtotal'] * $currencies->get_value($currency_id), $decimal);

$sh_total = round($order->info['shipping_cost'] * $currencies->get_value($currency_id), $decimal);

$tx_total = round($order->info['tax'] * $currencies->get_value($currency_id), $decimal);

$tx_item = round($this->ec_generate_PDI($currency_id, true) * $currencies->get_value($currency_id), $decimal);

//$ha_total = round((($order->info['total'] ) - $order->info['subtotal'] - $order->info['shipping_cost'] - $order->info['tax']) * $currencies->get_value($currency_id), $decimal);

$ha_total = round((($order->info['total'] ) - $order->info['subtotal'] - $order->info['shipping_cost'] - ($order->info['tax'] - $tx_item)) * $currencies->get_value($currency_id), $decimal);

$ot_total = round($order->info['total'] * $currencies->get_value($currency_id), $decimal);

$su_totalex = $su_total - $tx_item;

//$order_info['PAYPAL_ORDER_TOTAL'] = $su_total + $sh_total + $tx_total + $ha_total; //**** Use the sum of all items to avoid decimal rounds mismatch the total.

$order_info['PAYPAL_ORDER_TOTAL'] = $ot_total; //if only ordertotal is given the ship+order is not checked and never a problem

$order_info['PAYPAL_CURRENCY'] = $currency_id;

 

$email = "Order total=" . $ot_total . "\nItemEx" . $su_totalex . "\n Shipping=" . $sh_total . "\ntxtotal=" . $tx_total . "\ntxitem=" . $tx_item . "\nhatotal=" . $ha_total . "\norder total=" . ($su_totalex + $sh_total + $tx_total + $ha_total) . "\n";

tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, 'PayPal EC Check Error', $email, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

 

note, I send myself an email to check the amount, can delete afterwards.

 

Now the payments come through. However,still the status is warning:

they send me:

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

 

and I can really not see any error, If i add it all up it fits..?

Share this post


Link to post
Share on other sites
Now the payments come through. However,still the status is warning:

they send me:

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

 

and I can really not see any error, If i add it all up it fits..?

 

G'Day

 

I came up with a different fix - simply change the handling and tax to $0.00 it works with our set up as our items are tax inclusive anyway. Not a single complaint so far.

 

Just a mater of changing the tax and handling values to 0.00

 

 

$tx_total = 0.00;

$ha_toatl = 0.00;

Share this post


Link to post
Share on other sites
G'Day

 

I came up with a different fix - simply change the handling and tax to $0.00 it works with our set up as our items are tax inclusive anyway. Not a single complaint so far.

 

Just a mater of changing the tax and handling values to 0.00

 

 

$tx_total = 0.00;

$ha_toatl = 0.00;

That is the easy route yes, but it looks a little more professional when Items are specified.

Just some good support from paypal would be nice to figure this one out.

 

Anyway, it works, just the warning is not so nice.

Share this post


Link to post
Share on other sites

I have the same problem as well. Just started out of nowhere yesterday. Buyers cannot complete a purchase with PayPal.

 

In function: before_process()

Response from PayPal:

 

[security] = N/A

[RequesterCredentials]

[0]

[Credentials]

[0]

[username] = N/A

[Password] = N/A

[subject] = N/A

 

[DoExpressCheckoutPaymentResponse]

[0]

[Timestamp] = 2008-07-24T17:33:21Z

[Ack] = FailureWithWarning

[CorrelationID] = a806252b44ca

[Errors]

[0]

[shortMessage] = Invalid Data

[LongMessage] = Handling total is invalid.

[ErrorCode] = 10428

[severityCode] = Error

 

etc. etc.

 

What is the fix?

Share this post


Link to post
Share on other sites

I just recently noticed that after I confirm the payment at the paypal site the system redirects me back to the Payment Information page instead of the Confirmation page (where the blue purchase button is), is this an error on my cart or is this supposed to be this way?

Share this post


Link to post
Share on other sites

Apparently PayPal changed their server behavior so the negative value is no longer accepted. For the time being please tweak your osCommerce setting 'Display TAX with Price' to work around the problem. I'll make a fix for this change when I get time.

Share this post


Link to post
Share on other sites

Hi AlexStudio,

 

The same problem for me :

 

Error #1: Invalid Data (10428)

Handling total is invalid.

 

Error #2: Transaction refused because of an invalid argument. See additional error messages for details. (10413)

The totals of the cart item amounts do not match order amounts.

 

I changed the $ha_toatl in paypal_ec.php but nothing work at all, always the same error message.

 

I sent a ticket to paypal, no answer so far...

 

The behaviour of their server is completly weird because the error message appears when you try to pay with credit card within creating a paypal account.

 

If you log in with your paypal account to pay, and the account is verified and has credit, the transaction is successfull (no error message).

 

It's not very nice, because most of the time customers don't have paypal account, so they have an error, and they can't buy.

 

When you'll have a fix it would be very helpfull.

 

Thank you very much,

Share this post


Link to post
Share on other sites

"[LongMessage] = The totals of the cart item amounts do not match order amounts."

 

Does anyone know if there has been a fix for the above error from PayPal?

Share this post


Link to post
Share on other sites

A new error I got today

 

> In function: pre_confirmation_check()

> Response from PayPal:

>

> [security] = N/A

> [RequesterCredentials]

> [0]

> [Credentials]

> [0]

> [username] = xxxx.com

> [Password] = XXXXXXXXXXXXXXXX

> [subject] = N/A

>

> [faultcode] = SOAP-ENV:Client

> [faultstring] = XML syntax error

Share this post


Link to post
Share on other sites

BODY {font-family="Tahoma"} TT {font-family="Courier"} BLOCKQUOTE.CITE {padding-left:0.5em; margin-left:0; margin-right:0; margin-top:0; margin-bottom:0; border-left:"solid 2";} Has anyone had experience with this error. Is there a fix available?

"The totals of the cart item amounts do not match order amounts."

 

In function: before_process()

Response from PayPal:

 

[security] = N/A

[RequesterCredentials]

[0]

[Credentials]

[0]

[username] = N/A

[Password] = N/A

[subject] = N/A

 

[DoExpressCheckoutPaymentResponse]

[0]

[Timestamp] = 2008-09-14T06:24:15Z

[Ack] = FailureWithWarning

[CorrelationID] = 2fd540f051c55

[Errors]

[0]

[shortMessage] = Invalid Data

[LongMessage] = Handling total is invalid.

[ErrorCode] = 10428

[severityCode] = Error

 

[1]

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

 

[Version] = 2.0

[build] = 690663

[DoExpressCheckoutPaymentResponseDetails]

[0]

[PaymentInfo]

[0]

[TransactionType] = none

[PaymentType] = none

[PaymentStatus] = None

[PendingReason] = none

[ReasonCode] = none

 

From this request: (WARNING!!) DO NOT expose your API Username/Password to the public!!

 

[?xml version="1.0" encoding="utf-8"?]

[soap:Envelope xmlns:soap=http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema]

[soap:Header]

[RequesterCredentials xmlns=urn:ebay:api:PayPalAPI]

[Credentials xmlns=urn:ebay:apis:eBLBaseComponents]

[username]snipped[/username]

[Password]snipped[/Password]

[/Credentials]

[/RequesterCredentials]

[/soap:Header]

[soap:Body]

[DoExpressCheckoutPaymentReq xmlns=urn:ebay:api:PayPalAPI]

[DoExpressCheckoutPaymentRequest]

[Version xmlns=urn:ebay:apis:eBLBaseComponents]2.0[/Version]

[DoExpressCheckoutPaymentRequestDetails xmlns=urn:ebay:apis:eBLBaseComponents]

[PaymentAction]Sale[/PaymentAction]

[Token]snipped[/Token]

[PayerID]snipped[/PayerID]

[PaymentDetails]

[OrderTotal currencyID=USD]111.09[/OrderTotal]

[OrderDescription]Order placed on September 14, 2008, 1:22 am snipped[/OrderDescription]

[itemTotal currencyID=USD]106.4[/itemTotal]

[shippingTotal currencyID=USD]4.8[/shippingTotal]

 

[HandlingTotal currencyID=USD]-0.11[/HandlingTotal]

 

[TaxTotal currencyID=USD]0[/TaxTotal]

[NotifyURL]https://snipped paypal_ec/ipn.php?language=english[/NotifyURL]

[Custom]Phone: -- Email:snipped[/Custom]

[shipToAddress]

[Name][/Name]

[street1][/street1]

[street2][/street2]

[CityName][/CityName]

[stateOrProvince][/stateOrProvince]

[PostalCode][/PostalCode]

[Country][/Country]

[/shipToAddress]

[snipped]

[/PaymentDetails]

[/DoExpressCheckoutPaymentRequestDetails]

[/DoExpressCheckoutPaymentRequest]

[/DoExpressCheckoutPaymentReq]

[/soap:Body]

[/soap:Envelope]

Share this post


Link to post
Share on other sites

I'm getting this error:

 

An error occured when we tried to process your payment. Please contact the store owner for assistance.

 

Transaction refused because of an invalid argument. See additional error messages for details. (10415)

A successful transaction has already been completed for this token.

 

The process seems to do everything fine, it shoots me over to paypal and then back to my cart. Seems like the actual transaction is taking place when I go over to paypal, but then when I get sent back to my cart and click the "pay" button I get the error.

 

The transaction is going trough on the paypal side and the user gets charged but I don't get anything on the osc side.

 

Had anyone encountered this before?

Share this post


Link to post
Share on other sites
I'm getting this error:

 

An error occured when we tried to process your payment. Please contact the store owner for assistance.

 

Transaction refused because of an invalid argument. See additional error messages for details. (10415)

A successful transaction has already been completed for this token.

 

The process seems to do everything fine, it shoots me over to paypal and then back to my cart. Seems like the actual transaction is taking place when I go over to paypal, but then when I get sent back to my cart and click the "pay" button I get the error.

 

The transaction is going trough on the paypal side and the user gets charged but I don't get anything on the osc side.

 

Had anyone encountered this before?

 

 

Update - for some reason my cart was still using checkout_shipping instead of ec_shipping and checkout_confirmation instead of express_checout in some instances.

 

Now thats resolved on to the next one:

 

I have installed Online Gift Cards contribution, everything works fine but I get an error if the total - gift cards = 0. The contribution has some code to work around this but it doesn't seem to work with EC IPN (it skips payment info if the total is 0). Does anyone know how to hide the paypal button if the amount is 0?

 

This is the code from the gift card contrib.

 

/* ogc mod to skip payment info if gift card reduces amount < $0 ---- 9/18/08 */

 if (tep_session_is_registered('gift_card')) {
   $gift_card_query = tep_db_query("select * from `".TABLE_GIFT_CARDS."` where gift_cards_code='".$_SESSION['gift_card']."' and gift_cards_enabled='1'");
   if (tep_db_num_rows($gift_card_query)>0) {
  $gift_card_row = tep_db_fetch_array($gift_card_query);
  $remaining_amount = $gift_card_row['gift_cards_amount_remaining'];
  // check to see if the user has a valid amount left on gift card
  $order_amount_left_over =   $order->info['total'] - $remaining_amount;

  if ($order_amount_left_over <= 0) {
    tep_redirect(FILENAME_CHECKOUT_CONFIRMATION);
  }
}
 }

 /* end of ocg mod -- 9/18/08 */

Share this post


Link to post
Share on other sites

I did a hack to get coupons working with this module again. It's not pretty but it works.

 

In includes>modules>payment>paypal_ec.php

 

Find (in 2 places)

$su_total = round($order->info['subtotal'] * $currencies->get_value($currency_id), $decimal);

 

Replace

$su_total = (round($order->info['subtotal'] * $currencies->get_value($currency_id), $decimal) +round(($order->info['total'] - $order->info['subtotal'] - $order->info['shipping_cost'] - $order->info['tax']) * $currencies->get_value($currency_id), $decimal));

 

Find x 2

$order_info['PAYPAL_ORDER_TOTAL'] = $su_total + $sh_total + $tx_total + $ha_toatl; //**** Use the sum of all items to avoid decimal rounds mismatch the total.

 

Replace

$order_info['PAYPAL_ORDER_TOTAL'] = $su_total + $sh_total + $tx_total; //**** Use the sum of all items to avoid decimal rounds mismatch the total.

 

Find x 2

$order_info['PAYPAL_HANDLING_TOTAL'] = $ha_toatl;

 

Replace

$order_info['PAYPAL_HANDLING_TOTAL'] = '';

Share this post


Link to post
Share on other sites

I'm still having the same issues after this hack. I get an errors because the total is $0 (after the gift card is applied). I would just love to find a way to skip payment when the total is $0.

 

I did a hack to get coupons working with this module again. It's not pretty but it works.

 

In includes>modules>payment>paypal_ec.php

 

Find (in 2 places)

$su_total = round($order->info['subtotal'] * $currencies->get_value($currency_id), $decimal);

 

Replace

$su_total = (round($order->info['subtotal'] * $currencies->get_value($currency_id), $decimal) +round(($order->info['total'] - $order->info['subtotal'] - $order->info['shipping_cost'] - $order->info['tax']) * $currencies->get_value($currency_id), $decimal));

 

Find x 2

$order_info['PAYPAL_ORDER_TOTAL'] = $su_total + $sh_total + $tx_total + $ha_toatl; //**** Use the sum of all items to avoid decimal rounds mismatch the total.

 

Replace

$order_info['PAYPAL_ORDER_TOTAL'] = $su_total + $sh_total + $tx_total; //**** Use the sum of all items to avoid decimal rounds mismatch the total.

 

Find x 2

$order_info['PAYPAL_HANDLING_TOTAL'] = $ha_toatl;

 

Replace

$order_info['PAYPAL_HANDLING_TOTAL'] = '';

Share this post


Link to post
Share on other sites
Apparently PayPal changed their server behavior so the negative value is no longer accepted. For the time being please tweak your osCommerce setting 'Display TAX with Price' to work around the problem. I'll make a fix for this change when I get time.

 

Is this contribution no longer supported by anyone?

Share this post


Link to post
Share on other sites

I just added this module and it totally blanked out my webstore, not the admin section though.

 

www.luvubeauty.com/shop1/

 

thankfully it's just a test store and I am really really hoping you can help me

Share this post


Link to post
Share on other sites

I have installed the PayPal Express Checkout IPN Payment Module with oscMax2 rc3 and it is functioning correctly when making a standard purchase. However, I would like to be able to use the coupon module included with oscMax. When I attempt to redeem a coupon I get the following error:

 

An error occured when we tried to process your payment. Please contact the store owner for assistance.<br><br>Invalid Data (10428)<br>Handling total is invalid

 

I assume I need to add some code to account for the coupon. I'm hoping someone can tell me what I need to add or point me in the right direction. Any help is appreciated. Thank you.

Share this post


Link to post
Share on other sites

Hello,

 

I have just installed this module and like another user above my shop has disappeared with just some errors showing:

 

Warning: main(includes/languages/english/FILENAME_DEFAULT) [function.main]: failed to open stream: No such file or directory in /home/sites/******.co.uk/public_html/index.php on line 36

 

Warning: main(includes/languages/english/FILENAME_DEFAULT) [function.main]: failed to open stream: No such file or directory in /home/sites/********.co.uk/public_html/index.php on line 36

 

Warning: main(includes/languages/english/FILENAME_DEFAULT) [function.main]: failed to open stream: No such file or directory in /home/sites/********.co.uk/public_html/index.php on line 36

 

Fatal error: main() [function.require]: Failed opening required 'includes/languages/english/FILENAME_DEFAULT' (include_path='.:/usr/share/pear') in /home/sites/*******.co.uk/public_html/index.php on line 36

 

(NOTE:*I have taken the shop name out.)

 

I am using an oscommerce template bought from templatemonster if that has anything to do with it?

 

Does anybody know how I can fix this problem?

 

Thanks in advance.

Helen.

Edited by helenmarie123

Share this post


Link to post
Share on other sites

I just installed this on a testsite before transferring over to live, but doesn't it seem strange to anyone that the stock update is commented out? When I go through with test orders, the stock is in fact not depleted by 1 for the item. Just a FYI, someone should check this, because it could cause some serious problems in your store.

 

Edit: Easy to fix though, just uncomment the stock code in ppeb.php

Edited by JangoF

Share this post


Link to post
Share on other sites

i installed this contrubute and it works great, i am so happy.

 

one small prblem.

 

in the admin when it says

 

Utilize Express Checkout Button?

Do you want to show the Express Checkout Button in checkout shipping page? (RECOMMENDED: Yes)

 

i said yes but when i go to the shipping page their is just a x where the picture should be. what is the file name and where is it looking so i can put something their. that is so their will be a picture their. its an easy fix i just need to know what to name the file and where to put it.

Share this post


Link to post
Share on other sites

This only occurs when there is a "Special" item in the shopping cart.

 

Anyone shed some light on this problem?

 

BODY {font-family="Tahoma"} TT {font-family="Courier"} BLOCKQUOTE.CITE {padding-left:0.5em; margin-left:0; margin-right:0; margin-top:0; margin-bottom:0; border-left:"solid 2";} Has anyone had experience with this error. Is there a fix available?

"The totals of the cart item amounts do not match order amounts."

 

In function: before_process()

Response from PayPal:

 

[security] = N/A

[RequesterCredentials]

[0]

[Credentials]

[0]

[username] = N/A

[Password] = N/A

[subject] = N/A

 

[DoExpressCheckoutPaymentResponse]

[0]

[Timestamp] = 2008-09-14T06:24:15Z

[Ack] = FailureWithWarning

[CorrelationID] = 2fd540f051c55

[Errors]

[0]

[shortMessage] = Invalid Data

[LongMessage] = Handling total is invalid.

[ErrorCode] = 10428

[severityCode] = Error

 

[1]

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

 

[Version] = 2.0

[build] = 690663

[DoExpressCheckoutPaymentResponseDetails]

[0]

[PaymentInfo]

[0]

[TransactionType] = none

[PaymentType] = none

[PaymentStatus] = None

[PendingReason] = none

[ReasonCode] = none

 

From this request: (WARNING!!) DO NOT expose your API Username/Password to the public!!

 

[?xml version="1.0" encoding="utf-8"?]

[soap:Envelope xmlns:soap=http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema]

[soap:Header]

[RequesterCredentials xmlns=urn:ebay:api:PayPalAPI]

[Credentials xmlns=urn:ebay:apis:eBLBaseComponents]

[username]snipped[/username]

[Password]snipped[/Password]

[/Credentials]

[/RequesterCredentials]

[/soap:Header]

[soap:Body]

[DoExpressCheckoutPaymentReq xmlns=urn:ebay:api:PayPalAPI]

[DoExpressCheckoutPaymentRequest]

[Version xmlns=urn:ebay:apis:eBLBaseComponents]2.0[/Version]

[DoExpressCheckoutPaymentRequestDetails xmlns=urn:ebay:apis:eBLBaseComponents]

[PaymentAction]Sale[/PaymentAction]

[Token]snipped[/Token]

[PayerID]snipped[/PayerID]

[PaymentDetails]

[OrderTotal currencyID=USD]111.09[/OrderTotal]

[OrderDescription]Order placed on September 14, 2008, 1:22 am snipped[/OrderDescription]

[itemTotal currencyID=USD]106.4[/itemTotal]

[shippingTotal currencyID=USD]4.8[/shippingTotal]

 

[HandlingTotal currencyID=USD]-0.11[/HandlingTotal]

 

[TaxTotal currencyID=USD]0[/TaxTotal]

[NotifyURL]https://snipped paypal_ec/ipn.php?language=english[/NotifyURL]

[Custom]Phone: -- Email:snipped[/Custom]

[shipToAddress]

[Name][/Name]

[street1][/street1]

[street2][/street2]

[CityName][/CityName]

[stateOrProvince][/stateOrProvince]

[PostalCode][/PostalCode]

[Country][/Country]

[/shipToAddress]

[snipped]

[/PaymentDetails]

[/DoExpressCheckoutPaymentRequestDetails]

[/DoExpressCheckoutPaymentRequest]

[/DoExpressCheckoutPaymentReq]

[/soap:Body]

[/soap:Envelope]

Share this post


Link to post
Share on other sites

I noticed that there hasn't been any resolved fix to the issue where clicking the "pay" button redirects to login.php. There was a similar problem in Paypal WPP Direct Payments and Express Checkout support thread. It was resolved here: http://forums.oscommerce.com/index.php?sho...t&p=1395526

 

It seems as though catalog/includes/modules/payment/paypal_wpp.php and catalog/includes/modules/payment/paypal_ec.php are similar. However, when I applied the fix in the above thread, I encountered this error: Fatal error: Cannot redeclare class payment in /homepages/40/d251991198/htdocs/catalog/includes/classes/payment.php on line 13

 

I think I'm on the right track to a fix for those of us who are redirected to the login.php page. Can someone please help me out here?

 

Thanks in advance.

Edited by modawg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now