Jump to content
Sign in to follow this  
Becki

Tax and sub-total issue in UK!Why sub-tot inc VAT?

Recommended Posts

Hi all,

 

I wonder if anyone can point me inthe right direction...

 

I have changed the settings in admin so that I apply a tax (VAT) of 17.5% to all products and the prices show in my shop with VAT included (as should be). Then I look at the sub-total in the checkout process (and the invoice and packing slip) and it is the same as the Grand total. I want the sub total to be the total ex VAT and then list the VAT (as it does) and then the grand total inc VAT. It seems to work if i show the prices in the shop as ex VAT but i do not want to do this.

 

Can anyone help please?

 

Thanks very much

 

Becki

Share this post


Link to post
Share on other sites
Hi all,

 

I wonder if anyone can point me inthe right direction...

 

I have changed the settings in admin so that I apply a tax (VAT) of 17.5% to all products and the prices show in my shop with VAT included (as should be). Then I look at the sub-total in the checkout process (and the invoice and packing slip) and it is the same as the Grand total. I want the sub total to be the total ex VAT and then list the VAT (as it does) and then the grand total inc VAT. It seems to work if i show the prices in the shop as ex VAT but i do not want to do this.

 

Can anyone help please?

 

Thanks very much

 

Becki

 

Has anyone got a solution to this please - it must be quite easy but I'm no codeing expert!

I just want the sub-total to show the prices ex VAT rather than including VAT (this doesn't make any sense)

 

 

Thanks

 

Becki

Share this post


Link to post
Share on other sites

first thing to do is to ensure your order totals follow the correct order. So goto your osc Admin->Modules->Order Total

 

Total modules with lower order are set first by osc. The default behaviour works so it must be something else either configuration or a module in your store that causes this.

Share this post


Link to post
Share on other sites
first thing to do is to ensure your order totals follow the correct order. So goto your osc Admin->Modules->Order Total

 

Total modules with lower order are set first by osc. The default behaviour works so it must be something else either configuration or a module in your store that causes this.

 

 

Ok thanks, I'll check tonight (but I think I already did - I'll make sure)

 

becki

Share this post


Link to post
Share on other sites
first thing to do is to ensure your order totals follow the correct order. So goto your osc Admin->Modules->Order Total

 

Total modules with lower order are set first by osc. The default behaviour works so it must be something else either configuration or a module in your store that causes this.

 

Hi,

 

I checked and I have sub-total = 1, then VAT -2, shipping - 3, and total - 4. But the sub-total always shows the actual total!

 

I can't understand it or solve it. I have created a tax zone of UK and rate of 17.5% for all zones. If you are right in stating it normally works I don't know what's causing it. I started with STS4.3 and HTC installed and then installed PWA. Do you know from which file the sub-total is calculated and then stored in the database? It's like the sub-total is just taking the Grand total values. If I knew where this was created etc I could look to see if i have edited that file but I don't think I have.

 

I also have a proplem with VAT Report V2 where it is lists the VAT and shipping values of orders in the wrong columns (i.e Vat in the shipping and vice versa, and also it should display the sub-total but actually is the grand total minus the shipping price.) But in the database the VAT and Shipping values seem to be stored correctly.

 

Is sub-total really supposed to show the price ex VAT or just the TOTAL minus the shipping (in that case it is working i suppose) BUT i wanted it to show ex vat ex shipping.

 

So you'd have:

Sub total ex vat ex shipping

VAT

Shipping

Total inc vat inc shipping

 

 

Please help! :)

 

Becki

Share this post


Link to post
Share on other sites

Becki, I have exact the same problem as you, and I have struggled for the past 6 months to find a solution. No luck so far!

 

Oscommerce seems to work if you under Configuration chooses "false" to display prices incl. tax. Then I can get a logical build-up / specification of the invoice. But otherwise no. So to get a decent invoice you have to select "false" to show prices incl. prices, which basically leads to a lot of customer dissatisfaction when people find out the tax is being added at checkout.

 

If just it was possible to let the invoice start with the price excl. tax, and show prices incl. tax, then all problems would be solved.

 

Please let me know if you find a solution to this dilemma. I have so far not been able to find an explanation anywhere, and also the calculation of the tax is - for me - a very black-box.

 

Mogens

Share this post


Link to post
Share on other sites
Becki, I have exact the same problem as you, and I have struggled for the past 6 months to find a solution. No luck so far!

 

Oscommerce seems to work if you under Configuration chooses "false" to display prices incl. tax. Then I can get a logical build-up / specification of the invoice. But otherwise no. So to get a decent invoice you have to select "false" to show prices incl. prices, which basically leads to a lot of customer dissatisfaction when people find out the tax is being added at checkout.

 

If just it was possible to let the invoice start with the price excl. tax, and show prices incl. tax, then all problems would be solved.

 

Please let me know if you find a solution to this dilemma. I have so far not been able to find an explanation anywhere, and also the calculation of the tax is - for me - a very black-box.

 

Mogens

 

 

HI,

 

I managed to fix this over the weekend, I installed a contribution called Order Total excluding VAT found here:

 

 

http://www.oscommerce.com/community/contri...subtotal+ex+vat

 

Just install the files into the correct folders, go to admin > Modules > Order Totals and make the new sub_total ex VAT replace the old sub-total. Worked great for me!

 

 

Hope this helps

 

 

Becki

Share this post


Link to post
Share on other sites
HI,

 

I managed to fix this over the weekend, I installed a contribution called Order Total excluding VAT found here:

http://www.oscommerce.com/community/contri...subtotal+ex+vat

 

Just install the files into the correct folders, go to admin > Modules > Order Totals and make the new sub_total ex VAT replace the old sub-total. Worked great for me!

Hope this helps

Becki

 

i think i might have the same problem,

 

will download tomorrow to check it out!

Share this post


Link to post
Share on other sites
HI,

 

I managed to fix this over the weekend, I installed a contribution called Order Total excluding VAT found here:

http://www.oscommerce.com/community/contri...subtotal+ex+vat

 

Just install the files into the correct folders, go to admin > Modules > Order Totals and make the new sub_total ex VAT replace the old sub-total. Worked great for me!

Hope this helps

Becki

 

Hi Becki,

I was using this contribution as well but realized that also the shipping must be taxed (VAT) even if sent from the Post office.

Anyway, have you managed to get the shipping ex VAT as well??

Thanks in advance,

Roberto

Share this post


Link to post
Share on other sites
HI,

 

I managed to fix this over the weekend, I installed a contribution called Order Total excluding VAT found here:

http://www.oscommerce.com/community/contri...subtotal+ex+vat

 

Just install the files into the correct folders, go to admin > Modules > Order Totals and make the new sub_total ex VAT replace the old sub-total. Worked great for me!

Hope this helps

Becki

 

Hi Becki,

I was using this contribution as well but realized that also the shipping must be taxed (VAT) even if sent from the Post office.

Anyway, have you managed to get the shipping ex VAT as well??

Forgot to say, I tried to integrate the ot_shipping.php with the contribution ot_subtotal_ex.php but it didn't work :-(

Thanks in advance,

Roberto

Share this post


Link to post
Share on other sites
I was using this contribution as well but realized that also the shipping must be taxed (VAT) even if sent from the Post office. Anyway, have you managed to get the shipping ex VAT as well??

 

I'm also interested in this mod.

 

VAT in the UK to be added after subtotal and shipping.

 

Anyone working on this?

 

Nick

Share this post


Link to post
Share on other sites

is it really working for you? i have also tried to do the same thing by adding these new files but it always show vat as 0.88. How can i corect this

Share this post


Link to post
Share on other sites
is it really working for you? i have also tried to do the same thing by adding these new files but it always show vat as 0.88. How can i corect this

 

It works for me - many thanks for the tip. Great contribution too - no pasting :)

 

me like.

 

I still have another problem though - ex vat and inc vat prices are the same on the product lines - any ideas people?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×