Jump to content
Sign in to follow this  
Snowman

osC Affiliate Alpha 2.0 - Testers Wanted

Recommended Posts

A couple of suggestions/comments from myself.

 

First and foremost, it is looking good. We appreciate when people step up to the plate like this.

 

The Company I work for is a publisher on Commission Junction, So, I have some experience with affiliate programs (not so much from the programming side). There are a couple of suggestions I would make:

 

1) Have the option for the admin to APPROVE the affiliate's information BEFORE they are able to sign-in. Which might just mean not allowing a login/password during sign-up and having a random password generator which would e-mail it to them upon approval. This should not be overlooked. I for one would not like to give out commission to adult sites, etc.

 

2) You should have the affiliate setup in a multi-tiered situation. If an affiliate has more than 1 site this solution is fine.. However, I find that a lot of affilates have a lot of sites (and they seem to be in the affiliate buisness). So, you would have their main account with sub-accounts (could be treated like address book) for each domain they use.. with tracking for each domain and a TOTAL tracking for the affiliate parent account. This is a little more advanced and will probably be best to be released after the first version (just to get an affiliate solution out there) as an enhancement. It really should be looked at though.

 

3) After getting a banner and clicking on it, you go to the page and the ?ref=## stays in the Address location. I would suggest not to allow this to happen. It should refresh and have no indication that you are using a referal affiliate. If the affiliate is smart, he will hide this in the status window as well. Some people don't like the idea of giving someone else a commission over the web and will simply remove the referer id # from the link (or address bar). I haven't looked at your code but I assume that you are setting the ref id in the session and not in a cookie (I didn't see it in my cookie). The industry standard is to set it in a cookie in case the people go back to that site later.. the affiliate still gets credit for the sale.

 

I'm sure I will have more!

Share this post


Link to post
Share on other sites

Also, just to add, CJ uses a script to track impressions & clicks, etc.

 

Their code looks like this:

 

<a href="http://www.qksrv.net/click-AFFILIATE_WEBSITE_ID#-OSC_SHOP_LINK_#" target="_blank" onmouseover="window.status='http://www.osc_shop.com/catalog';return true;" onmouseout="window.status=' ';return true;"><img src="http://www.qksrv.net/image-AFFILIATE_WEBSITE_ID#-OSC_SHOP_LINK_#" width="1" height="1" border="0">

 

Therefore, when the click on the link http://www.qksrv.net/click-1010101-000001 qksrv.net simply sets the cookie and redirects them to http://www.osc_shop.com/catalog and hence it looks like a normal link. Then on the checkout page the cookie retriever pulls the affiliate ID out and sends it to the admin to APPROVE. Once approved, then the commission shows up under affiliate login. A more honest approach would to have a status along with the sale so the affiliate knows it is "pending approval", "approved", "declined".

 

The 1x1 image is for the "impression" tracking. I am not sure exactly how all that is done but it seems to be a server-side script that the webserver runs and if it is "image-AFF#-LINK#" it returns an image and if it is "click-AFF#-LINK#" it fowards & redirects to a URL (which should be able to be set by the link setup in admin).

Share this post


Link to post
Share on other sites

I don't think it a problem to have affiliate account seperate from customer account. I know most of my affiliates will not be my customers.

Share this post


Link to post
Share on other sites

Ok, being the Mac guy, I tested it with IE 5 and NS 7.0. After a little difficulty getting the logins right, all seemed to work. By difficulty, I mean that if you log in as affiliate first, then go login as a customer, it doesn't seem to register the sale. That could just be a Mac NS thing. After I logged off as customer and cleared my cache and cookies, all worked fine.

 

One thing I did notice is that in IE, the formatting on the summary is a little funky and the scroller doesn't work (the welcome). I can send you screen shot if you want. Since IE is the most used browser on a Mac, if might be something to look at. When I get a hold of the mod, I can take it a look at it.

 

Other than that, great work!!!

 

Thanks Steve

 

J

Share this post


Link to post
Share on other sites

I am not a low level kind of guy, so the only thing I can think of for tracking impression would be to scan your server log files each night to see to whom ad images were served.

 

There has to be a better way but, this one would work.

 

Scott.

Share this post


Link to post
Share on other sites

:? Snow Man,

 

How long does it usually take from beta2 to actuall distribution? I think tihs program is something we have been looking for. Keep up the good work and good luck.

 

Thanks,

Rick

Share this post


Link to post
Share on other sites
:? Snow Man,

 

How long does it usually take from beta2 to actuall distribution? I think tihs program is something we have been looking for. Keep up the good work and good luck.

 

Thanks,

Rick

 

How long is a piece of string???

 

Jarmen - The news scroller is a weird issue, one minute it works fine the next it plays up....it's only a remote IFRame that is scrolling ( I know IFrames arent fully supported by everyone and i will add a better solution when i have everything else sorted)

 

hobzilla - The way CJ does there tracking is good and im going to delve under the bonnet of phpMyAds to see if i can find out how its done, and if it can be applied to this mod without too much difficulty.

 

As for the option of approval of affiliates i will do this for version 3.

 

Multi level affiliates is starting to get complex and i think this is going to have to wait till all the bugs are ironed out and a stable version of 2.2 is released.

 

The ?ref=## only stays in the address bar on default.php when you go to another page it dissapears. The reason i have set the ref as a session variable is because a lot of people dont have cookies enabled and osC seems to keep clear of cookies where possible as well.

 

It wouldnt be too hard to swap over to a cookie or to use both for that matter, so as to cover both bases, it can be looked at for release 3.

Share this post


Link to post
Share on other sites

So Steve,

When can we see this contribution available. I'm ready to start using this beta on my site:)

Share this post


Link to post
Share on other sites

Ive been working on it all day...just finishing up the admin siide of things

 

so hopefully sometime this weekend

Share this post


Link to post
Share on other sites

I signed up. After completing the information, got an error message in a pop-up window:

"Problems with this page..."

Line 21

Char 3

Error 'document.account_edit.firstname' is null or not an object

Code 0

http://www.snowstore.net.au/demostore/affi...iate_signup.php

 

Also, the affiliate news is not scrolling, seems like it wants to but something is "holding it down". :)

 

When using the links in the affiliate section, I got prompted to login again, after I had allready logged in.

 

Placed a banner on a test page and it seems to be working fine.

 

Be back later with more testing.

Share this post


Link to post
Share on other sites

the document object problem and the news scroller issue are already noted.

 

as for the login issue, im still investigating a solution to it.

Share this post


Link to post
Share on other sites

Hi,

 

How does the "Visits" work ?

Visits represents the total number of click-throughs by visitors from your website

I have clicked though only once from my banner on my site, so should the "visit" counter be "1" or higher. It's currently sitting at 15 and increasing each time I view another page.

 

I also signed up for the affiliate scheme as ref=37, bought a couple of things and received no commission !!

 

When does the commission become active? Immediately, or when you have approved the order ?

 

I also got a load of php warnings on the checkout (inserted as comments in my order). I presume you know about these though :-)

 

 

Regards

 

 

Paul

Share this post


Link to post
Share on other sites

Good job Steve.

 

As for affiliate approval, it can easely be done by making something like a copy of contact_us.php (new_affiliate.php?) for those who's interested.

 

This page could promote all features, earnings and so on, and they can leave their web-site address, and when approved you can send the login-URL.

 

We can all do that, so I don't think you have to worry about that.

 

Looking forward to the final release.


Best Regards

olby

Share this post


Link to post
Share on other sites

Great Mod, looking forward for the download.

 

Only thing that would be a nice addition is if say an affiliate wanted to do a direct to product page link. Have a banner generator where affiliate would put product copy paste link in and the generator would make button and source code.

Share this post


Link to post
Share on other sites

elfmuse im looking into that for 3.0

 

Paul can you please post the warnings you were receiving????

 

Visits should post a clickthrough each time a customer visits the site. I am playing with the backend code a bit so this is why weird issues like this pop up now and again....

Share this post


Link to post
Share on other sites

I didn't even think about that! An affiliate to be able to link directly to a product would be great. That way they could just post the images and a description with a link directly to add to cart or something. I can wait for a 3.0 for that.

 

Go, Steve, Go.

 

Josef

Share this post


Link to post
Share on other sites

Paul the warnings in the checkout are to do with the dynamic shipping system im developing. The errors are only to do with the shipping modules not the affiliate module....

 

====================================

Warning: file("http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3300&Destination_Postcode=AC1 ACIA&Country=GB&Weight=7000&Service_Type=Air&Height=100&Width=100&Length=100&Quantity=1") - Success in /home/snowzone/public_html/demostore/includes/modules/shipping/auspost_air.php on line 60

 

Warning: Invalid argument supplied for foreach() in /home/snowzone/public_html/demostore/includes/modules/shipping/auspost_air.php on line 61

 

Warning: file("http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3300&Destination_Postcode=AC1 ACIA&Country=GB&Weight=7000&Service_Type=Air&Height=100&Width=100&Length=100&Quantity=1") - Success in /home/snowzone/public_html/demostore/includes/modules/shipping/auspost_economy.php on line 60

 

Warning: Invalid argument supplied for foreach() in /home/snowzone/public_html/demostore/includes/modules/shipping/auspost_economy.php on line 61

 

Warning: file("http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3300&Destination_Postcode=AC1 ACIA&Country=GB&Weight=7000&Service_Type=Air&Height=100&Width=100&Length=100&Quantity=1") - Success in /home/snowzone/public_html/demostore/includes/modules/shipping/auspost_sea.php on line 60

 

Warning: Invalid argument supplied for foreach() in /home/snowzone/public_html/demostore/includes/modules/shipping/auspost_sea.php on line 61

====================================

 

as for the issues you have experienced with the tracking of sales ....you have got me totally stumped....

 

Can you clear your cache and try again.....

 

I havent been able to recreate the problem....

Share this post


Link to post
Share on other sites

Ah found the problem.....when you entered your Postcode you entered it as AC1 ACIA ...the drc calculator doesnt like spaces..... i entered an order with AC1ACIA and it worked perfectly....

 

Ill have to look into that issue...

 

The errors that came up in the checkout may also have caused the session variable to be damaged as well...hence no affiliate payment....I ran an order thru and it worked fine and you were credited the payment....

 

As for the tracking ....i dont know....

 

What browser/system are you on?

Share this post


Link to post
Share on other sites

I was using Win2k/SP3 IE6/SP1 ... nothing special !!

 

Just as a matter of interest, I've tried to log back into the affiliate area .. and can't. Mental block on the username. Tried everything I thought I'd used !

 

Also tried the "forgotten my password" and it can't find me. Have you cleared the database ?

 

... and before you ask I did use the right email address !

 

Paul

Share this post


Link to post
Share on other sites

um yes sorry i was playing in the admin backend and an error deleted your account.

 

If you signup again you will find it is now working fine... (i hope)

Share this post


Link to post
Share on other sites

Hi there,

 

Have just re-signed up (new ID of 45).

I've made two separate purchases going via my affiliate banner:

 

The affiliate admin shows only 1 transaction and 19 visits:

Bit odd considering i've only made 2 visits and bought 2 items:

Order No: 93 and 94.

 

Is this to do with the "spaces" or have I broken it :-)

 

Paul

 

Impressions: [?] n/a

Visits: [?] 19

Transactions: [?] 1

Conversion: [?] 19%

Amount: [?] $669.97AUD

Average: [?] $67.00AUD

Clickthrough Rate: [?] $0.01AUD

Pay Per Sale Rate: [?] $5.00AUD

Commission Rate: [?] 10.0000%

Commission: [?] $67.00AUD

Share this post


Link to post
Share on other sites

Hmmm

 

Id love to see you run a transaction thru to see whats going on...the stats you displayed are right according to the backend...ive eliminated the issue with the UK postcodes so it shouldnt cause a problem...

 

the only thing i can think of is that for some reon your system isnt holding the session properly....

 

This is why this code is an Alpha and why its taken so long to get ready for release....

Share this post


Link to post
Share on other sites

Just done another order, originating from a banner on my site with ref=45.

Confirmation email was Order Number 97.

 

Still only 1 transaction recorded on the Summary (from the 3 order made). I've cleared my cache, logged out of the affiliate area and logged back in.

 

Would it make any difference being logged into your OSC shop as a customer at the same time ?

 

Paul

Share this post


Link to post
Share on other sites

hmm it would well be the problem but im not sure....as soon as i have finished the backend i will package a prerelease for others to try and figure out whats going on...

 

I havent been able to recreate the issue that you experience...unyet ive been working on the problem all day...

 

This is where my lack of PHP knowledge lets me down... :oops: :cry:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×