Jump to content
Sign in to follow this  
Snowman

osC Affiliate Alpha 2.0 - Testers Wanted

Recommended Posts

Ok finally its almost ready and im just putting a bit of spit polish onto the back end systems.

 

However what i need now is for a whole lot of people to signup as affiliates and test the living crap out of the code to see if its stable.

 

go to:Australian SnowzonE Demostore

 

Note: This site has my dynamic shipping solution installed as well. So this will get tested at the same time when orders are put through the system.

 

I just have a bit of tidying up to do on the admin side of things and providing the testing goes ok over the next 2 days the code will be contributed sometime over this weekend.

 

Oh and dont worry about the sales status reporting as 0 in the reports...i havent set it right up yet.

 

Oh and if you had signed up as an affiliate before now you will need to resign.

Share this post


Link to post
Share on other sites

I signed up and went to edit my account. There was no info there. :shock:

 

I tried to login, but I was not in the system. :shock:

 

I think I busted it :cry:

Share this post


Link to post
Share on other sites

Good news ... I can log into the affilate program. Just not to the store. I take it these are two seperate things?

 

Perhaps Edit Account should be covered by a loging or something or one would become very confused ... I was confused :lookround:

Share this post


Link to post
Share on other sites

Hmmm good point...no one has pointed that out to me before...

 

the affiliate section is seperate to the account section so that functions, sessions and cookies dont interfere...

Share this post


Link to post
Share on other sites

Snowman,

 

I've giving you system a try. However, I ran into a problem creating an account. After filling in all my personal info, I pressed CONTINE and IE pop up with a dialog box that says:

 

Problems with this Web page might prevent it from being displayed properly....

 

Details:

Line: 21

Char 3

Error: 'document.account_edit.firstname' is null or not an object

Code: 0

URL: http:// www.snowzone.net.au/demostore/affiliate_signup.php?osCsid=86ac3544b9c45e595e3e2e8d1cde8da8

 

 

I was able to click past the error dialog, with no apparent problem.

 

After I signed in the system showed me the Affilate summary screen. The Affilate News did not scroll up in the window The first line kept scrolling up one line then poping back down again.

 

Finally I ordered an item. I got another error dialog with this info:

 

Details:

Line: 37

Char 3

Error: 'cvvnumber' is undefined

Code: 0

URL: http://www.snowzone.net.au/demostore/check...kup_payment.php

 

 

However, I was able to click though the dialog again and confirm the order.

 

I am running IE 6.0.2600.0000.xpclnt_qfe.010827-1903

 

 

Hope this helps,

 

Scott.

Share this post


Link to post
Share on other sites

the cvv number im aware of....thats to do with a module im working on...

 

'document.account_edit.firstname' is an error im also aware of but havent fixed yet....

 

as for the news scroller im buggered if i know why its doing that...sometimes it does sometimes it doesnt

 

 

Thanks for the info

Share this post


Link to post
Share on other sites

Nice.

 

Everything seems to work for me, email, and all the fuctions on the affia box. I bought a total of $650.00, the actual products were 450, the other 200 is shipping cost, so I only get pay on 450 wich 10% is $45 dollars. And it seems to work well.

 

The only confused things is that, the store acount seperate from the modual account. Is there an anti cheat? Good start! :-))

 

Keep up the good work

 

Nouck

 

4 thumps up.

Share this post


Link to post
Share on other sites

The only thing I can see is that when I signed up, I was automatically logged into the Affiliate area - I didn't have to wait for my email to arrive with the username/pass combo.

 

I went to build myself a banner - and my ?ref=0 which was wrong. So I logged out and back in (using the details sent in the email) and now my ?ref=14

 

So that could be a problem...

 

HTH


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Nouck

 

Why is it confusing to have a seperate affiliate account to a customers account???

 

A few people have mentioned this to me but i didnt see it as an issue...

 

Burt

 

I guess i'll have to unregister the session once signup is complete to stop the problem you had from occurring. Havent had that one pop-up before...thanks for pointing it out...

 

This is one reason why it has taken so long to get Alpha 2 out....it is nolonger a simple little mod....

Share this post


Link to post
Share on other sites
Why is it confusing to have a seperate affiliate account to a customers account???
I think that it should be kept 100% seperate. I run an Affiliate Scheme on a site and 95% of my Affiliates are people wanting to earn a $?$, they are not interested in becoming a customer. Maybe this is a UK-centric thing though? Don't know.

 

I guess i'll have to unregister the session once signup is complete to stop the problem you had from occurring. Havent had that one pop-up before...thanks for pointing it out...
No worries, the one I presently run does exactly that - "thanks for signing up - now go check your email and log in" type of thing...

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I agree with you burt.

 

Affiliate accounts should be totally seperate to customer accounts.

 

As for the bug with the login after signup...ive added an session unregister so that should solve that problem.

Share this post


Link to post
Share on other sites

Can this system support deep-linking to products? Text links?

 

Burt is right about the affiliate code not coming through when getting the banner code...

Share this post


Link to post
Share on other sites

Products can be linked to....however they need to be done manually at this stage....essentially any link to your the site with ?ref=YOURID will work.

 

Im just investigating the issue with the refid now...

Share this post


Link to post
Share on other sites

It's looking great though Steve - you clever man! :bigups:

 

From the sign-up e-mail:Payments will be made on a quarterly basis with a threshold of $50.00 If at the end of the quarter your commission amount has not reached the $50.00 minimum, the total amount will be rolled over to the next quarter.

 

Will the script automatically do this and then inform the site admin when the affiliate has reached $50 (or whatever is set) minimum that it's time to pay him/her?

Share this post


Link to post
Share on other sites
It's looking great though Steve - you clever man! :bigups:

 

From the sign-up e-mail:Payments will be made on a quarterly basis with a threshold of $50.00 If at the end of the quarter your commission amount has not reached the $50.00 minimum, the total amount will be rolled over to the next quarter.

 

Will the script automatically do this and then inform the site admin when the affiliate has reached $50 (or whatever is set) minimum that it's time to pay him/her?

 

Alpha 3 will do it automatically i hope....i was going to add it and a few other back end goodies into Alpha 2 but ive been too busy with $$$ making work to get a chance....

 

At this stage the payment system is still manually done but ive set up the system in such a way that it will be easy to intergrate updates....

 

for example their is a spot on the affiliate summary for impressions....(i havent found the right way to go about doing this yet...but its something that is for the near future.

 

(oh and if someone knows a way to do up some code to track impressions of the sites banners on affiliates websites please let me know.)

Share this post


Link to post
Share on other sites
(oh and if someone knows a way to do up some code to track impressions of the sites banners on affiliates websites please let me know.)

 

The only thing I can think of is to parse the img src through a PHP page which counts and updates the database as necessary. So the link will look something like:

 

 

<a href="http://www.snowzone.net.au/demostore/default.php?ref=14" target="_blank"><img src="http://www.snowzone.net.au/demostore/image.php?image=banner_a&ref=14" border="0"></a>

 

Now image.php will need to parse the ref and add an impression to the database, but will also need to send a mime type and display the image. Not simple and definately heavy on the database...

 

Whilst doing this, I just logged back into Snowzone to build a banner and get this:

 

<a href="http://www.snowzone.net.au/demostore/default.php?ref=14" target="_blank"><img src="http://www.snowzone.net.au/demostore/images/" border="0"></a>

 

The img src is not giving an image... .jpg or .gif or .png etc...

 

HTH


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I dont use OSC as my home page I just have a link to it. If people leave the cart to go to my home page and then come back to the cart will the affiliate program still keep track of them? does it use cookies or would I have to pass the info from page to page manually?

Share this post


Link to post
Share on other sites

um just playing with the sql at the moment hence the image name isnt showing.

 

as for tracking affiliates....it only tracks during a session at this stage.

Share this post


Link to post
Share on other sites

The main reason I decided on OSC was because of a string where I saw that you were doing an affiliate mod after that other guy created one and didnt release it as a contribution.

I am glad to see this being released soon, and it looks very impressive and I'm really excited to try it out

 

I'm not sure if this is possible but just a thought for a future release.

GIving the option in admin to "Hard Wire" so to speak a customer to an affiliate ID that way affiliates keep there customer commissions. Of course not every body would like this so it should be optional, And if possible tracking cutomers beyond the session

 

Thank you for taking the time to put this whole thing together. It's gonna be a huge asset

Share this post


Link to post
Share on other sites

Hello Steve,

all looks great but I have few.

I made registration on affiliate and click on banner to enter on the store.

I do this 3-4 times, but when I check clicktroughs statistic there was 10 clicks and one of them without refere info (26/09/2002 07:34:20).

My username is teodorp and pass: 1qaz2wsx

Please check this.

 

This mod is really good job. :P


I have to know...:)

Share this post


Link to post
Share on other sites

Hi again,

I think the problem is becouse I click on Test Banner and you delete this banner...


I have to know...:)

Share this post


Link to post
Share on other sites

Yeah i have been playing around in the backend a bit so there may be a few issues that popup every now and again.

 

As for the ability to "Hard Wire" a customer to an affiliate i guess it would be possible

 

A cookie could be set with a time limit of say 30 days as an option or something laong those lines....I havent really thought about it yet...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×