Jump to content

Archived

This topic is now archived and is closed to further replies.

nox171

blank installation page on ispconfig

Recommended Posts

Hallo everyone,

After stucking all the day trying to install oscommerce (and reading your forum) ,I decided to post a new topic.

First of all sorry for my english...

I run Ispconfig under a suse installation hosted in a webfarm.

Following the installation step I created a new site with a new user and database.

I have downloaded the oscommerce file on my machine, unzipped and via FTP (binary mode) uploaded to the new site under the folder:

.../web18/web/

In the site configuration the safe php option is off

and I've added the following line in the form:

php_admin_flag register_globals on
php_admin_flag register_long_arrays on
php_admin_flag magic_quotes_gpc on
php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728
php_admin_flag session.autostart off
php_value register_long_arrays on
php_admin_flag register_globals on

 

But after that if I try to go to my installation page http://mysite.com/catalog/install/

I always get a blank page!! Whit no code inside... :( :(

 

Have anybody got some idea?!

Please I'm very desperate....

 

Thanks

 

/nox

Share this post


Link to post
Share on other sites

How it can be possible that I receive a white page instead of the installation page?

I tryed the configuration again without the catalog folder but the result is the same... :(

 

The white page could be possible because the php scripts don't work well?!?! :huh:

Share this post


Link to post
Share on other sites
How it can be possible that I receive a white page instead of the installation page?

I tryed the configuration again without the catalog folder but the result is the same... :(

 

The white page could be possible because the php scripts don't work well?!?! :huh:

 

 

Hi,

always locked on the same blank page.

Could it be possible because in the httpd.conf file I have AllowOverride none??

 

Is possible to change it not for all the sites but only for one? Some code to insert in my ISPconfig Apache directive...

 

Because I receive this message

 # AllowOverride All # NOT SUPPORTED!

Share this post


Link to post
Share on other sites
Hi,

always locked on the same blank page.

Could it be possible because in the httpd.conf file I have AllowOverride none??

 

Is possible to change it not for all the sites but only for one? Some code to insert in my ISPconfig Apache directive...

 

Because I receive this message

 # AllowOverride All # NOT SUPPORTED!

 

How did you add those lines to the form???

Was that a .htaccess file you created?

Or how else did u do it?

N

Share this post


Link to post
Share on other sites
How did you add those lines to the form???

Was that a .htaccess file you created?

Or how else did u do it?

N

 

I add those lines on the Apache directives form on my ISPconfig panel in the specific site.

And I received that error because the ISPconfig do not support that instruction.

 

Now I tried with this:

php_admin_flag register_long_arrays on
php_admin_flag register_globals on
php_admin_flag magic_quotes_gpc on
<Directory /var/www/web37/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride all
Order allow,deny
Allow from all
<Files ~ '^.ht'>
Deny from all
</Files>
</Directory>

 

It seams that it works with no error but I receive always a blank page!! <_<

Share this post


Link to post
Share on other sites
I add those lines on the Apache directives form on my ISPconfig panel in the specific site.

And I received that error because the ISPconfig do not support that instruction.

 

Now I tried with this:

php_admin_flag register_long_arrays on
php_admin_flag register_globals on
php_admin_flag magic_quotes_gpc on
<Directory /var/www/web37/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride all
Order allow,deny
Allow from all
<Files ~ '^.ht'>
Deny from all
</Files>
</Directory>

 

It seams that it works with no error but I receive always a blank page!! <_<

 

Well, you wrote earlier, that in your httpd.conf AllowOverride is set to none, that's what's causing that blank page.

N

Share this post


Link to post
Share on other sites
Well, you wrote earlier, that in your httpd.conf AllowOverride is set to none, that's what's causing that blank page.

N

 

Yes, I know that should be set to "all", but I want to change it only for this site and not for the entire sites.. Is it possible??

Share this post


Link to post
Share on other sites

I just had the exact same problem with my install on ISPConfig. The solution for me was setting the include path through ini_set as follows

 

ini_set('include_path', '.:/usr/share/php5');

Share this post


Link to post
Share on other sites
I just had the exact same problem with my install on ISPConfig. The solution for me was setting the include path through ini_set as follows

 

ini_set('include_path', '.:/usr/share/php5');

 

Sorry... but where did you add this line? In the Apache Directives or did you create a file?

Share this post


Link to post
Share on other sites

Sorry I wasn't more clear.

 

As a quick test to see if this will do it, just copy this line:

 

ini_set('include_path', '.:/usr/share/php5');

 

into the top of index.php in the install folder. Then try again to run the install proccess and see if the page comes up. This line of code changes the include path for that page before it loads, however, after the script has executed, the include path goes back to what it is set as in the php.ini file on the server. So instead of adding that line on all of the pages in oscommerce, you can then set the include path through the apache directives with the line:

 

php_value include_path '.:/usr/share/php5'

Share this post


Link to post
Share on other sites
Hallo everyone,

After stucking all the day trying to install oscommerce (and reading your forum) ,I decided to post a new topic.

First of all sorry for my english...

I run Ispconfig under a suse installation hosted in a webfarm.

Following the installation step I created a new site with a new user and database.

I have downloaded the oscommerce file on my machine, unzipped and via FTP (binary mode) uploaded to the new site under the folder:

.../web18/web/

In the site configuration the safe php option is off

and I've added the following line in the form:

php_admin_flag register_globals on
php_admin_flag register_long_arrays on
php_admin_flag magic_quotes_gpc on
php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728
php_admin_flag session.autostart off
php_value register_long_arrays on
php_admin_flag register_globals on

 

But after that if I try to go to my installation page http://mysite.com/catalog/install/

I always get a blank page!! Whit no code inside... :( :(

 

Have anybody got some idea?!

Please I'm very desperate....

 

Thanks

/nox

 

If I read this right the address you should be using is http://www.yoursite.com/web18/web/catalog/install

Share this post


Link to post
Share on other sites
Sorry I wasn't more clear.

 

As a quick test to see if this will do it, just copy this line:

 

ini_set('include_path', '.:/usr/share/php5');

 

into the top of index.php in the install folder. Then try again to run the install proccess and see if the page comes up. This line of code changes the include path for that page before it loads, however, after the script has executed, the include path goes back to what it is set as in the php.ini file on the server. So instead of adding that line on all of the pages in oscommerce, you can then set the include path through the apache directives with the line:

 

php_value include_path '.:/usr/share/php5'

 

 

Thank you very much Jays_rhino!!

Now the installation works!

 

Cheers

Share this post


Link to post
Share on other sites

×