Jump to content
Sign in to follow this  
Roaddoctor

FedEx Direct 2.06 Support thread

Recommended Posts

I use the Free Shipping w/ Minimum Amount here and it works. It doesn't replace the FedEx choice, though. It just adds the free shipping option when they reach the threshold you set.

 

Thanks so much William. I just installed it and it works perfectly.

 

Thank you

Share this post


Link to post
Share on other sites

Has anyone been successfully using the ship separate check box?

Searched the thread to no avail.

 

I have everything but that functioning correctly.

I can check the box to my hearts content, but I never get multi-package totals.

This really screws me up as I have a number of oversize items, in addition to many items that can be shipped together.

 

For some reason it just does not seem to toggle the code.

Share this post


Link to post
Share on other sites

i am trying to install this on a new oscomerce site. the issue is that i offer 3 items that are bulky in size, so the dimensions are important in the quote. Is there an easy way to make that functional on this contribution?

I am looking for this also. This module calculates shipping quotes based solely on weight - not packaging dimensions. This is a huge problem because FedEx charges much more $$$ for bulky items. Anyone got any ideas/suggestions? Seems OSC is the only shopping cart app who's FedEx module doesn't allow for product dimensions?! (I checked Zen Cart, Magento, UberCart etc)

Edited by jasonabc

Share this post


Link to post
Share on other sites

Has anyone been successfully using the ship separate check box?

Searched the thread to no avail.

 

I have everything but that functioning correctly.

I can check the box to my hearts content, but I never get multi-package totals.

This really screws me up as I have a number of oversize items, in addition to many items that can be shipped together.

 

For some reason it just does not seem to toggle the code.

 

Mine acts the same. Any fixes for it?

Share this post


Link to post
Share on other sites

Just received a notice from FedEx that the FedEx Ship Manager API and the FedEx Ship Manager Direct solutions will be retired on May 31, 2012. Does this module use either of these two solutions from FedEx? Do I need to be worried about loosing the ability to ship via FedEx after 6/31/2012?


John Skurka

Share this post


Link to post
Share on other sites

Just received a notice from FedEx that the FedEx Ship Manager API and the FedEx Ship Manager Direct solutions will be retired on May 31, 2012. Does this module use either of these two solutions from FedEx? Do I need to be worried about loosing the ability to ship via FedEx after 6/31/2012?

 

I'm no expert, but I believe the answers to your questions are "No" and "Yes". There is a new Fedex WSDL available that to my knowledge has not yet been properly wrapped for OSC use. There is an OSC Fedex rate WSDL contribution, but it is only half baked. It has hard-coded values and isn't integrated with the checkout process.

 

I don't know to what degree the 3.0 OSC version utilizes the new Fedex WSDL. Even if it did, the task to migrate to 3.0 for most store owners would be large. Therefore, I think there is a real need to get a functioning Fedex WSDL addon available soon. Moreover, the WSDL is likely more accurate and has features that would benefit store owners and their customers, since Fedex has likely long ago abandoned this old Direct module.

 

It would be nice to see Fedex step up and deliver something, since they're the ones who stand to lose the most on 5/31/2012. Just my 2 cents...

Edited by robweidman

Share this post


Link to post
Share on other sites

I am having a huge problem.

 

I am new to oscommernce... so be kind...

 

I installed the module and installed it with the readme file.

 

Now when I go to checkout I get the following error

 

1054 - Unknown column 'products_ship_sep' in 'where clause'

 

select products_id, products_price, products_tax_class_id, products_weight from products where products_id = '43' and products_ship_sep = '0'

 

[TEP STOP]

 

Turning debug on and off does nothing. When I turn off the shipping module it works fine. WHat did I do wrong? Website is www.bestlexmarkdealer.com

 

feel free to open an account and place an order... I am just testing the system so I will not ship or bill...

Share this post


Link to post
Share on other sites

I'm not an expert but i would check your database. Does that column 'products_ship_sep' actually exist in products table? Maybe you missed something and need to run some SQL do add it.

 

Good luck

Share this post


Link to post
Share on other sites

Hi everyone,

 

When running the SQL in step 1 I get:

 

1142 - ALTER command denied to user 'tcci'@'localhost' for table 'products'

ALTER TABLE products ADD products_ship_sep BOOL NOT NULL DEFAULT 0

[TEP STOP]

 

Any suggestions?

 

-Tim

Edited by twincactus

Share this post


Link to post
Share on other sites

This is a caution for U.S.-based stores shipping to Canada. When your package arrives at Canadian customs by FedEx Ground, they assess an "entry fee" that is based on customs value. FedEx will bill you for this fee but it isn't included in the rate that they quote when your customer checks out. In my case, the shipping fee was about $20 which was paid by the customer and FedEx later billed me another $23 for the entry fee. According to the FedEx folks, this entry fee only applies to Ground service (perhaps it's already included in other classes of service).

 

I talked to the FexEx folks and they seemed not to care much about this issue so don't expect it to be fixed any time soon. The best solution, I think, is to simply eliminate Ground as one of the choices for international shipments. An alternate solution is to create a separate list of services for Canada (e.g. $this->canada_types) and modify the code to use it when the destination is Canada.


Don

Portland, OR USA

Share this post


Link to post
Share on other sites

Hey guys,

 

I am working an internship for a small sporting business and am trying to install this on their site. I have followed the instructions exactly and even double checked both categories.php files in file manager and they have been altered correctly, yet the shipping module will not show up to install.

 

The catalog/includes/modules/shipping/fedex1.php file does not exist in the file manager however, which is strange because when I completed step 1 of the installation guide, it said that my database was updated?!

 

I tried to install it a second time and received this error:

 

1060 - Duplicate column name 'products_ship_sep'

 

ALTER TABLE products ADD products_ship_sep BOOL NOT NULL DEFAULT 0

 

[TEP STOP]

I am very new to .php but I somewhat know what I'm doing. The site was set up by a previous host so I do not know how to access the database. I believe I just need to make a minor alteration to fix this problem but I don't know where to start.

 

All help is greatly appreciated, you can contact me through email as well at rfarya@hotmail.com

 

Thanks

Share this post


Link to post
Share on other sites

I am having an issue. I am using the 2.07 module, but when I get shipping rates it is telling me that the Express 1 day is cheaper than the 3 day super saver. screenshot.png

 

Any ideas?

 

Sorry I am a newbie,

David

Share this post


Link to post
Share on other sites

Hi guys, Just following up on my initial question. Anyone know what this error pertains too? is this on fedex's end? aka my accnt info may not be right? or something in my code thats going on.... really confused here..

 

 

thanks.

 

 

<intial question>

 

Installed module properly.

 

Got Error:

No meter number was obtained, check configuration. Error 9927 : Unable to validate account on FSS

 

anyone know what this means? or where i can look to find out what this means..

i can post up the debug informaiton but not sure if thats smart to do (personal i guess)

anyways if you're willing to help i can post it if required.

 

p.s i configured the shipping module with the correct fedex acnt number and other info.. (to the best of my knowledge)

 

I have the same issue, but can nowhere find a solution for this. Somebody any idea?

Share this post


Link to post
Share on other sites

I am having an issue. I am using the 2.07 module, but when I get shipping rates it is telling me that the Express 1 day is cheaper than the 3 day super saver. screenshot.png

 

Any ideas?

 

Sorry I am a newbie,

David

 

 

---------------------------------------------------------------------------------------------

 

Hi,

 

i am having the same issue. all my rates are high and not discounted. please help.

 

 

Thank you

Share this post


Link to post
Share on other sites

I'm about to install this Mod. Does anyone have the answer to "justdaveky's" problem? It looks like "Home Delivery" is one day. I've never seen a one-day home delivery. It's usually 5-7 days. Maybe FedEx' api got bad data from FedEx?

 

:(

 

Note:

Road Doctor was last Last Active: Jun 06 2010 09:36

 

Is he not supporting this mod now? He won't get many donations if there's no support ...

 

"Any donations to help offset our development cost is appreciated. See the readme.txt"
Edited by mb01a

Share this post


Link to post
Share on other sites

I am also having issues w/ Real Time for 2.3.1

 

it works, but only shows ONE day delivery...all the options don't show.

 

I didn't comment them out:

$this->domestic_types = array(
            '01' => 'Priority (by 10:30AM, later for rural)',
            '03' => '2 Day Air',
            '05' => 'Standard Overnight (by 3PM, later for rural)',
            '06' => 'First Overnight', 
            '20' => 'Express Saver (3 Day)',
            '90' => 'Home Delivery',
            '92' => 'Ground Service'
            );

     $this->international_types = array(
            '01' => 'International Priority (1-3 Days)',
            '03' => 'International Economy (4-5 Days)',
            '06' => 'International First',
            '90' => 'Home Delivery',
            '92' => 'Ground Service'
            );
   }

anyone know where the issue may be?


Web Developer, Firebug, and Notepad++ are powerful free tools for web design.

Share this post


Link to post
Share on other sites

Has anyone been successfully using the ship separate check box?

Searched the thread to no avail.

 

I have everything but that functioning correctly.

I can check the box to my hearts content, but I never get multi-package totals.

This really screws me up as I have a number of oversize items, in addition to many items that can be shipped together.

 

For some reason it just does not seem to toggle the code.

 

My shop is running v2.2 RC2 with FedEx module 2.07 and an 2.07.1.1 update. It acted the same way. What I did to fix this is go to the admin control panel for modules. Click shipping, then Federal Express. Edit the following to suit your needs:

 

Max. weight

 

Max. quantity of ship boxes

 

These values are NOT only for when the FedEx site is disabled, but are also used for the ship separately function. My values were set to low for some of my heavy items. I arbitrarily picked 10 for the number of boxes and 150 pounds. Now it seems to be working fine.

Edited by pchem

Share this post


Link to post
Share on other sites

My shop is running v2.2 RC2 with FedEx module 2.07 and an 2.07.1.1 update. It acted the same way. What I did to fix this is go to the admin control panel for modules. Click shipping, then Federal Express. Edit the following to suit your needs:

 

Max. weight

 

Max. quantity of ship boxes

 

These values are NOT only for when the FedEx site is disabled, but are also used for the ship separately function. My values were set to low for some of my heavy items. I arbitrarily picked 10 for the number of boxes and 150 pounds. Now it seems to be working fine.

 

Seems we have both resolved the issues today.

I have to thank you for the little poke.

 

In my case, it was a combination of missing adding one of the array values in the db query as described in 2.6 install (havent checked 2.7 instructions), and swapping the string positions as described in the 2.7.01 fix.

My error is mostly a result from having a heavily customized installation.

 

As pchem has noted, yes, you need to have max boxes and max weight on to have this work.

imc I selected 15 boxes, 200 lb max.

 

Hope this can help someone in the future.

Edited by minionsweb

Share this post


Link to post
Share on other sites

Contribution page: http://www.oscommerce.com/community/contributions,1462

 

VERSION 2.06

FEATURES ADDED

1. Added per product check box for "Ship Seperate" designation so that

FedEx will now generate item seperate quotes when desired (heavy items...)

2. Added ability to disable the module entirely by weight limit or box

quantity.

3. Products not checked "Ship Seperately" continue to be processed per your

stores existing configuration.

4. In Checkout_shipping, the customer now sees an item count and total weight,

along with an accurate quote for the entire order!

 

Includes Zone support (V 2.05)

 

Any donations to help offset our development cost is appreciated. See the readme.txt

 

Please post any feedback or issues or suggestions for further improvement.

 

Enjoy!!

 

-Dave

Roaddoctor

 

 

Hello Road Doc!

 

I just installed your FedEx add-on. May i ask a question?

 

I don't have all of my FedEx info inserted into the module yet, waiting to talk to our fedex rep. I'm getting the following error:

1054 - Unknown column 'products_ship_sep' in 'where clause'

select products_id, products_price, products_tax_class_id, products_weight from products where products_id = '49' and products_ship_sep = '0'

[TEP STOP]

 

It looks like it can't find a column in the database named products_ship_sep. In the file i downloaded there wans't a sql update.

 

Thank you for your help!

 

Aaron

Share this post


Link to post
Share on other sites

Hi All, I'm trying to install this mod with no luck... I can't even get Fedex to display in checkout_shipping?

 

I get no errors, no meter ID and nothing (even though the mod is enabled) shows in checkout shipping.

 

I know this is mod is near the end of life, however, I was hoping the community comes up with something that works with Fedex Automatic Labels (ultimately where I'm hoping to go with this) before spring 2012.

 

I have called fedex tech support, and confirmed my account number is good, but... They can't tell me if my site has made a request for a meter ID, only that one has not been issued. I have tried every combination of setting I found in the forum with no luck. It's running on my VPS with openSSL, I get nothing from the "debug mode" (prob cause its not talking with Fedex?), I tried 2.07.1 and .2 patches, I tried disabling my UPS and Can Post Mods to see if it would make any diference and still nothing.

 

I have copied by settings below... Hope someone can help!

 

Enable Fedex Shipping
True

Your Fedex Account Number
*********

Your Fedex Meter ID
NONE

cURL Path
NONE

Debug Mode
False

Weight Units
KGS

Which server to use
production

First line of street address
*** ******** Rd.

Second line of street address
Unit 5

City name
Pickering

State or Province name
ON

Postal code
******

Phone number
905-***-****

Drop off type
1

Display Transit Times
True

Fedex surcharge?
1.00

Show List Rates?
True

Insurance?
NONE

Residential surcharge?
2.5

Enable Envelope Rates?
True

Sort rates:
High to Low

Timeout in Seconds
NONE

Max. weight
NONE

Max. quantity of ship boxes
NONE

Tax Class
GST/HST Shipping

Tier 1 Discount Weight
NONE

Tier 1 Discount Percent
NONE

Tier 2 Discount Weight
NONE

Tier 2 Discount Percent
NONE

Sort Order
1

Shipping Zone
--none--

Share this post


Link to post
Share on other sites

Hi Scott,

 

When you installed your copy, did it have you add anything to the database? My install seems to be looking for a few missing columns in that database.

 

Thank you!

 

Hi All, I'm trying to install this mod with no luck... I can't even get Fedex to display in checkout_shipping?

 

I get no errors, no meter ID and nothing (even though the mod is enabled) shows in checkout shipping.

 

I know this is mod is near the end of life, however, I was hoping the community comes up with something that works with Fedex Automatic Labels (ultimately where I'm hoping to go with this) before spring 2012.

 

I have called fedex tech support, and confirmed my account number is good, but... They can't tell me if my site has made a request for a meter ID, only that one has not been issued. I have tried every combination of setting I found in the forum with no luck. It's running on my VPS with openSSL, I get nothing from the "debug mode" (prob cause its not talking with Fedex?), I tried 2.07.1 and .2 patches, I tried disabling my UPS and Can Post Mods to see if it would make any diference and still nothing.

 

I have copied by settings below... Hope someone can help!

 

Enable Fedex Shipping
True

Your Fedex Account Number
*********

Your Fedex Meter ID
NONE

cURL Path
NONE

Debug Mode
False

Weight Units
KGS

Which server to use
production

First line of street address
*** ******** Rd.

Second line of street address
Unit 5

City name
Pickering

State or Province name
ON

Postal code
******

Phone number
905-***-****

Drop off type
1

Display Transit Times
True

Fedex surcharge?
1.00

Show List Rates?
True

Insurance?
NONE

Residential surcharge?
2.5

Enable Envelope Rates?
True

Sort rates:
High to Low

Timeout in Seconds
NONE

Max. weight
NONE

Max. quantity of ship boxes
NONE

Tax Class
GST/HST Shipping

Tier 1 Discount Weight
NONE

Tier 1 Discount Percent
NONE

Tier 2 Discount Weight
NONE

Tier 2 Discount Percent
NONE

Sort Order
1

Shipping Zone
--none--

Share this post


Link to post
Share on other sites

Hi Mossman, thank you for your quick reply...

 

When you installed your copy, did it have you add anything to the database? My install seems to be looking for a few missing columns in that database

 

Yes the database us updated successfully.

 

You may have missed step one in the readme?

 

1. Database

 

Upload file fedex1.sql.php to the /catalog folder of your oscommerce website.

Enter in your browser adress: http://"Your host"/fedex1.sql.php end press "Enter";

Delete the file fedex1.sql.php

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×