Jump to content
Latest News: (loading..)
Sign in to follow this  
Roaddoctor

FedEx Direct 2.06 Support thread

Recommended Posts

Hi Irina

Have you figured out anything on this? We are also getting rate quotes for Canada that are much less than the actual shipping cost.

bopp

 

what I figured out is that if you get a quote from the FedEx site without logging in it doesn't apply any account discounts or whatever so the quote on the fedex site if not logged in is higher. If I log in to my account on the fedex website and then get the quote, it is exactly the same as the OSC quote. So problem solved for me and the customer.

Share this post


Link to post
Share on other sites

This module just stopped working all of a sudden. It's been working for over a year. Nothing has changed on the server end.

 

I get the error: "No data returned from Fedex, perhaps the Fedex site is down"

 

I called fedex and everything looks good on their end. I checked all of the contrib files and they are current/unchanged. (and did a 'diff' on all files.)

 

Any ideas?

 

Please help!

Share this post


Link to post
Share on other sites
Hi Irina

Have you figured out anything on this? We are also getting rate quotes for Canada that are much less than the actual shipping cost.

bopp

 

 

bopper-

 

If you figure this out please let me know as well, as I have more customers that are coming from Canada, and it seems like the import fee or a fee for insurance is not being added into the quote in OSC, and that is the difference.

 

Evan

Edited by dsolutions

Share this post


Link to post
Share on other sites

I'm not sure why my codebox didn't work.....sorry for the horrifically long post.


~man....I'm such a noob.

Share this post


Link to post
Share on other sites

Sorry to bother everyone but I have tried to use this module but I do not think I downloaded the complete package but pieces of it.

 

Where in the world - a direct link please - do you download a complete working package for this module?

 

Fedex Real Time Quotes

 

I have been all over this page: http://addons.oscommerce.com/info/1462

 

But it all seems like pieces and I am looking for the module that works - I could not even figure out where to begin?

 

Please anyone?

 

Thanks

Share this post


Link to post
Share on other sites

April 21, 2009

 

I got this working today. I'm no guru, just thought I'd share my installation experience.

 

1. You need a Fedex account. Their website sucks nads, so you may have to call them to get it done. (Seriously, their website is the most confusing, unhelpful website I've ever used). In certain places you will see that you need Meter ID, but don't worry. It gets automatically assigned once everything else is working. (You'll see if magically appear in your admin when all is done and you've tested successfully).

 

2. In case it's not obvious, everything you need is on this page: http://www.oscommerce.com/community/contributions,1462.

 

3. I started with 2.07, then also grabbed the download for 2.07.2. The 2.07 file contains everything you need. The patch only contains one file: fedex1.php. The 2.07.2 patch also includes the 2.07.1 patch, so read it up on both of those to see if you need them.

 

4. Unzipped the 2.07 file into my directory structure. I didn't call my root directory "catalog" so it took some fudging to get the files in their right places. Thankfully there isn't many. And the zip wants to start of putting stuff in a directory called "fedex_direct_2.07". Not too helpful.

 

5. I took the fedex1.php file from the 2.07.2 patch and copied it over the original. It's in (home)/includes/modules/shipping/fedex1.php.

 

6. I removed the other shipping modules in my admin that I had tooled around with.

 

7. At this point I during my first run, I originally ran the DB change file and installed the add-on and got errors. That's when I discovered the section in the readme file that had additional instructions. Not the original instructions, but instructions written by Richard Cranium 7 Mar 2009 on that page. I went and made the changes listed in Steps 2 and 3 (about 2/3 down through his readme file). (Also, there are a couple of notes just before Step 1 to look at) There's a pile of crap there that has you manually editing the categories file and one other. For some reason I made the changes exactly as he specified and still somehow missed a bracket at the end of:

 

'products_ship_sep' => '',

'manufacturers_id' => '';

 

Put one in ) just before that last semi-colon.

 

8. The database changes are made by a file fedex1.sql.php. Put it somewhere on your server, perhaps the home directory, and run it manually using your browser. Something like www.mywonderfulsite.com/fedex1.sql.php. Remove the file when you're done.

 

9. Install the add-on using the admin. Go through the config items, they should be pretty straight forward. Other than your Fedex account # and your address, the rest should be pretty close to default. There are some changes to make if you're a Canadian store, as I am.

 

10. When it's working in your store, go to the Fedex site and put in the same info for a quote and make sure the prices match your store.

 

Final note: you should probably read the entire readme file if you have the time. I still haven't but I should.

 

Hope that helps somebody.

Share this post


Link to post
Share on other sites

Style Sheet?

 

I finally got this working today.

 

Works great.

 

However, when you hover over the FedEx shipping choices you can not read the text because of the colors.

 

I have looked in the osCommerce standard style sheet and can not find anything to change this color.

 

I have looked in the fexdex1.php and I could not find where to change the colors.

 

Does anyone know where I change this behavior or colors at?

 

http://www.fesup-usa.com/shopping/

 

You can do a guest quick check out and see how when you hover over the fedex choices you can not read them.

 

Thanks

Share this post


Link to post
Share on other sites

After a few hours of searching I found it to be in the catalog/stylesheet.css

 

.moduleRow { }
.moduleRowOver { background-color: #404040; cursor: pointer; cursor: hand; }
.moduleRowSelected { background-color: #932929; }

 

Issue fixed.

 

 

Style Sheet?

 

I finally got this working today.

 

Works great.

 

However, when you hover over the FedEx shipping choices you can not read the text because of the colors.

 

I have looked in the osCommerce standard style sheet and can not find anything to change this color.

 

I have looked in the fexdex1.php and I could not find where to change the colors.

 

Does anyone know where I change this behavior or colors at?

 

http://www.fesup-usa.com/shopping/

 

You can do a guest quick check out and see how when you hover over the fedex choices you can not read them.

 

Thanks

Share this post


Link to post
Share on other sites
This module just stopped working all of a sudden. It's been working for over a year. Nothing has changed on the server end.

 

I get the error: "No data returned from Fedex, perhaps the Fedex site is down"

 

I called fedex and everything looks good on their end. I checked all of the contrib files and they are current/unchanged. (and did a 'diff' on all files.)

 

Any ideas?

 

Please help!

 

I have experienced the same problem on two of my sites. First site started earlier this week and my second site started doing this yesterday. Has this happened to anyone else and has someone found a solution or the problem causing this?

Share this post


Link to post
Share on other sites

I have installed the contrib, and it seems to work correctly.

 

The only thing is that I only get quoted for Ground. I have checked the array for service type requested and they are all enabled. (not commented).

 

Im sure i'm not the only one that experienced that.

Share this post


Link to post
Share on other sites
I have installed the contrib, and it seems to work correctly.

 

The only thing is that I only get quoted for Ground. I have checked the array for service type requested and they are all enabled. (not commented).

 

Im sure i'm not the only one that experienced that.

 

Ok, I found the solution, I need to turn SHOW LIST RATES to FALSE.

Share this post


Link to post
Share on other sites
what I figured out is that if you get a quote from the FedEx site without logging in it doesn't apply any account discounts or whatever so the quote on the fedex site if not logged in is higher. If I log in to my account on the fedex website and then get the quote, it is exactly the same as the OSC quote. So problem solved for me and the customer.

What do you mean if you log into your fedex account? In OSC code? where in the code do you log in so that rates are discounted?

 

thank you

Share this post


Link to post
Share on other sites

Hia All,

 

I've been using this mod which came pre-installed (I think)with my installation of CRE Loaded.

 

However it seems like I need to apply an upgrade, which I think I did successfully, but I'm running into difficulty with the modification of the admin/categories.php file. The file is obviously very similar between the OSC and CRE versions, but different enough that I'm not able to translate the instructions and get it working in my CRE store.

 

Can anyone point me to a thread or some documentation that may help. Short of that, is there anyone who can assist me in getting this working for me in CRE? The specific functionality I'm interested in is the ability to specify ship separately.

 

Thanks All,

Chris Hackett

 

P.S. I know this is an OSC support forum / thread, and if I had it to do over again, I would probably NOT use CRE. But alas, my bed is made, and now I'm tossing and turning in it.

Share this post


Link to post
Share on other sites

I'm getting this error after installing the Contribution:

 

,"Invalid Recipient postal code format for specified country."99,""

 

I've seen mentions of this error, but I haven't seen any posts about how to resolve it.

 

Can anyone help?

 

I haven't modified the Contribution.

 

dlc

Share this post


Link to post
Share on other sites

Is it possible to have it toggle so I can switch between getting the discounted rate versus the normal rate on fedex's website with no account number?

Share this post


Link to post
Share on other sites

Is it possible to have it toggle so I can switch between getting the discounted rate versus the normal rate on fedex's website with no account number?

 

find

 

Show List Rates?

True

False

 

in the module settings


-Dave

Share this post


Link to post
Share on other sites

HI all - changing the subject.

 

I had this contrib working perfectly, the install and everything about it like clock work (worked fine for one month). Then I tried to add flat rate shipping option/module (the one included with OSC) in admin so that I could have flat rate OR the fed ex options to choose from at checkout. I set the flat rate to zone US and $0.00 for free shipping. I did nothing else, only used admin.

 

Now the fed Ex module does not work at all, it just does not show up, the only option I get at checkout is the flat rate free shipping, its stuck on that even after i uninstalled the flat rate completely, and re-installed the Fed Ex, its still stuck on one flat rate free shipping.

 

Any ideas?

 

Jac

Share this post


Link to post
Share on other sites

Could someone please point me in the right direction on what to modify to hide the display of total shipping weight at checkout to the customer. I've been looking around in checkout_shipping.php and fedex1.php but i'm not finding it. Anyone know?

Share this post


Link to post
Share on other sites

Could someone please point me in the right direction on what to modify to hide the display of total shipping weight at checkout to the customer. I've been looking around in checkout_shipping.php and fedex1.php but i'm not finding it. Anyone know?

 

nevermind, figured it out.

Edited by chris3g

Share this post


Link to post
Share on other sites

I have an account with FedEx and everything seems to work, but the rates that my customers get when checking out are lower than my discounted rates.

 

I have tried all different setting, if I get rates for Canada right then rates for US start to mess up, any input from you experts will be appreciated, Thanks

Edited by SpiceUp

Share this post


Link to post
Share on other sites

I have installed the 2.0.7 module and it works perfectly for domestic rates in USA. However, when the address is international, I cannot get a quote. Always get the "No Rates Returned, :" no matter which country.

Any advice is greatly appreciated.

Share this post


Link to post
Share on other sites

Hello,

 

I don't have any meter Id.

 

Its getting an error "No meter number was obtained, check configuration. Error 5012 : Account number not in database"

 

The debug message is :

Data sent to Fedex for Meter: 0,"211"10,"282453525"4003,"Sanjoy Ganguly"4007,"BaxterGolfArt.com"4008,"41995 Boardwalk, Suite L1"4011,"Palm Desert"4012,"CA"4013,"92211"4014,"US"4015,"1360850190"99,""

Data returned from Fedex for Meter: 0,"311"2,"5012"3,"Account number not in database"99,""

 

Could anyone please tell me where the problem lies!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×