Jump to content
chris23

[CONTRIBUTION] Subcategory textboxes

Recommended Posts

Hi,

 

Good pick up. I've tried this with linked products and get the same result. To fix this, edit products_info.php

 

*cut*

 

Thanks for the post

 

 

Regards,

 

Chris

Hi Chris, I have found something else... When you have a category, with none description, but with a copied (linked) product, it shows the description of another categorie. I don't think their is a solution for, because your watching a individual product.

Share this post


Link to post
Share on other sites
Hi Chris, I have found something else... When you have a category, with none description, but with a copied (linked) product, it shows the description of another categorie. I don't think their is a solution for, because your watching a individual product.

 

I'll have a look at this and see if there's a way around it


Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites

I am trying to relocate all the textboxes to the bottom of the page. I have gotten all category pages to relocate the textboxes to the bottom by changing the location in index.php, however subcategory pages are still appearing above the product list, and I want it to be below.

 

I have tried moving the script in product_info.php to right before the

</table></form></td>

<!-- body_text_eof //-->

but that doesn't seem to work either.

 

Is there a different file I need to edit to get subcategory boxes below the product list?

 

Thanks for the help!

Justin

Share this post


Link to post
Share on other sites
I have tried moving the script in product_info.php to right before the

</table></form></td>

<!-- body_text_eof //-->

but that doesn't seem to work either.

 

Is there a different file I need to edit to get subcategory boxes below the product list?

 

You're in the right file - product_info.php. Without seeing your copy of this file, I can't tell you exactly where to put the include code but a bit of trial and error will get you there!

 

Chris


Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for this nice contribution!

Everything works until i try to save the text when i get a blank page. The text is saved but i must hit back 2 times to enter another textbox. Also after i installed this contrib when I upload a category or edit a product, all I get is a blank page. When I hit BACK, everything is fine. The category was added and the changes are saved. Now, when I try to change anything, whether it's a module, or a description, or making something true or false, I always get that blank page.

 

Please help me with this problem if you can.

Share this post


Link to post
Share on other sites

Hi,

 

I have tried several times to install this contribution - but I can't make it work :(

 

I keep getting this info:

 

1146 - Table 'Thalbit_oscommerce_st0.extra_cat_info' doesn't exist

 

select categories_description.categories_id, categories_name from categories left join categories_description using (categories_id) left join extra_cat_info on extra_cat_info.categories_id = categories_description.categories_id where extra_cat_info.categories_id is null and parent_id !=0 and categories_description.language_id=4 order by categories_name

 

[TEP STOP]

 

and I have no idea what it means (I'm pretty new with this oscommerce-thing....and I have no SQL or programming skills)

I have asked my hosting company if they could check the SQL and make sure it has been added according to the installation file - they confirmed, that the query has been added.

 

What am I doing wrong - or doesn't this contribution work with my webshop?

Have I missed something during the installation or should I just give up and find another solution - even though I belive this is the one I'm looking for?

 

I'm looking forward for some help and if I'm lucky the answer to my problem :blink:

 

Thanks in advance :rolleyes:

 

 

Best regards

Christine


THE PROBLEM WITH WOMEN IS THAT THEY GET ALL WORRIED AND CRAZY ABOUT NOTHING

AND THEN THEY MARRY HIM

Share this post


Link to post
Share on other sites

Hi,

 

I am experiencing some problems with this contribution.

 

I have installed and all seems to work well. ( I get no error messages )

 

I can change the four configuration values under Configuration section within the admin.

 

However when I navigate to Catalog -> Subcategory textbox I get a screen that does not enable me to add a text box.

 

I have included a screen shot below.

 

admin_problem.gif

 

When I click on the insert button, the same screen returns with the insert button not appearing.

 

Any help much appreciated.

 

Regards & thanks,

 

wolfmann.

Share this post


Link to post
Share on other sites

I can't see the images of the category!?

I think is that script:

<?php
//  category textbox mod
// first query - get current category id
if (DISPLAY_EXTRA_CATEGORIES == 'true'){
$text_query = tep_db_query("select c.categories_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");
$text = tep_db_fetch_array($text_query);
// now get textbox description for this category (if set) and display
if(isset($text['categories_id'])){
$query2 = tep_db_query("select categories_description from " . TABLE_EXTRA_CATEGORIES . " where ". TABLE_EXTRA_CATEGORIES.".categories_id=". $text['categories_id'] . " and ". TABLE_EXTRA_CATEGORIES . ".language_id = '" . (int)$languages_id . "'");
while($category_info_text = tep_db_fetch_array($query2)){
if(!empty($category_info_text['categories_description'])){ // prevent output where description not set for particular language
   echo ("<tr><td><div class=\"cat_info_box\">".$category_info_text['categories_description']."</div></td></tr>");
  }
}
 }
}
 ?>

Who can help me?

Share this post


Link to post
Share on other sites

Hello,

 

I have a template, and I tried to install this add-ons. But had some problems with the installiation.

 

In the code of index.php there isn't this part:

 

<tr>
	<td><?php include(DIR_WS_MODULES . FILENAME_PRODUCT_LISTING); ?></td>
  </tr>

 

just

 

<?php include(DIR_WS_MODULES . FILENAME_PRODUCT_LISTING); ?>

 

I inserted the code

<?php include(DIR_WS_MODULES . FILENAME_CAT_TEXTBOX_MODULE); // added for Subcategory textboxes ?>

 

after the ?> and there are some error messages:

 

Warning: include(includes/modules/products_extra_category.php) [function.include]: failed to open stream: No such file or directory in /web/XXX/XXX/probabolt/index.php on line 342

Warning: include() [function.include]: Failed opening 'includes/modules/products_extra_category.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /web/XXX/XXX/probabolt/index.php on line 342

 

What is the problem, can you help me?

 

Thanks.

Edited by peeter

Share this post


Link to post
Share on other sites

Hello,

 

I use this contribution for a long time now. Very useful!

On several places in my site I use FCKEDITOR for html editing.

A lot of time I have spent to implement this editor also within this contribution.

I failed! The problem is maybe the use of infobox.

Who can help me in the right direction.

 

Thanks,

 

Jan

Edited by janwalhof

Share this post


Link to post
Share on other sites

i have installed the subcategory textbox on my webshop..

 

It works, but the layout changes!! the whole body (including the products) and the subcategory tekst (-; moves below my left collumn.

please have a look at http://www.merchandisingconcepts.nl/websho...dex.php?cPath=1

 

this only happens if I type something in the tekstbox... if i leave it empty in the contol panel, the layout doesn't change.

 

I have tried several things.. pasting the codes on different places in the index file etc... didnt work

 

The width of the box might be the problem.. maybe this can press the whole body to the botton of the page???? Could this be the problem and does someone have a solution?

 

please help me!!!

Share this post


Link to post
Share on other sites
If I select Subcategory textbox, I see

 

HEADING_TITLE

 

TABLE_HEADING_CATEGORY_ID TABLE_HEADING_CATEGORY_NAME TABLE_HEADING_CATEGORY_DESCRIPTIONDISPLAY_TRUNC_CHAR TABLE_HEADING_ACTION

 

TEXT_PAGING_FORMAT

 

Hi, I am not sure if this contribution is still being supported, but I have it all running OK, but I do have the same problem that Bruce had all those years ago! I have made sure I have copied catalog/admin/includes/languages/english/products_extra_category.php across, but the error is still present. However, as I mention, it still works OK, but is a little worrying.

 

Does this contribution work OK with any SEO and Meta Tags add-ons installed? Also, I wish to have the same feature for Manufacturers, and have found http://addons.oscommerce.com/info/6490, which I hope will do the trick.

 

Hope there is still some help out there for this very, very useful SEO friendly add-on.

 

Jonathan

Share this post


Link to post
Share on other sites

Thanks for this contribution. I have installed and it works very well.

 

I have installed several contributions to a non-standard oscommerce template. I am very much a beginner with PHP.

 

I wonder if this contribution could have caused a blank space to appear at the top of my header. I have had a poke around in header.php and the glitch doesn't seem to stem from there. The blank space/row appears on all of the site pages.

 

Regards

Edited by appstyle

Share this post


Link to post
Share on other sites

thanks for this contribution, it works well with subcategories , but when i want a text in main categories: no problem in admin, it works but it doesn't work in catalog.

thanks for your help.

Share this post


Link to post
Share on other sites

I have this app installed currently. There is no problems with adding, viewing or changing any of the subcategory text. I am however having a problem getting it to read any HTML code that I put in the file.

 

 

I copy and pasted directly from dreamweaver into the textbox, but when I submit the file it removes all my code and makes it a block of text. I have tried just about everything I could think of to get it working but to no avail. suggestions?

Share this post


Link to post
Share on other sites

Hi all, I am having trouble at the first hurdle.

 

How do you run an sql file???

I have no idea what phpmyadmin is btw (keep hearing this).

 

Ok I know it must sound stupid to you guys but i'm not very computer literate. I have managed quite a few add-ons so far and i am sure i will have no problems uploading and amending the listed php files but the sql thing has me confused, can't seem to find any info on what to do.

 

thanks in advance

Share this post


Link to post
Share on other sites

Hi all!

I just installed this contribution and for some reason the table heading text in admin is table_heading_category_id, table_head_category_name and table_heading_action. The only one that is right is the Contents [first 150 chars only]...even the headings in the text area are all table headings. I have dropped and reran the sql and nothing changed. Can someone steer me in the right direction for this please?

Thanks!

Share this post


Link to post
Share on other sites

Hi all!

I just installed this contribution and for some reason the table heading text in admin is table_heading_category_id, table_head_category_name and table_heading_action. The only one that is right is the Contents [first 150 chars only]...even the headings in the text area are all table headings. I have dropped and reran the sql and nothing changed. Can someone steer me in the right direction for this please?

Thanks!

I have the excact same problem!

I did the complete install again, reran the SQL and uploaded all the files again, but still no luck.

Can anybody help?

 

btw the contribution works just fine otherwise.

Share this post


Link to post
Share on other sites

I have the excact same problem!

I did the complete install again, reran the SQL and uploaded all the files again, but still no luck.

Can anybody help?

 

btw the contribution works just fine otherwise.

 

I just found out that the language files in 2.0.4. do not match the php files!

If you use an old language file (I used a 1.2 version) all the table heading text will work.

Share this post


Link to post
Share on other sites

I'm trying to add some php code in the subcategory textbox to pull the latest posts off my wordpress blog that deal with that particular category. For some reason I am unable to add php directly to the box - only html.

 

Does anyone have thoughts on this? I can't seem to figure out why, but I'm probably missing something silly.

Share this post


Link to post
Share on other sites

Hi All,

 

I have managed to install this mod but the textbox does not appear in the right place and expands all of my product listing to over the site width. Is there a quick fix to enable the textbox to appear in the right location/column?

Share this post


Link to post
Share on other sites

Hi All,

 

I have managed to install this mod but the textbox does not appear in the right place and expands all of my product listing to over the site width. Is there a quick fix to enable the textbox to appear in the right location/column?

 

 

FYI i have tried to move this line of code in the index.php file to see if i can position the box in another location but no joy?

<?php include(DIR_WS_MODULES . FILENAME_CAT_TEXTBOX_MODULE); // added for Subcategory textboxes ?>

 

 

Can anyone help please?

Share this post


Link to post
Share on other sites

Hi all,

 

I have installed this contribution into my shops, it is just what I needed.

On my site, I use the tiny_mce html editor for several fields.

Now I'm not good in the php field and despite several hours of trying, no luck so far.

 

Is anybody who integrated tiny_mce into this contrib willing to share code, or is there anyone who will tell me what to put where in products_extra_category.php?

 

Thanks in advance!

 

Regards,

 

Wiljo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×