Jump to content

Archived

This topic is now archived and is closed to further replies.

jpweber

How to install SSL on OSC: A Simple 1-2-3 Instruction

Recommended Posts

Also I have noticed everything on the Admin side appears just fine, padlock and https without any issues, it seems to only be on the site itself, not the admin pages

Share this post


Link to post
Share on other sites

My osCommerce store is wrapped within Joomla. When I access the store using a direct link (http://socaltecdivers.com/catalog) and go to checkout, the address line reverts to https and the padlock shows up in the lower right corner of the browser just like it should...

 

However, when I access it through the Joomla wrapper (http://socaltecdivers.com/index.php?option=com_wrapper&Itemid=163), the lock never appears.

 

So my dumb question is... Am I still secure? If I am, how do I reassure customers that their info is protected. If not, what are my options? Thanks in advance.

 

Bruce

Share this post


Link to post
Share on other sites
My osCommerce store is wrapped within Joomla. When I access the store using a direct link (http://socaltecdivers.com/catalog) and go to checkout, the address line reverts to https and the padlock shows up in the lower right corner of the browser just like it should...

 

However, when I access it through the Joomla wrapper (http://socaltecdivers.com/index.php?option=com_wrapper&Itemid=163), the lock never appears.

 

So my dumb question is... Am I still secure? If I am, how do I reassure customers that their info is protected. If not, what are my options? Thanks in advance.

 

Bruce

You need to ask this to the relevant forum where you got your code from, as this is oscommerce only.

Share this post


Link to post
Share on other sites
You need to ask this to the relevant forum where you got your code from, as this is oscommerce only.

 

 

This was the thread that I pulled the SSL install info from. Figured someone out there had a similar set-up. I'll try the Joomla forum. Thanks.

 

Bruce

Share this post


Link to post
Share on other sites

Hi!

 

Can you help me, please, with some advice?

 

i have shared ssl. have updeted files as find out that in forum. now i have some errors:

 

tihs one i got when going into admin:

Fatal error: Call to undefined function: net_connect() in /home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/admin/includes/functions/database.php on line 19

 

this one i got when trying to open page:

Parse error: parse error, unexpected T_STRING in /home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/includes/configure.php on line 16

 

now i'm in alley

 

thanks

 

erx

Share this post


Link to post
Share on other sites

Newbie having trouble here- I have read this entire thread and various other resources to get my SSL to work and nothing. So I am hoping this post will solve my 12 day headache.

My clients website is http://www.pullersdirect.com. I used Cpanel-4 on my server to create a key, CSR and CRT. It created a new root level directory (/ssl) and the CRT is saved at (/ssl/certs/pullersdirect.com.crt).

My catalog is installed two level s below root (/public_html/osc/).

 

I modified the /osc/includes/config.php file to the following:

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.pullersdirect.com/'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://pullersdirect.com'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', '.pullersdirect.com');
 define('HTTPS_COOKIE_DOMAIN', '.pullersdirect.com');
 define('HTTP_COOKIE_PATH', '/osc/');
 define('HTTPS_COOKIE_PATH', '/osc/');
 define('DIR_WS_HTTP_CATALOG', '/osc/');
 define('DIR_WS_HTTPS_CATALOG', '/osc/');

 

I modified the /osc/admin/includes/config.php file to the following:

// define our webserver variables
// FS = Filesystem (physical)
// WS = Webserver (virtual)
 define('HTTP_SERVER', 'https://www.pullersdirect.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'https://pullersdirect.com');
 define('HTTPS_CATALOG_SERVER', 'https://pullersdirect.com');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)
 define('DIR_WS_ADMIN', '/admin/');

 

When I upload the config files I was not able to log in, both at the admin level and as a catalog user. The foolowing is the error code:

You tried to access the address [url="https://pullersdirect.com/osc/login.php?osCsid=7b40880d8375ed12ff2e9d840a671334"]https://pullersdirect.com/osc/login.php?osC...f2e9d840a671334[/url], which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page.
Secure connection: fatal error (40)
Failed to connect to server. 

 

As a guest when I go to checkout - I get the following error:

You tried to access the address [url="https://pullersdirect.com/osc/checkout_shipping.php?osCsid=7b40880d8375ed12ff2e9d840a671334"]https://pullersdirect.com/osc/checkout_ship...f2e9d840a671334[/url], which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page.
Secure connection: fatal error (40)
Failed to connect to server.

 

Any help would be appreciated- I know it is something I am just missing. Thank you to all that have helped in this thread.

Share this post


Link to post
Share on other sites

a thing is, i have shared ssl

 

includes/configure.php i have like this

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.wizardartworks.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://streamline.xssl.net/wizardartworks.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', 'true');//secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.wizardartworks.co.uk');

define('HTTPS_COOKIE_DOMAIN', 'https://streamline.xssl.net/wizardartworks.co.uk');

define('HTTP_COOKIE_PATH', 'wizardartworks.co.uk');

define('HTTPS_COOKIE_PATH', 'wizardartworks.co.uk');

define('DIR_WS_HTTP_CATALOG', 'wizardartworks.co.uk');

define('DIR_WS_HTTPS_CATALOG', 'wizardartworks.co.uk');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');

define('DIR_FS_DOCUMENT_ROOT', '/home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/');

define('DIR_FS_CATALOG', '/home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'musql11.streamline.net'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '******');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', 'wizardartworks_co_uk_-_oscommerce');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

 

 

 

 

admin/includes/configure.php like this

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.wizardartworks.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.wizardartworks.co.uk');

define('HTTPS_CATALOG_SERVER', 'https://streamline.xssl.net/wizardartworks.co.uk');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/'); // absolute pate required

define('DIR_WS_CATALOG', '/'); // absolute path required

define('DIR_FS_CATALOG', '/home/fhlinux204/w/wizardartworks.co.uk/user/htdocs/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'mysql11.streamline.net'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '******');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', 'wizardartworks_co_uk_-_oscommerce');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

 

define('DIR_WS_ADMIN', '/admin/ -- /admin/ have changed to /store/ all the same

 

now after log in into admin i got

 

1046 - No database selected

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

can't open page there is only -- Unable to connect to database server!

 

i tryied a lot versions folloved by forum, all the same.

 

any help will be appreciate

 

erx

Share this post


Link to post
Share on other sites

Hi everyone,

 

I have been knocking my head on my desk for months with this problem that only few people seem to have. Maybe here someone could help.

 

I have a self issued geotrust certificate which works fine for some customers and myself. BUT others have their cart content lost when they click to checkout.

 

As soon as a secured page opens the content is lost.

 

Browser related??? Apparently internet explorer 6 has a patch for this problem, but haven't digged in that one yet.

 

I have given up and removed the secured checkout from my store but if you have any help or ideas it would be appreciated.

 

 

Thanks,

 

Pat

Share this post


Link to post
Share on other sites

I Just moved my oscommerce site from olm.net hosting to networksolutions.com hosting and have had a Site Safe SSL Certificate Installed by Network Solutions.

 

I am getting an error on initial page (can anybody diagnose?) and i am unable to reach any of my secure pages (Internet Explorer cannot display the webpage), and admin panel states it is un protected.

 

I AM DESPARATE LOSING BUSINESS AS I TYPE.

 

site www.msrparts.com

the security certificate is in msrparts.com so i realize that some things in my config file may need to be changed, but i am wondering if the error on the initial page might need to be dealt with first.

 

Thank you greatly.

Sitara

Share this post


Link to post
Share on other sites

Oh please help me. I'm hoping for an easy fix. Here's my problem. . .

 

I read and followed the initial SSL certificate set-up instructions. I got a certificate from Godaddy and had my host install it. I changed the code in my config files as instructed. After all that (and that was a lot of work for this newbie), my site does not appear to be secure, http instead of https (even on login and checkout pages), and no lock symbol.

 

What did I do wrong? Am I missing a step. Find my site at www.righteousmoves.com

 

Thanks in advance. :)

 

Crystal

Share this post


Link to post
Share on other sites
Oh please help me. I'm hoping for an easy fix. Here's my problem. . .

 

I read and followed the initial SSL certificate set-up instructions. I got a certificate from Godaddy and had my host install it. I changed the code in my config files as instructed. After all that (and that was a lot of work for this newbie), my site does not appear to be secure, http instead of https (even on login and checkout pages), and no lock symbol.

 

What did I do wrong? Am I missing a step. Find my site at www.righteousmoves.com

 

Thanks in advance. :)

 

Crystal

make sure your catalog\includes\configure.php files has the ENABLE_SSL line set to true and the HTTPS_SERVER is also populated with the secure server url.

 

If you already have done these changes the next thing is to ensure the application_top.php identifies the secure connection. This is server dependent.

 

// set the type of request (secure or not)

$request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

Share this post


Link to post
Share on other sites
make sure your catalog\includes\configure.php files has the ENABLE_SSL line set to true and the HTTPS_SERVER is also populated with the secure server url.

 

If you already have done these changes the next thing is to ensure the application_top.php identifies the secure connection. This is server dependent.

 

// set the type of request (secure or not)

$request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

 

Thanks so much for the tip. However, I asked my host company for some help and they force redirected my http site to https. So, it covers the entire site now. Good for customers, but is that bad for search engines? This is all so complex!

 

Crystal

Share this post


Link to post
Share on other sites
GoDaddy is a really strange host. Link please?

Hi jpweber,

Thanks for all your support in this thread. I hope maybe, you can give me a help.

I have just installed a private SSL certificate, so far everything seems to work all right. However I am facing just one problem.

I am getting the following message: Warning: I am able to write to the configuration file: /public_html/catalog/includes/configure.php.

This is a potential security risk - please set the right user permissions on this file.

The configure.php files are set to 644, I tried 755 and 777 as well, but none worked out the problem.

Do you have any idea what should I do to fix it?

Any help is very much appreciated.

Kind regards,

BrazilianLink

Share this post


Link to post
Share on other sites
Hi jpweber,

Thanks for all your support in this thread. I hope maybe, you can give me a help.

I have just installed a private SSL certificate, so far everything seems to work all right. However I am facing just one problem.

I am getting the following message: Warning: I am able to write to the configuration file: /public_html/catalog/includes/configure.php.

This is a potential security risk - please set the right user permissions on this file.

The configure.php files are set to 644, I tried 755 and 777 as well, but none worked out the problem.

Do you have any idea what should I do to fix it?

Any help is very much appreciated.

Kind regards,

BrazilianLink

 

Brazil: Setting your catalog/includes/configure.php file permissions to CHMOD 777 or 755 (depending on your host) should solve this problem. If it doesn't, contact your host and let them know. Sorry for the delay in responding ... I've been in and out of town on business, and then the holidays. Let me know if things work out.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Denis, this is a complex error, and your page might very well be viewed properly in other browsers. Are you using Opera or something?

 

Anyway, why do you have the "www" in some of your paths, but no "www" in other paths? They should all be consistent. I'll try to look more into this.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Erx, sorry for the delay.

 

At the bottom of your configure files, you didn't declare your database (didn't put the proper user in or something). So either you didn't declare it, or didn't declare it properly.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
Denis, this is a complex error, and your page might very well be viewed properly in other browsers. Are you using Opera or something?

 

Anyway, why do you have the "www" in some of your paths, but no "www" in other paths? They should all be consistent. I'll try to look more into this.

 

I use both Opera and Firefox.

The paths for https:// (I thought - a big mistake right there) should match the certificate which I did without the 'www'. I can correct that easy enough to all sans-www.

Let me know what you need to look into it further - I can provide ftp access, code - whatever you need. My thought (again trouble) was that my server stuck the certificate not in the place where OSC is expecting to find it, but not sure where that should be. Currently the site is up and running without security, so if you need me to upload the config files to duplicate the errors, just let me know.

Thank you for your attention. I know everyone wants a piece of your time and wants it yesterday.

Share this post


Link to post
Share on other sites
I use both Opera and Firefox.

The paths for https:// (I thought - a big mistake right there) should match the certificate which I did without the 'www'. I can correct that easy enough to all sans-www.

Let me know what you need to look into it further - I can provide ftp access, code - whatever you need. My thought (again trouble) was that my server stuck the certificate not in the place where OSC is expecting to find it, but not sure where that should be. Currently the site is up and running without security, so if you need me to upload the config files to duplicate the errors, just let me know.

Thank you for your attention. I know everyone wants a piece of your time and wants it yesterday.

 

If your certificate was issued to your domain without the www, then your entire config files should be without the www. If you want more, just e-mail me. I'll have time Tuesday morning (EST).


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Hey Jason,

 

I just read through nearly the entire post and looking at your configuration of configure.php under admin. I dont think its a good idea personally to put https for for where it asks for http .. this must cause some overhead on SSL .. even for the admin section you only need SSL for authentication and possibly dealing with customer info and/or customer info.. as long as your directory structure is protected and no one can access the files without a valid session you shouldnt have a problem..

Share this post


Link to post
Share on other sites
Hey Jason,

 

I just read through nearly the entire post and looking at your configuration of configure.php under admin. I dont think its a good idea personally to put https for for where it asks for http .. this must cause some overhead on SSL .. even for the admin section you only need SSL for authentication and possibly dealing with customer info and/or customer info.. as long as your directory structure is protected and no one can access the files without a valid session you shouldnt have a problem..

 

 

The point is ... is that your admin must be protected by SSL. If you don't protect it, you're leaving yourself wide open to a variety of potential issues. It's also a good idea to rename your "admin" folder to something else -- whatever .... johndoe4549903243, or whatever you'd like, and then alter your admin/includes/configure.php accordingly, switching each case of "admin" to whatever name you chose, since hackers know that for most OSC sites, all you need to get into the admin is to type /admin after the domain.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

really stupid question however I have my files hosted @ Globat.com and i have a shared SSL account.

 

when i connect to it via FTP i have the following;

 

httpdocs

httpsdocs

 

httpsdocs - are my SSL section.

and httpdocs is normal.

 

my question is do I need to upload my shopping cart to both httpdocs & httpsdocs to get SSL working?

 

Thanks.

Share this post


Link to post
Share on other sites

Thanks for the tut.... Ive got one minor problem after switching over to ssl. I have my site split into HTTPDOCS and HTTPSDOCS with the admin section removed from the non-secure folder. The entire shop seams to work fine Although all of my images will only upload to HTTPSDOCS. I need them to upload to HTTPDOCS.

 

I tried changing this line of code in admin/inlcudes/configure.php

 

From

define('DIR_FS_CATALOG', '/home/httpd/vhosts/palmer-pursuit.com/httpsdocs/ecom/');

 

to

define('DIR_FS_CATALOG', '/home/httpd/vhosts/palmer-pursuit.com/httpdocs/ecom/');

 

I get a red bar that says that image directory does not exist. I even made sure that the permissions were set the same as /images/ in the HTTPSDOCS folder.

 

 

here is my config

 

<?php
// Please, note that all changes in this file will be lost
// after reconfiguring application by Plesk
define('HTTP_SERVER', 'https://www.palmer-pursuit.com');
define('HTTP_CATALOG_SERVER', 'http://www.palmer-pursuit.com');
define('HTTPS_CATALOG_SERVER', 'https://www.palmer-pursuit.com');
define('ENABLE_SSL_CATALOG', 'true');
define('DIR_FS_$DOCUMENT_ROOT', '/home/httpd/vhosts/palmer-pursuit.com/httpsdocs');
define('DIR_WS_ADMIN', '/ecom/admin/');
define('DIR_FS_ADMIN', '/home/httpd/vhosts/palmer-pursuit.com/httpdocs/ecom/admin');
define('DIR_WS_CATALOG', '/ecom/');
define('DIR_FS_CATALOG', '/home/httpd/vhosts/palmer-pursuit.com/httpsdocs/ecom/');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

 

Thanks for your help in advance.

Share this post


Link to post
Share on other sites
really stupid question however I have my files hosted @ Globat.com and i have a shared SSL account.

 

when i connect to it via FTP i have the following;

 

httpdocs

httpsdocs

 

httpsdocs - are my SSL section.

and httpdocs is normal.

 

my question is do I need to upload my shopping cart to both httpdocs & httpsdocs to get SSL working?

 

Thanks.

 

Drew: Yes.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

×