Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

jpweber

How to install SSL on OSC: A Simple 1-2-3 Instruction

Recommended Posts

Laura, your mistake is in your includes/configure.php file. Change this line:

 

define('DIR_WS_HTTPS_CATALOG', '');

 

to

 

define('DIR_WS_HTTPS_CATALOG', '/');

 

After that it should work if everything else is set up correctly.

 

Good luck, keep us posted.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Laura, if you're with a host on a shared server, which it appears you are, it's best to go to your admin too -- www.gypsiedream.com/admin, or whatever, and go to configuration --> cache --> set the use cache to false.

 

Then in you includes/configure.php file and admin/includes/configure.php ... change the bottom line:

 

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

 

to

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
Yeah ... you have the loginbox contribution. There's nothing wrong with that. But if you insist, here's my login box code:

 

 

And regarding the SSL, you can get the RapidSSL for just 15 bucks from many places. E-mail (not message) me if you need any referrals. I'd just fork up the 15 bucks and be done with it. Good luck.

 

Thank you very much for your help. The code you posted helped me to change the login box. thank you. i appriciate your help. i wish you all the best.

Share this post


Link to post
Share on other sites
Laura, if you're with a host on a shared server, which it appears you are, it's best to go to your admin too -- www.gypsiedream.com/admin, or whatever, and go to configuration --> cache --> set the use cache to false.

 

Then in you includes/configure.php file and admin/includes/configure.php ... change the bottom line:

 

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

 

to

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

 

Hi,

I tried what you suggested and still the same issues. Do you have any other suggestions?

 

Thanks,

Laura

Share this post


Link to post
Share on other sites

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.grunionfabrication.com$
RewriteRule ^(.*)$ http://grunionfabrication.com/$1 [R=301,L]

 

So I put this on my .htaccess page and when you go to www.grunionfabrication.com it takes you to grunionfabrication.com perfectly! However as you mentioned grunionfabrication.com/index.php will still come in if typed and is a duplicate page as grunionfabrication.com.... You mentioned search engines will penalize this... Is there any way to avoid this or is it normal to have those pages be the same? Thanks for your help on that!

Share this post


Link to post
Share on other sites
Thank you very much for your help. The code you posted helped me to change the login box. thank you. i appriciate your help. i wish you all the best.

 

No problem. If I were you, I'd consider getting rid of the:

 

Welcome, Guest! Would you like to log in? Or would you prefer to create an account?

 

On your home page, and replacing it with 2, 3, or 4 keyword and key-phrase-loaded sentences describing what your company is all about. You already have the login and create account in the right column. Time to start putting some keywords and keyphrases in near the top, as an introduction.

 

Just a suggestion. Good luck.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
Hi,

I tried what you suggested and still the same issues. Do you have any other suggestions?

 

Thanks,

Laura

 

Laura, you're almost there. SOMEWHERE in your includes/configure.php file, you have an occurence of /catalog/ ..... Find this occurrence of /catalog/ and replace it with just a forward slash: /. Your store is in the root (as it should be), so there should be no occurrences of /catalog/ in there.

 

This will solve your problem. If worst comes to worst, you can e-mail me your config file and I'll do it for you, since it's such a simple modification.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.grunionfabrication.com$
RewriteRule ^(.*)$ http://grunionfabrication.com/$1 [R=301,L]

 

So I put this on my .htaccess page and when you go to www.grunionfabrication.com it takes you to grunionfabrication.com perfectly! However as you mentioned grunionfabrication.com/index.php will still come in if typed and is a duplicate page as grunionfabrication.com.... You mentioned search engines will penalize this... Is there any way to avoid this or is it normal to have those pages be the same? Thanks for your help on that!

 

Elaine. What you need to do is go to your root catalog files. I don't understand why you have a folder, "~grunionf" in there. Maybe that's just temporary until you get the site up?

 

Anyway ... you would go to wherever your root files are located -- where your main index.php, product_info.php files, etc., are located. Look for files like shipping.php, privacy.php, condtions.php, etc., etc., and files in there like this.

 

Replace all occurrences of:

FILENAME_DEFAULT

 

with

 

"/" (with the quotation marks)

 

This is a smart thing to do (I do it, as you'll see on my latest one -- http://www.thevisiondepot.com/using_tvd.php ) .... if you click the continue button, it points to my root website, www.thevisiondepot.com, NOT www.thevisiondepot.com/index.php. Mind you, this site is only 3 or 4 months old, so it still needs work. But that's a smart thing to do.

 

So if you do the same -- replace the occurrences in your root directory files of FILENAME_DEFAULT with "/" (with quotation marks), all continue buttons will point to http://grunionfabrication.com. I would also advise others reading this to do this in your includes/application_top.php file. It appears that Elaine, you don't use breadcrumbs at all. But for others, in this file, find:

$breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);

$breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT));

 

change to

 

$breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER);

$breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link("/"));

 

Good luck.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Jason,

I really have NO IDEA where that "~grunionf" comes from... There is no file with that name in it at all. I think it came from when I installed osCommerce through my cpanel with startlogic. all of the catalog files have been moved to my root (public_html?) folder.

I will do what you said about the FILENAME_DEFAULT though.... also, I know this is a thread about ssl but I was wondering if you know anything about the ultimate seo cont... I had a question about installing it maybe I could pm it to you? Nothing big just small.... Thanks for your help!

Share this post


Link to post
Share on other sites

AHA! Nevermind, I got rid of that grunionf thing by removing it from my config files... Now that I am changing all my files around, I have heard that there is something I can put into my .htaccess file that will redirect my pages to working ones? since all of the onces that the search engine has indexed already points to the old ones and I dont want to loose customers.....

Share this post


Link to post
Share on other sites
Laura, you're almost there. SOMEWHERE in your includes/configure.php file, you have an occurence of /catalog/ ..... Find this occurrence of /catalog/ and replace it with just a forward slash: /. Your store is in the root (as it should be), so there should be no occurrences of /catalog/ in there.

 

This will solve your problem. If worst comes to worst, you can e-mail me your config file and I'll do it for you, since it's such a simple modification.

 

 

That fixed it.

 

Many, many, many Thanks!

Laura

Share this post


Link to post
Share on other sites
AHA! Nevermind, I got rid of that grunionf thing by removing it from my config files... Now that I am changing all my files around, I have heard that there is something I can put into my .htaccess file that will redirect my pages to working ones? since all of the onces that the search engine has indexed already points to the old ones and I dont want to loose customers.....

 

I would have to look into you host's cpanel and check out their redirects, see if they allow 'em from there. I wouldn't know the code off hand, although it would probably look very similar to the other code, like this:

 

RewriteEngine on
RewriteCond %{HTTP_HOST} ^grunionfabrication.com/~grunionf/$
RewriteRule ^(.*)$ http://grunionfabrication.com/$1 [R=301,L]

 

And yes, what do you need to know about Chemo's Ultimate SEO's?


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
No problem. If I were you, I'd consider getting rid of the:

 

Welcome, Guest! Would you like to log in? Or would you prefer to create an account?

 

On your home page, and replacing it with 2, 3, or 4 keyword and key-phrase-loaded sentences describing what your company is all about. You already have the login and create account in the right column. Time to start putting some keywords and keyphrases in near the top, as an introduction.

 

Just a suggestion. Good luck.

Thank you very much for your suggestion. i think you are right. Most likely i will do it in the near future.

Share this post


Link to post
Share on other sites
Hello!

Anyone know of a hosting company that is good and reliable and installs SSL certs for you?

 

I use godaddy for both my hosting and ssl and I haven't had any problems with them yet. (though I haven't been with them for too long, so it's hard to judge for sure) I just got ssl from them less than a week ago and it was an easy process. My domain is held there too so I didn't need to worry about having to verify anything.


My site: Medieval Swords

Share this post


Link to post
Share on other sites
I use godaddy for both my hosting and ssl and I haven't had any problems with them yet. (though I haven't been with them for too long, so it's hard to judge for sure) I just got ssl from them less than a week ago and it was an easy process. My domain is held there too so I didn't need to worry about having to verify anything.

 

We're not allowed to solicit in here; if you send me an e-mail, I'll give you my recommendations. GoDaddy wouldn't be one of 'em.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Hi, Does anyone know how to resolve this?

 

When I click on my check out or my account I get this error now.

 

Warning: Cannot modify header information - headers already sent by (output started at /home/gypsi3/public_html/includes/languages/english.php:1) in /home/gypsi3/public_html/includes/functions/general.php on line 29

 

Previous to this I was getting parse errors and replaced the english.php with a backed up file. I got back to my site and now this. I didn't remember editing my english.php when I enabled my ssl cert. But I think this has something to do with it.

 

this is line 29 of my functions/general.php file:

 

function tep_exit() {

 

 

Thanks, Laura

Share this post


Link to post
Share on other sites
We're not allowed to solicit in here; if you send me an e-mail, I'll give you my recommendations. GoDaddy wouldn't be one of 'em.

 

Simply stating my experience. Are there problems with godaddy I should know about?


My site: Medieval Swords

Share this post


Link to post
Share on other sites
We're not allowed to solicit in here; if you send me an e-mail, I'll give you my recommendations. GoDaddy wouldn't be one of 'em.

 

Hi Jason:

I think I need your recommendations. I am looking for a good hosting and will PM you soon.

 

N

Share this post


Link to post
Share on other sites

We're having a strange problem when SSL is enabled. When you select the My Account | Create New Account (/catalog/create_account.php) link all looks to work well (it goes to the SSL link). However when I enter all the data an and press continue the page simply refreshes. No information is written to the database. If the site is NOT in SSL mode (define('ENABLE_SSL', 'false')) all works fine. This seem to also be the case when attempting to log into the site.

 

I have attached both config files.

 

Any help is greatly appriciated.

 

include/configure.php

  define('HTTP_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTPS_SERVER', 'https://www.islandtreasuresgourmet.com');
 define('ENABLE_SSL', 'true');
 define('HTTP_COOKIE_DOMAIN', 'www.islandtreasuresgourmet.com');
 define('HTTPS_COOKIE_DOMAIN', '.islandtreasuresgourmet.com');
 define('HTTP_COOKIE_PATH', '/catalog/');
 define('HTTPS_COOKIE_PATH', '/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/www/docs/itgourmet/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

admin/include/configure.php

  
 define('HTTP_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTP_CATALOG_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTPS_CATALOG_SERVER', 'https://www.islandtreasuresgourmet.com'); 
 define('ENABLE_SSL_CATALOG', 'true');
 define('DIR_FS_DOCUMENT_ROOT', $_SERVER['DOCUMENT_ROOT']); 
 define('DIR_WS_ADMIN', '/catalog/admin/');
 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
 define('DIR_WS_CATALOG', '/catalog/');
 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

Share this post


Link to post
Share on other sites
Hi, Does anyone know how to resolve this?

 

When I click on my check out or my account I get this error now.

 

Warning: Cannot modify header information - headers already sent by (output started at /home/gypsi3/public_html/includes/languages/english.php:1) in /home/gypsi3/public_html/includes/functions/general.php on line 29

 

Thanks, Laura

 

 

Laura ... in you /includes/languages/english.php file, you have whitespace before the first <?php or most likely after the last ?> ... eliminate this and you will fix the error.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
Simply stating my experience. Are there problems with godaddy I should know about?

 

I don't know from experience; I've read poor things about 'em in here, but I can't speak for myself, and I can't cite exactly what poor things were dead. If you do a google search on GoDaddy SSL I'm sure you'll find plenty of reviews.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
We're having a strange problem when SSL is enabled. When you select the My Account | Create New Account (/catalog/create_account.php) link all looks to work well (it goes to the SSL link). However when I enter all the data an and press continue the page simply refreshes. No information is written to the database. If the site is NOT in SSL mode (define('ENABLE_SSL', 'false')) all works fine. This seem to also be the case when attempting to log into the site.

[/code]

 

You can try changing the beginning of your catalog/includes/configure.php to this, but I'm not sure if it'd make a difference:

 

  define('HTTP_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTPS_SERVER', 'https://www.islandtreasuresgourmet.com');
 define('ENABLE_SSL', 'true');
 define('HTTP_COOKIE_DOMAIN', 'www.islandtreasuresgourmet.com');
 define('HTTPS_COOKIE_DOMAIN', '.islandtreasuresgourmet.com');

 

to

 

  define('HTTP_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTPS_SERVER', 'https://www.islandtreasuresgourmet.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', '.islandtreasuresgourmet.com');
 define('HTTPS_COOKIE_DOMAIN', '');

 

Good luck. If I could get onto you site, I'd have a better idea, but your site is down at the moment.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
You can try changing the beginning of your catalog/includes/configure.php to this, but I'm not sure if it'd make a difference:

 

  define('HTTP_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTPS_SERVER', 'https://www.islandtreasuresgourmet.com');
 define('ENABLE_SSL', 'true');
 define('HTTP_COOKIE_DOMAIN', 'www.islandtreasuresgourmet.com');
 define('HTTPS_COOKIE_DOMAIN', '.islandtreasuresgourmet.com');

 

to

 

  define('HTTP_SERVER', 'http://www.islandtreasuresgourmet.com');
 define('HTTPS_SERVER', 'https://www.islandtreasuresgourmet.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', '.islandtreasuresgourmet.com');
 define('HTTPS_COOKIE_DOMAIN', '');

 

Good luck. If I could get onto you site, I'd have a better idea, but your site is down at the moment.

 

Gave your suggestion a try with no luck. As for the site, we had a DNS configuration issue which is not resolved. Btw, we are current using a self signed certificate for testing.

Share this post


Link to post
Share on other sites
Laura ... in you /includes/languages/english.php file, you have whitespace before the first <?php or most likely after the last ?> ... eliminate this and you will fix the error.

 

Thank you so much Jason. That cleared that up. My whole parse problem and the resulting english.php thing came about because I was trying to make a box so that I could put the SSL seal on my righthand column and then eventually bring down my paypal logo from the top of the page. I guess it is all so confusing to me. I read your earlier post about putting it where the Oscommerce logo use to be, but I have no idea where that is. The website was already modified for me, and the person who did it will not offer any help. Can you offer simple instructions on getting my SSL seal and Paypal logo where it needs to be?

 

Again, Thank you for being so helpful.

Laura

Share this post


Link to post
Share on other sites

×