Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

jpweber

How to install SSL on OSC: A Simple 1-2-3 Instruction

Recommended Posts

Yes, your webserver, which is the eb-n1 thing. Ask your web hosting company for the path if you're still unsure, but that's probably it. It's probably something very similar to your company name or domain, so go with the eb-n1.

 

But the ONLY thing that should be httpS in your catalog/ADMIN/includes/configure.php folder is the following line:

 

define('HTTP_CATALOG_SERVER', 'https://www.domain.com');

define('HTTPS_CATALOG_SERVER', 'httpS://www.domain.com');

 

Nothing else with your shared SSL.

 

I mean, you can try adding these lines to your admin/includes/configure.php file:

define('DIR_WS_ADMIN', '/catalog/admin/');

define('DIR_FS_ADMIN', '/fullpath/to/yourserver/catalog/admin/');

Shared SSLs are strange, and very different based on your host. They should offer full support in helping you get this up and running.

 

Also, try adjusting your browser's settings. For instance, I think IE goes something like:

tools>internet options>security>custom level>display mixed content: enable

 

After that, don't forget about the http://forums.oscommerce.com/topic/334107-ssl-implementation-help/ link -- specifically, the first two posts by Jim.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Hi,

when I look on page source, there is more than 60 http starting links. What is easiest way to change it to https?

Is there some function or file to change those link which should be https? Maybe .htaccess or something?

Share this post


Link to post
Share on other sites

HTTP links on the HTTPS pages are normal.

 

You will only have problems trying to LOAD CONTENT (scripts, images, iframes, fonts) from HTTP sources on HTTPS pages.

 

If the SSL is setup, installed, and working correctly all the links should be correct.

 

If you need help setting up SSL click the "SSL Implementation Help" link in my signature.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Thanks for reply, Jim.

Reading various topics I realized that http links on page cause red striked https in address bar. My question is what is easiest way to get green one in client side?

I think I installed SSL certificate right way because I have green https in admin pages.

 

Goran

Share this post


Link to post
Share on other sites

I can tell you've been to the SSL help thread but you must not have read the first post in it closely.

 

Your config file shows none of the changes required to enable SSL,

 

These:

define('HTTPS_SERVER', 'http://3d-carving.com');
define('ENABLE_SSL', false);
define('HTTPS_COOKIE_DOMAIN', '');

 

Should be:

define('HTTPS_SERVER', 'https://www.3d-carving.com');
define('ENABLE_SSL', true);
define('HTTPS_COOKIE_DOMAIN', 'www.3d-carving.com');


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

You're miracle maker. Yesterday and today I've tried to set it. And now, I don't know why wasn't set up already.

Thank you. Can you point me to topic where I could read of redirecting/staying on pages with https:// prefix in url?

Thank you very much.

Share this post


Link to post
Share on other sites

Having the shop SSL all the time isn't a good idea.

 

Osc is setup to use SSL on only the pages that need it.

 

You should leave it that way,

:)


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Great help thanks a lot!

 

I have a little problem: i installed many sites on the same server, the main site has SSL, now the other sites admin console send me to the main site when i click on any of the links instead of the proper site.

Am i missing something?

 

Please help.

Share this post


Link to post
Share on other sites

LInks are constructed by data in the /admin/includes/configure.php (or /admin/includes/local/configure.php if it is present).

 

Links can be modified by any active .htaccess file(s) or active redirects in your web host cPanel.

 

Now you know where to look.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Hi,

 

Can you please help regarding SSL/Cookies. I have inherited a site cortaflex.co.nz build on OsCommerce. we move the everything over to our server (reseller account with hostgator) which has a shared SSL enabled.

 

I have spent 2 days trawling through the forums and non of the suggestions work, even your instructions.

 

I have tried both SSL and forcing cookies but nothing.

 

The main problem I have is when a customer adds to a cart and goes straight to the shopping cart then once signed in (which loses all the styling btw) they go to the hosted payment gateway. Once the payment is complete the transaction is lost and they are asked to log back in. There is no record of the order in the system but the client has been charged.

 

I think this is related to a lesser evil problem where you simply add to your cart, then from there click view card and the session is lost and the cart is empty.

 

Can you please help.

 

The current config is below:

 

 define('HTTP_SERVER', 'http://www.cortaflex.co.nz/'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://secure187.websitewelcome.com/~wwwcorta/'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', '.cortaflex.co.nz/');
 define('HTTPS_COOKIE_DOMAIN', '.secure187.websitewelcome.com/~wwwcorta/');
 define('HTTP_COOKIE_PATH', 'catalog/');
 define('HTTPS_COOKIE_PATH', 'catalog/');
 define('DIR_WS_HTTP_CATALOG', 'catalog/');
 define('DIR_WS_HTTPS_CATALOG', 'catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

Cheers,

Kevin.

Share this post


Link to post
Share on other sites

We have just purchased SSL. Our website lay within a 'htdocs' folder. The host has made another 'htdocs_secure' folder and has copied our website into it. We made the changes to the configure.php files as instructed in this thread but the https pages were not found. Are we entering the wrong thing in HTTPS SERVER? Any help is appreciated, we are new to this.

Share this post


Link to post
Share on other sites

×