Jump to content
Sign in to follow this  
fear4me

CSS Menu

Recommended Posts

Hi Roger,

 

Yes i did follow all the instructions, only renamed categories_css.php to categories.php.

Works in STS 4.2, not in 4.3... maybe it has something to do with the extra code for

infoboxes added in STS 4.3?

 

Cheers,

Eric :D

 

Oh... forgot to mention, i didn't change the pointer to categories_css.php because i renamed

the php-file to categories.php to avoid conflicts with STS.

 

Cheers,

Eric :D

Share this post


Link to post
Share on other sites
Did you follow the CSSmenu-instructions? Or only the STS-instructions? Because you have to change the pointer to categories_css.php.

 

Hi Roger,

 

I think that i know what the problem is.

My test shop in which the css menu works okay has only about 10 categories and 50 products.

My real shop has about 100 categories and 5000 products...

 

When i looked in the page source of the test shop i have seen a array has been build of all

the products specially for the css menu. So i think i get a time out when building the menu

for the many many more products of my real shop...

 

Is the css menu usable when you have that many products in your shop?

The standard categorie menu builds only a array of the main categories

when opening the index page and the rest when clicking on a categorie or am i wrong?

Is it possible to make this the same for this really nice css menu?

 

Cheers,

Eric :D

Share this post


Link to post
Share on other sites
I'll release version 0.3 today, which includes the count-function and also includes the Aguzi-addition to show products in the menu, which I made also language-dependend.

 

Both will be available through settings in the categories_css.php . :thumbsup:

 

Fear4Me

Hello

 

Great Contrib.

I?ve installed the 3.0 ver, and it?s is working very well.

How ever, I need another help:

 

When I use the Firefox 1.5.0.8 the mouse is bumpy when in the menu. Can anyone test it? (please see my store in www.decortuning.com/decor)

 

One other thing, some of my first submenus are a bit long and don?t visible in the page.

(look for ?Logos Auto? in the sub menus, the brands aren?t all visible)

 

Does anyone have an idea in how to arrange this?

 

Best regards to all!

Share this post


Link to post
Share on other sites
Hello

 

Great Contrib.

I�ve installed the 3.0 ver, and it�s is working very well.

How ever, I need another help:

 

When I use the Firefox 1.5.0.8 the mouse is bumpy when in the menu. Can anyone test it? (please see my store in www.decortuning.com/decor)

 

One other thing, some of my first submenus are a bit long and don�t visible in the page.

(look for �Logos Auto� in the sub menus, the brands aren�t all visible)

 

Does anyone have an idea in how to arrange this?

 

Best regards to all!

 

The submenu's look just fine in my browser (FF 1.5.0.8 in 1280x1024). The mouse works also perfectly in FF 1.5.0.8. Maybe someone else could test in an other version or browser...

Share this post


Link to post
Share on other sites
Hi Roger,

 

I think that i know what the problem is.

My test shop in which the css menu works okay has only about 10 categories and 50 products.

My real shop has about 100 categories and 5000 products...

 

When i looked in the page source of the test shop i have seen a array has been build of all

the products specially for the css menu. So i think i get a time out when building the menu

for the many many more products of my real shop...

 

Is the css menu usable when you have that many products in your shop?

The standard categorie menu builds only a array of the main categories

when opening the index page and the rest when clicking on a categorie or am i wrong?

Is it possible to make this the same for this really nice css menu?

 

Cheers,

Eric :D

 

I'm developing our E-shop with live data at the moment with 940 categories and 19320 products without problems in the menu. I have disabled the showproducts-option, because we won't need it. Our testserver isn't the fastest, but everything is showing up within 4 seconds. I'm only struggling the first time I call the page which takes about 20 seconds. I'm not sure if its the problem of the menu, or just another internal networktraffic problem.

Share this post


Link to post
Share on other sites

Hi All,

 

I had this working in a few test sites, but when moving to a host with php 5.1.6 it seems to have stopped working....

 

The page spits out php text starting like so :---

0 ) { $returnval .= "

"; } if ( $productsDisplay > $maxProductsInMenu )

 

ending with error message

Fatal error: Call to undefined function PrintSubMenus() in /vhosts/rpc.com.au/www/catalog-rg-on/includes/boxes/categories_css.php on line 284

 

 

All the code looks fine and complete... the function of course exists :)

 

I have tried with both the register globals set to off and the register globals contribution installed and a fresh install of osc on this server ...

 

Any assistance welcome.

TIA

Share this post


Link to post
Share on other sites

Totally unsure why this may have fixed the errors below, but I replace the all of the <? with <?php as it seemed the php code was not being read correctly ..

 

 

This seemed to fix the errors and the CSS menus came back to life ......

 

 

Go figure!!

 

 

 

Hi All,

 

I had this working in a few test sites, but when moving to a host with php 5.1.6 it seems to have stopped working....

 

The page spits out php text starting like so :---

0 ) { $returnval .= "

"; } if ( $productsDisplay > $maxProductsInMenu )

 

ending with error message

Fatal error: Call to undefined function PrintSubMenus() in /vhosts/rpc.com.au/www/catalog-rg-on/includes/boxes/categories_css.php on line 284

All the code looks fine and complete... the function of course exists :)

 

I have tried with both the register globals set to off and the register globals contribution installed and a fresh install of osc on this server ...

 

Any assistance welcome.

TIA

Share this post


Link to post
Share on other sites

Hi, i have a problem with the with the css menu, when i turn on the cache, the menu is getting screwed-up.

Without cache it works like a charm...

Somebody had the same problem?

Share this post


Link to post
Share on other sites

Great contribution! It has worked great for me for about 3 months now. But I recently ran into a problem with it....under the new IE 7 it displays kinda funky. Has anyone else had issues with the new IE 7?

 

You can see what I mean at HTTP://www.westixonline.com/Frames/Mesh/c10/index.html

 

Any help with this is greatly appriciated.

 

matt


---

CorradoMatt

http://www.westixonline.com - an oscommerce / creloaded site

Share this post


Link to post
Share on other sites

Nevermind all.....I figured it out......if you are having problems with IE 7 just do this.....

 

somewhere in the /* menu links style */ area of the css code add this line...

 

overflow: auto; /*force hasLayout in IE7 */

 

That fixed everything for me!

 

Thanks everyone.

 

Matt


---

CorradoMatt

http://www.westixonline.com - an oscommerce / creloaded site

Share this post


Link to post
Share on other sites

I didn't see the answer to this in this thread - I added the contribution, it's WONDERFUL! Had no problems changing colors, etc...

 

That being said, I am having it show the products (see here) - but now the order that I had the products in originally is realllly wacked out... how can I get it back to "alphabetical" order?

 

Thanks so much!

Share this post


Link to post
Share on other sites

i tried categories_css.php menu ..it is working fine ..but when i tried to use that same file with different names the submenus are not working..pls help

Share this post


Link to post
Share on other sites

Trying to link this in with the other elements on my website....

 

I'd like to add another entry to the main categories menu (along with an appropriate submenu).

Applications would be various functions like 'request a catalog', 'search the site', 'view video clips' etc.

 

Can you tell me how this can be done?

 

 

Also a couple of helpful suggestions - use z-index so the submenus appear in front of the product images rather than behind them. Put the javascript in a separate file.

Edited by radders

Share this post


Link to post
Share on other sites
Trying to link this in with the other elements on my website....

 

I'd like to add another entry to the main categories menu (along with an appropriate submenu).

Applications would be various functions like 'request a catalog', 'search the site', 'view video clips' etc.

 

Can you tell me how this can be done?

Also a couple of helpful suggestions - use z-index so the submenus appear in front of the product images rather than behind them. Put the javascript in a separate file.

 

Because you have the CSS already loaded you could define the block as:

 

<div class='suckerdiv'>
<ul id='suckertree1'>
 <li><a href="mynewitem.html">Your item goes here</a></li>
</ul>

Share this post


Link to post
Share on other sites

Yes thanks for the suggestion. I've been trying variations of that idea for a couple of days now.

One of two things happen. Either I can't get the new item's submenu to show in Internet Explorer or the categories menu disappears completely.

Share this post


Link to post
Share on other sites

Is there a fix for the z-index problem in I.E. 7?

In Firefox everything looks good but I cannot seem to get the submenus to appear in the foreground in Explorer.

 

Thanks

Share this post


Link to post
Share on other sites

OK progess is being made. I got around the problem of adding extra items to the suckerfish menu by just creating a second suckerfish menu right above the first one. Just had to inform the javascript that there were two menus and it was all plain sailing (touch wood and whistle).

 

So far though the submenus are still hidden behind the product images in IE7 (and quite possibly in other versions of explorer). Not a problem in Firefox though. I notice that this only happens with the product images not the category images so it may have something to do with the way my product images are floated. I would have said it was just me but jcssmenu seems fine with it all in both browsers.

 

Apart from this it looks great!

 

Great News!! It is all fixed

Edited by radders

Share this post


Link to post
Share on other sites

is there a way to get this addon to only show like 3 categories deep? I have way to many categories... just wondering if theres a quick fix. I see where you can turn off ones with nothing in them....

Share this post


Link to post
Share on other sites

I have so many categories, is there a way to limit how many categories show and the a 'more..' prompt will show?

Share this post


Link to post
Share on other sites
I have so many categories, is there a way to limit how many categories show and the a 'more..' prompt will show?

 

yup i'm looking for the same thing... it would be kickass if you could do this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×