Latest News: (loading..)
Sign in to follow this  
Followers 0
kaliphornia

Fatal error: Cannot redeclare tep_get_category_tree()

3 posts in this topic

Hi All,

 

I've seen posts on this question before in this forum, but the suggested solutions didn't clear up the problem for me.

 

I'm running an install of OSC V 2.2 MS2 with STS V 4.2:

 

http://www.gweb.modwest.com/clients/nb/catalog/

 

I'm getting this error at the bottom of every page:

 

Fatal error: Cannot redeclare tep_get_category_tree() (previously declared in /htdocs/www/clients/nb/catalog/includes/modules/sts_inc/sts_user_code.php:33) in /htdocs/www/clients/nb/catalog/includes/modules/sts_inc/sts_user_code.php on line 33

 

The other posts I read about this said to look for duplicate functions/pages. The only other place the tep_get_category_tree() function appears to be declared is in admin/includes/functions/general.php. I tried removing the function from that file, but am still getting the same error, so I put it back in.

 

Any help clearing this up would be greatly appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites
Hi All,

 

I've seen posts on this question before in this forum, but the suggested solutions didn't clear up the problem for me.

 

I'm running an install of OSC V 2.2 MS2 with STS V 4.2:

 

http://www.gweb.modwest.com/clients/nb/catalog/

 

I'm getting this error at the bottom of every page:

 

Fatal error: Cannot redeclare tep_get_category_tree() (previously declared in /htdocs/www/clients/nb/catalog/includes/modules/sts_inc/sts_user_code.php:33) in /htdocs/www/clients/nb/catalog/includes/modules/sts_inc/sts_user_code.php on line 33

 

The other posts I read about this said to look for duplicate functions/pages. The only other place the tep_get_category_tree() function appears to be declared is in admin/includes/functions/general.php. I tried removing the function from that file, but am still getting the same error, so I put it back in.

 

Any help clearing this up would be greatly appreciated.

 

Thanks.

Your sts_user_code.php file is called twice. Check in the admin, STS Module, Default, that the parameter "Files for normal template" contains only one instance of "sts_user_code.php".

 

The file sts_display_output.php should be called only from sts_footer.php (at the end of the file). Check that you have nothing related to STS in the application_bottom.php file.

Share this post


Link to post
Share on other sites
Your sts_user_code.php file is called twice. Check in the admin, STS Module, Default, that the parameter "Files for normal template" contains only one instance of "sts_user_code.php".

 

The file sts_display_output.php should be called only from sts_footer.php (at the end of the file). Check that you have nothing related to STS in the application_bottom.php file.

 

Hi,

 

I am now receiving this error right out of nowhere!!!!

 

Since this is quite an old thread and there is a relation to STS in the application_bottom.php by default I figure that the problem lies elsewhere.

I have checked the admin and everything is ok there according to your post Bill.

 

Any clues?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0