Jump to content
Sign in to follow this  
rudolph

Easypopulate not getting it

Recommended Posts

Hi, can any body help please?

Trying to use easy populate, downloaded the "Download Complete tab-delimited .txt file to edit"

but get this when i try to insert db, even unedited.

 

Warning: move_uploaded_file(C:/Domains/final/wwwroot/catalog//catalog/temp/EP2006Sep21-1705.txt): failed to open stream: No such file or directory in C:\Domains\final\wwwroot\catalog\admin\easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move 'C:\WINDOWS\TEMP\php8B7D.tmp' to 'C:/Domains/finalcs/wwwroot/catalog//catalog/temp/EP2006Sep21-1705.txt' in C:\Domains\finalcs\wwwroot\catalog\admin\easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: C:\WINDOWS\TEMP\php8B7D.tmp

User filename: EP2006Sep21-1705.txt

Size: 102681

 

Warning: file(C:/Domains/final/wwwroot/catalog//catalog/temp/EP2006Sep21-1705.txt): failed to open stream: No such file or directory in C:\Domains\final\wwwroot\catalog\admin\easypopulate.php on line 667

 

Warning: Invalid argument supplied for foreach() in C:\Domains\final\wwwroot\catalog\admin\easypopulate.php on line 690

 

Created catalog\temp and chmod777. any help would be welcome

Thanx

Edited by rudolph

Share this post


Link to post
Share on other sites

The problem is here:

 

C:/Domains/final/wwwroot/catalog//catalog/temp/EP2006Sep21-1705.txt

 

Go to the easypopulate.php file and change the setting of "$tempdir" from /catalog/temp/ to just /temp/ (might have to get rid of the leading / aswell, but don't think so.)

Share this post


Link to post
Share on other sites

Hi,

 

I am having the exact same problem. I have already changed my $tempdir and $tempdir2 to '/temp/' and I still have the same problem (I have chmod to 777).

 

// Please set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php

$tempdir = "/temp/";

$tempdir2 = "/temp/";

 

 

 

I have OSCommerce version 2.2 MS2 and have never had a 'catalog' folder.

 

 

I have installed the Easy Populate version #EP_v2_76c_MS2 and did not install any other Contributions with it. Do I have to do that?

 

 

Please help! Thank you,

 

 

Jan

 

 

PS: I also created a tmp directory and chmod to 777.

 

 

My Error message looks like this:

 

Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/temp/EP2006Sep22-0606.txt): failed to open stream: No such file or directory in /home/domain/public_html/shop/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpLTm2Yn' to 'DIR_FS_DOCUMENT_ROOT/temp/EP2006Sep22-0606.txt' in /home/domain/public_html/shop/admin/easypopulate_functions.php on line 32

 

File uploaded.

Temporary filename: /tmp/phpLTm2Yn

User filename: EP2006Sep22-0606.txt

Size: 58135

 

Warning: file(DIR_FS_DOCUMENT_ROOT/temp/EP2006Sep22-0606.txt): failed to open stream: No such file or directory in /home/domain/public_html/shop/admin/easypopulate.php on line 667

 

Warning: Invalid argument supplied for foreach() in /home/domain/public_html/shop/admin/easypopulate.php on line 690

Edited by romantix

Share this post


Link to post
Share on other sites

Have you set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php? I personaly don't quite understand this statement, as I overlooked to do it (following the instructions in EasyPopulate_Manual.rtf not 1readmeFIRST.txt - I had read it first, then it wasn't mentioned in the Manual.rtf so it slipped my mind) but it seems to be working ok. The only thing I can find that it might refer to in mine is DIR_FS_DOCUMENT_ROOT, but that's pointing at the right place anyway. Try it it might work for you, or check and see if DIR_FS_DOCUMENT_ROOT is pointing at the stores directory. Mine's never been called catalog either.

Share this post


Link to post
Share on other sites

I have checked and I had it setup correctly:

 

define('DIR_FS_$DOCUMENT_ROOT', '/home/domain/public_html/'); // where the pages are located on the server

 

This got me thinking though! I have installed OSCommerce through our Cpanel (Fantastico) and it installed version 2.2 MS2. It created a folder called /shop/ where all the OSCommerce files are. Some contributions I've installed run correctly and I am unable to make the rest of them work. Could that be because of the directory structure? Would it help if I rename 'shop' to 'catalog' or move the files up to the root? (which would mean getting rid of the shop folder alltogether). I have an existing website running from index.html on the root. Is the index.php then going to replace that?

 

Some of the other lines in this configure.php seem to suggest that OSC is aware of the current files/folders structure:

 

For example:

 

define('DIR_WS_ADMIN', '/shop/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/domain/public_html/shop/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/shop/'); // absolute path required

define('DIR_FS_CATALOG', '/home/domain/public_html/shop/'); // absolute path required

 

I've even tried to change the line in question to:

 

define('DIR_FS_$DOCUMENT_ROOT', '/home/domain/public_html/shop/'); // where the pages are located on the server

 

to no avail! :(

 

Please help - thanks again,

 

Jan

Edited by romantix

Share this post


Link to post
Share on other sites
The problem is here:

 

C:/Domains/final/wwwroot/catalog//catalog/temp/EP2006Sep21-1705.txt

 

Go to the easypopulate.php file and change the setting of "$tempdir" from /catalog/temp/ to just /temp/ (might have to get rid of the leading / aswell, but don't think so.)

 

 

:lol: Thank you!, it add all information to db :( Except the images,

Images where uploaded to default folder: catalog/images There where no error reported after incursion

into db, Safed me tons of time, Thanks again!

Share this post


Link to post
Share on other sites

Another piece of information:

 

The Error message referes to:

 

/home/gourmet/public_html/shop/admin/easypopulate_functions.php on line 32

 

here is what I have on that line in this file:

 

move_uploaded_file($filename['tmp_name'], $target);

 

And also refers to:

 

Warning: Invalid argument supplied for foreach() in /home/gourmet/public_html/shop/admin/easypopulate.php on line 690

 

here is what I have in that section:

 

// get the entire file into an array

$readed = file(DIR_FS_DOCUMENT_ROOT . $tempdir . $localfile);

}

 

// now we string the entire thing together in case there were carriage returns in the data

$newreaded = "";

foreach ($readed as $read){

$newreaded .= $read;

 

Would anyone know what I could try to do to fix this please?

 

 

Thank you so much,

 

Jan

Edited by romantix

Share this post


Link to post
Share on other sites
:lol: Thank you!, it add all information to db :( Except the images,

Images where uploaded to default folder: catalog/images There where no error reported after incursion

into db, Safed me tons of time, Thanks again!

 

:blush: wondered if you would be kind engorge to help struggling newbie? :'(

EP works great! Except for images. I did install OSC in default dir, tried changing directory like manual said ,now looks like this:

//**** Image Defaulting ****

global $default_images, $default_image_manufacturer, $default_image_product, $default_image_category;

$default_image_manufacturer = DIR_WS_CATALOG_IMAGES;

$default_image_product = DIR_WS_CATALOG_IMAGES;

$default_image_category = DIR_WS_CATALOG_IMAGES;

 

did go through post, probably 100 or more, did get the same question but no answers, PLEASE HELP!

Share this post


Link to post
Share on other sites

So you put the image file in the image folder on your server and put the filename into the image field in the database, but it hasn't made the connection between them when it was uploaded? Does the filename show up when you go to the edit product details page in your admin section?

 

It might be worth trying to upload the database file again, as I've noticed that it occasionaly misses things (so I always make sure I check the output it echoes to make sure it hasn't barfed.)

Share this post


Link to post
Share on other sites
So you put the image file in the image folder on your server and put the filename into the image field in the database, but it hasn't made the connection between them when it was uploaded? Does the filename show up when you go to the edit product details page in your admin section?

 

It might be worth trying to upload the database file again, as I've noticed that it occasionaly misses things (so I always make sure I check the output it echoes to make sure it hasn't barfed.)

 

itinerant baker, Thanks for your response

Yes image names do show, above it a message : "IMAGE DOES NOT EXIST"

Share this post


Link to post
Share on other sites
itinerant baker, Thanks for your response

Yes image names do show, above it a message : "IMAGE DOES NOT EXIST"

 

:blush: O.k did say newbie, forgot to add file extensions myimage(.jpg)

Edited by rudolph

Share this post


Link to post
Share on other sites
Doh! >_<

At least it works now, that's the main thing. I was going to ask you if you'ld plugged it in at the wall aswell. ;)

 

 

lol

:thumbsup: thanks for your help ,appreciate it

Share this post


Link to post
Share on other sites
Another piece of information:

 

The Error message referes to:

 

/home/gourmet/public_html/shop/admin/easypopulate_functions.php on line 32

 

here is what I have on that line in this file:

 

move_uploaded_file($filename['tmp_name'], $target);

 

And also refers to:

 

Warning: Invalid argument supplied for foreach() in /home/gourmet/public_html/shop/admin/easypopulate.php on line 690

 

here is what I have in that section:

 

// get the entire file into an array

$readed = file(DIR_FS_DOCUMENT_ROOT . $tempdir . $localfile);

}

 

// now we string the entire thing together in case there were carriage returns in the data

$newreaded = "";

foreach ($readed as $read){

$newreaded .= $read;

 

Would anyone know what I could try to do to fix this please?

Thank you so much,

 

Jan

 

 

Hi Jan, I think I have a similar problem you had:

 

I installed 2 weeks ago oscommerce-2.2ms2-060817 and register_globals_v1.5_bug_fixes_1_2 contribution successfully in my shared server (stargateinc). I haven´t changed the directory structure.

 

I´ve installed EP_v2_76d_MS2. I can access to EP. Here are the steps I followed to install this contribution:

 

1.- Directory catalog/temp created with chdmod 777 (with dreamweaver and rechecked with cuteFTP).

2.- I´ve some products in my database, all of them with model number.

3.- I copied file easypopulate.php and easypopulate_functions into admin/ and the file /catalog/admin/includes/classes/table_block.php has been copied.

4.- For adding link to the Admin, I edited file admin/includes/boxes/catalog.php correctly.

5.- I´ve changed configuration variuables in easypopulate.php:

--> $modelsize = 9; // I only need 9 digits to my model number. All products will have a 9 digit code.

--> I´ve changed the froogle paths correctly

6.- I corrected the EP download problem (No files where created in the temp directory).

7.- Now I´m unable to upload files. or to export if I choose to save the file it in the temp directory

 

Catalog/admin/includes/configure.php:

 

define('HTTP_SERVER', 'http://www.estacion-sonora.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.estacion-sonora.com');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/oliver66/public_html/estacion-sonora/catalog/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/home/oliver66/public_html/estacion-sonora/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'mylogin');

define('DB_SERVER_PASSWORD', 'mypassword');

define('DB_DATABASE', 'oliver66_ESTACION');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

catalog/admin/easypopulate.php

$tempdir = DIR_FS_DOCUMENT_ROOT . "/catalog/temp/";

 

-------------------------------------------------------------------------

I donwnloaded a file with EP and tried to upload the same file. This is the error I get when I try to upload:

 

Warning: move_uploaded_file(/catalog/temp/EP2006dic26-0606M.txt) [function.move-uploaded-file]:

failed to open stream: No such file or directory in

/home/oliver66/public_html/estacion-sonora/catalog/admin/easypopulate_functions.php on line 43

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/php807WEY'

to '/catalog/temp/EP2006dic26-0606M.txt' in

/home/oliver66/public_html/estacion-sonora/catalog/admin/easypopulate_functions.php on line 43

 

File uploaded.

Temporary filename: /tmp/php807WEY

User filename: EP2006dic26-0606M.txt

Size:

 

Warning: file(/catalog/temp/EP2006dic26-0606M.txt) [function.file]: failed to open stream:

No such file or directory in

/home/oliver66/public_html/estacion-sonora/catalog/admin/easypopulate.php on line 815

 

Warning: Invalid argument supplied for foreach() in

/home/oliver66/public_html/estacion-sonora/catalog/admin/easypopulate.php on line 854

 

------------------------------------------------------------------------

 

I tried to change in catalog/admin/easypopulate.php $tempdir = DIR_FS_DOCUMENT_ROOT . "/catalog/temp/"; to

 

$tempdir = "/catalog/temp/";

$tempdir2 = "/catalog/temp/";

 

Also

 

$tempdir = "/temp/";

$tempdir2 = "/temp/";

 

 

It didn´t work. I need help, I could´t find a solution in this forum. Please let me know if you have an idea...

 

Thanks a lot 4 your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×