Jump to content
Sign in to follow this  
mushindo

Automatic Store Feeds Contribution

Recommended Posts

Hi Chris,

 

It can take a few hours for Google to process your newly uploaded feed file. Just look at your status in your account.

But the work you had to do is done, now you only need to wait a little bit for Google. It shouldn't be long.

 

Regards,

 

-Ben

 

Hi Ben,

 

Basically, I wanted to understand first how googlebase works and then to discover if I have done anything wrong with ur contri.

I followed all the instructions in the tutorial of googlebase and I managed to create the required txt/csv file. After 24h I can see my products in http://www.google.com/base/. In the "Status" column of my "Active Items" says "Published and searchable". As far as I understand I have to wait 24h again, to search my products in http://www.google.com/products/.

 

Then I tried to compare the formats of both txt and they were not similar.

 

froogle_us_file.txt

link 	 title 	 description 	 expiration_date 	 label 	 price 	 image_link 	 id	 instock 	 shipping 	 brand 	 quantity	 payment_accepted	 payment_notes	 tax_percent	 tax_region	 product_type 	 currency 	 language 	 ship_to 	condition	 location
https://shop.antcor.com/shop/product_info.php?language=en&currency=USD&products_id=129	IkarusOS Level1	IkarusOS is a network services operating system which turns an embedded based system into a dedicated (WI-FI) router. IkarusOS enabled deployments are easily configured provisioned and monitored through IkarusOS Manager which is a software application that provides real-time visibility and control of all IkarusOS based systems of the network. The complete administration and configuration of IkarusOS systems is done through IkarusOS Manager executed from any platform that supports Java.  IkarusOS  Product Page   IkarusOS  Manual   Ikarus OS "Level 1" (CPE edition)  supported functionality   Features   Level  1 (CPE)	Wireless  AP mode	No   Wireless  WDS	No   Wireless  Repeater	No   Wireless  Client	Yes   Wireless  Station	Yes   Bridging   Yes   Routing   Yes   QoS  & Bandwidth Management	Yes   Firewall   Yes   DHCP  Server	Yes   DHCP  Relay	Yes   DHCP  Client	Yes   NAT   Yes   Vlan  802.1Q	Yes   Hot  Spot	Yes   PPTP  Client   Yes   PPPoE  Client	Yes   NTP  Client	Yes   HTTP  Server	Yes   SNMP  Agent	Yes   Updates/Upgrades  Unlimited   Support  free over email   License  never expire   	2007-10-20	IkarusOS Level1,Level 1 (CPE),AntCor	24.00	https://shop.antcor.com/shop/images/ikarusoslogo.jpg	129us 	 Y 	 US:Ground:3.95,CA:Ground:3.95,UK:Ground:3.30,DE:Ground:0,AT:Ground:3.30,IE:Ground:3.30,CH:Ground:3.30,DK:Ground:3.30,PL:Ground:3.30,FR:Ground:3.30 	 AntCor 	 49993 	 Visa,MasterCard,AmericanExpress,Discover,check,WireTransfer,PayPal 	 We also accept payments by PayPal and by Bank Transfer. 	 7 	 Florida 	 Software 	 USD 	 en 	 ALL 	 new 	 Address of the items's location here

 

file_I _create_for_google.base

"link "	" title "	" description "	" expiration_date "	" label "	" price "	" image_link "	" id"	" instock "	" shipping "	" brand "	" quantity"	" payment_accepted"	" payment_notes"	" tax_percent"	" tax_region"	" product_type "	" currency "	" language "	" ship_to "	"condition"	" location"
"https://shop.antcor.com/shop/product_info.php?language=en&currency=USD&products_id=129"	"IkarusOS Level1"	"IkarusOS is a network services operating system which turns an embedded based system into a dedicated (WI-FI) router. IkarusOS enabled deployments are easily configured provisioned and monitored through IkarusOS Manager which is a software application that provides real-time visibility and control of all IkarusOS based systems of the network. The complete administration and configuration of IkarusOS systems is done through IkarusOS Manager executed from any platform that supports Java.  IkarusOS  Product Page   IkarusOS  Manual   Ikarus OS ""Level 1"" (CPE edition)  supported functionality   Features   Level  1 (CPE)	Wireless  AP mode	No   Wireless  WDS	No   Wireless  Repeater	No   Wireless  Client	Yes   Wireless  Station	Yes   Bridging   Yes   Routing   Yes   QoS  & Bandwidth Management	Yes   Firewall   Yes   DHCP  Server	Yes   DHCP  Relay	Yes   DHCP  Client	Yes   NAT   Yes   Vlan  802.1Q	Yes   Hot  Spot	Yes   PPTP  Client   Yes   PPPoE  Client	Yes   NTP  Client	Yes   HTTP  Server	Yes   SNMP  Agent	Yes   Updates/Upgrades  Unlimited   Support  free over email   License  never expire   "	10/20/07	"IkarusOS Level1,Level 1 (CPE),AntCor"	24	"https://shop.antcor.com/shop/images/ikarusoslogo.jpg"	"129us "	" Y "	" US:Ground:3.95,CA:Ground:3.95,UK:Ground:3.30,DE:Ground:0,AT:Ground:3.30,IE:Ground:3.30,CH:Ground:3.30,DK:Ground:3.30,PL:Ground:3.30,FR:Ground:3.30 "	" AntCor "	49993	" Visa,MasterCard,AmericanExpress,Discover,check,WireTransfer,PayPal "	" We also accept payments by PayPal and by Bank Transfer. "	7	" Florida "	" Software "	" USD "	" en "	" ALL "	" new "	" Address of the items's location here "

 

The difference is in the quotation marks, " " , google_base needs ?

Why I can't see which files I have uploaded in ftp://uploads.google.com/ ?

I need your help,because now I know the procedure I have to do every time in google.base, I appreciate the automation of ur contri.

Keep up.

 

Chris,

Thanx on behalf.

Share this post


Link to post
Share on other sites

i only have 2 small problems, 1 is that i have duplicate links of froogle US FTP Filename, UK, and DE under feed settings, was wondering how i can remove the duplicates. The other was that i dont have a download link, only run feed, sign up, login.

 

Thanks

Share this post


Link to post
Share on other sites

Help!!!

 

I get this message when i click on froogle Uk RUN FEED

 

File completed: froogle_uk_file.txt

Connected to uploads.google.com, for user username

uploads.google.com: FTP upload has failed!

 

When i look in the feeds folder there is no file and it is set to 777

 

All files are unmodifid.

 

Is there some thing im missing as i have does when it says in the reedme.

 

 

Thanks

Share this post


Link to post
Share on other sites
Help!!!

 

I get this message when i click on froogle Uk RUN FEED

 

File completed: froogle_uk_file.txt

Connected to uploads.google.com, for user username

uploads.google.com: FTP upload has failed!

 

When i look in the feeds folder there is no file and it is set to 777

 

All files are unmodifid.

 

Is there some thing im missing as i have does when it says in the reedme.

Thanks

 

Hi Robert,

 

It seems like you skipped a step in the configuration, as written on the readme.txt file:

 

-------------

STEP 5: Go To Admin -> Store Feeds and sign-up for whichever accounts you wish to push your store feeds to. Be sure to write down all login information and account info.

 

NOTE: To send a file to Google Base with this feeder, you first have to "Register a new bulk upload file" for every localization of Google Base you wish to sumbit. And to do so, you MUST login in your Google Base account from the login page of each localization (use the links provided in Admin -> Store Feeds).

You have 1 Google Base account, but you can only reach the localized sections only through the localized login pages.

-------------

 

As you can see on the message you pasted here, it was trying to connect to Google using the FTP user "username", which is the default one. It has to match your own settings (the user that you created in your Google Base account).

 

Regards,

 

-Ben

Share this post


Link to post
Share on other sites
Hi Norma,

 

I don't know, I have to say.... I'm very sorry I can't help on that... :(

 

I hope you can find. When/if you do, please come back here to post your solution, that will help others in the future.

 

Regards,

 

-Ben

 

Well, it's finally up and working. Last night I ran my first successful upload to Google Base. It took my programmer brother to spend 4 hours at my store, figuring out how this contrib worked and then tweaking it so it works for me. The first problem had to do with the SQL version. We got that fixed (by adding parentheses in a certain area - as posted on this forum). Then we had some problems with what directory the /feeds was supposed to be in. Ended up working only in my root website directory. Uploaded successfully, but gazillion errors. Google had problems with the label and location fields. We hard-coded the location into the feeders.php file, then took out the label field. Since he was on a roll by that time, he added the MPN field for me. We finally got a successful upload. Interesting that the UPC field was not required, as I had heard it was on this forum. Will have to go back and add that when it becomes required. My items are now searchable in Google Base. Yeah!!

Share this post


Link to post
Share on other sites

i noticed if i upload through ep then itll upload fine, but lets say if i want to modify the item itself through the control panel, and i dont input as upc code then it gives me a 1062 error, is it required if i do any adjustments through the control panel? for now i just duplicated the upc code with the part #

Share this post


Link to post
Share on other sites

Just out of curiosity, I’m trying to have my customers download their product as soon as they purchase. Is this possible?

 

Also what if I wanted to let them know it takes 7 to 10 business days after they make a purchase?

 

Is there a way to let them know this once they purchase their product?

Share this post


Link to post
Share on other sites
was wondering if any has or would know a simple way to edit the google base feed to do the following:

 

Append the product name with the category name so it goes to google as one continuous title. An example would be this:

 

title

Product1 Category1

 

Thank you all in advance for your help.

 

I am still trying to figure this one out. I have been merging the title and category in excel manually and submitting it but it would be great to have it done automatically. Does anyone have any solution to this? I just cant wrap my brain around the feeder page.

Share this post


Link to post
Share on other sites

Well, I figured it out if there is anyone out there who wants to do the same thing, ie:

 

title

Product1 Category1

 

Change:

 

products_description.products_name AS name,

 

To:

CONCAT(products_description.products_name ,' ' ,categories_description.categories_name) AS name,

 

This is extremely helpful for those who have products with names which dont quite fully describe the product and would like to append the product name with the category (or subcategory) name.

Share this post


Link to post
Share on other sites

I have my storefeeds configured so it uploads a file to googlebase just fine. Still working on getting the errors cleaned up.

 

However, my yahoo feed just won't log in. the data.txt feed is created, I just get a can't login error.

 

If I use FTP program, I can login just fine

 

Any ideas on why the feed won't log in but via FTP I can for yahoo feed?

 

Thanks.

Share this post


Link to post
Share on other sites
I have my storefeeds configured so it uploads a file to googlebase just fine. Still working on getting the errors cleaned up.

 

However, my yahoo feed just won't log in. the data.txt feed is created, I just get a can't login error.

 

If I use FTP program, I can login just fine

 

Any ideas on why the feed won't log in but via FTP I can for yahoo feed?

 

Thanks.

 

Figured it out.

 

The yahoo feeder had this:

$ftp_user_pass = YAHOO_FTP_PASSWORD;

 

Whereas the froogle feeder had this:

$ftp_user_pass = FROOGLE_FTP_PASS;

 

 

I change the yahoo feed so it read "PASS" and not "PASSWORD" and it works fine

I

Share this post


Link to post
Share on other sites

I am wondering if anyone has figured out a way of excluding certain products from being on the feed?

 

Thanks.

Share this post


Link to post
Share on other sites
Figured it out.

 

The yahoo feeder had this:

$ftp_user_pass = YAHOO_FTP_PASSWORD;

 

Whereas the froogle feeder had this:

$ftp_user_pass = FROOGLE_FTP_PASS;

I change the yahoo feed so it read "PASS" and not "PASSWORD" and it works fine

I

 

Hi varn,

 

Great that you found it, thanks for reporting it here!

 

I'll include this in the next release that I'll make at some point in the future, when I'll have more time.

 

Thanks!

 

-Ben

Share this post


Link to post
Share on other sites
Just out of curiosity, I’m trying to have my customers download their product as soon as they purchase. Is this possible?

 

Also what if I wanted to let them know it takes 7 to 10 business days after they make a purchase?

 

Is there a way to let them know this once they purchase their product?

 

Hi Stephen,

 

You are not in the right topic for that. I'd suggest that you post in a more appropriate topic, you have a better chance to get an answer.

 

Regards,

 

-Ben

Share this post


Link to post
Share on other sites

quick question! please i need some help in here

 

1st question:

.. when i run my feed of googlebase.. it shows that file is created and thats it!! it doesnt show the time for generation and it doesnot connect to ftp at all!!!

there is no error generated for ftp upload! the file generated is perfect! but the problem is that it does not upload itself!

 

2nd question:

i was using googlefeeder 1.20 and now gonna switch to automatic store feeds v3. but i am using chemo's ultimated seo urls contribution! will it work ?? or do i have to change anything for that?

 

3rd question:

this contribution is for Froogle (Google base), Yahoo, Bizrate, and the new Bidhopper Store! but if we want to send feed to pricerunner.co.uk, pricecomparison.co.uk, pricegrabber.co.uk, wht do we have to alter in it??

 

 

please guys.. help me out here.. i knw many people want to send their feeds to maximum websites!

i hope you guys will answer my questions!

thanx in advance!

bye


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites

any replies guys???? its more than 24 hours now but there is no reply :(

 

quick question! please i need some help in here

 

1st question:

.. when i run my feed of googlebase.. it shows that file is created and thats it!! it doesnt show the time for generation and it doesnot connect to ftp at all!!!

there is no error generated for ftp upload! the file generated is perfect! but the problem is that it does not upload itself!

 

2nd question:

i was using googlefeeder 1.20 and now gonna switch to automatic store feeds v3. but i am using chemo's ultimated seo urls contribution! will it work ?? or do i have to change anything for that?

 

3rd question:

this contribution is for Froogle (Google base), Yahoo, Bizrate, and the new Bidhopper Store! but if we want to send feed to pricerunner.co.uk, pricecomparison.co.uk, pricegrabber.co.uk, wht do we have to alter in it??

please guys.. help me out here.. i knw many people want to send their feeds to maximum websites!

i hope you guys will answer my questions!

thanx in advance!

bye


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites

im not sure why but i removed all my tax rates and it still calculates taxed prices and uploads prices with my tax rate included

Share this post


Link to post
Share on other sites
Well, it's finally up and working. Last night I ran my first successful upload to Google Base. It took my programmer brother to spend 4 hours at my store, figuring out how this contrib worked and then tweaking it so it works for me. The first problem had to do with the SQL version. We got that fixed (by adding parentheses in a certain area - as posted on this forum). Then we had some problems with what directory the /feeds was supposed to be in. Ended up working only in my root website directory. Uploaded successfully, but gazillion errors. Google had problems with the label and location fields. We hard-coded the location into the feeders.php file, then took out the label field. Since he was on a roll by that time, he added the MPN field for me. We finally got a successful upload. Interesting that the UPC field was not required, as I had heard it was on this forum. Will have to go back and add that when it becomes required. My items are now searchable in Google Base. Yeah!!

 

 

Hello,

 

Can you tell me how and where you hardcoded the location in the feeders.php file. I have the same errors (google error: "We didn't understand this location", and "This attribute is no longer supported. Please use a supported attribute. - help shipping:" ,and "This attribute is no longer supported. Please use a supported attribute. - help label:" ).

 

I would like to get the location, label and shipping errors cleaned up so I can successfully upload my feed.

 

Thanks for any help you can give me!!

Share this post


Link to post
Share on other sites

everything is working file till creation of the file... the file is 8mb and is ok with me.. but its not being uploaded!!

 

the resulting page shows

 

File completed: gbase.txt
thats it!! nothing more!! rest page is blank!!

 

and i tried putting wrong password.. but it shows same result!! thats mean its not connecting to ftp!!

 

im using GODADDY hosting!! (it might help)

 

 

wht should i do?????? please i need help as soon as possible!!!


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites

I've found the way special prices are included / excluded in the froogle feed to be dependant on expiry date.

e.g. when you create a special with no exp date the form enters 0000-00-00 into the specials table.

 

For a standard osc store this is fine. hoevever if you use, store manager or some other way of importing / adding / changing specials the exp date field may be given a null value.

 

the froogle feeder then doesn't recognise the items special price & lists it at full price.

 

So far I've come up with several theoretical solutions, but which one is correct.

 

 

add some my sql to the feeder along the lines of -

UPDATE `specials` SET `expires_date`="0000-00-00 00:00:00" WHERE `expires_date` IS NULL

 

change the sql in the feeder (not sure how as I guess it looks at the exp date so it doesn't show specials that have expired)

Share this post


Link to post
Share on other sites

Hi Iget tis error when i run the froogle us

 

Error when connecting itself to the data base

 

anyone know how to fix

Share this post


Link to post
Share on other sites

Hello Guys,

 

I use Ultimate SEO, and i tried to upload the regular file and i'm getting erores on yahoo,

So i tried to update the yahoo.php file that nahi_sonu uploaded,

I'm getting this error:

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2) in /home/content/y/o/s/yos40/html/admin/yahoo.php on line 43
Error when connecting itself to the data base

 

this the area of 43 from row 38 to 52

//(0=False 1=True) (optional_sec must be enabled to use any options)
$optional_sec = 0;
$instock = 0;
//END of Advance Optional Values

if (!($link=mysql_connect($home,$user,$pass)))
{
echo "Error when connecting itself to the data base";
exit();
}
if (!mysql_select_db( $base , $link ))
{
echo "Error the data base does not exist";
exit();
}

 

Any body can help me

P.S.

I am not using MYSQL 5.0 i'm still using the 4.00

Share this post


Link to post
Share on other sites

I have my site on a server that I share with another one of my sites. and the feed is showing up the urls as

grunionfabrication.com/moto/product_info.php

instead of

grunionmoto.com/product_info.php

Like it should. Since grunionmoto.com is just pointing to the "moto" folder on the grunionfabrication.com server the feed is not writing the file correctly so it is getting rejected by google. Anyone know how I can fix this?

Share this post


Link to post
Share on other sites
i only have 2 small problems, 1 is that i have duplicate links of froogle US FTP Filename, UK, and DE under feed settings, was wondering how i can remove the duplicates. The other was that i dont have a download link, only run feed, sign up, login.

 

Thanks

 

Funny - I have the exact same problem. I am looking for a sql command that will delete such however have yet to find anything.

 

Anyone out there have any ideas of how to remove these? During my experiments to remove I now have 10 or more of each and every single line and still no download link to the ".txt" file once it is completed.

Share this post


Link to post
Share on other sites

i know this is going to sound very lame but does anyone have the signin/up URLs for MSN,yahoo etc

 

google was easy to find but my serach talents are letting me down this morning <_<

 

TA

 

Si.

Edited by scranmer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×