Jump to content
Sign in to follow this  
mushindo

Automatic Store Feeds Contribution

Recommended Posts

Hi

 

The same problem with me also.

 

FTP open connection failed to uploads.google.com

 

but i try to connect to uploads.google.com with my username and password into an FTP client, it is successfully connected.

 

but using code it gives me the above error.

 

 

FTP LOGIN ISSUE:

 

With the revamp of Froogle, now called Google Base, their system now requires you to do the following for creating a bulk upload for your store:

 

1. Create a bulk upload: indicate filename, title, description, and optional URL.

2. Create a new FTP account: many people miss this one and just use the email / password to FTP into google for uploading bulk uploads.

 

The issue I have run across today, and confirmed with 3 other customers, is that after setting up an FTP login set and including it into your admin "feed settings" section, it continued to come back with the FTP connection errors most people are reporting.

 

My next step in troubleshooting was to attempt to use these logins via a browser and an FTP client, with logic being IF I can successfully login via browser or FTP client, that indicates the issue is most likely not with the coding but with Google.

 

Sure enough I plugged in uploads.google.com then my username and password into an FTP client, and it rejected it.

 

This may or may not be the reason so many people feeds are being rejected, but if you do experience a FTP error when running your feed, I suggest you take your logins and plug them into an FTP program first. If it rejects it, then report it to google. If not, then report it back here with the exact error to help us improve the code.

 

Thanks.

Share this post


Link to post
Share on other sites

Hello,

 

I've installed 3.2a, haven't installed any of the updates yet.

 

I have my login settings correct, and I ran the PHP code to update the database as instructed.

 

When I run my froogle from the admin area, I get the following showing up on my web browser.

 

: SQL error Unknown column 'products.manufacturers_id' in 'on clause'| sql = SELECT concat( 'http://www.oldfoundry.com/catalog/product_info.php?language=en&currency=USD&products_id=' ,products.products_id) AS product_url, products_model AS prodModel, products_weight, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price) * 1,2) AS price, CONCAT( 'http://www.oldfoundry.com/catalog/images/' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM categories, categories_description, products, products_description, products_to_categories left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id ) left join specials on ( specials.products_id = products.products_id AND ( ( (specials.expires_date > CURRENT_DATE) OR (specials.expires_date = 0) ) AND ( specials.status = 1 ) ) ) WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id AND products.products_status != 0 AND products.products_price != 0 AND products.products_price != '' AND products_description.language_id = '1' AND products_description.language_id = '1' AND categories_description.language_id = '1' ORDER BY products.products_id ASC

 

 

Any ideas?

 

Thank you, wonderful contribution,

 

Jason

Share this post


Link to post
Share on other sites

Hello again,

 

I have installed the 3.3b update that included the SQL update, and I still get the same screen output.

 

Thank you for any suggestions, I wish I could figure it out,

 

Jason

Share this post


Link to post
Share on other sites

I have been searching for a fix for this for DAYS - thank you so much for posting this. Adding the ( ) was just what I needed to get it working!

 

Thank you, thank you, thank you!

Jeana

 

I think the link is not working - here is what I changed.

 

MySQL 5 Fix

 

The current version of the Froogle Feeder errors when using MySQL 5. This can be resolved by making the following change: (Just add the parenthesis and see what happens)

 

Around line 89:

 

FROM categories,

categories_description,

products,

products_description,

products_to_categories

 

Change to:

 

FROM (categories,

categories_description,

products,

products_description,

products_to_categories)

Share this post


Link to post
Share on other sites

Hi

 

The same problem with me also.

 

FTP open connection failed to uploads.google.com

 

but i try to connect to uploads.google.com with my username and password into an FTP client, it is successfully connected.

 

but using code it gives me the above error.

 

Was this issue ever resolved, and if so how? I have the same issue. There is a work around from google that will pull the file from their site, and you can schedule from their site as well. But I want to be in control of when I push instead of their pulling method.

Share this post


Link to post
Share on other sites

Hello all,

 

I was wondering if anybody can tell me how i can get the froogleus.php to pull the product type from the top/main category level instead of the lowest/bottom subcategory level.

 

For example, I sell Flat Screen TV Wall Mounts<----(this is the top/main category level)

and the subcategories read like this; Mounts17''to32''TV<---(thisislowest/bottomsubcategory level)

 

Currently the feed pulls the product type from the bottom/lower subcategory level (Mounts17''to32''TV) but i want it to pull it from the top/main category level (Flat Screen TV Wall Mounts).

 

Can anybody tell me how to do this.

 

I think the code to be changed is this one in froogleus.php (but i may be wrong)

 

--------------------------------------------------------------------------------------------------------------------

 

if($product_type == 1)

{

$catNameTemp = strtolower($catName);

$output .= " \t " . $row->catName;

 

----------------------------------------------------------------------------------------------------------------------

 

Thank you in advance

Share this post


Link to post
Share on other sites

I have been searching for a fix for this for DAYS - thank you so much for posting this. Adding the ( ) was just what I needed to get it working!

 

Thank you, thank you, thank you!

Jeana

 

 

well i found this code and noticed it was already fixed, but i was still getting the same error..

then i noticed that the default language id was improperly named

define('DEFAULT_LANGUAGE', 1);   //Change this to the id of your language.  BY default 1 is english

 

so i changed that to this and all is well

define('DEFAULT_LANGUAGE_ID', 1);   //Change this to the id of your language.  BY default 1 is english

 

fixed it for me and thanks guys for another great contribution even if it does take some google mastering to get it running

 

also will there be a version for amazon that runs on 2.3

Edited by MattFlemm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×