Jump to content
Latest News: (loading..)
Sign in to follow this  
gentlegiant

table rate shipping not working at all

Recommended Posts

ok, Other shipping modules work such as flat rate etc....

But, when I'm ONLY using table rate then nothing is displayed at all about shipping costs and no cost is added on. if I add flat rate or only have flat rate the section on shipping costs is their but still doesn't display table rate.

I've tried Additional Shipping Options for Table Rate Module (2.2MS2)v1.1 by Justin Pinder and it does the same thing..

 

Anyone got any ideas?

 

Thanks

Edited by gentlegiant

Share this post


Link to post
Share on other sites

You did not say how your table rate was set up in your post. I assume you have enable the table rate (set to true), then another setting that can be looked at is the table rate is based on weight or price. If it happens to be weight, and your products have no weight, then no cost of shipping would show up.

I may be stating the obviour but just in case.

Ken

 

ok, Other shipping modules work such as flat rate etc....

But, when I'm ONLY using table rate then nothing is displayed at all about shipping costs and no cost is added on. if I add flat rate or only have flat rate the section on shipping costs is their but still doesn't display table rate.

I've tried Additional Shipping Options for Table Rate Module (2.2MS2)v1.1 by Justin Pinder and it does the same thing..

 

Anyone got any ideas?

 

Thanks


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Setup as follows

 

Table Rate Shipping Options

 

Enable Table Method

True

 

Shipping Table

25:8.50,50:5.50,10000:0.00

 

Shipping Table 2-Day

 

 

Shipping Table 3-Day

 

 

Shipping Table Next-Day

 

 

Table Method

weight

 

Handling Fee

1

 

Tax Class

--none--

 

Shipping Zone

Normal - UK Mainland

 

Sort Order

0

 

I last had the table rate update on....

 

You did not say how your table rate was set up in your post. I assume you have enable the table rate (set to true), then another setting that can be looked at is the table rate is based on weight or price. If it happens to be weight, and your products have no weight, then no cost of shipping would show up.

I may be stating the obviour but just in case.

Ken

Share this post


Link to post
Share on other sites
Setup as follows

 

Table Method

weight

So, your table rate is based on weight? Do all your product have weight? It seems from the table in your post, the heavier, the less shipping cost, 25kg (or whatever unit) costs ?8.50; 50kg cost ?5.50, which does not make sense? but would make sense if it is based on price, i.e., the more customers spend, the less cost for shipping. and are you using a modified table rate module?

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

and try to set the shipping zone to 'none'...

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

OK I've now configured it the way we want it.... It's still not adding ANYTHING on for shipping nor does shipping appear during checkout.

 

Enable Table Method

True

 

Shipping Table

50:9.95,100:29.95

 

Shipping Table 2-Day

 

Shipping Table 3-Day

 

Shipping Table Next-Day

 

Table Method

weight

 

Handling Fee

0

 

Tax Class

--none--

 

Shipping Zone

--none--

 

Sort Order

0

 

and try to set the shipping zone to 'none'...

 

Ken

Share this post


Link to post
Share on other sites
Table Method

weight

Could you confirm the product you tested on actually have a none-zero weight (>0)?

 

ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Table Method

weight

Could you confirm the product you tested on actually has a none-zero weight (>0)?

 

ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Right, the products that have a 9.95 shipping are set to 1kg, the ones that require 29.95 shipping have 100kg waight....

I've got it to finally give me shipping, however it charges 9.95 for the smaller items which is ok.... but then charges 59.90 ( 2X 29.95) for the larger items.....

 

Any ideas?

 

Could you confirm the product you tested on actually has a none-zero weight (>0)?

 

ken

Share this post


Link to post
Share on other sites
Right, the products that have a 9.95 shipping are set to 1kg, the ones that require 29.95 shipping have 100kg waight....

I've got it to finally give me shipping, however it charges 9.95 for the smaller items which is ok.... but then charges 59.90 ( 2X 29.95) for the larger items.....

 

Any ideas?

 

Sorry, no idea. If you are using a modified shipping module, better to post your question to that support thread for that contribution. :o

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Right, the products that have a 9.95 shipping are set to 1kg, the ones that require 29.95 shipping have 100kg waight....

I've got it to finally give me shipping, however it charges 9.95 for the smaller items which is ok.... but then charges 59.90 ( 2X 29.95) for the larger items.....

 

Any ideas?

 

There are 3 other parameters that you may want to play with. They are under the configuration -> shippng/packaging. Try to set the maximum package weight to over 100kg, and both the tare weight & percentage increase to zero.

 

HTH

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
There are 3 other parameters that you may want to play with. They are under the configuration -> shippng/packaging. Try to set the maximum package weight to over 100kg, and both the tare weight & percentage increase to zero.

 

HTH

Ken

There is a problem with the Shipping Table Rate Module. It does not calculate the different rates, just goes by the first entry of each table.

 

There is a bug report on this:

http://www.oscommerce.com/community/bugs,9...pping%2BModules

 

But the bug report does not have a fix. It suggests making changes with paypal, but that does no good for those for us who are not using paypal.

 

Has anyone come up with a fix?

Share this post


Link to post
Share on other sites
There is a problem with the Shipping Table Rate Module. It does not calculate the different rates, just goes by the first entry of each table.

 

There is a bug report on this:

http://www.oscommerce.com/community/bugs,9...pping%2BModules

 

But the bug report does not have a fix. It suggests making changes with paypal, but that does no good for those for us who are not using paypal.

 

Has anyone come up with a fix?

 

I'm having the same issues Newtech and I'm also looking for a solution.

 

Darkwing

Share this post


Link to post
Share on other sites
There is a problem with the Shipping Table Rate Module. It does not calculate the different rates, just goes by the first entry of each table.

 

There is a bug report on this:

http://www.oscommerce.com/community/bugs,9...pping%2BModules

 

But the bug report does not have a fix. It suggests making changes with paypal, but that does no good for those for us who are not using paypal.

 

Has anyone come up with a fix?

Has anybody been able to get multiple tables shipping based upon price to work?

Share this post


Link to post
Share on other sites

:'(

Has anybody been able to get multiple tables shipping based upon price to work?

 

I am very much interested in this as well. I can't see how I can get the table to work through multiple zones.

 

In fact if I choose a zone the table method is blocked. I am not sure if the table method is at all workable. Perhaps I am beating a dead horse.

 

There is some option that I need to fix as my weighs are being converted from KG to Lbs. I don't know where to turn this off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×