Latest News: (loading..)
Sign in to follow this  
Followers 0
anderskiel

pbpBB2 and osC shared account creation

214 posts in this topic

I got the "Hacking Attempt" with this: index.php?trid=b531685276782970d1a5c6460e6fca50

 

The trid looked good to me, but it seemed that the session record was not found in your database trans_phpbb table.

 

Please make sure you have setup the database table correctly, and check the session records to see if they exist or not.

 

 

I did step 2.1 SWL Script.

It looks like that:

create table trans_phpbb ( osCsid char(32) default '' not null, sess_uid int(11) default 0 not null, sess_uip char(8) default '' not null, sess_logged int(1) default 0 not null, sess_trans char(32) default '' not null, primary key (sess_uid))

 

So here is a capture screen to see my table looks like:

http://www.orbitalcomputers.ro/Picture2.jpg

 

I do not know how to do.

 

Please help.

Share this post


Link to post
Share on other sites
I did step 2.1 SWL Script.

It looks like that:

create table trans_phpbb ( osCsid char(32) default '' not null, sess_uid int(11) default 0 not null, sess_uip char(8) default '' not null, sess_logged int(1) default 0 not null, sess_trans char(32) default '' not null, primary key (sess_uid))

 

So here is a capture screen to see my table looks like:

http://www.orbitalcomputers.ro/Picture2.jpg

 

I do not know how to do.

 

Please help.

Well, your trans_phpbb table looked good to me, except that the phpbb/common.php couldn't locate this table.

 

Please make sure your phpBB is using the same database as your osCommerce, otherwise this contrib will not work.

Share this post


Link to post
Share on other sites

Kevin and Olimpiu,

 

Your problems looked identical to me, both your phpBB couldn't locate the database table trans_phpbb.

 

Kevin has a windows based server, how about Olimpiu?

 

I need to know if this problem is related to the server base, so I can try to fix it.

Share this post


Link to post
Share on other sites
Well, your trans_phpbb table looked good to me, except that the phpbb/common.php couldn't locate this table.

 

Please make sure your phpBB is using the same database as your osCommerce, otherwise this contrib will not work.

 

 

Yes, it is the same DataBase used.

Could it be a must have a setting on the Apache Server that in this moment it is possible not being enabled?

Share this post


Link to post
Share on other sites
Kevin and Olimpiu,

 

Your problems looked identical to me, both your phpBB couldn't locate the database table trans_phpbb.

 

Kevin has a windows based server, how about Olimpiu?

 

I need to know if this problem is related to the server base, so I can try to fix it.

 

 

No Alex, I am hosted at a company. The site is not installed on Wondows Sistem.

Share this post


Link to post
Share on other sites
No Alex, I am hosted at a company. The site is not installed on Wondows Sistem.

 

Just for info

 

My config is

 

win xp

ip address 192.168.1.100 (which is set up as that in osc/phpbb config files and apache)

Apache 2.2.3

PHP 5.2.0

php 5.0.27-community-nt

 

Thanks for the help btw, i know it makes even even more awkward when the site isnt available over the net.

 

Cheers

 

Kev

Share this post


Link to post
Share on other sites
How about your MySQL version?

 

HERE IS MY SERVER INFO

 

 

Server Host: ns.20.ro (127.0.0.1) Database Host: localhost (127.0.0.1)

Server OS: Linux 2.6.10-2.3.legacy_FC2 Database: MySQL 4.1.19-standard

Server Date: 02/03/2007 14:51:14 Datebase Date: 02/03/2007 14:51:14

Server Up Time: 15:51:14 up 41 days, 1:31, 0 users, load average: 0.04, 0.04, 0.05

 

HTTP Server: Apache

PHP Version: 4.3.11 (Zend: 1.3.0)

Share this post


Link to post
Share on other sites
sorry mysql is 5.0.27-community-nt lol

 

 

Hi Alex,

 

I resolved my problems with integration.

 

IMPORTANT READ THIS:

Reinstalled Oscommerce, and at the 2nd screen I've checked option for SESSIONS TO BE SAVED IN DataBase. now it works.

 

With this option checked this Integration works perfectly.

 

Great contrib!!!!!

Thx Alex for yout support. :)

Share this post


Link to post
Share on other sites
Hi Alex,

 

I resolved my problems with integration.

 

IMPORTANT READ THIS:

Reinstalled Oscommerce, and at the 2nd screen I've checked option for SESSIONS TO BE SAVED IN DataBase. now it works.

 

With this option checked this Integration works perfectly.

 

Great contrib!!!!!

Thx Alex for yout support. :)

 

Wow thats solved it, inspired fix there, although if you go into includes/configure.php there is a setting in there

which is:

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

It was blank before, changed it to mysql and it worked first time :) (that will save reinstalls)

 

Thanks everyone for the help :D

Edited by kevicho

Share this post


Link to post
Share on other sites
Wow thats solved it, inspired fix there, although if you go into includes/configure.php there is a setting in there

which is:

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

It was blank before, changed it to mysql and it worked first time :) (that will save reinstalls)

 

Thanks everyone for the help :D

 

Glad to see that you got it work too Kev. :)

 

So it seems we get Hacking Attempt if STORE SESSIONS is leaved empty.

To solve the "Hacking attempt" issue, check includes/configure.php for this line.

 

Setting STORE SESSIONS to 'mysql' makes this contribution work.

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'.

Share this post


Link to post
Share on other sites

I'm glad it finally worked. I didn't think about that problem before. I will put it in the install guide with the next update version.

 

:thumbsup:

Share this post


Link to post
Share on other sites

Just installed your hack a while back and I found a bug with it, so i did a clean install of PHPBB latest version an OSCommerce latest version. Everything is working like a charm, apart from the new post icon on PHPBB does not work. For example

two user called A and B

 

now if User a is logged off, and user B has posted a new message. then user a decides to logon on, when he does there are no new message icon being displayed on any of the threads even though new messages have been posted.

 

however if Both User A and User B are online at the same time and User B has Posted a message, the Message indicator works. The only time this does not work is when the user is not logged on to the board. I'm useing the latest version of the PHPBB intergration.

 

 

Any ideas. btw I used the file in the Rar file to replace the existing PHPBB files.

Share this post


Link to post
Share on other sites

Also, can you sne me the Code chamhes you made in PHPBB as I would like to try it on another PGPBB version.

 

TIA

Share this post


Link to post
Share on other sites
Also, can you sne me the Code chamhes you made in PHPBB as I would like to try it on another PGPBB version.

 

TIA

 

God knows what i was typeing.

 

Translation Time

 

Also, can you send me the code changes you made in PHPBB as I would like to try it on another PHPBB version.

 

TIA

Share this post


Link to post
Share on other sites
God knows what i was typeing.

 

Translation Time

 

Also, can you send me the code changes you made in PHPBB as I would like to try it on another PHPBB version.

 

TIA

Please look into the files in phpbb2 folder of the package. All mods related are commented.

 

I do know about the new post problem, but did have time to dig into it.

Edited by AlexStudio

Share this post


Link to post
Share on other sites
Please look into the files in phpbb2 folder of the package. All mods related are commented.

 

I do know about the new post problem, but did have time to dig into it.

 

 

o.k. so will that be fixed in the next release? :)

Share this post


Link to post
Share on other sites
o.k. so will that be fixed in the next release? :)

Don't know yet. I didn't have time to dig into it, so I don't know why it's not working. We'll see.

Share this post


Link to post
Share on other sites

phpBB2.0.22 Integration v1.3 update released

  • Bug fixed - catalog/create_account.php didn't log trans_phpbb session data into database after account creation form successfully submitted, which caused the new customer not be able login to forum, nor can he logout from store.
  • Bug fixed - Posting new message prior to login would redirect users to the login form in the forum. Fixed phpbb2/login.php to redirect all login attempts to the osCommerce login page.
  • Bug fixed - The login code in catalog/login.php came with the original phpbb2.0.8a integration contribution updated the user_session_time and user_lastvisit fields in phpbb_users table incorrectly, which caused the new posts icon not working properly. Fixed catalog/login.php to use the correct time to update the user_lastvisit field, and not to update user_session_time on login. Now the new posts icon works.
  • Bug fixed - catalog/logoff.php skipped to kill session if no data found in trans_phpbb table. Now it kills session no matter if the trans_phpbb session record exists or not.

Edited by AlexStudio

Share this post


Link to post
Share on other sites
phpBB2.0.22 Integration v1.3 update released
  • Bug fixed - catalog/create_account.php didn't log trans_phpbb session data into database after account creation form successfully submitted, which caused the new customer not be able login to forum, nor can he logout from store.
  • Bug fixed - Posting new message prior to login would redirect users to the login form in the forum. Fixed phpbb2/login.php to redirect all login attempts to the osCommerce login page.
  • Bug fixed - The login code in catalog/login.php came with the original phpbb2.0.8a integration contribution updated the user_session_time and user_lastvisit fields in phpbb_users table incorrectly, which caused the new posts icon not working properly. Fixed catalog/login.php to use the correct time to update the user_lastvisit field, and not to update user_session_time on login. Now the new posts icon works.
  • Bug fixed - catalog/logoff.php skipped to kill session if no data found in trans_phpbb table. Now it kills session no matter if the trans_phpbb session record exists or not.

 

 

Hi Alex,

I've made an update from v1.2 to v1.3 and now i got errors:

If i choose LogOut from phpbb then it redirects me to

http://orbitalcomputers.ro/catalog/logoff....d3505807a819b5b

 

Something seems to not work in logoff.php

Share this post


Link to post
Share on other sites
Hi Alex,

I've made an update from v1.2 to v1.3 and now i got errors:

If i choose LogOut from phpbb then it redirects me to

http://orbitalcomputers.ro/catalog/logoff....d3505807a819b5b

 

Something seems to not work in logoff.php

 

Solved the problem:

 

There is a "}" in the code that i've commented and now it works.

 

here is my correction:

 

 

FIND THE LINES:

 

$cart->reset();

 

//// BOF phpBB2 Integration v1.2

}

if ( isset( $HTTP_GET_VARS[ 'redirect' ] )) //// <---logoff from phpBB, so send user back to phpbb

{

 

REPLACE WITH:

 

$cart->reset();

 

//// BOF phpBB2 Integration v1.2

if ( isset( $HTTP_GET_VARS[ 'redirect' ] )) //// <---logoff from phpBB, so send user back to phpbb

{

Share this post


Link to post
Share on other sites

I checked the package again, the code in catalog/logoff.php is good.

 

Only I forgot that there is no file in the package to be compared with for upgrading from 1.2 to 1.3.

 

So, please do it carefully and don't miss any thing in the updated code. I will fix it in the next update package soon.

Share this post


Link to post
Share on other sites

Hi, how does this compare/offer advantage over phpBB-osCommerce Bridge which sounds quite good

Share this post


Link to post
Share on other sites
Hi, how does this compare/offer advantage over phpBB-osCommerce Bridge which sounds quite good

The phpBB-osCommerce Bridge forces username as firstname + last initial, phpBB2 integration allows any username chosen.

 

phpBB-osCommerce Bridge requires phpBB to be installed under osCommerce catalog folder, and share osCommerce sessions. However, if you login from phpBB, you are not login to osCommerce. phpBB2 integration recommends to install phpBB in a folder aside, and no matter where you login from, you're login to both side.

 

Both phpBB2 integration and phpBB-osCommerce Bridge contrib are based on phpbb2.0.8a integration, but phpBB2 integration fixed more bugs in the old code, and it is ready to support phpBB SEO.

 

Also, I believe this phpBB2 integration contrib has a better install guide document, and is easier to install.

 

All above comparisons between these 2 contrib are based on my impression of the first phpBB-osCommerce Bridge version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0