Jump to content

Archived

This topic is now archived and is closed to further replies.

olsonsp4c

Missing Customers in Admin

Recommended Posts

Hello!

 

I migrated by store from one server to another and changed domains...

 

I duplicated the SQL, uploaded the files to the new server, and in the SQL, deleted all my old customers and reset the customers table autoincrement to 1. Then I created 2 customers to test my shop. These customers are not showing up in the Admin when I click "Customers"

 

I checked the SQL and they are in the database properly as 1 and 2; however, they are not showing up in the Admin. I checked customers.php in /admin against the original and they are exactly the same.

 

Any ideas why?

 

thanks!

 

Scott

Share this post


Link to post
Share on other sites

I trouble shot some more and figured out that I am getting these errors at the first login, this may be causing issues as I know these errors are related directly to phpbb2:

 

Warning: Missing argument 3 for tep_get_zone_name() in /home/p4x/www/www/includes/functions/general.php on line 300

 

Warning: Cannot modify header information - headers already sent by (output started at /home/p4x/www/www/includes/functions/general.php:300) in /home/p4x/www/www/includes/functions/general.php on line 33

 

I've thoroughly researched these issues in the forums and can find no good solution.

 

It's frustrating as I've been trying to get my site live for over 1 year and I can't seem to get the code to mesh!

 

Appreciate you all.

 

Scott

olsonsp4c

Share this post


Link to post
Share on other sites
I trouble shot some more and figured out that I am getting these errors at the first login, this may be causing issues as I know these errors are related directly to phpbb2:

 

Warning: Missing argument 3 for tep_get_zone_name() in /home/p4x/www/www/includes/functions/general.php on line 300

 

Warning: Cannot modify header information - headers already sent by (output started at /home/p4x/www/www/includes/functions/general.php:300) in /home/p4x/www/www/includes/functions/general.php on line 33

 

I've thoroughly researched these issues in the forums and can find no good solution.

 

It's frustrating as I've been trying to get my site live for over 1 year and I can't seem to get the code to mesh!

 

Appreciate you all.

 

Scott

olsonsp4c

 

Try restore the backup again in your database


Wade Morris

Amarillo, Texas

 

Before you do any changes on your site you need to do BACKUP! BACKUP!

Share this post


Link to post
Share on other sites
Try restore the backup again in your database

 

Thanks! Did this and still the same problem... appreciate the response.

Share this post


Link to post
Share on other sites
Thanks! Did this and still the same problem... appreciate the response.

 

 

are you still getting that warning?


Wade Morris

Amarillo, Texas

 

Before you do any changes on your site you need to do BACKUP! BACKUP!

Share this post


Link to post
Share on other sites

I am still getting the same warning - I've checked the "white space" at the beginning and end of general.php and that was not a problem. I'll look back through for the header info - this only happens during the 1st login AFTER the successful account creation and subsequent logoff. It never happens again after that (I can then login without the error); however, though the customer info is in the database, it doesn't show up in the admin under "Customers"...

 

appreciate you all...

 

Scott

olsonsp4c :D

Share this post


Link to post
Share on other sites

OK, I combed through general.php - there is only 1 call to header() in the line 33 mentioned in the error. Still confused. I'm clueless as far as the zone error on line 300... below is line 300 of general.php:

 

////
// Returns the zone (State/Province) name
// TABLES: zones
[300]  function tep_get_zone_name($country_id, $zone_id, $default_zone) {
$zone_query = tep_db_query("select zone_name from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country_id . "' and zone_id = '" . (int)$zone_id . "'");
if (tep_db_num_rows($zone_query)) {
  $zone = tep_db_fetch_array($zone_query);
  return $zone['zone_name'];
} else {
  return $default_zone;
}
 }

 

Thanks!

Scott (olsonsp4c)

Share this post


Link to post
Share on other sites

×