Jump to content
Sign in to follow this  
derrickh

Google Checkout Level 2

Recommended Posts

Derrick, thanks for all your efforts.

 

I wish to uninstall your contribution before trying the official google version. Could you tell me how to uninstall the sql entries please; or will it not cause a problem if I leave the entries? Will disabling your vesion in admin, and then removing the files and edits be satisfactory?

 

Thanks

Dave


-Dave

Share this post


Link to post
Share on other sites

Leaving the SQL inserts wont hurt anything, they're only for the config screen and if they're left in, they will just be ignored. To remove the contrib, you can just undo the edits to the shoppingcart.php file.

 

D

 

Derrick, thanks for all your efforts.

 

I wish to uninstall your contribution before trying the official google version. Could you tell me how to uninstall the sql entries please; or will it not cause a problem if I leave the entries? Will disabling your vesion in admin, and then removing the files and edits be satisfactory?

 

Thanks

Dave

Share this post


Link to post
Share on other sites

Dear All,

 

I am a php dummy. The best thing I can undersatnd google checkout contribution is to copy those files into related folder. I did see Google Check out under Payments Module. I click Install, it was installed successfully. When I click Edit to enter the google "merchant ID" and "merchant key", I got the following error:

 

Fatal error: Call to undefined function: tep_cfg_select_multioption() in /home/*****/public_html/admin/modules.php(228) : eval()'d code on line 1

 

Can anyone help me with this? Or if you know the correct link of solving this problem, please direct it to me. Thank you.

 

Grant

Share this post


Link to post
Share on other sites

So quiet here, no one knows?

Dear All,

 

I am a php dummy. The best thing I can undersatnd google checkout contribution is to copy those files into related folder. I did see Google Check out under Payments Module. I click Install, it was installed successfully. When I click Edit to enter the google "merchant ID" and "merchant key", I got the following error:

 

Fatal error: Call to undefined function: tep_cfg_select_multioption() in /home/*****/public_html/admin/modules.php(228) : eval()'d code on line 1

 

Can anyone help me with this? Or if you know the correct link of solving this problem, please direct it to me. Thank you.

 

Grant

Share this post


Link to post
Share on other sites

Does anyone use SWREG (www.swreg.org)? I see they just released new pricing and have a lot of options. Just curious on anyone?s experience.

 

Thanks,

 

Scott

Share this post


Link to post
Share on other sites

I wanted to verify if my server is compatable for this. When I check server info from the admin panel this is what i have:

 

I have SSL

XML says: XML Support active

XML Namespace Support active

EXPAT Version 1.95.6

 

(is the expat different then the domxml I didnt see domxml anywhere in my server info.)

 

Curl support enabled

libcurl/7.11.1 OpenSSL/0.9.7a ipv6 zlib/1.2.1.2

 

Will these work with this contribution??

Share this post


Link to post
Share on other sites

Has anyone successfully removed this contrib? Does anyone have any suggestions?

 

I really like this contrib, thought it was working well, untill I had 6 sales in one night and none of them removed the stock or showed as a sale in my admin.

 

It is working properly with the shipping and such, however, I need to have the stock removed, and thats not happening.

Share this post


Link to post
Share on other sites
Has anyone successfully removed this contrib? Does anyone have any suggestions?

 

I really like this contrib, thought it was working well, untill I had 6 sales in one night and none of them removed the stock or showed as a sale in my admin.

 

It is working properly with the shipping and such, however, I need to have the stock removed, and thats not happening.

 

Well, I just found the post in this topic about the api callback, perhaps this will fix my stock removal issue, we'll see. I'll be happy to keep the contrib if it is.

Share this post


Link to post
Share on other sites

Hi

 

I can't use discount coupon in google checkout. Have this contribution option for discount?

Or have google checkout option for discount?

Share this post


Link to post
Share on other sites

Derrick, I just noticed this post:

 

3. All of this is moot. Now that Google has released their own OSCommerce Contrib, I'm shutting this one down unless a reason comes up to keep it going. I hope it was a decent bridge for everyone that used it during the 4 weeks it was in use.

Thanks,

 

Derrick Hopkins

 

After reviewing the google release and the support thread for it, I think I'll stay with this one for now. I really appreciate all the work you put into it, it has helped many of us who otherwise would have been stuck. I wish you'd stick with us who have decided to stick with this contrib.

 

Overall I am very happy with it (even though I thought of removing it), while it has its little annoying nuances it does work well for me.

 

I did have an issue with the coupon codes and was told this by the google dev team " Google generated coupons and Merchant Calculations can not be used in conjunction with each other at this time. If you wish to offer coupons, you must either offer coupons through your Merchant Calculations results, or you just not perform Merchant Calculations, using only flat rate shipping and tax tables. If you eliminate Merchant Calculations you will be able to offer Google generated coupons. "

 

I had not been aware that there was a coupon already set up in the default code to give $10 off to anyone who uses ANY coupon code. I had set up the coupons through google for 20% and gave out the code, then had a customer use that code and they received $10 off a $20 order. I freaked out, then the google api support pointed my code error out.

 

The biggest problem with setting up a coupon in the code is that the customer can enter any ol thing into the coupon code box at checkout and do it several times as there is no limit on the number of uses per coupon. I didnt want someone figuring that one out and using coupon codes till they received items for free.

 

 

I changed the info in the Google_Button_Code.php to the following to prevent use of coupons. Around line 53

 

$accept_merchant_coupons = "false";

$accept_gift_certificates = "false";

 

My biggest issue at this point is, if there is a stock quantity of 0 it is still allowing customers to proceed through checkout using the google button. I had a customer checkout twice with the same cart on two different days.

 

It also doesnt change the item to inactive if the purchase drops the quantity to 0. I have been going in and doing this manually. The callback seems to be working ok otherwise.

 

I did notice too that the shipping on my other store (which is a table rate) appears to be working OK and calculating correctly when checking out through google but when it comes back to my store (in my admin) it is way off. Since the customer is paying correctly I am not too concerned about it, but it is something I have to double check with every order to be sure they didnt pay that price.

 

Guess we'll have to help each other out on this one till they get the bugs worked out on the google sponsored contrib

Share this post


Link to post
Share on other sites

HI

 

Just adding my $0.02

 

This Mod just works! Dont forget to make the change at this post http://forums.oscommerce.com/index.php?sho...24396&st=99

 

I have used goggle's own OSCommerce Contrib and it is very buggy. can't get it to work.

 

 

My only request is to use the product_modle instead of the product_id when the order is written to Oscommerce. This change was made from version 2.5 to 2.6. If anyone knows how to change this please let me know.

 

Thanks

 

Joe


----------------------------

Long Island, New York

Share this post


Link to post
Share on other sites

One other thing i noticed is that when the shipping price is sent back to oscommerce it is doubled. if anyone has aqny idea how to correct this please let us know

 

thanks

 

joe


----------------------------

Long Island, New York

Share this post


Link to post
Share on other sites

I have had some not so tech savvy buyers this past week who seemed confused by my cart and checkout.

 

I have used some borrowed code from another post here (Thank you everyone on this topic). I have a one page checkout now, which I am very happy with.

 

The problem is, buyers were clicking the checkout and proceeding through then emailing and calling because they wanted to pay with a credit card even though I had noted in several places that this was the checkout for check/money order/cash.

 

For some reason, even though the google checkout button stands out significantly on the page, they just followed the flow of the site and clicked checkout, ignoring the google checkout button.

 

I worked on the shoping_cart.php and wiggled it around a little so that now the only checkout button is the google checkout and put a text hyperlink to the checkout page for check/money order buyers. "Click here to checkout with cash, money order, or personal check." I've also changed the link in my header from the checkout page to the shopping cart page. (Example: When one clicks "Checkout" it takes them to the shopping cart where the google button is)

 

I havent had any buyer errors since, and this seems to be working well. (If you'd like to see it PM me for my site url).

 

I prefer to have buyers use google checkout over cash as I hate to wait to see if they were just playing on my site or a serious buyer. I dont mind the little quirks of this contrib and since googles free for 2007 I would rather use it!

 

I just thought I would offer my situation as an example if some others were having the same issue.

 

I am still a php infant, learning as I go. If I find out any little tweaks to make this work better for us I will certainly pass them along.

 

 

(Thanks again Derrick for this contrib! :thumbsup: )

Share this post


Link to post
Share on other sites
Hello, my server checks out ok, but I am getting this error when entering the sql file.

 

*************

Error

 

SQL query:

 

INSERT INTO `configuration_group` ( `configuration_group_id` , `configuration_group_title` , `configuration_group_description` , `sort_order` , `visible` )

VALUES ( 300, 'Google Checkout', 'Set up values for Google Checkout', 22, 1 ) ;

 

MySQL said: Documentation

#1062 - Duplicate entry '300' for key 1

 

******************

 

Anyone have any ideas?

 

Thanks in advance!

 

I encountered this same problem. I noticed that the Quick Updates contribution also uses "300" as the configuration_group_id. Unfortunately, if you change 300 to 301 (or some other #) it makes the area where you can configure Quick Updates stop working. I'd imagine there's a reference to this configuration_group_id in one of the Q.U. PHP files that needs to also be changed.

 

However even with the config page broken, Quick Updates still functions normally as best I can tell. None the less, it got me around this problem. I'll deal with the Q.U. config page later and just get Google Cart working for now.

Share this post


Link to post
Share on other sites

Hello!

 

whenever the cart is empty and you go into it, instead of a button it just says...

 

"Fatal error: You must have at least one item. in /home/bandsnow/public_html/store/catalog/includes/functions/CheckoutAPIFunctions.php on line 182"

 

How can i make this go away?!?

 

can you email me at: bandsnow@bandsnow.com

Share this post


Link to post
Share on other sites
Hello!

 

whenever the cart is empty and you go into it, instead of a button it just says...

 

"Fatal error: You must have at least one item. in /home/bandsnow/public_html/store/catalog/includes/functions/CheckoutAPIFunctions.php on line 182"

 

How can i make this go away?!?

 

can you email me at: bandsnow@bandsnow.com

 

EMAIL ME AT BRETTLEWIS@BANDSNOW.COM

Share this post


Link to post
Share on other sites

Please can anybody tell me why I get integrations errors in my google seller account, I have tried BOTH google checkout contribs and I get the following:

 

We encountered an error trying to access your server at https://www.secret-desire.co<WBR>.uk/google_ipn.php; the error we got is: java.net.MalformedURLException: no protocol:

 

I have no idea where the <WBR> comes from, I did not type it as part of the api path ?

 

This means using this contrib it returns the buyer to checkout_success.php, using the other google checkout contrib it returns them to my index.php

Share this post


Link to post
Share on other sites
Derrick,

 

I am getting the following error when trying to add any item to shopping cart.

Error calling function "CreateItem()": Missing Parameter: "$unit_price" must be provided. in /homepages/26/d174015599/htdocs/Tea-n-Honey/includes/functions/GlobalAPIFunctions.php on line 419

 

Any ideas?

 

Regards,

 

Steve

 

Hello, i have the same problem of animatco, i had a backup, i`ve restored it, and i`m having the same error.

 

Plesase, we need some help here!!!

 

Jhon

Share this post


Link to post
Share on other sites
Hello, i have the same problem of animatco, i had a backup, i`ve restored it, and i`m having the same error.

 

Plesase, we need some help here!!!

 

Jhon

 

 

 

I've been the last two hours looking for this error, i think that the problem is that some article has price of $0.0, and this make like the price was not sended.

 

But i`ve still having this problem: I have no google checkout button (seems like it could not find the image), and when i click it, it takes me to google checkout and tells me:

 

Oops!

Store name has sent Google a shopping cart with errors in it. We'll contact them to ask that they fix this problem. As this could be a temporary issue, you can go back in your browser to try checking out again.

 

I'll apreciate your help.

 

Jhon ;)

Edited by jaiversin

Share this post


Link to post
Share on other sites

I've decided to return to making updates to this contribution. It's been on my site without problem for nearly a year but if any one has issues, post them here and I'll see about getting a fix up for it.

 

D

Share this post


Link to post
Share on other sites

Hello,

I want to display My logo when client moves to google site for payment.

Any suggestion as to how this can be achieved will be highly appreciated.

 

 

Thanks,

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

That would be very cool, I would also be interested in that as well. I have seen this done on some of the big retailers sites, like Target, Toys-R-Us,etc.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Hello,

 

I have just installed google checkout 1.4beta everything is done and i have gone through every step in the installation but when i click on google checkout button in the shopping cart nothing happens!! just refreshes the page i have tried removing the form tag as well (suggested by one the people here) but it still doesnt make any difference. :(

 

Please help

 

THank you

 

hoda

Share this post


Link to post
Share on other sites

Google 1.4 isn't supported here anymore. You need to address your issues in the Google boards for OSC Google Checkout.

 

I would post you the link but they will delete it.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×