Jump to content
Jack_mcs

SiteMonitor

Recommended Posts

Jack,

I've installed version 1.5

In Site Monitor -> Admin, I get this error when clicking "delete reference file":

 

Warning: fopen(sitemonitor_reference.php) [function.fopen]: failed to open stream: Permission denied in /home/myusername/public_html/admin/includes/functions/sitemonitor_functions.php on line 208

Failed to open file sitemonitor_reference.php

 

I changed permissions for sitemonitor_functions.php but it makes no difference.

 

Can you advise please?


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites
Jack,

I've installed version 1.5

In Site Monitor -> Admin, I get this error when clicking "delete reference file":

 

Warning: fopen(sitemonitor_reference.php) [function.fopen]: failed to open stream: Permission denied in /home/myusername/public_html/admin/includes/functions/sitemonitor_functions.php on line 208

Failed to open file sitemonitor_reference.php

 

I changed permissions for sitemonitor_functions.php but it makes no difference.

 

Can you advise please?

Goto admin->Tools->Server Info and search for "allow_url_fopen." If that is not set to on, then that is the problem. You can ask your host to turn it on but they probably won't. In that case, you can add "allow_url_fopen = on" (without the quotes) to a php.ini file in the admin. If that dosn't work, then the code in SiteMonitor would need to be changed.

 

Jack

Share this post


Link to post
Share on other sites

Jack

 

I'm not sure what fixed it but I reinstalled the contribution and all works great!

I changed some permissions and altered a file and it emails me.

 

Even though I'm on localhost I would still like to try the cron part. I'm just not sure how to do that.

Where do I put this: php /home/xxxx/public_html/catalog/xxxx/sitemonitor.php

 

Or do I need the contribution Job Scheduler http://addons.oscommerce.com/info/1612 to test it?

 

Thanks,

 

George

Share this post


Link to post
Share on other sites
Jack

 

I'm not sure what fixed it but I reinstalled the contribution and all works great!

I changed some permissions and altered a file and it emails me.

 

Even though I'm on localhost I would still like to try the cron part. I'm just not sure how to do that.

Where do I put this: php /home/xxxx/public_html/catalog/xxxx/sitemonitor.php

 

Or do I need the contribution Job Scheduler http://addons.oscommerce.com/info/1612 to test it?

 

Thanks,

 

George

Sorry, but I haven't a clue. As mentioned, it serves no purpose, so I've never tried. I can tell you that cron is a Unix program and won't run on a Windows server. But there may be a way to simulate it since XAmpp is installed. Or, it looks like the contribution you mentioned would work just as well.

 

Jack

Share this post


Link to post
Share on other sites
Goto admin->Tools->Server Info and search for "allow_url_fopen." If that is not set to on, then that is the problem. You can ask your host to turn it on but they probably won't. In that case, you can add "allow_url_fopen = on" (without the quotes) to a php.ini file in the admin. If that dosn't work, then the code in SiteMonitor would need to be changed.

 

Jack

 

Jack,

 

do I just make a php file with "allow_url_fopen = on" and name it php.ini? do I upload it to public_html/admin ?


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites
Jack,

 

do I just make a php file with "allow_url_fopen = on" and name it php.ini? do I upload it to public_html/admin ?

Yes, unless there is already a php.ini file there, in which case you would want to edit that one. It won't break anything to try it. If it doesn't work, you can just delete the file and be back to where you are now.

 

Jack

Share this post


Link to post
Share on other sites
Yes, unless there is already a php.ini file there, in which case you would want to edit that one. It won't break anything to try it. If it doesn't work, you can just delete the file and be back to where you are now.

 

Jack, thanks for explaining.

I tried the php.ini file but it still doesn't work.

You mentioned changing the code, would that imply big changes? I would really like to be able to use this contribution too.

 

Isabella


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites
Jack, thanks for explaining.

I tried the php.ini file but it still doesn't work.

You mentioned changing the code, would that imply big changes? I would really like to be able to use this contribution too.

 

Isabella

Did you check if that option is enabled (you can also just ask your host)? If it is enabled, there wouldn't be any reason to change the code. If it isn't enabled, then the code change shouldn't be too involved, that's assuming the problem is with the open, of course.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites
Did you check if that option is enabled (you can also just ask your host)? If it is enabled, there wouldn't be any reason to change the code. If it isn't enabled, then the code change shouldn't be too involved, that's assuming the problem is with the open, of course.

Jack

 

That option is turned off on my server, I phoned my host to turn it on but they said they wouldn't for the reason that: "they already have problems with their database and don't allow that option to be turned on anymore"....not sure what that means exactly but that's what they told me.

 

I have tried the php.ini file, placed it html->admin, it didn't work. I tried placing it in html->admin->includes->functions, it didn't work either.

I made a text file with just "allow_url_fopen = on" and named it php.ini. I'm not sure that's the correct way to do it. Does it need to have "<?php ?>" ?

 

Isabella


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites
That option is turned off on my server, I phoned my host to turn it on but they said they wouldn't for the reason that: "they already have problems with their database and don't allow that option to be turned on anymore"....not sure what that means exactly but that's what they told me.

 

I have tried the php.ini file, placed it html->admin, it didn't work. I tried placing it in html->admin->includes->functions, it didn't work either.

I made a text file with just "allow_url_fopen = on" and named it php.ini. I'm not sure that's the correct way to do it. Does it need to have "<?php ?>" ?

 

Isabella

Some hosts turn that option off since they see it as a security problem. You can't just add the command to enable it into any file, it had to be one named php.ini. That file should be in admin. If that is the problem and the php.ini file doesn't work, then the code would have to be changed so it uses curl in order for it to work on your server.

 

Jack

Share this post


Link to post
Share on other sites

I'm afraid I don't know anything about curl...... :'( .......if it's just a small change, could you possibly tell me how to make the change please? If it's too much work, never mind.

 

Isabella


~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites
I'm afraid I don't know anything about curl...... :'( .......if it's just a small change, could you possibly tell me how to make the change please? If it's too much work, never mind.

 

Isabella

Well, I meant small change as changes go. You first have to make sure your host offers curl, which they should since the other call is disabled. They you will need to replace the code in SiteMonitor to use curl functions instead of the fopen one. You can get a hint on how to do that fromhere. I intend to add the code for curl at some point but it would most likely be quite a ways down the road due to other committments.

 

Jack

Share this post


Link to post
Share on other sites
I intend to add the code for curl at some point but it would most likely be quite a ways down the road due to other committments.

 

I understand, thanks anyway. Btw thanks for that link, I'll see if I can understand some of it. :blink:

 

Isabella

Edited by Biancoblu

~ Don't mistake my kindness for weakness ~

Share this post


Link to post
Share on other sites

I get this error in the configuration screen.

 

FAILED: Exclude list does not begin with quotes.

 

and I get these errors when I click on either update button in the Admin screen of sitemonitor.

 

Warning: opendir(/home/username/public_html) [function.opendir]: failed to open dir: No such file or directory in /home/xxxxxxx/public-html/tickets/admin/includes/functions/sitemonitor_functions.php on line 93

 

Warning: readdir(): supplied argument is not a valid Directory resource in /home/xxxxxxxx/public-html/tickets/admin/includes/functions/sitemonitor_functions.php on line 95

Reference file creation failed.

 

Can someone help me, please?

Edited by umtwebby

Share this post


Link to post
Share on other sites
I get this error in the configuration screen.

 

FAILED: Exclude list does not begin with quotes.

 

and I get these errors when I click on either update button in the Admin screen of sitemonitor.

 

Warning: opendir(/home/username/public_html) [function.opendir]: failed to open dir: No such file or directory in /home/xxxxxxx/public-html/tickets/admin/includes/functions/sitemonitor_functions.php on line 93

 

Warning: readdir(): supplied argument is not a valid Directory resource in /home/xxxxxxxx/public-html/tickets/admin/includes/functions/sitemonitor_functions.php on line 95

Reference file creation failed.

 

Can someone help me, please?

Please goto admin->SiteMonitor->Configure, copy the text from the exclude list box and post it here.

 

Jack

Share this post


Link to post
Share on other sites
Please goto admin->SiteMonitor->Configure, copy the text from the exclude list box and post it here.

 

Jack

 

Hello Jack,

 

I have no text in the excludes list box on that page as I thought that I would require all pages to be monitored

Edited by umtwebby

Share this post


Link to post
Share on other sites
Hello Jack,

 

I have no text in the excludes list box on that page as I thought that I would require all pages to be monitored

Hmm, that might a bug in the code then. I don't think I ever tested it with an empty list. Try entering "" (two quote marks) in the list and saving it. That might satsify the code if that is the problem.

 

Jack

Share this post


Link to post
Share on other sites
Hmm, that might a bug in the code then. I don't think I ever tested it with an empty list. Try entering "" (two quote marks) in the list and saving it. That might satsify the code if that is the problem.

 

Jack

 

 

Hello Jack, Nope it didn't work still got the same message.

 

If I put anything in the excludes box I get:

 

Warning: file(/home/xxxxxxxxx/public_html/admin/sitemonitor_configure.php) [function.file]: failed to open stream: No such file or directory in /home/xxxxxxxx/public_html/folder/admin/sitemonitor_configure_setup.php on line 160

 

Warning: chmod() [function.chmod]: No such file or directory in /home/xxxxxxxxx/public_html/folder/admin/includes/functions/sitemonitor_functions.php on line 233

Cannot change the mode of file (/home/xxxxxxxxxxx/public_html/admin/sitemonitor_configure.php)

 

I am certain I followed the instructions but it seems I have does something wrong

 

Thanks

Share this post


Link to post
Share on other sites

That error is saying it can't open the sitemonitor_configure.php file. Be sure that the file is thee and that it has contents. Also try changing its permissions to whatever the permissions are on the images directory.

 

Jack

Share this post


Link to post
Share on other sites
That error is saying it can't open the sitemonitor_configure.php file. Be sure that the file is thee and that it has contents. Also try changing its permissions to whatever the permissions are on the images directory.

 

Jack

 

 

I just went through this exact scenario doing a new install - and my problem was the path I had input in the admin: sitemonitor->configure screen for the "start directory" parameter was wrong. Make sure that's right, and your script should then be able to find the file that sitemonitor_configure.php is looking for.

Edited by cmakynen

Share this post


Link to post
Share on other sites

Hi I installed this contribution few days ago and it was working fine, but today its not working anymore, When I click the Update button it takes about 5 min and then in IE7 i get the bank page cannot be display and in Firefox i get a pop up "Opening sitemonitor_admin.php" asking me if i want to open or save the file or open it, much like when you download something. Can someone e please help.

Share this post


Link to post
Share on other sites
Hi I installed this contribution few days ago and it was working fine, but today its not working anymore, When I click the Update button it takes about 5 min and then in IE7 i get the bank page cannot be display and in Firefox i get a pop up "Opening sitemonitor_admin.php" asking me if i want to open or save the file or open it, much like when you download something. Can someone e please help.
If the code was working there is no reason for it to stop working other than some external change. You might try asking your host if they have changed anything at the time it stopped working. Or if you made some change, look there.

 

Jack

Share this post


Link to post
Share on other sites

I am just trying to install this

 

am getting this error

 

Quote

 

Warning: opendir(hsphere/local/home/......./............com): failed to open dir: No such file or directory in /hsphere/local/home/...../......./....../includes/functions/sitemonitor_functions.php on line 93

 

Warning: readdir(): supplied argument is not a valid Directory resource in /hsphere/local/home/......./........com/......./includes/functions/sitemonitor_functions.php on line 95

Reference file creation failed.

 

Unquote

 

What am I missing here? Any help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×