Jump to content
Jack_mcs

SiteMonitor

Recommended Posts

I fixed the problem, it should be like this:

 

/* ------------------------------------------------------- */

// require(DIR_WS_BOXES . 'sitemonitor.php');

/* ------------------------------------------------------- */

 

---------

 

but second problem! I can't see Sitemonitor in admin page, to Configure it!

Share this post


Link to post
Share on other sites

step 5 and 6 doesn't work, I should run these files or Sitemonitor will appear in osC Admin page?

Share this post


Link to post
Share on other sites

I fixed the problem, it should be like this:

 

/* ------------------------------------------------------- */

// require(DIR_WS_BOXES . 'sitemonitor.php');

/* ------------------------------------------------------- */

 

---------

 

but second problem! I can't see Sitemonitor in admin page, to Configure it!

That's because the slashes you added, //, tells the code not to show the boxes. So you didn't fix the cause of the errors. They are just not happening because the code is no longer being used.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

:blush: ops, rather than editing admin/includes/"files", I was editing shop/includes/"files"

it was my mistake :-"

 

however, it works, but I think I should restore my data and do all these again.

 

if I received any new error I'll ask you.

 

thanks for helping

Share this post


Link to post
Share on other sites

now everything is ok, I restored my data and I installed SiteMonitor fresh and without any problem during installation.

but when I'm in admin area I see this error on top of my page:

 

WARNING: Your admin name is admin. That should be changed.

WARNING: Your images directory is not protected by a .htaccess file.

 

Regards

Edited by Reza55

Share this post


Link to post
Share on other sites

now everything is ok, I restored my data and I installed SiteMonitor fresh and without any problem during installation.

but when I'm in admin area I see this error on top of my page:

 

WARNING: Your admin name is admin. That should be changed.

WARNING: Your images directory is not protected by a .htaccess file.

 

Regards

You can view previous posts on this or ask in the general support forum. It has to do with your site, not this contribution. The contribution is only reporting the problems.

Share this post


Link to post
Share on other sites

You can view previous posts on this or ask in the general support forum. It has to do with your site, not this contribution. The contribution is only reporting the problems.

 

I checked previous comments before ask you, but answers edited and deleted! (I don' know why)

these warnings show when I click on sitemonitor/admin

 

however, thanks for responding

Share this post


Link to post
Share on other sites

Hi, Jack_mcs,

I just installed your SiteMonitor v2.7. When I tried to set the TEXT_SITEMONITOR_CONFGIURE_SETUP, I got some errors and warnings, like failed to open dir: No such file or directory. I changed my admin name to something else before I installed this addons. So, my question is, is the error or warning related to the admin name change? Thanks!

Share this post


Link to post
Share on other sites

Hi, Jack_mcs,

I just installed your SiteMonitor v2.7. When I tried to set the TEXT_SITEMONITOR_CONFGIURE_SETUP, I got some errors and warnings, like failed to open dir: No such file or directory. I changed my admin name to something else before I installed this addons. So, my question is, is the error or warning related to the admin name change? Thanks!

Capital letters being displayed like that means you've made a mistake in the installation. Probably didn't upload the included files, or uploaded to the wrong location like the previous poster.

Share this post


Link to post
Share on other sites

Jack_mcs, yesterday you could help me but you passed me to post my question in general category, today same hacker attacked me. thank you!

 

WARNING: Your admin name is admin. That should be changed.

WARNING: Your images directory is not protected by a .htaccess file.

 

and exactly they attacked me from images directory.

 

thanks!

Share this post


Link to post
Share on other sites

Jack_mcs, yesterday you could help me but you passed me to post my question in general category, today same hacker attacked me. thank you!

 

WARNING: Your admin name is admin. That should be changed.

WARNING: Your images directory is not protected by a .htaccess file.

 

and exactly they attacked me from images directory.

 

thanks!

Uh, you're welcome?

 

But, seriously? I've spent many hours coding the script (I haven't received your payment by the way) and now I have to spend the time it takes to teach you how to use it? Hold on while I get a tissue to wipe your nose too.

Share this post


Link to post
Share on other sites

Jack,

 

Didn't you know that you are personally responsible for EVERY osCommerce store .......in the world ?! :lol:

 

 

Reza,

 

It is SOLELY up to you to secure your website, if you are getting hacked......it is your own fault. There is tons of information on this forum to help members do just about everything and when a member like Jack offers extra help, you should be very grateful as he and others on this forum volunteer their time to offer assistance to those who request it.

 

 

 

JMO

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Jack_mcs, you are talking from side of power, because you developed this plug-in , it's ok.

please don't spend your time to teach others, you could tell me you need money.

ask for money, I'll give you.

Share this post


Link to post
Share on other sites

DunWeb, he is responsible regarding what he developed. I didn't insult him and I didn't use any bad word to conversation with him, just I said you could help me but you didn't.

 

you support each other very good, you can spend this energy and time to support others too.

even it's ok if you ask for money. the main problem is money.

Edited by Reza55

Share this post


Link to post
Share on other sites

Didn't you know that you are personally responsible for EVERY osCommerce store .......in the world ?! :lol:

I think I missed class the day that part was explained. :)

Share this post


Link to post
Share on other sites

Jack_mcs, you are talking from side of power, because you developed this plug-in , it's ok.

please don't spend your time to teach others, you could tell me you need money.

ask for money, I'll give you.

No, I'm talking from a point of view that it is my free time to give away so I can give it away as I see fit. It isn't about money. That comment was meant to point out that you didn't pay anything for the work that went into this contribution so you don't get any support for it, unless I, or some other member decides to do so. I provided you with the information you needed to get the answer to your question. You made the decision not to follow up on it. Not much I can do about that.

Share this post


Link to post
Share on other sites
DunWeb, he is responsible regarding what he developed. I didn't insult him and I didn't use any bad word to conversation with him, just I said you could help me but you didn't.

 

you support each other very good, you can spend this energy and time to support others too.

even it's ok if you ask for money. the main problem is money.

 

Reza,

 

You OBVIOUSLY have no idea how much time and energy is put into creating the contributions that members download here for free and although Jack has written the contribution, it was released under GPL, without warranty and without support. Again, Jack VOLUNTEERS his time here to help OSC members with problems that arise with his contributions and others, HE DOES NOT HAVE TO ! But, he chooses to, as do other members here.

 

It is NOT about the money, if it were he wouldn't suggest a donation....he would CHARGE for his work. People download osCommerce first and foremost because it is free, and if that person is skilled enough in PHP, HTML, SQL and JAVA then they can successfully update the base download by themselves. However, if they are not then they seek the advice and support of this community again FOR FREE. 99% of the time, this works..........however, osCommerce users are disillusioned into thinking that EVERYTHING about this endeavor is FREE, it is not !

 

So, when you find that contribution that will make your website function more the way you want it, you download it and read the installation instructions and SKIP right over the 'If you find this contribution useful, please make a small donation to........." and then come onto the forum DEMANDING support.......don't waste too much time scratching your head wondering why the contribution creator isn't responding to your PM's or emails. The answer would be obvious.

 

 

JMO

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Hello, thanks for this contribution , I have installed but I have a problem. My oscommerce version is V 2.2 RC1, we are planning to move to the latest version in about a month or two but now with this version when we click onto site monitor it takes ages to load and then a loading error message appears in the webbrowser. Is Site Monitor compatible with RC1?

 

Thanks in advance.

 

Mariano.

Share this post


Link to post
Share on other sites

I have just completed the installation of SiteMonitor but if I try to use Admin->SiteMonitor->Admin I get a pink "Your username is invalid." error message along the top of the page, and it wont let me use the SiteMonitor admin section.

 

Does anyone know what the problem is?

 

Bill

Share this post


Link to post
Share on other sites

I have just completed the installation of SiteMonitor but if I try to use Admin->SiteMonitor->Admin I get a pink "Your username is invalid." error message along the top of the page, and it wont let me use the SiteMonitor admin section.

 

Does anyone know what the problem is?

When having a problem with a contribution (any contribution), please bother to at least skim the last few pages of the support thread or, better yet, search the forums for the problem. If you can't find a solution, then post the question.

Share this post


Link to post
Share on other sites

So the error is saying, "Your username is invalid" and the message is showing your system username is "stopdra1" and that your SiteMonitor user name is "username." Please explain what part of that you don't understand?

 

 

Hey I figured it out myself before, but I deleted the files by accident and now I have to do it again I'm getting the same error message and my site username is set to what I want it to be..

 

Here is the sitemoniter php configure file to show you what I mean

 

$reference_reset = 3; //delete the reference file this many days apart

 

$quarantine = 0; //set to 1 to move new files found to the quarantine directory

 

$to = '*********.com'; //where email is sent to

$from = 'From: *********'; //where email is sent from

 

$start_dir = '/home/stopdra1/public_html/'; //your shops root

$admin_dir = 'http'; //your shops admin

$admin_username = 'stopdra1_osc3'; //your admin username

$admin_password = 'vp[4xf6pxsG0'; //your admin password

$excludeList = array('admin/quarantine', 'cgi-bin','admin'); //don't check these directories - change to your liking - must be set prior to first run

$hackIgnoreList = array('jpg', 'jpeg','gif','png','txt','zip'); //don't check these types of files - change to your liking

$hackCodeSegments = array('error_reporting(0)', 'base64_decode','<frame','gzdecode','eval','ob_start("security_update")', 'Goog1e_analist_up', 'eval(gzinflate(base64_decode', 'Web Shell', '@eval', ' header;', 'shell_exec', 'system','SetCookie'); //enter any hacker code that you would like to check for

?>

 

Please help me out I'm sorry I'm not very php savy

Share this post


Link to post
Share on other sites

Hey I figured it out myself before, but I deleted the files by accident and now I have to do it again I'm getting the same error message and my site username is set to what I want it to be..

 

Here is the sitemoniter php configure file to show you what I mean

 

$admin_username = 'stopdra1_osc3'; //your admin username

$admin_password = 'vp[4xf6pxsG0'; //your admin password

Now that the login has been posted here, your first step needs to be chaning those. As for the settings, the username and password are only for using the curl option, which is usually not needed. That might be causing your problem, though I don't think so. The other parts look correct. You should look in the modules section of admin to be sure your start directory path matches what is really set up.

Share this post


Link to post
Share on other sites

I did scan the support thread, and all of oscommerce support, and googled it. I couldn't find the answer anywhere. I do appreciate that your comment means that the answer is here somewhere so I looked again. But still couldn't find it. Is there any chance you could point me at the answer?

 

I did find one posting in this support thread to do with user name but the error message they got was very different to mine, and I did not see how the answer fitted in with my problem. My error message is:

 

"Your username is invalid. Please change it and try again.: System -> /var/www/html/shop/ - SiteMonitor -> /home/username/public_html/"

 

Your indulgence on this would be hugely appreciated.

 

Thanks,

Bill

 

When having a problem with a contribution (any contribution), please bother to at least skim the last few pages of the support thread or, better yet, search the forums for the problem. If you can't find a solution, then post the question.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×