Jump to content
Sign in to follow this  
affordableweb-design.co.uk

HSBC Problems + PayPal Showing ?0 as total

Recommended Posts

Hi there i am maintaining a website. http://yankeecandle.biz/

 

I have managed to get HSBC payments working, but then the server had an OS upgrade, now it is showing this error:

 

Hacking atempt! - orderHash=HlTqjKUQVbNtnyviySfDpaaJDtQ= hash=error while loading shared libraries

 

So i tried to install PayPal payments, downloaded the latest version from this website (v1.3 PayPal IPN) installed it and now when you get to the paypal page it shows the total value as ?0

 

Any ideas on either of these problems would be great,

 

Thanks in advance form richie

Share this post


Link to post
Share on other sites

So what? is it "affordable web design" because you get us to do your work for you?

 

Get lost SPAMMER! :P

 

Matti


Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites

im sure that no web designer can say that he has never been stuck before....... i had the hsbc working but now something has changed on the server and there is not enough documentation to say what, provided by HSBC. The paypal one i should be able to sort out myself, just wondered if anyone had, had any problems before like it.

Share this post


Link to post
Share on other sites
not really, im just stuck and need some help?

 

 

Hey - it was 3:00am - I was only kidding (smiley) :)

 

The cause is most likely (as you say) the server upgrade. There are register_globals patches to be found in the Contributions section. I had an installation the other day on a PHP5, MySQL 5 server the other day, the following worked in the catalog .htaccess file:

 

php_value register_globals 1
php_value register_long_arrays 1

 

Try that first - if not and you do have PHP5, you will need to ask your host to either change the values, or at least register_long_arrays and then apply the register_globals patches. Make sure you begin with the latest patched version of osCommerce (has MySQL 5 patches already done)

 

Matti


Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites

register_globals On

register_long_arrays On

 

anyone got any ideas what needs to be installed on the server for the HSBC payments to work, as before he did the server upgrade to a new red hat linux, it was all working fine.

 

once again any help is appreciated :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×