Jump to content
Sign in to follow this  
demp

Easy Populate 1146 1054 errors

Recommended Posts

I have installed easy populate, but am very frustrated because I keep getting a 1146 and 1054 error when trying to export catalogs from the easypopulate utility. I installed exactly as the read me stated. Please help!

 

1054 - Unknown column 'p.products_price1_qty' in 'field list'

 

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_price1_qty as v_products_price1_qty, p.products_price1 as v_products_price1, p.products_price2_qty as v_products_price2_qty, p.products_price2 as v_products_price2, p.products_price3_qty as v_products_price3_qty, p.products_price3 as v_products_price3, p.products_price4_qty as v_products_price4_qty, p.products_price4 as v_products_price4, p.products_price5_qty as v_products_price5_qty, p.products_price5 as v_products_price5, p.products_price6_qty as v_products_price6_qty, p.products_price6 as v_products_price6, p.products_price7_qty as v_products_price7_qty, p.products_price7 as v_products_price7, p.products_price8_qty as v_products_price8_qty, p.products_price8 as v_products_price8, p.products_qty_blocks as v_products_qty_blocks, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id

 

[TEP STOP]

 

1146 - Table 'demp_osc1.TABLE_PRODUCTS_TO_PRODUCTS_EXTRA_FIELDS' doesn't exist

 

SELECT p.products_id as v_products_id, p.products_model as v_products_model, subc.products_extra_fields_id as v_products_extra_fields_id, subc.products_extra_fields_value as v_products_extra_fields_value, ptoc.products_extra_fields_name as v_products_extra_fields_name FROM products as p, TABLE_PRODUCTS_TO_PRODUCTS_EXTRA_FIELDS as subc, TABLE_PRODUCTS_EXTRA_FIELDS as ptoc WHERE p.products_id = subc.products_id AND ptoc.products_extra_fields_id = subc.products_extra_fields_id

 

[TEP STOP]

Share this post


Link to post
Share on other sites

It would appear that the EP that you installed was actually meant to be used with some other contrib - I am not 100% sure of this but from looking at the code you can see that it makes reference to different pricing - notice all the additional fields for pricing. Prob the Seperate price per Customer though pse dont quote me on that - I could be wrong.

 

The second 1146 error, Im think thats because you need to have the mod installed for extra fields.

 

I have the EP v2.76 which can be used the Linda's Tags Controller and my EP is working 100% - great contribution I must add - and many thanks to the authors.

 

It might be a good idea for you to install the Header Tags Controller first before adding EP. That way you can add your products and set them up correctly the first time instead of adding then having to go back to sort out the meta tags description and keywords.

 

I have found that with some of the mods its necessary to add other mods first in order add the mod you want. Hope this makes sense.


Rose

The strong survive BUT the best succeed !!

1064 - You have an error in your SQL syntax

Share this post


Link to post
Share on other sites
It would appear that the EP that you installed was actually meant to be used with some other contrib - I am not 100% sure of this but from looking at the code you can see that it makes reference to different pricing - notice all the additional fields for pricing. Prob the Seperate price per Customer though pse dont quote me on that - I could be wrong.

 

The second 1146 error, Im think thats because you need to have the mod installed for extra fields.

 

I have the EP v2.76 which can be used the Linda's Tags Controller and my EP is working 100% - great contribution I must add - and many thanks to the authors.

 

It might be a good idea for you to install the Header Tags Controller first before adding EP. That way you can add your products and set them up correctly the first time instead of adding then having to go back to sort out the meta tags description and keywords.

 

I have found that with some of the mods its necessary to add other mods first in order add the mod you want. Hope this makes sense.

 

I installed version 2.76 instead of the version 3.0 that I was trying and also installed the Header Tags Controller. Everything works great! Thank you so much for your help! What wonderful contributions!:D

Share this post


Link to post
Share on other sites
My pleasure :)

 

I am glad that I was able to be of some help if you run into any further prob give me a shout and If I am able to assist will be more than willing to assist. :)

 

 

I have been working with Easy Populate and am having another problem. I added a few test products through the Oscommerce control panel. I downloaded a complete EP tab delimited .txt file to edit. I added more products to the file and edited the few products and then uploaded the EP tab delimited .txt file.

 

The problem is that after uploading, the new products that I added are not showing on my website, nor are the changes that I made to the two existing products. There was no error when uploading the file.

 

Any help would be greatly appreciated.

 

Thanks!

Share this post


Link to post
Share on other sites

i cannot get my easy populate file to insert into db. it reads at the top after hitting insert db button:

File uploaded.

Temporary filename: /tmp/phpaU4ObB

User filename: EP2006Aug03-1010.txt

Size: 10333

 

i read that it could be incorrect permissions or temp dir path is wrong. i checked permissions and path and both are correct. could it be anything else. i have been looking for 3 days to try and figure this out without any luck.

thank you in advance for any help anybody can give me.

eric

Share this post


Link to post
Share on other sites
I have been working with Easy Populate and am having another problem. I added a few test products through the Oscommerce control panel. I downloaded a complete EP tab delimited .txt file to edit. I added more products to the file and edited the few products and then uploaded the EP tab delimited .txt file.

 

The problem is that after uploading, the new products that I added are not showing on my website, nor are the changes that I made to the two existing products. There was no error when uploading the file.

 

Any help would be greatly appreciated.

 

Thanks!

 

same problem.. i hope we can find a solution

Share this post


Link to post
Share on other sites
same problem.. i hope we can find a solution

 

I hope someone has a solution, I have tried everything and am totally stuck as well. Anyone?

Share this post


Link to post
Share on other sites
I hope someone has a solution, I have tried everything and am totally stuck as well. Anyone?

Has anyone had any luck yet!! Please Help!!!!

Share this post


Link to post
Share on other sites

After much searching and troubleshooting, I fixed the issue with the first product only being added. I am now using EP 2.9. I found the following fix on the oscmax forums posted by michael_S. It worked for me, so hopefully it will work for others with this issue.

 

Try this change in easypopulate.php:

 

FIND

array_walk($readed, 'walk');

 

REPLACE WITH

//array_walk($readed, 'walk');

foreach ($readed as $readed_record) {

walk($readed_record);

}

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×