Jump to content
Sign in to follow this  
Guest

Returned to Cookie Usage AFTER authorization

Recommended Posts

Guest

It seems we are but an unfortunate few that has opted for this contrib. Finding help on SECPay is proving impossible.

 

I have no problem with any other part of my website as far as cookies or session IDs are concerned, but for some reason, after processing a transaction, whether it be succesfull or not, I am returned to my website's cookie usage page. The transaction was authorised by SECPay, and if the authorisation was succesfull it would then continue to process the transaction and charge the card for it, yet still takes me back to my Cookie Usage page and on top of that, the cart has not been emptied and the order has not been processed in my store. Obviously this causes confusion and customers retry the transaction and get charged twice and the only way that I know of the transaction is the email from SECPay informing me of the transaction. This forces me to phone up the customer and confirm the content of their order.

 

This seems very strange as I was told by SECPay that they dont accept cookies and that the transaction info is transferred via a form. The problem seems to be on the callback. I was told by SECPay that OSC passes a certain value to SECPay which is returned once the Auth has been done. This value that is returned by SECPay seems to either be wrong or interpreted incorrectly by my OSC install.

 

Anybody out there that had a similar problem or know of anything that I could try would be most appreciated.

 

:huh: Thanks

Share this post


Link to post
Share on other sites
Guest

*bump*

ANYBODY???? :'(

Share this post


Link to post
Share on other sites
*bump*

ANYBODY???? :'(

 

there is only 1 reason for a cookie usage page to appear:

 

an action is set in the GET array while no session is started.

 

-no session is started when the client is identified as a spider or you force cookies and no cookie is accepted (yet).


Treasurer MFC

Share this post


Link to post
Share on other sites
Guest
there is only 1 reason for a cookie usage page to appear:

 

an action is set in the GET array while no session is started.

 

-no session is started when the client is identified as a spider or you force cookies and no cookie is accepted (yet).

I have checked and rechecked this setting again and again. I am NOT forcing cookies. If I block cookies with my browser I defintely get the sID string at the back of all URLs. ( dont know whether this is an indication that cookies are not neede to use my site).

 

I have deleted all cookies and cleared all temp internet files to make sure I am not viewing a cached version of this page and the setting is:

FORCE COOKIES = False

 

Is there any other way that I can confirm that the setting displayed in my browser is actually in effect. I have had some trouble with my server (shared) and they have recently restored loads of my files on top of which I have also restored some. Since my gateway has informed me that they do not accept cookies but some string, possibly contained in the session ID, is there anyway that my server deletes this session once it has been passed to the remote gateway and when the gateway does the callback it can not find this ID and as a result passes me to the Cookie Usage page?

Share this post


Link to post
Share on other sites
Guest
I have checked and rechecked this setting again and again. I am NOT forcing cookies. If I block cookies with my browser I defintely get the sID string at the back of all URLs. ( dont know whether this is an indication that cookies are not neede to use my site).

 

I have deleted all cookies and cleared all temp internet files to make sure I am not viewing a cached version of this page and the setting is:

FORCE COOKIES = False

 

Is there any other way that I can confirm that the setting displayed in my browser is actually in effect. I have had some trouble with my server (shared) and they have recently restored loads of my files on top of which I have also restored some. Since my gateway has informed me that they do not accept cookies but some string, possibly contained in the session ID, is there anyway that my server deletes this session once it has been passed to the remote gateway and when the gateway does the callback it can not find this ID and as a result passes me to the Cookie Usage page?

 

I have just made a discovery!! When I turn my Prevent Spider Sessions to False, I get my confirmation at the end of the sale. For some reason, all clients visiting my site are treated as Spiders as I have had several complaints from customers who actuallly took the time to complain, and also got the same result from friends I asked to test this. ALL CLIENTS ARE TREATED AS SPIDERS!!! This is a big problem as you can imagine! Does this mean there is a something in my spider.txt that is causing this???

 

Thanks

Anton

Share this post


Link to post
Share on other sites
I have just made a discovery!! When I turn my Prevent Spider Sessions to False, I get my confirmation at the end of the sale. For some reason, all clients visiting my site are treated as Spiders as I have had several complaints from customers who actuallly took the time to complain, and also got the same result from friends I asked to test this. ALL CLIENTS ARE TREATED AS SPIDERS!!! This is a big problem as you can imagine! Does this mean there is a something in my spider.txt that is causing this???

 

Thanks

Anton

 

check if you have "ox/" in that file as it turns all firefox clients into spiders.


Treasurer MFC

Share this post


Link to post
Share on other sites
Guest
check if you have "ox/" in that file as it turns all firefox clients into spiders.

 

I dont have an /ox in the file. I have IE6 though and I have the problem with my browser. Anything else it could be? Is there another way of disallowing spiders to create sessions apart from this setting? I have read that I can also add something to my application_top.php that will stop spiders from creating sessions. Or will this only work in conjunction with the Prevent Spider Session setting?

Share this post


Link to post
Share on other sites
Guest
I dont have an /ox in the file. I have IE6 though and I have the problem with my browser. Anything else it could be? Is there another way of disallowing spiders to create sessions apart from this setting? I have read that I can also add something to my application_top.php that will stop spiders from creating sessions. Or will this only work in conjunction with the Prevent Spider Session setting?

 

 

Thanks for your help. This was indeed the problem in the end. By removing the useragent used by SECPay, I am no longer returned to the cookie usage page.

 

For those that might have the same problem:

Remove Java from the spiders.txt file.

 

B)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×