Jump to content
kgt

[Contribution] Discount Coupon Codes

Recommended Posts

I've not experienced this issue before - but I would start by using a comparison program to compare the files in Admin that are changed by this contribution. (compare your changed files with the files included with the contribution).

 

Does anyone know how to fix this???????

~Tracy
 

Share this post


Link to post
Share on other sites
I've not experienced this issue before - but I would start by using a comparison program to compare the files in Admin that are changed by this contribution. (compare your changed files with the files included with the contribution).

 

 

Never heard of a comparison program - where do I do a find a good one?

Share this post


Link to post
Share on other sites

didn't find the edit button but @ TracyS : Which contribution are you talking about for the paypal ipn? I'm currently using the latest ipn (2.3.3).. what should i do? i've added the two bits at the paypal_ipn.php (in the readme - common probz section)

Share this post


Link to post
Share on other sites
Never heard of a comparison program - where do I do a find a good one?

 

I use WinMerge (do a google search and you should find it - free program).

There are several other programs available as well, but that's the only one I've used.


~Tracy
 

Share this post


Link to post
Share on other sites
i did put the two paypal bits... but it still doesn't work.. im using the 2.3.3 version of paypal IPN

 

We don't use PayPal on our store, so I don't know how to trouble shoot it. You might try using Google to search for the errors you are getting, or search for the contrib and paypal like so:

 

site:forums.oscommerce.com "Discount Coupon" +paypal


~Tracy
 

Share this post


Link to post
Share on other sites

Awesome contribution!!

 

Installed today and followed your common problems info and fixed every problem.

 

However, (you knew that was coming didn't ya :blink: ) I see a need. While searching through this thread a ran across this being mentioned by another person but I never saw a solution mentioned so I wanted to bring it up again.

 

Imagine for a moment.

If a customer loads their cart and begins to check out, say - maybe they want to see what the shipping will cost or maybe they can't add very good and they want to see what the total is before adding more stuff to their cart, whatever the reason. They go to the order total page and they have input their coupon code (Because they can't add and want to see what the total is or whatever.) and then they decide - "Hey, I still gots me a bit a money to spend." So they go back surfing through my store and add a few more products. Finally they are pretty sure that they are at their limit and want to check out. Only when they get to the place to put the coupon in again and they do so it says they already used it. Now, these simple minded folk are not about to E-mail me and let me know they want another coupon, nope they are going to walk right out my door (figuratively of course) and find another business that doesn't waste their time. You see where I am going with this?

 

This needs to be fixed. The code should not be recorded as being used by the customer until they have committed their money and checked out. Perhaps this is the way it is and there is a problem with my store, I don't know. If anyone has a suggestion I am all ears. :lol:

 

Have a look if you like. http://gscoffeeclub.com Please realize this store is live and you will be charged if you go through with the order.

 

I say again, this is an awesome contribution.

 

Thanks,

 

Gary

Edited by gmltw

Share this post


Link to post
Share on other sites

I downloaded Winmerge, came back with 6 files that are different but when I double click on them it tells me they are the same - it would seem only the carriage returns are different.

 

I tried uploading all the admin files again but that made no change. All orders with a discount coupon applied has no options available that are normally available on the admin orders page.

 

Is there some code that is missing from the orders.php file??

Share this post


Link to post
Share on other sites

This sounds to me like a case of file corruption. Are you uploading files to your server in ASCII mode? (Binary can corrupt php files). Also - what program are you using to make edits to the php files? (some programs will corrupt the php).

 

 

I downloaded Winmerge, came back with 6 files that are different but when I double click on them it tells me they are the same - it would seem only the carriage returns are different.

 

I tried uploading all the admin files again but that made no change. All orders with a discount coupon applied has no options available that are normally available on the admin orders page.

 

Is there some code that is missing from the orders.php file??


~Tracy
 

Share this post


Link to post
Share on other sites
This sounds to me like a case of file corruption. Are you uploading files to your server in ASCII mode? (Binary can corrupt php files). Also - what program are you using to make edits to the php files? (some programs will corrupt the php).

 

 

I have no idea sorry. I haven't done anything different to all the other times I have uploaded files. I use core ftp to upload my files and I use word pad to edit php files and again I have always used this and never had problems. This is not the 1st mod I have installed.

Share this post


Link to post
Share on other sites

I get this when I click Checkout:

 

1146 - Table 'thebras_thebraspecialistcomonlinestore.TABLE_DISCOUNT_COUPONS' doesn't exist

 

SELECT dc.* FROM TABLE_DISCOUNT_COUPONS dc WHERE coupons_id = 'Test' AND ( coupons_date_start <= CURDATE() OR coupons_date_start IS NULL ) AND ( coupons_date_end >= CURDATE() OR coupons_date_end IS NULL )

 

[TEP STOP]

 

 

The table does exist, I checked the tables to see if it was there and it is and it is populated with the coupon code Test. Please help!!

Share this post


Link to post
Share on other sites
This needs to be fixed. The code should not be recorded as being used by the customer until they have committed their money and checked out. Perhaps this is the way it is and there is a problem with my store, I don't know. If anyone has a suggestion I am all ears. :lol:

does nobody else think that this is a serious problem??? i think this makes the whole contribution completely unusable! ... a click on the browsers reload or back-button is enough to waste the code.

 

when i am doing onlineshopping myself, i usually click through until the point of no return to see the total price, shipping rates etc. i would really be pissed off, if my discount code gets lost without really buying anything.

 

if entered codes get marked after the payment is closed a new problem arises. this would make it possible to use the code multiple times by opening concurrent sessions.

 

does anybody have an idea to solve this problem??

Edited by PowerShopper

Share this post


Link to post
Share on other sites

Hi, I dont know if anyone is able to help me with this small problem I am having, but here goes...:D

 

First, GREAT contribution, very well documented, installed pefectly first time and works great, except for 1 issue which seems to be due to another contribution.

 

I have installed a Contribution which allows users to toggle between Inc VAT and Exc VAT prices (its a UK store ;) )

 

This is defaulted to Exc VAT, and the coupons work prefectly.

 

When the user switches to Inc VAT strange things start to happen at the checkout. By the looks of it when Inc VAT is on everything is calculated as normal BUT no VAT is added to the order total, so it goes like this:

 

Order Total (Exc VAT)

- Discount Coupon Amount

+ Shipping Charge (Inc VAT)

 

 

I understand the other contribution is nothing to do with you, but if there is anywhere you can suggest I can start looking that would be a great help!

 

:D

Share this post


Link to post
Share on other sites
I've installed this (v3.3.1) and it seems to be successful, but for some reason the page catalog/admin/coupons.php is totally blank, so I can't make it work. I wouldn't have been surprised if I'd messed up an edit somewhere, but as far as I can see, that page is generated by supplied files. Any suggestions about where I might have gone wrong?

 

I'm not sure if there is a problem with shipping charges (they are complicated in this store), because I can't get as far as testing.

 

I am having the same problem, my catalog/admin/coupons.php is totally blank aswell! Did anyone find a solution for this?

Share this post


Link to post
Share on other sites

Can someone tell me if this contribution has any changes that would affect the orders.php page in admin? This is where I am missing the pending/processing/delivered/comments options when a discount coupon has been applied. :'(

Share this post


Link to post
Share on other sites

Hi,

 

I had this contrib working fine intill I installed the Fast Easy Checkout contrib. Now I can't get the discount coupon option to show anywhere during checkout plus the comment box disappeared too!

 

Any suggestions?

Share this post


Link to post
Share on other sites
I am having the same problem, my catalog/admin/coupons.php is totally blank aswell! Did anyone find a solution for this?

 

I am not sure what version you downloaded, but my catalog/admin/coupons.php has a lengthy bit of code in it. It came that way with the download. I just copied it to my catalog.

Share this post


Link to post
Share on other sites
I am not sure what version you downloaded, but my catalog/admin/coupons.php has a lengthy bit of code in it. It came that way with the download. I just copied it to my catalog.

You misunderstand. There is code in the file, but when you go to that page with a web browser, it is totally blank. I suspec that there may be a problem with php5 compatibility

Share this post


Link to post
Share on other sites

1146 - Table 'elutstyr.TABLE_DISCOUNT_COUPONS' doesn't exist

 

SELECT dc.* FROM TABLE_DISCOUNT_COUPONS dc WHERE coupons_id = 'K6VLX80MTR' AND ( coupons_date_start <= CURDATE() OR coupons_date_start IS NULL ) AND ( coupons_date_end >= CURDATE() OR coupons_date_end IS NULL )

 

[TEP STOP]

 

any suggestions? i have run the sql query...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×