Jump to content
kgt

[Contribution] Discount Coupon Codes

Recommended Posts

Dear KGT,

 

I just instal your contributio and I really like it. I was using the version 1 so I upgrade to the 3.3 because I wanted to put some products on specials and desable the coupon for products on specials. Unfortunatly, on my admin, in the order total modules, my Discount Coupon setup show me 8 blank boxes after "Display Sudtotal with applied discount". I am missing:

- Exclude product specials?

- Random Code Length

- Display discount total lines for each tax group?

- Allow negative order total?

- Use the language file to format display string?

- Display Format for Order Total Line

- Debug Mode

 

Do you have any ideas? I double check all file and the instalation procedure but I don't find anything.

Regards,

Sam

Share this post


Link to post
Share on other sites

When I try and run the database modifications manually via Sql I receive the following error:

 

#1171 - All parts of a PRIMARY KEY must be NOT NULL; If you need NULL in a key, use UNIQUE instead

 

I have noticed that this problem had been touched upon before but I cannot find a revised soultion for manual entering the necessary changes into SQL. Can someone produce and updated version that can let me do it?

 

Many thanks

Share this post


Link to post
Share on other sites

I've managed to install the SQL manual by changing the second table to this:

CREATE TABLE IF NOT EXISTS discount_coupons_to_orders (
id INT(11) NOT NULL AUTO_INCREMENT,
coupons_id VARCHAR(32) NOT NULL DEFAULT '',
orders_id INT(11) NOT NULL DEFAULT '0',
PRIMARY KEY  (id)
);

 

But I have another problem. When I try and create a code in the admin I get the following error:

1136 - Column count doesn't match value count at row 1

insert into discount_coupons values ( 'GJHVWQ', '3 For 2 Offer', '17', 'fixed', null, null, 10, 34.99, 'price', 10)

 

 

This problem has been addressed by crash3903 on the 28th of June but there solution amends a admin/coupons.php file that looks nothing like the one with the current download. As I am manual altering the db I don't think the solution is relevant anyway.

 

Any one have any ideas on who to solve this?

Share this post


Link to post
Share on other sites
regrading google checkout problem:I'd love to help, but without an error message I can't exactly do anything.

 

Here is the rror message I am getting when applying this 'fix' for Google Checkout:

Error: 	 Error parsing XML; message from parser is: Invalid value for body of unit-price in checkout-shopping-cart/shopping-cart/items/item: This is not a number
Warnings: 	XML failed to validate against the schema at line: 15, column: 15, with error: cvc-datatype-valid.1.2.1: '--17.99' is not a valid value for 'decimal'.
XML failed to validate against the schema at line: 15, column: 15, with error: cvc-complex-type.2.2: Element 'unit-price' must have no element [children], and the value must be valid.

 

And here is the part of the 'XML received' by Google that appears to contain the problem:

<item>
	<item-name>Discount Coupon 3FOR2 applied</item-name>
	<item-description>Discount Coupon 3FOR2 applied</item-description>
	<unit-price currency="GBP">--17.99</unit-price>
	<quantity>1</quantity>
</item>

Edited by amigaman

Share this post


Link to post
Share on other sites

I have fixed it by disabling the minus sign from the the sub-total. This is done the Discount Coupon admin under the Modules/Order Total tab. Anyone know of a fix that will still allow the minus to be displayed?

Share this post


Link to post
Share on other sites
Hooray i solved it was an issues between QT pro version and Discount Coupon checkout_payment.php all works now fine :)

 

Hi cyborgt100,

 

Could you elaborate on what you did? I have QT Pro installed as well, and I'm having the same problem as you did.

 

Thanks!

Share this post


Link to post
Share on other sites

Very nice work!!!

 

But a little problem. I use the lastest 3.3. When I config:

 

Display subtotal with applied discount? false

 

The item is $30, discount is -$5. it display:

 

subtotal: $25
discount: -$5
Total: $20

 

Could you check with it?

Edited by zdhmp3

Share this post


Link to post
Share on other sites
I've managed to install the SQL manual by changing the second table to this:

CREATE TABLE IF NOT EXISTS discount_coupons_to_orders (
id INT(11) NOT NULL AUTO_INCREMENT,
coupons_id VARCHAR(32) NOT NULL DEFAULT '',
orders_id INT(11) NOT NULL DEFAULT '0',
PRIMARY KEY  (id)
);

 

But I have another problem. When I try and create a code in the admin I get the following error:

1136 - Column count doesn't match value count at row 1

insert into discount_coupons values ( 'GJHVWQ', '3 For 2 Offer', '17', 'fixed', null, null, 10, 34.99, 'price', 10)

This problem has been addressed by crash3903 on the 28th of June but there solution amends a admin/coupons.php file that looks nothing like the one with the current download. As I am manual altering the db I don't think the solution is relevant anyway.

 

Any one have any ideas on who to solve this?

 

The solution for the error that you are getting is that you tried to install the sql file manually. If you use the modules -> order totals , Discount Coupons install like the instructions said it will install all the necessary database tables and this problem should go away.

 

I was saying the same thing till I went back and looked at the instructions again, I deleted the tables that where in there for discount_coupons and ran the install and now it works perfectly.

Share this post


Link to post
Share on other sites

Hi Kristen,

 

I finally had a customer call me about the error they were getting when trying to use a coupon code. I can now finally pinpoint what is happening and reproduce it. It turns out, if they are a new customer and they put items in their cart and click on "checkout" - they are then prompted to create an account. After they create their account they click on "continue", which brings them back to the checkout process. When they enter their discount coupon code they get an error.

 

The error is happening because the customer group id for the customer group exclusions section is not being passed properly. I have a post on the SPPC forums in hopes of finding a resolution. The post is here: http://forums.oscommerce.com/index.php?s=&...t&p=1100340

 

In case anyone else experiences this difficulty with SPPC and Discount Coupons (if they're using the Customer Groups Exclusion) - here is the error code being generated:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND coupons_id="MM0707"' at line 4

SELECT dc2cg.customers_group_id FROM discount_coupons_to_customer_groups dc2cg WHERE customers_group_id= AND coupons_id="MM0707"

 

Of course your coupons_id="_______" will vary from mine. But the rest should basically be the same. Once I have this resolved I will post again here. Feel free to follow the SPPC thread in the meantime as well - or post a resolution if you already have one :thumbsup:


~Tracy
 

Share this post


Link to post
Share on other sites
Hi cyborgt100,

 

Could you elaborate on what you did? I have QT Pro installed as well, and I'm having the same problem as you did.

 

Thanks!

 

 

I copy over a fresh copy of the file from QT pro checkout_payment.php then manual entering the discount coupon codes, coding according from Readme file

or was it the other way ?

 

if you any probs lett me know i send the coding over to you

 

 

Is there any way to add more then 1 discount coupon per transaction I can either do shipping or products not both

so either a discount that does the whole transaction or add indiviual discount 1 for shipping and one for products

Share this post


Link to post
Share on other sites

The contribution sounds great, but I am having a problem with the installation. Sorry if this question is repeat, but I looked upto page 20 or so and didnt see anything like it...

 

I have copied and changed all the files as instructed as far as I know, though when I try to click on the configuration section in the admin section for installation, (or anything else other than the main admin page itself), I receive the following error,

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/ysjvbrv/public_html/catalog/admin/includes/boxes/catalog.php on line 32

 

 

Any help is greatly appreciated...Thanks

Share this post


Link to post
Share on other sites
The contribution sounds great, but I am having a problem with the installation. Sorry if this question is repeat, but I looked upto page 20 or so and didnt see anything like it...

 

I have copied and changed all the files as instructed as far as I know, though when I try to click on the configuration section in the admin section for installation, (or anything else other than the main admin page itself), I receive the following error,

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/ysjvbrv/public_html/catalog/admin/includes/boxes/catalog.php on line 32

Any help is greatly appreciated...Thanks

 

I replaced the file with the original catalog.php file than I received an similar problem with .../boxes/reports.php.

 

I replace this with the original and now all seems fine with the catalog as a whole, but I do not want to install the contribution with out these two files...I am assuming I will have a problem...

 

 

Thanks for your help in advance...

Share this post


Link to post
Share on other sites

Hello

 

This contribution seems to be very great, but I have a problem :blush:

 

I follow the installation instructions with this version : ot_discount_coupon_codes_3.3 but I don't have the discount coupons menu in the admin section

 

I have also install this contribution : BOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce and I have applied the beachglassdirect.com solution on http://www.oscommerce.com/community/contributions,4269 but no better.

 

here is my /catalog/admin/includes/boxes/catalog.php before changing :

 

<?php

/*

$Id: catalog.php,v 1.21 2003/07/09 01:18:53 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2)

 

Please note: DO NOT DELETE this file if disabling the above contribution.

Edits are listed by number. Locate and modify as needed to disable the contribution.

*/

?>

<!-- catalog //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_CATALOG,

'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

 

if ($selected_box == 'catalog') {

// BOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 1 of 1

// reverse comments to below lines to disable

// $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');

$contents[] = array('text' =>tep_admin_files_boxes(FILENAME_CATEGORIES, BOX_CATALOG_CATEGORIES_PRODUCTS) .

tep_admin_files_boxes(FILENAME_PRODUCTS_ATTRIBUTES, BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES) .

tep_admin_files_boxes(FILENAME_MANUFACTURERS, BOX_CATALOG_MANUFACTURERS) .

tep_admin_files_boxes(FILENAME_REVIEWS, BOX_CATALOG_REVIEWS) .

tep_admin_files_boxes(FILENAME_SPECIALS, BOX_CATALOG_SPECIALS) .

tep_admin_files_boxes(FILENAME_PRODUCTS_EXPECTED, BOX_CATALOG_PRODUCTS_EXPECTED));

// EOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 1 of 1

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- catalog_eof //-->

 

If someone could help : thanks :thumbsup:

 

Sorry for my english :huh:

Edited by alexbfr

Share this post


Link to post
Share on other sites
Hi Kristen,

 

I finally had a customer call me about the error they were getting when trying to use a coupon code. I can now finally pinpoint what is happening and reproduce it. It turns out, if they are a new customer and they put items in their cart and click on "checkout" - they are then prompted to create an account. After they create their account they click on "continue", which brings them back to the checkout process. When they enter their discount coupon code they get an error.

 

The error is happening because the customer group id for the customer group exclusions section is not being passed properly. I have a post on the SPPC forums in hopes of finding a resolution. The post is here: http://forums.oscommerce.com/index.php?s=&...t&p=1100340

 

In case anyone else experiences this difficulty with SPPC and Discount Coupons (if they're using the Customer Groups Exclusion) - here is the error code being generated:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND coupons_id="MM0707"' at line 4

SELECT dc2cg.customers_group_id FROM discount_coupons_to_customer_groups dc2cg WHERE customers_group_id= AND coupons_id="MM0707"

 

Of course your coupons_id="_______" will vary from mine. But the rest should basically be the same. Once I have this resolved I will post again here. Feel free to follow the SPPC thread in the meantime as well - or post a resolution if you already have one :thumbsup:

 

Ok - we have the fix! For those using Separate Price per Customer, Discount Coupon Codes, and the Add On for being able to exclude Customer Groups - you need to make sure that you have the fix posted here:

http://forums.oscommerce.com/index.php?s=&...t&p=1100353

 

If you do not have the fix posted at the above link, then someone who does not already have a customer account will not be able to use a coupon code during checkout if they are creating their account during checkout. The customer_group_id is not being passed. I will update the instructions for the Add On shortly :thumbsup:


~Tracy
 

Share this post


Link to post
Share on other sites
Hello

 

This contribution seems to be very great, but I have a problem :blush:

 

I follow the installation instructions with this version : ot_discount_coupon_codes_3.3 but I don't have the discount coupons menu in the admin section

 

I have also install this contribution : BOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce and I have applied the beachglassdirect.com solution on http://www.oscommerce.com/community/contributions,4269 but no better.

 

here is my /catalog/admin/includes/boxes/catalog.php before changing :

 

<?php

/*

$Id: catalog.php,v 1.21 2003/07/09 01:18:53 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2)

 

Please note: DO NOT DELETE this file if disabling the above contribution.

Edits are listed by number. Locate and modify as needed to disable the contribution.

*/

?>

<!-- catalog //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_CATALOG,

'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

 

if ($selected_box == 'catalog') {

// BOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 1 of 1

// reverse comments to below lines to disable

// $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>');

$contents[] = array('text' =>tep_admin_files_boxes(FILENAME_CATEGORIES, BOX_CATALOG_CATEGORIES_PRODUCTS) .

tep_admin_files_boxes(FILENAME_PRODUCTS_ATTRIBUTES, BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES) .

tep_admin_files_boxes(FILENAME_MANUFACTURERS, BOX_CATALOG_MANUFACTURERS) .

tep_admin_files_boxes(FILENAME_REVIEWS, BOX_CATALOG_REVIEWS) .

tep_admin_files_boxes(FILENAME_SPECIALS, BOX_CATALOG_SPECIALS) .

tep_admin_files_boxes(FILENAME_PRODUCTS_EXPECTED, BOX_CATALOG_PRODUCTS_EXPECTED));

// EOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 1 of 1

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- catalog_eof //-->

 

If someone could help : thanks :thumbsup:

 

Sorry for my english :huh:

 

if I add this :

//kgt - discount coupons

'<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>'.

'<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );

//end kgt - discount coupons

 

I have an error when I log on the admin section :

 

Parse error: syntax error, unexpected ')' in /includes/boxes/catalog.php on line 38

 

line 38 is :

'<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );

Share this post


Link to post
Share on other sites
if I add this :

//kgt - discount coupons

'<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>'.

'<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );

//end kgt - discount coupons

 

I have an error when I log on the admin section :

 

Parse error: syntax error, unexpected ')' in /includes/boxes/catalog.php on line 38

 

line 38 is :

'<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );

 

Sorry for my post, I find the solution on /includes/boxes/catalog.php

thanks KGT for this contribution :rolleyes:

Share this post


Link to post
Share on other sites

I am having an issue with this mod I am very well versed with contributions and writing my own but this one is mind boggling.

 

It all works fine with the exception of 2 things.

 

 

1. If I use aggregate shopping cart it will pass the right discounted amount. If I pass all items to paypal and pass amount= over to paypal, paypal seems to recalcualte and not use the value I pass over for the amount therefore not adding in the coupon/discount.

 

 

#2. When you go into Admin / orders and slect an order without discount / coupon it shows all the order information, the customer notification box the packaging slip / invoice buttons and then the OsCommerce copyright thingy.

 

If you take the same order and they use a coupon it shows all the information but it will display coupon discount code 11111 applied $-20.00

 

And then it jumps right to the oscommerce copyright thingy and not displaying the customer noification box etc.

Please help me greatly.

 

Thanks,

Shawn

Share this post


Link to post
Share on other sites

I'm a newbie to oscommerce and I have Got a problem with install of discount code 3.3

I copied everything over that it said to copy as far as the new files, I then went in and edited my existing php files exactly as it said to do. After it was all said and done when I go to my admin page the only thing that is there is my banner and the one button for config. All the other buttons for customers etc are gone.

 

Then when I reverted all of the files back to the way they were before editing (besides deleting the new files) My admin buttons all came back. At that time I saw that the Discount coupon module was still there and was able to be installed but no coupons are showing up. Dont know what exactly to do from here. Would be nice to be able to get this to work. I'm sure I must be missing something but I dont know what. Any help will be greatly appreciated.

 

Oh by the way this isnt the first contribute that I cant get to work. I tried the email invoice ones too... they never worked.

 

Oh just another thing. To add to the second part there. There is no place to enter in the coupons even though the module is enabled.

Edited by CKENT00369

Share this post


Link to post
Share on other sites
I'm a newbie to oscommerce and I have Got a problem with install of discount code 3.3

I copied everything over that it said to copy as far as the new files, I then went in and edited my existing php files exactly as it said to do. After it was all said and done when I go to my admin page the only thing that is there is my banner and the one button for config. All the other buttons for customers etc are gone.

 

Then when I reverted all of the files back to the way they were before editing (besides deleting the new files) My admin buttons all came back. At that time I saw that the Discount coupon module was still there and was able to be installed but no coupons are showing up. Dont know what exactly to do from here. Would be nice to be able to get this to work. I'm sure I must be missing something but I dont know what. Any help will be greatly appreciated.

 

Oh by the way this isnt the first contribute that I cant get to work. I tried the email invoice ones too... they never worked.

 

Oh just another thing. To add to the second part there. There is no place to enter in the coupons even though the module is enabled.

 

Ok I figured out that part for the most part after searching this forum forever come to find out there was a . after the <br> ' on two areas.

 

Now that that is all fixed and my admin is working and all... When I put something in the cart from the catalog then go to checkout my Checkout_payment.php is a blank white page. I am going to keep searching on this But if someone knows the fix please let me know

 

Thank you all very much

Share this post


Link to post
Share on other sites
Ok I figured out that part for the most part after searching this forum forever come to find out there was a . after the <br> ' on two areas.

 

Now that that is all fixed and my admin is working and all... When I put something in the cart from the catalog then go to checkout my Checkout_payment.php is a blank white page. I am going to keep searching on this But if someone knows the fix please let me know

 

Thank you all very much

 

Ok everyone I got it I was missing some small parts like a ?> oops my bad

Share this post


Link to post
Share on other sites
The contribution sounds great, but I am having a problem with the installation. Sorry if this question is repeat, but I looked upto page 20 or so and didnt see anything like it...

 

I have copied and changed all the files as instructed as far as I know, though when I try to click on the configuration section in the admin section for installation, (or anything else other than the main admin page itself), I receive the following error,

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/ysjvbrv/public_html/catalog/admin/includes/boxes/catalog.php on line 32

Any help is greatly appreciated...Thanks

 

The answer is on page 68...missing a .

Share this post


Link to post
Share on other sites
#2. When you go into Admin / orders and slect an order without discount / coupon it shows all the order information, the customer notification box the packaging slip / invoice buttons and then the OsCommerce copyright thingy.

 

If you take the same order and they use a coupon it shows all the information but it will display coupon discount code 11111 applied $-20.00

 

And then it jumps right to the oscommerce copyright thingy and not displaying the customer noification box etc.

Please help me greatly.

 

Thanks,

Shawn

 

ok Sorry to keep posting. But now I am having this exact same problem. Not sure exactly where to fix this one at.

Share this post


Link to post
Share on other sites

Howdy,

 

The install went okay shy of a few missing .'s...

 

However, when I enter a discount code for -$5.00 on an order of $18.82 the Sub-Total is changed to $8.82. When I enter the same discount code for -$5.00 on an order of $543.82 I get a Sub-Total of $547.02.

 

If I comment out the following in order.php I get the correct Sub-Totals but no discount:

 

global $coupon;

if( tep_session_is_registered( 'coupon' ) && tep_not_null( $coupon ) ) {

require_once( DIR_WS_CLASSES.'discount_coupon.php' );

$this->coupon = new discount_coupon( $coupon, $this->delivery );

$this->coupon->total_valid_products( $products );

$valid_products_count = 0;

}

 

I would greatly appreciate any help you can give me in this matter.

 

Thank you!

 

Corey

Share this post


Link to post
Share on other sites

Hello all

 

I did my best searching in the support thread and couldn't find anything. So here is my problem... Anytime I try the files, I put all the proper files in the correct places. Anytime you get to the checkout_payment.php page it is blank, even when not using discount coupons add in. Anyone have any ideas?

Share this post


Link to post
Share on other sites

First off i would like to congratulate KQT on a brilliant contibution. I like many on here have loads of contributions loaded and this is one of my favourites. The install notes are fantastic and bar a few small changes the contribution works ' out of ther box' .... excellent job and much appreciated!

 

Ok...so my question is based on central50 'Exclude products on sale' add on from the 11May. I would really like to use this extra as its important that people get the discount when checking out with mixed special/normal products in their basket. An addon with #replace this code# with this #code# insructions for 3.3 would be really nice and would finish off the package.

 

Has anyone figured out how to do this yet? ive tried to follow central50's instructions but they were for 3.0 :(

 

Maybe KQT could add this to the next update? i think it needs it!

 

cheers MonkeyNuts

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×